Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-03-2020 22:19:22

giona
Membre
Inscription : 13-02-2017

pb grub et crypt après install

Salut à tou-te-s,
Je viens de réinstaller debian buster 10-3-0 amd64 mate après une première tentative aux multiples déconvenues principalement ergonomiques et d'usage comme des bug graphiques, impossibilité de copier coller dans le terminal et d'autres problemes dont ceux (ou "celui", si ces deux problemes sont liés?) qui reviennent après ma deuxième installation et qui me poussent à écrire ce post: grub qui ouvre possiblement en deux temps et avec une interface graphique très rustique: une premiere page avec

-debian GNU/LINUX
Options avancées pour Debian GNU/LINUX



si je vais sur la deuxieme ligne, ça dirige sur une page non moins rustique qui me propose:

- Debian GNU/LINUX, avec linux 4.19.0.8.amd64
Debian GNU/LINUX, avec linux 4.19.0.8.amd64 (recovery mode)



Si je laisse tourner ou que je tape directement sur entrée, il se charge et me propose de taper ma phrase de pass (puisque j'ai chiffré mon disque mais pas grub) et quand je la tape, les étoiles  apparaissent à la place des caractères!!!!

Voici le contenu de Grub dans /etc/default

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"




J'ai été voir sur ce post:
https://debian-facile.org/viewtopic.php?id=17452
mais il ne  m'a pas semblé que ça répondait à mes questions...

Qu'est-ce que je peux dire de plus sinon... bise avec les pieds smile

Dernière modification par giona (24-03-2020 22:23:19)

Hors ligne

#2 24-03-2020 22:44:19

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : pb grub et crypt après install

les étoiles  apparaissent à la place des caractères!!!!


C'est normal, les passphrases n'apparaissent jamais
.... au cas ou quelqu'un regarderait par dessus ton épaule ...

Dernière modification par ubub (24-03-2020 22:45:48)

Hors ligne

#3 25-03-2020 00:51:36

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

C'est normal


et non, il ne devrait y avoir rien du tout qui s'affiche!!!!! au cas où quelqu'un derriere mon épaule compte le nombre de caracteres de ma passphrase....

Hors ligne

#4 25-03-2020 11:41:00

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

Ça dépend des goûts et des habitudes, et surtout du programme qui gère la saisie du mot de passe.
Historiquement, l'invite de login en mode texte d'Unix n'affiche rien. cryptsetup non plus. Par contre on peut constater que plymouth au démarrage et des gestionnaires de connexion graphique à l'ouverture de session affichent des étoiles ou des points.

Si le mot de passe de chiffrement est demandé par le gestionnaire de mot de passe système de systemd, l'affichage d'étoiles peut être désactivé en tapant sur la touche Tab ou BackSpace.

Il vaut mieux montrer que raconter.

Hors ligne

#5 31-03-2020 11:33:05

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

Il n'y a vraiment personne qui a une idée?
Les dernières réponses ne m'ont pas vraiment aidées sachant qu'avec une install de debian téléchargé en torrent sur le site officiel, j'ai pas trop de choix du programme...
Est-ce que je vais juste voir ailleurs?
ps: tab ni backspace n'y ont rien changé, d'autant que je cherche à ce que ce soit automatique, comme ça l'a toujours été sur mes debian... mais merci quand même

Hors ligne

#6 31-03-2020 11:56:44

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

giona a écrit :

tab ni backspace n'y ont rien changé


Chez moi ça marche (sans plymouth). Est-ce que plymouth est installé chez toi ?


Il vaut mieux montrer que raconter.

Hors ligne

#7 31-03-2020 13:12:48

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

oui...

Hors ligne

#8 31-03-2020 13:18:30

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

Démarre sans le paramètre "splash" dans la ligne de commande du noyau et teste si tab/backspace désactive l'affichage des *

Il vaut mieux montrer que raconter.

Hors ligne

#9 31-03-2020 15:59:59

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

Je ne parviens pas à trouver comment retirer le parametre splash dans la ligne de commande du noyau, il n'est pas dans le menu grub quand je tape e au boot.
ps: je voulais mettre une image dans le post, j'ai pris une photo basse qualité pour montrer la page du grub, mais ce n'est pas possible?

Hors ligne

#10 31-03-2020 16:36:17

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

S'il n'y est pas, il n'y a pas lieu de l'enlever.

Il vaut mieux montrer que raconter.

Hors ligne

#11 01-04-2020 22:28:43

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

Apparemment, quand plymouth est installé c'est le paramètre "nosplash" qu'il faut ajouter pour l'inhiber et rendre Tab/BackSpace efficace.

Il vaut mieux montrer que raconter.

Hors ligne

#12 02-04-2020 19:06:46

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

Ok, là malheureusement, j'atteins mes limites techniques: modifier le kernel, c'est quand même du temps quand on sait pas y faire et mon but n'est pas d'avoir à faire tab ni backspace à chaque fois que je démarre mon ordi. J'aurai voulu comprendre si au niveau du grub qui a un comportement étrange j'ai des probleme de sécurité ou pas sachant qu'il y a un comportement inhabituel par rapport au résultat attendu quand on installe avec le dvd debian. Est-ce que je réinstalle un grub avec le cd grub? Est-ce que le probleme avec le kernel pourrait avoir une incidence sur le programme de chiffrement?
Sinon, je vais passer à d'autres souci que j'ai sur l'ordi...:(
Merci beaucoup!

Hors ligne

#13 02-04-2020 19:26:39

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

giona a écrit :

modifier le kernel


Il n'est pas question de modifier le noyau mais de lui passer le paramètre "nosplash" via GRUB. Par l'édition du menu pour tester, dans /etc/default/grub si c'est efficace.
Si tu as fait le partitionnement assisté avec LVM chiffré, la phrase de passe sera demandée uniquement par l'initramfs sans affichage d'étoiles.

giona a écrit :

J'aurai voulu comprendre si au niveau du grub qui a un comportement étrange j'ai des probleme de sécurité ou pas sachant qu'il y a un comportement inhabituel par rapport au résultat attendu quand on installe avec le dvd debian


De quoi parles-tu ?


Il vaut mieux montrer que raconter.

Hors ligne

#14 02-04-2020 21:57:30

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

raleur a écrit :

Par l'édition du menu pour tester, dans /etc/default/grub si c'est efficace.


nope... J'ai rajouté nosplash dans le fichier grub, si j'ai bien compris ce que je devais faire, mais ça n'a pas changé...

raleur a écrit :

Si tu as fait le partitionnement assisté avec LVM chiffré, la phrase de passe sera demandée uniquement par l'initramfs sans affichage d'étoiles.


C'est pourtant bien ce que j'ai fais, d'où ma surprise et mon incompréhension.

De quoi parles-tu ?



du premier post. Comme il y a deux choses au démarrage qui me surprennent, j'ai eu un doute sur le possible lien entre eux.
J'ai fait une installation en mode graphique black avec partitionnement assisté lvm chiffré.

Hors ligne

#15 02-04-2020 22:16:10

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

giona a écrit :

J'ai rajouté nosplash dans le fichier grub, si j'ai bien compris ce que je devais faire, mais ça n'a pas changé


Et tu as exécuté update-grub ensuite pour regénérer grub.cfg ? Sinon effectivement ça ne change rien. C'est pour ça que je te dis de tester d'abord directement depuis le menu de GRUB.

giona a écrit :

du premier post. Comme il y a deux choses au démarrage qui me surprennent


Lesquelles ? Je n'ai rien vu d'autre que l'affichage d'étoiles lors de la frappe de la phrase de passe dans ton message initial.

Dernière modification par raleur (02-04-2020 22:16:38)


Il vaut mieux montrer que raconter.

Hors ligne

#16 03-04-2020 11:26:29

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

raleur a écrit :


Et tu as exécuté update-grub ensuite pour regénérer grub.cfg ? Sinon effectivement ça ne change rien.





raleur a écrit :

C'est pour ça que je te dis de tester d'abord directement depuis le menu de GRUB.


Alors ça par contre, je ne vois pas comment on teste directement depuis le menu de GRUB... Il fallait juste que j'écrive directement après être entré dans le grub via e ?


raleur a écrit :

Lesquelles ?


Le fait que le grub démarre avec une interface graphique d'un autre age...

Hors ligne

#17 03-04-2020 11:51:51

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

giona a écrit :

Alors ça par contre, je ne vois pas comment on teste directement depuis le menu de GRUB... Il fallait juste que j'écrive directement après être entré dans le grub via e ?


Oui à la fin de la ligne qui commence par "linux", et F10 pour démarrer ensuite (ne pas revenir au menu sinon les changements sont perdus. A la lecture de tes premiers message, je croyais que tu savais faire.

giona a écrit :

Le fait que le grub démarre avec une interface graphique d'un autre age.


Question de goût. J'aime la sobriété. GRUB est déjà assez usine à gaz comme ça, inutile d'en rajouter une couche graphique.

Dernière modification par raleur (03-04-2020 11:52:40)


Il vaut mieux montrer que raconter.

Hors ligne

#18 03-04-2020 12:04:54

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

C'est pas tant qu'elle me manque, seulement ça m'indique que quelque chose d'anormal s'est produit, isn't it?

Hors ligne

#19 03-04-2020 12:20:12

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

Non, pas forcément. Ça dépend ce que tu entends par "d'un autre âge".

Dernière modification par raleur (03-04-2020 12:20:23)


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums