Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-03-2020 22:19:22

giona
Membre
Inscription : 13-02-2017

pb grub et crypt après install

Salut à tou-te-s,
Je viens de réinstaller debian buster 10-3-0 amd64 mate après une première tentative aux multiples déconvenues principalement ergonomiques et d'usage comme des bug graphiques, impossibilité de copier coller dans le terminal et d'autres problemes dont ceux (ou "celui", si ces deux problemes sont liés?) qui reviennent après ma deuxième installation et qui me poussent à écrire ce post: grub qui ouvre possiblement en deux temps et avec une interface graphique très rustique: une premiere page avec

-debian GNU/LINUX
Options avancées pour Debian GNU/LINUX



si je vais sur la deuxieme ligne, ça dirige sur une page non moins rustique qui me propose:

- Debian GNU/LINUX, avec linux 4.19.0.8.amd64
Debian GNU/LINUX, avec linux 4.19.0.8.amd64 (recovery mode)



Si je laisse tourner ou que je tape directement sur entrée, il se charge et me propose de taper ma phrase de pass (puisque j'ai chiffré mon disque mais pas grub) et quand je la tape, les étoiles  apparaissent à la place des caractères!!!!

Voici le contenu de Grub dans /etc/default

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"




J'ai été voir sur ce post:
https://debian-facile.org/viewtopic.php?id=17452
mais il ne  m'a pas semblé que ça répondait à mes questions...

Qu'est-ce que je peux dire de plus sinon... bise avec les pieds smile

Dernière modification par giona (24-03-2020 22:23:19)

Hors ligne

#2 24-03-2020 22:44:19

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : pb grub et crypt après install

les étoiles  apparaissent à la place des caractères!!!!


C'est normal, les passphrases n'apparaissent jamais
.... au cas ou quelqu'un regarderait par dessus ton épaule ...

Dernière modification par ubub (24-03-2020 22:45:48)

Hors ligne

#3 25-03-2020 00:51:36

giona
Membre
Inscription : 13-02-2017

Re : pb grub et crypt après install

C'est normal


et non, il ne devrait y avoir rien du tout qui s'affiche!!!!! au cas où quelqu'un derriere mon épaule compte le nombre de caracteres de ma passphrase....

Hors ligne

#4 25-03-2020 11:41:00

raleur
Membre
Inscription : 03-10-2014

Re : pb grub et crypt après install

Ça dépend des goûts et des habitudes, et surtout du programme qui gère la saisie du mot de passe.
Historiquement, l'invite de login en mode texte d'Unix n'affiche rien. cryptsetup non plus. Par contre on peut constater que plymouth au démarrage et des gestionnaires de connexion graphique à l'ouverture de session affichent des étoiles ou des points.

Si le mot de passe de chiffrement est demandé par le gestionnaire de mot de passe système de systemd, l'affichage d'étoiles peut être désactivé en tapant sur la touche Tab ou BackSpace.

Hors ligne

Pied de page des forums