Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-05-2020 17:24:40

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bonjour à tous,

voilà mon problème:

lors d'un apt-get upgrade voilà le résultat:

 Les paquets suivants seront mis à jour :
  bind9-host dnsutils libbind9-161 libdns-export1104 libdns1104 libirs161
  libisc-export1100 libisc1100 libisccc161 libisccfg163 liblwres161
11 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/4904 ko dans les archives.
Après cette opération, 4096 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
dpkg: unrecoverable fatal error, aborting:
 loading files list file for package 'blender-data': cannot read /var/lib/dpkg/info/blender-data.list (Erreur d'entrée/sortie)
E: Sub-process /usr/bin/dpkg returned an error code (2)
 



j'ai essayé de désinstallé blender, impossible.
j'ai essayé de le réinstallé impossible également. Pareil pour inkscape.
j'ai utiliser le terminal, puis muon, mais bien sur c'est le même résultat.

ps: je suis certain de ne pas l'avoir installé... les seuls logiciels graphique que j'utilise sont gimp et rawthérapee... (je sais vous allez dire c'est pas possible...)

bref, je voudrais désinstallé blender et inkscape... proprement. Évidemment je ne comprend pas le message d'erreur...

Merci de votre aide. smile

Dernière modification par al1 (27-05-2020 16:10:50)

Hors ligne

#2 25-05-2020 17:28:13

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

j'ai oublier de mentionner que blender ne se lance pas.

Hors ligne

#3 25-05-2020 17:32:21

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

voici mes sources list

 
deb http://deb.debian.org/debian/ buster main contrib non-free
#deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://security.debian.org/debian-security buster/updates main

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ buster-updates main
 



je ne peux pas installer de logiciels... (???)

Hors ligne

#4 25-05-2020 17:35:30

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

blender-data semble bloquer tous téléchargements bizarre non?

Hors ligne

#5 25-05-2020 17:50:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.8 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Il semblerait qu'un fichier spécifique sur ton système ne soit pas lisible, ce qui empêche le bon fonctionnement de apt-get.
Est-ce que tu peux partager le retour de la commande suivante ?

stat /var/lib/dpkg/info/blender-data.list


Jouer sous Debian ? Facile !

Hors ligne

#6 25-05-2020 17:55:11

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

voici

Fichier : /var/lib/dpkg/info/blender-data.list
   Taille : 124461        Blocs : 248        Blocs d'E/S : 4096   fichier
Périphérique : 801h/2049d    Inœud : 8658758     Liens : 1
Accès : (0644/-rw-r--r--)  UID : (    0/    root)   GID : (    0/    root)
Accès : 2020-05-25 18:13:38.005262468 +0200
Modif. : 2020-05-18 12:11:52.941928649 +0200
Changt : 2020-05-18 12:11:52.997930235 +0200
  Créé : -

Hors ligne

#7 25-05-2020 17:55:33

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

désolé la balise autre code ne marche pas...

Hors ligne

#8 25-05-2020 17:58:20

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Au passage un bonjour à la Bretagne, ma mère est sur Tréguier, que c'est beau là-bas !!!

Hors ligne

#9 25-05-2020 17:58:54

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

al1 a écrit :

désolé la balise autre code ne marche pas...



tu peux les mettre à la main [balise]le code ici…[/balise] en remplaçant balise par code.

Hors ligne

#10 25-05-2020 18:00:52

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

ok

  Fichier : /var/lib/dpkg/info/blender-data.list
   Taille : 124461     Blocs : 248        Blocs d'E/S : 4096   fichier
Périphérique : 801h/2049d  Inœud : 8658758     Liens : 1
Accès : (0644/-rw-r--r--)  UID : (    0/    root)   GID : (    0/    root)
 Accès : 2020-05-25 18:13:38.005262468 +0200
Modif. : 2020-05-18 12:11:52.941928649 +0200
Changt : 2020-05-18 12:11:52.997930235 +0200
  Créé : -

Hors ligne

#11 25-05-2020 18:16:26

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Il faut continuer d'explorer wink Que dit la commande :


df /var/lib/dpkg/info
 

Hors ligne

#12 25-05-2020 18:19:16

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

voilà

 Sys. de fichiers blocs de 1K  Utilisé Disponible Uti% Monté sur
/dev/sda1          234263544 20434488  201859472  10% /

Hors ligne

#13 25-05-2020 18:21:07

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Bien, donc il n'y a pas de problème d'espace.

Hors ligne

#14 25-05-2020 18:27:38

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

d'accord... smile

Hors ligne

#15 25-05-2020 18:28:20

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Maintenant on va regarder si il y a des paquets cassés :


dpkg --list |grep ^..r
 



EDIT: Hum… il aurait mieux valu essayer :


dpkg --audit
 


C'est prévu pour !

Dernière modification par enicar (25-05-2020 18:30:33)

Hors ligne

#16 25-05-2020 19:06:58

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

aucune réponse...

Hors ligne

#17 25-05-2020 19:16:18

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : 5.8.7
(G)UI : openbox
Inscription : 26-08-2010

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Tout ça c'est bien embêtant… Et que dis :


apt-cache policy blender-data
 

Hors ligne

#18 25-05-2020 19:24:02

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Le fichier '/var/lib/dpkg/info/blender-data.list' est un fichier texte contenant la liste des fichiers du paquet associé.

Fais-en une copie et supprime le.

Désinstalle ensuite le paquet et réinstalle le.

Hors ligne

#19 25-05-2020 19:29:55

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

et voici

 blender-data:
  Installé : 2.79.b+dfsg0-7
  Candidat : 2.79.b+dfsg0-7
 Table de version :
 *** 2.79.b+dfsg0-7 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

Hors ligne

#20 25-05-2020 19:31:11

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

ok j'ai voulu faire cela mais j'ai eu peur... smile

ok je vais le faire...

Hors ligne

#21 25-05-2020 19:33:55

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Après la suppression du fichier, réinstalle juste le paquet, cela devrait suffire :

apt reinstall blender-data

Hors ligne

#22 25-05-2020 19:36:15

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

désolé pourriez-vous me dire comment le faire depuis le terminal... je ne peux le faire depuis thunar avec clic droit supprimer... (je l'ai copié et j'ai eu également un message d'erreur d'entrée/sortie mais j'ai pu le copier tout de même...)

Hors ligne

#23 25-05-2020 19:37:08

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

est-ce
apt-get autoremove blender-data  ?

Hors ligne

#24 25-05-2020 19:41:02

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 11-08-2015

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

Fais d'abord une copie le fichier pour voir :

cp /var/lib/dpkg/info/blender-data.list .

Hors ligne

#25 25-05-2020 20:05:39

al1
Membre
Lieu : sud france
Distrib. : Debian Buster
(G)UI : OpenBox
Inscription : 15-06-2018

Re : erreur apt-get upgrade et peu pas désinstallé un prog [RESOLUT]

voilà

 cp: erreur de lecture dans '/var/lib/dpkg/info/blender-data.list': Erreur d'entrée/sortie



en mode graphique j'ai eu la même réponse mais j'ai pu "ignorer" le message et le copier tout de même...

Hors ligne

Pied de page des forums