Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-06-2020 14:18:04

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Pas de gestion CSM dans le bios >

Bonjour la compagnie!

Je viens de recevoir un nouveau laptop Asus.
Je compte installer le classique dualboot Debian / Windows 10 mais je suis surprise...

En checkant le bios:

> je peux desactiver le fastboot
> je peux desactiver le Secure boot

Mais je ne vois aucune option dans ce bios, en ce qui concerne le CSM.

Le bios est de type "American Megatrends", version 314.

J'ai fait quelques recherche google mais sans résultat pour le moment.

Une idée ? Une expérience ?

D'avance merci pour votre aide

Hors ligne

#2 30-06-2020 14:56:43

raleur
Membre
Inscription : 03-10-2014

Re : Pas de gestion CSM dans le bios >

Bienvenue dans la modernité. Le BIOS/CSM, c'était trop simple et ça marchait trop bien, quel ennui. Vive l'UEFI ! Plein de nouveaux bugs passionnants !
Sinon, des fois ça s'appelle "legacy" plutôt que "CSM".

Concrètement, pourquoi as-tu besoin de CSM ?

Hors ligne

#3 30-06-2020 15:16:13

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Salut raleur, et grand merci pour ton aide.

Histoire de préparer ma future install, j'ai consulté ce tuto: https://debian-facile.org/doc:install:d … -de-l-uefi

Dans la section "Désactiver le secure boot et autres configurations" il est indique qu'il faut desactiver le CSM.
Du coup j'ai deja jete un coup d'oeil dans le bios histoire de reperer ce dont j'ai besoin et je n'ai rien vu concernant le CSM. D'ou ma question wink

Je n'ai rien vu concernant le legacy non plus.

Maintenant, pour un peu plus de contexte... j'ai 2 HDD:

> un SSD avec windows, qui contient un EFI.
> un HDD que j'ai deja partitionne: 500GB pour mes datas et 500GB pour ma future debian.

Ce dont je suis certaine, c'est que le fast boot et le secure boot doivent etre desactives.
Mais pour le CSM... maintenant tu me fais douter.

Hors ligne

#4 30-06-2020 15:24:02

raleur
Membre
Inscription : 03-10-2014

Re : Pas de gestion CSM dans le bios >

caema a écrit :

Dans la section "Désactiver le secure boot et autres configurations" il est indique qu'il faut desactiver le CSM.


Pas obligatoire. Ça ne sert que pour s'assurer que l'ordinateur ne bootera jamais en legacy par accident.

caema a écrit :

Ce dont je suis certaine, c'est que le fast boot et le secure boot doivent etre desactives.


Pas forcément. Debian 10 est compatible avec le secure boot.
Quant au fast boot, je n'ai jamais eu besoin d'y toucher. On le confond souvent avec le démarrage rapide (fast startup) de Windows, qui n'a rien à voir.

Dernière modification par raleur (30-06-2020 15:30:26)

Hors ligne

#5 30-06-2020 15:35:16

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Oh... et bien je me suis compliqué la tache en fait !
Comme on dit.. pourquoi faire simple quand on peut faire complique..

Bon, et bien merci pour ces quelques precisions bien utiles.

Je vais donc laisser le secure boot et le fast boot actives, et.... lancer une install !


Merci !

Dernière modification par caema (30-06-2020 15:58:23)

Hors ligne

#6 30-06-2020 15:57:14

raleur
Membre
Inscription : 03-10-2014

Re : Pas de gestion CSM dans le bios >

Concernant le secure boot, il vaut quand même mieux le désactiver si tu n'en as pas besoin. Ça complique les choses, et ça peut poser des problèmes.

Hors ligne

#7 30-06-2020 15:58:50

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Ok, bien recu pour le secure boot !

On verra pour la suite ce soir mais j'anticipe un petit truc...

J'ai deja eu, lors de l'installation (au moment de partitionner si je me souviens bien) une question de type de ce type:

"This machine's firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using "BIOS compatibility mode". If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.
If you wish to install in UEFI mode and don't care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here."

SI cela se passe encore, maintenant que tu connais un peu le workflow que je souhaite mettre en place (2 HDD > un contient windows et l'autre Debian ), qui suis-je censee repondre ?

Hors ligne

#8 30-06-2020 16:19:56

KsmoinO
Modérateur
Distrib. : Raspbian stable/testing/sid
Noyau : Linux 4
(G)UI : i3
Inscription : 05-10-2007

Re : Pas de gestion CSM dans le bios >

Bonjour

Normalement en suivant la doc à l'étape Partitionnement (https://debian-facile.org/doc:install:d … tionnement) tu as ce qu'il faut pour ne pas avoir ce message. C'est à dire la partition EFI windows doit être détectée comme tel par l'installer (et potentiellement montée dans /boot/efi).

De plus comme ton système ne semble pas gérer le boot bios, le mode de compatibilité BIOS ne devrait pas être utilisé dessus. Donc tu devrais pouvoir continuer malgré tout.

Hors ligne

#9 30-06-2020 16:34:42

raleur
Membre
Inscription : 03-10-2014

Re : Pas de gestion CSM dans le bios >

Tiens, tu fais l'installation en anglais ?

En clair, l'installateur demande s'il faut forcer l'installation en mode UEFI car il a été amorcé en mode UEFI et il semble exister un système installé utilisant le mode de compatibilité BIOS (legacy/CSM). Apparemment les critères de détection possibles sont :
- étiquette de disque ("disk label" = table de partition) DOS avec au moins une partition primaire ou logique
- étiquette de disque GPT avec une partition d'amorçage BIOS (BIOS boot) et pas de partition système EFI (ESP)

Cet avertissement n'a aucune raison de se produire avec des disques vides.
Si le firmware UEFI de la machine ne supporte pas le boot legacy/CSM, alors ne pas forcer l'installation en mode UEFI produira un système non amorçable.

Recommendations :
- Une partition système EFI sur chaque disque pour l'OS correspondant pour une indépendance totale des deux OS. Installe Windows en premier, il créera la sienne sur son disque. Lors de l'installation de Debian, si tu choisis le partitionnement manuel, assure-toi que le disque a une étiquette GPT (pas obligatoire mais mieux pour l'UEFI et d'autres choses alors pourquoi se priver) et crée une autre partition EFI sur l'autre disque et marque celle de Windows comme "ne pas utiliser".

Hors ligne

#10 30-06-2020 21:22:55

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Bon alors à l'installation s'est bien passée !
Merci pour vos conseils.

Par contre.. Au reboot, pas de windows au grub
J'ai tout de même tenté le démarrage debian et j'ai pas mal d'erreurs de ce type:
watchdog: BUG: soft lockup - CPU#10 stuck for 23s! [kworker/10:1:118] 512.385371]
Et je reste "coincée" sans pouvoir démarrer debian.

Je penche pour un problème matériel mais si vous avez un avis

Hors ligne

#11 30-06-2020 21:49:50

raleur
Membre
Inscription : 03-10-2014

Re : Pas de gestion CSM dans le bios >

Ce matériel est peut-être un peu trop récent pour cette version de Debian.

Hors ligne

#12 30-06-2020 22:08:42

KsmoinO
Modérateur
Distrib. : Raspbian stable/testing/sid
Noyau : Linux 4
(G)UI : i3
Inscription : 05-10-2007

Re : Pas de gestion CSM dans le bios >

Certains ayant eu ce problème l'ont corrigés de plusieurs façons dont
- Maj kernel
- remplacement alim trop juste
(voir avec une recherche internet avec "BUG: soft lockup")

Si tu as une grosse carte vidéo dans la machine ou un autre périphérique gourmand, tu peux essayer de le retirer et de redémarrer sans.

Sinon booter sur un live, faire un chroot et essayer de mettre à jour grub, l'initrd et le kernel

Enfin pour ton boot windows dès que tu auras un linux il faudrait voir le retour de la commande fdisk -l pour s'assurer qu'on ait toujours les partitions windows.

Hors ligne

#13 Hier 09:44:38

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Merci pour vos reactions.

> Au niveau de ma version de Debian: debian-live-10.4.0-amd64-kde.iso

> Pour la configuration du laptop:

ASUS VivoBook (N580GD-E4045T).

* Intel Core i7-8750H
* 16 GB DDR4
* GeForce GTX 1050 (4 GB)
* SSD 256 GB + HDD 1TO

Impossible pour moi de toucher a l'alim ou la carte graphique vu que c'est un laptop.
Je vais tenter, ce soir j'espere, de booter sur le live.

pour la mise a jour du kernel... je ne suis pas vraiment au courant et je vais avoir besoin d'eclaircissement a ce niveau si vous avez des details je suis preneuse.

Oh et autre precision, j'ai pas windows dans le GRUB menu, mais la partition est toujours presente, hier soir j'ai pu y acceder en bidouillant dans le BIOS.
Puis windows est sur le SSD, Debian a ete installe sur le HDD.

Je vais faire quelques recherches Google egalement et j'essaye de vous tenir au jus des que j'ai pu realiser certains tests.

Dernière modification par caema (Hier 09:45:44)

Hors ligne

#14 Hier 11:59:22

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.6.0 amd64
(G)UI : Xfce4 - LightDM
Inscription : 24-06-2014

Re : Pas de gestion CSM dans le bios >

Si ce matériel est TROP récent je ne vois que deux solutions :
- garder debian10 et installer un noyau récent depuis les backports
- installer bullseye (noyau 5.7 depuis aujourd'hui !) ce qui serait préférable car il prend "mieux" en charge les pilotes Nvidia

Ce qui est à la portée d'un débutant éveillé . . .  coffeecup.gif

Dernière modification par jarek (Hier 12:02:09)


Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.
Ryzen3 3200G - Asrock B450

En ligne

#15 Hier 12:09:15

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

merci pour ces nouvelles informations!

Je vais me renseigner sur bullseye, je ne connais pas du tout.

EDIT: ahhhh nouvelle Debian wink

Mais visiblement, vous penchez plutot pour un souci au niveau de la carte graphique si je comprends bien.

Dernière modification par caema (Hier 12:12:17)

Hors ligne

#16 Hier 13:08:17

KsmoinO
Modérateur
Distrib. : Raspbian stable/testing/sid
Noyau : Linux 4
(G)UI : i3
Inscription : 05-10-2007

Re : Pas de gestion CSM dans le bios >

Bonjour

La carte graphique n'est qu'une piste parmi d'autre wink. Dans ton cas l'installation de Debian bullseye sera peut être la solution la plus simple. Elle évitera de devoir booter sur un live pour faire un chroot pour faire les mises à jour.

Si malgré tout tu veux tenter le chroot tu peux trouver de la doc ici : https://debian-facile.org/doc:systeme:chroot

Une fois dans le chroot, tu pourras faire les mises à jours du système installé (apt-get update && apt-get dist-upgrade), mettre à jour l'initram (update-initramfs -k all -u), vérifier que ton install voit bien windows (os-prober) et mettre à jour grub (update-grub2) et essayer de rebooter.

Hors ligne

#17 Hier 13:18:18

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Pfffff vous etes au top sur ce forum...

Merci pour toutes ces explications et informations.

J'espere vraiment avoir le temps de tester cela ce soir car je suis au bureau, mais je viendrai de toute façon rendre des comptes ici wink

Au passage KsmoinO, vu que tu es moderateur, aucun souci si le titre de mon post ne correspond plus vraiment ?

Merci!

Hors ligne

#18 Hier 13:44:30

KsmoinO
Modérateur
Distrib. : Raspbian stable/testing/sid
Noyau : Linux 4
(G)UI : i3
Inscription : 05-10-2007

Re : Pas de gestion CSM dans le bios >

Je suis un vieux modérateur, ça devait faire 10 ans que je n'étais pas revenu sur le forum big_smile

Je laisserai les actuels voir si besoin wink

Hors ligne

#19 Hier 15:16:38

jarek
Membre
Lieu : Haute Loire
Distrib. : bullseye
Noyau : linux 5.6.0 amd64
(G)UI : Xfce4 - LightDM
Inscription : 24-06-2014

Re : Pas de gestion CSM dans le bios >

Je ne penche pas du tout vers un problème précis, simplement la question a été soulevée par Raleur (matériel trop récent ?), et je propose.
Pour bullseye ou backports buster, voir la doc Debian, ça commence là https://wiki.debian.org/fr/FrontPage

Le Diable a inventé l'Administration afin que les Hommes perdent tout espoir à jamais.
Ryzen3 3200G - Asrock B450

En ligne

#20 Hier 15:25:01

caema
Membre
Distrib. : Debian GNU/Linux 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Plasma | KDE
Inscription : 15-09-2017

Re : Pas de gestion CSM dans le bios >

Grand merci a vous toutes et tous.

Je vous tiens au courant durant la semaine smile

Hors ligne

Pied de page des forums