Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-08-2020 14:45:10

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

[Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour,

Tout nouvellement inscrit sur Debian-Facile, je me lance avec une 1er problème roll
Depuis 2j, lorsque je démarre mon ordinateur, tout est normal, c'est-à-dire que mon clavier est en Azerty, correspondant bien à l'option "Français (variante)" (celle où Shift+AtlGr+é donne un É) choisie et affichée dans les paramètres linguistiques (et je peux rentrer mon mot de passe sans soucis).
Sauf que, Firefox, mais aussi Thunderbird notamment, sont en Qwerty...
J'ai testé aussi, Whatdesk, Signal-desktop, qui il me semble sont des applications empaquetées Electron, et donc embarquant Chromium...?

Ça ressemblerait fort au problème rencontré par Kellogs ici...
Par contre, je ne vois pas trop comment adopter la solution proposée, ne sachant pas backporter une application sur une version différente... et ma version du paquet xkb-data semblant être la version stable (2.26-2, en tout cas celle embarquée dans Buster stable).

Pour ne pas avoir à apprendre en accéléré le clavier Qwerty sans l'avoir sous les yeux, et pouvoir utiliser mes logiciels (Firefox est probablement le logiciel le plus utilisé sur mon ordi neutral), j'ai trouvé (je ne sais plus où) la commande :

setxkbmap fr


qui me remet bien mon clavier en Azerty, mais pas en "Français (variante)"... : Shift+AtlGr+é donne un ⅛ ...
Par contre, cette commande ne semble avoir aucune implication sur l'ensemble des autres applications, qui continuent d'utiliser l'option "Français (variante)".

Pour info, je lance régulièrement les mises à jour via

sudo apt update

puis

sudo apt upgrade


et ne saurais pas vraiment dire si cela est apparu après une mise à jour ou pas... (dans le même temps, j'essaye aussi de trouver une solution à un problème de mise en veille-extinction de l'ordinateur, ça sera le sujet d'une demande d'aide dans un autre fil).

Voilà ! Bon, on en survit, mais tout de même, c'est pas très marrant d'avoir à faire cette commande après chaque démarrage, et d'avoir ses combinaisons de touches perturbées lors de l'écriture.
Si quelqu'un a des pistes, je suis preneur ! hmm
Merci d'avance.

(note: j'ai posté dans la partie Matériel du forum, suivant le post mentionné plus haut, mais si besoin, je peux le déplacer ailleurs)

Dernière modification par greb (13-09-2020 22:02:16)


Ordinateur portable Thinkpad W540

Hors ligne

#2 26-08-2020 15:38:43

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour
ceci est correct chez toi ?


cat /etc/default/keyboard
 



# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""

BACKSPACE="guess"
 


le paquet pour mettre firefox en fr est installé ?


apt-cache policy firefox-esr-l10n-fr
 



firefox-esr-l10n-fr:
  Installé : 68.11.0esr-1
  Candidat : 68.11.0esr-1
 Table de version :
 *** 68.11.0esr-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        500 https://deb.debian.org/debian bullseye/main i386 Packages
        100 /var/lib/dpkg/status
 



et ceci


cat /etc/default/locale
 



#  File generated by update-locale
LANG="fr_FR.UTF-8"
 



Nota: si tu a fait une installation en Français normalement ça se passe bien
ta machine est un portable ou PC de bureau ?

idem pour Thunderbird tu a un paquet pour "fr"


thunderbird-l10n-fr
 



si tout est correct voir si quelqu'un a une idée  roll

Dernière modification par robert2a (26-08-2020 15:48:54)

En ligne

#3 26-08-2020 15:45:08

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour robert2a,
Merci beaucoup de prendre du temps pour mon souci !

Pour les commandes :

$ cat /etc/default/keyboard
XKBLAYOUT=fr
XKBVARIANT=oss
BACKSPACE=guess
 



Pour Firefox, oui, normalement :

$ sudo apt install firefox-esr-l10n-fr
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
firefox-esr-l10n-fr est déjà la version la plus récente (68.11.0esr-1~deb10u1).



Et

$ cat /etc/default/locale
#  File generated by update-locale
LANG=fr_FR.UTF-8
 


Ordinateur portable Thinkpad W540

Hors ligne

#4 26-08-2020 15:59:33

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

pour l'ordi un => Thinkpad W540  smile  (pas vue avant )

évite de faire un "install" sur un paquet déjà installé , avec "apt" tu a des commandes pour visualiser l'état d un paquet
ou utilise l'option "--reinstall install" pour éviter de passer le paquet en " installer manuellement "

attendre voir si quelqu'un d'autre  a une idée pour ce souci.  smile

En ligne

#5 26-08-2020 19:41:50

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Ah, ok, je ne savais pas pour "apt install", je note, merci ! smile

Ordinateur portable Thinkpad W540

Hors ligne

#6 08-09-2020 13:59:39

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour,
Pas d'avancée de mon côté (et je me fais avoir à chaque démarrage en oubliant que certaines applications sont en Qwerty…).
J'ai juste trouvé que la commande

setxkbmap fr oss


permettait de mettre mon clavier dans la configuration souhaitée ; Français - variante (cf. 1er post).
Je continue de fouiller…
Et bien sûr, je suis preneur de toute nouvelle piste d'investigation wink


Ordinateur portable Thinkpad W540

Hors ligne

#7 08-09-2020 18:06:26

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour,
J'utilise aussi Thunderbird et firefox, en francais (et azerty ..), avec les paquets dédiés ...l10n-french , et ça marche ..
Par contre j'ai le même fichier /etc/default/keyboard que cité plus haut par Robert2a ..
Peut-être, une fois copié ton fichier actuel (pour le remettre si ca marche pas ) , tu peux essayer de changer les variables

XKBVARIANT="latin9"


et peut-être aussi rajouter au début

XKBMODEL="pc105"


pour avoir un fichier ressemblant au notre, et voir si ça change qqchose ..
sinon, aussi, j'ai trouvé ça sur le net : https://hotline.asdrad.com/selectionner … ier_fr-oss
où ils donnent une maniere d'activer un clavier oss sous debian (mais je sais pas ce que ca vaut, ni exactement ce que ca fait ...)
ce que j'en ai lu sur le net , c'est que tu n'es pas le seul a avoir un probleme avec "oss"
sinon, y'a peut-etre des pistes là aussi:
https://forum.kubuntu-fr.org/viewtopic.php?id=2053819
Une fois les modifs faites, j'imagine il faut rebooter l'ordinateur ..

Hors ligne

#8 09-09-2020 16:43:51

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour ubub,
Merci beaucoup pour tes suggestions.
Malheureusement, aucune ne semble changer quoi que ce soit…
J'ai modifié suivant tes conseils

XKBVARIANT="latin9"


et

XKBMODEL="pc105"


puis redémarré, mais rien n'y fait…
Par curiosité, j'ai tenté d'ajouter des guillemets aux paramètres :

XKBVARIANT="oss"


au lieu de

XKBVARIANT=oss


comme cela était dans mon fichier d'origine. Mais pas de changement non plus.

J'ai aussi tenté un

sudo dpkg-reconfigure keyboard-configuration


avec redémarrage, mais pas d'évolution non plus…
Mais je garde espoir, la solution doit bien exister quelque part ! roll


Ordinateur portable Thinkpad W540

Hors ligne

#9 11-09-2020 17:22:12

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonjour,
Pas trouvé de solution de configuration qui me semble vraiment résoudre le problème…

En attendant, suivant la suggestion du dernier message de ce post, j'ai fait de la sorte :
1. J'ai créé dans mon dossier /home/user/ un fichier clavier_fr_oss_demarrage.sh :


#!/bin/bash
setxkbmap fr oss
 


2. J'ai rendu exécutable ce fichier
3. J'ai créé dans mon dossier /home/user/.config/autostart/ un fichier setxkbmap-fr-oss.desktop :


[Desktop Entry]
Name=Clavier-fr-oss
Exec=/home/benjamin/clavier_fr_oss_demarrage.sh
Terminal=false
Type=Application
Comment=Reorder keyboard map to French-variant for all apps
 


qui fait comme si il y avait une application setxbkmap et la lance au démarrage de ma session.

Cela semble fonctionner smile

Bien que je doute que ce soit la manière la plus "propre" de résoudre le problème...
Je reste donc preneur de toute solution davantage "dans les règles" roll


Ordinateur portable Thinkpad W540

Hors ligne

#10 13-09-2020 22:01:54

greb
Membre
Lieu : Malawi
Distrib. : Debian 10 (+ W10)
Noyau : Linux 4.19.0-11-amd64
(G)UI : Gnome 3
Inscription : 25-08-2020

Re : [Résolu] Bug - Firefox, Thunderbird en Qwerty

Bonsoir,

Nouvel épisode dans mon soucis, avec un autre semblant de solution.

Par curiosité, j'ai tenté de me connecter sur ma session avec d'autres environnements de bureau, dont Cinammon, et LXQt installé pour l'occasion (paquet lxqt-core), en désactivant la solution du post précédent (lancement de setxkbmap fr oss au démarrage).
Dans les choix proposés à l'ouverture de session, j'ai pour Gnome les choix suivants :
- Gnome
- Gnome classique
- Gnome sur Xorg

Au final, sur Gnome, le clavier est en Qwerty.
Par contre, pour Gnome classique, Gnome sur Xorg, Cinammonet LXQt, il ne semble pas y avoir ce problème, et dans les applications où j'avais le problème, le clavier est bien en Azerty.

Je ne saurais pas expliquer la raison du pourquoi… mais ça semble régler en tous cas mon soucis, sans configuration hasardeuse, et sans changer radicalement mon bureau (Gnome sur Xorg semble être exactement similaire visuellement et en utilisation que Gnome, en tous cas en première approche).

Je passe donc le sujet en résolu.

Merci en tous cas pour toutes les pistes apportés !

Ordinateur portable Thinkpad W540

Hors ligne

Pied de page des forums