Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-09-2020 16:20:11

JesusKS
Membre
Distrib. : MX Linux 18.3 basé sur Debian 9
Noyau : Linux 4.19.0-1-amd64
(G)UI : i3wm
Inscription : 30-08-2016

[Résolu] Grub ne détecte pas les linux antérieurement installés

Grub ne détecte pas mon ancien linux après installation d'une +récente

Bonjour à tous,

J'espère que vous pourrais m'aider !

Je disposais de la distribution MXlinux 18.3 basée sur Debian 9 (après mise à jour car à la base c'était une 18.1 ) et à cause d'un problème avec Virtualbox que je n'arrivais pas à résoudre je me suis décidé à installer une nouvelle version sur une petite partition spécialement pour VB. Après cela, j'ai vu que grub n'affichait pas le premier système, mais aussi, accessoirement, que le choix de démarrage entre systèmes D ou non (MXLinux permet au démarrage d'avoir le choix) est en doublon (2 fois avec système D et deux fois sans). J'ai supposé avec espoir au départ que c'était peut-être un bogue genre mauvais renommage et j'ai essayé différentes entrées pour voir si je tombais sur MX 18 mais non... Par la suite j'ai fais un update-grub mais ça ramène à la même chose. Dramatique.

J'ai une piste : peut-être (je ne sais plus) que grub était sur le mbr ou gpt sur le MX 18 mais là tandis que le grub était du MX19 était sur l'EFI et que ça cause un problème (mais du coup windows que je n'utilise quasi-jamais est détecté donc peut-être que c'est une fausse piste).

Je vous demande de l'aide S.V.P.

Je vous remercie, désolé pour les probables fautes de français...

Edit : fautes corrigées au mieux.

Dernière modification par JesusKS (22-09-2020 20:26:51)

Hors ligne

#2 22-09-2020 19:10:53

JesusKS
Membre
Distrib. : MX Linux 18.3 basé sur Debian 9
Noyau : Linux 4.19.0-1-amd64
(G)UI : i3wm
Inscription : 30-08-2016

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

Bon grâce à Dieu j'ai pu résoudre le problème grâce à Dieu. J'explique :

En allant dans le bios j'ai vu que la distrib MX18 était disponible donc je l'ai mis en première dans la liste. Effectivement je suis retombé sur le grub que j'avais auparavant.
Ensuite j'ai fais un sudo update-grub et j'ai reboot l'ordinateur et là le grub listait la nouvellement installée MX19.

J'ai une explication logique : le grub de la MX19 est cantonnait la partition de la MX19 tandis que le grub de la MX18 est en amont à l'amorçage, sur l'efi (le mbr d'uefi). Ce qui explique que l'un détecte toutes les distro et l'autre non.

J'espère que ça servira à quelqu'un.

Ciao bonne semaine.

Dernière modification par JesusKS (22-09-2020 19:11:37)

Hors ligne

#3 22-09-2020 19:34:17

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

JesusKS a écrit :

J'espère que ça servira à quelqu'un.


Surtout si tu ajoutes que c'est résolu dans le titre :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. coyotus.png


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 22-09-2020 19:48:45

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

JesusKS a écrit :

le grub de la MX19 est cantonnait la partition de la MX19

scratchhead.gif moi lapin compris !


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#5 22-09-2020 19:56:24

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

Jean-Pierre Pinson a écrit :

le grub de la MX19 est cantonnait la partition de la MX19


le grub de la MX19 se cantonnait à la partition de la MX19 sans gérer l'autre installation. smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 22-09-2020 20:17:08

JesusKS
Membre
Distrib. : MX Linux 18.3 basé sur Debian 9
Noyau : Linux 4.19.0-1-amd64
(G)UI : i3wm
Inscription : 30-08-2016

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

smolski a écrit :

Jean-Pierre Pinson a écrit :

le grub de la MX19 est cantonnait la partition de la MX19


le grub de la MX19 se cantonnait à la partition de la MX19 sans gérer l'autre installation. smile




Oui je fais plusieurs trucs en même temps donc j'écris trop vite désolé. Merci je vais mettre en résolu !

Hors ligne

#7 22-09-2020 20:39:50

JesusKS
Membre
Distrib. : MX Linux 18.3 basé sur Debian 9
Noyau : Linux 4.19.0-1-amd64
(G)UI : i3wm
Inscription : 30-08-2016

Re : [Résolu] Grub ne détecte pas les linux antérieurement installés

JesusKS a écrit :

e choix de démarrage entre systèmes D ou non (MXLinux permet au démarrage d'avoir le choix) est en doublon (2 fois avec système D et deux fois sans).



En fait en m'attardant sur les différentes entrées de la MX19, c'est la version du noyau 4.19 qui diffère...

Dernière modification par JesusKS (22-09-2020 20:40:09)

Hors ligne

Pied de page des forums