Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-10-2020 11:30:20

robert2a
Membre
Inscription : 15-11-2014

Problème dépendance i386 .

Bonjour
sur bullseye j'ai un souci avec ce paquet qui ne peut être mit a jour


libllvm10/testing 1:10.0.1-6+b1 i386 [pouvant être mis à jour depuis : 1:10.0.1-6]
 




aptitude -s install libllvm10:i386
Les paquets suivants seront ENLEVÉS :                  
  libllvm10{a} linux-headers-5.8.0-2-amd64{u} linux-headers-5.8.0-2-common{u}
Les paquets suivants seront mis à jour :
  libllvm10:i386
1 paquets mis à jour, 0 nouvellement installés, 3 à enlever et 16 non mis à jour.
Il est nécessaire de télécharger 16,5 Mo d'archives. Après dépaquetage, 136 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 mesa-opencl-icd : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
 libxatracker2 : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
 libclang-cpp10 : Dépend: libllvm10 (= 1:10.0.1-6) but it is not going to be installed
 libgl1-mesa-dri : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
 libclang-common-10-dev : Dépend: libllvm10 (= 1:10.0.1-6) but it is not going to be installed
 mesa-vdpau-drivers : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
 mesa-vulkan-drivers : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
 mesa-va-drivers : Dépend: libllvm10 (>= 1:9~svn298832-1~) but it is not going to be installed
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libllvm10 [1:10.0.1-6 (now, testing)]                    
2)     libllvm10:i386 [1:10.0.1-6 (now)]                        



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                      
1)      libgl1:i386 [1.3.2-1 (now, testing)]                                
2)      libgl1-mesa-dri:i386 [20.1.9-1 (now, testing)]                      
3)      libgl1-mesa-glx:i386 [20.1.9-1 (now, testing)]                      
4)      libglx-mesa0:i386 [20.1.9-1 (now, testing)]                          
5)      libglx0:i386 [1.3.2-1 (now, testing)]                                
6)      libllvm10:i386 [1:10.0.1-6 (now)]                                    
7)      mesa-vulkan-drivers:i386 [20.1.9-1 (now, testing)]                  
8)      steam:i386 [1.0.0.66-2 (now, testing)]                              

      Conserver les paquets suivants dans leur version actuelle :            
9)      libllvm10 [1:10.0.1-6 (now, testing)]                                

      Leave the following dependencies unresolved:                          
10)     libvulkan1:i386 recommande mesa-vulkan-drivers:i386 | vulkan-icd:i386
11)     steam-devices recommande steam                                      
12)     steam:i386 recommande mesa-vulkan-drivers:i386                      



enlever le paquet ça me casse pas mal de chose
mettre a jour le paquet  idem

j'ai la version installé => liblllvm 1:10.0.1-6 i386
la version a mettre a jour => libllvm 1:10.0.1-6+b1 i386

nota: je suis sur une machine AMD R3 2200G driver libre amdgpu et le noyau 5.9.1-1 , steam:i386 est installé.


apt policy libllvm10 libllvm10:i386
libllvm10:
  Installé : 1:10.0.1-6
  Candidat : 1:10.0.1-6
 Table de version :
 *** 1:10.0.1-6 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libllvm10:i386:
  Installé : 1:10.0.1-6
  Candidat : 1:10.0.1-6+b1
 Table de version :
     1:10.0.1-6+b1 500
        500 http://deb.debian.org/debian bullseye/main i386 Packages
 *** 1:10.0.1-6 100
        100 /var/lib/dpkg/status
 

Dernière modification par robert2a (30-10-2020 11:48:04)

Hors ligne

#2 30-10-2020 13:20:39

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème dépendance i386 .

et si tu simules un apt upgrade ?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#3 30-10-2020 13:31:07

robert2a
Membre
Inscription : 15-11-2014

Re : Problème dépendance i386 .

le retour


apt -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libllvm10:i386
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
 

Hors ligne

#4 30-10-2020 14:08:22

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Problème dépendance i386 .

Ce souci est corrigé depuis un moment en Debian Sid. Si pour une raison quelconque tu souhaites rester avec testing, il va falloir attendre que la version 1:10.0.1-7 de libllvm10 y arrive.

À savoir qu’il y a un risque d’attendre un bon moment, ce paquet étant concerné par la transition en cours vers ocaml 4.11.1.

Jouer sous Debian ? Facile !

En ligne

#5 30-10-2020 14:13:09

robert2a
Membre
Inscription : 15-11-2014

Re : Problème dépendance i386 .

ok je bascule en sid , merci pour l'information
je sais que mesa demande des dépendances que testing n'a pas encore
je vais voir si je fait une mise a jour partielle pour libllvm10 ou complète vers sid

Hors ligne

#6 30-10-2020 17:41:31

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Problème dépendance i386 .

robert2a a écrit :

je vais voir si je fait une mise a jour partielle pour libllvm10 ou complète vers sid


Je pense que tu sais déjà ce que je conseille ici wink


Jouer sous Debian ? Facile !

En ligne

#7 30-10-2020 18:51:31

robert2a
Membre
Inscription : 15-11-2014

Re : Problème dépendance i386 .

oui je me doute wink
pour ce coup la je suis frileux , je vais attendre encore un peu , 156 paquets a mettre a jour , et je reste confiant sur testing .
tien j'ai vue que le driver nvidia sur sid  a évoluer , ça risque d'avoir résolu la compilation avec le 5.9.1-1 , reste a vérifier si cuda 10 tourne bien avec ce driver.
si j'ai le temps je teste a moins que quelqu'un confirme que tout est correct.
ps: sur cette machine je suis en AMD donc driver "free"

Hors ligne

Pied de page des forums