Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-11-2020 19:43:02

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

[Résolu] 3 paquets dans un état incohérent

Bonjour à tous,
depuis quelques temps j'ai trois paquets que je n'arrive pas à réparer. J'arrivais à vivre avec mais là ça me bloque pour installer autre chose (Discord en l'occurrence).
Voici l'erreur :

sudo apt-get upgrade

         
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  mercurial-common python-libxml2 python-pil
3 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
38 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 544 ko dans les archives.
Après cette opération, 4 096 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 320651 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mercurial-common_4.0-1+deb9u2_all.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mercurial-common_4.0-1+deb9u2_all.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Préparation du dépaquetage de .../python-libxml2_2.9.4+dfsg1-2.2+deb9u3_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-libxml2_2.9.4+dfsg1-2.2+deb9u3_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Préparation du dépaquetage de .../python-pil_4.0.0-4+deb9u2_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/mercurial-common_4.0-1+deb9u2_all.deb
 /var/cache/apt/archives/python-libxml2_2.9.4+dfsg1-2.2+deb9u3_amd64.deb
 /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ces paquets ne sont pas à jour, mais quand j'essaie de les mettre à jour avec Synaptic, j'obtiens :

E: /var/cache/apt/archives/mercurial-common_4.0-1+deb9u2_all.deb: le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
E: /var/cache/apt/archives/python-libxml2_2.9.4+dfsg1-2.2+deb9u3_amd64.deb: le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
E: /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb: le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1

Et si j'essaie de les supprimer dans Synaptic :

E: mercurial-common: Le paquet est dans un état incohérent; vous devriez  le réinstaller avant d'essayer de le supprimer.
E: python-libxml2: Le paquet est dans un état incohérent; vous devriez  le réinstaller avant d'essayer de le supprimer.
E: python-pil: 2.6087:Le paquet est dans un état incohérent; vous devriez  le réinstaller avant d'essayer de le supprimer.
 


Quant à l'installation de Discord :

sudo gdebi discord-0.0.12.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
Nécessite l'installation des paquets suivants : python-pil

Chat for Communities and Friends
 Discord is the easiest way to communicate over voice, video, and text. Chat,
 hang out, and stay close with your friends and communities.
Voulez-vous installer le paquet logiciel ? [o/N] :o
Fetched 0 B in 0s (0 B/s)                                                                                                                                                                    
Lecture des fichiers de modifications (« changelog »)... Terminé
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 320684 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-pil_4.0.0-4+deb9u2_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb
E:Sub-process /usr/bin/dpkg returned an error code (1)
 


Voilà, il s'agit peut-être de problèmes différents.
J'avoue que le plus urgent serait que j'arrive à faire fonctionner Discord, mais la méthode propre serait de réparer ces trois paquets.
Les méthodes trouvées ici ou là pour faire ça sont spécifiques à d'autres paquets ou consiste à supprimer des trucs en faisant attention, ce qui m'inquiète un peu...
Si vous avez des suggestions, je suis preneur.

Dernière modification par mth (05-11-2020 22:29:19)

Hors ligne

#2 05-11-2020 00:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] 3 paquets dans un état incohérent

Bonsoir mth,

mth a écrit :

le plus urgent serait que j'arrive à faire fonctionner Discord,


Regarde du côté d'appimage, flatpak ou snap... c'est légèrement lourdingue furieusement tendance.
Une alternative à tout ce bazar, est d'« Ouvrir Discord dans ton navigateur » (ne fais pas de chichi).

mth a écrit :

mais la méthode propre serait de réparer ces trois paquets.


Le problème initial semble lié au fait que /usr/bin/python pointe vers python3.5, et non python2.7 :

file /usr/bin/python

/usr/bin/python: symbolic link to python3.5


La solution consiste à supprimer ce lien symbolique... puis à recréer un lien python vers python2.7 :

sudo unlink /usr/bin/python


sudo ln -sv python2.7 /usr/bin/python

'/usr/bin/python' -> 'python2.7'


sudo apt-get --fix-broken install


Tu devras peut-être réinstaller (et/ou reconfigurer) certains paquets, à voir en fonction des retours.

Dernière modification par èfpé (05-11-2020 20:04:42)

Hors ligne

#3 05-11-2020 02:58:57

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] 3 paquets dans un état incohérent

Bonsoir
je pense qu'il serait bon de faire le point sur ta stretch avant de vouloir installé quoique ce soit
par exemple

Les paquets suivants seront mis à jour :
  mercurial-common python-libxml2 python-pil
3 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
38 partiellement installés ou enlevés.
 


purger ton cache


apt -s clean
 


retour en simulation sur ma machine


Del /var/cache/apt/archives/* /var/cache/apt/archives/partial/*
Del /var/lib/apt/lists/partial/*
Del /var/cache/apt/pkgcache.bin /var/cache/apt/srcpkgcache.bin
 


un update


apt update
 


une simulation de nettoyage par "autoremove"


apt -s autoremove --purge
 


ça va te donner la liste des 38 paquets dans un état incorrect ( a voir si des paquets important ou pas )
ensuite voir si tu peu désinstaller ces 3 paquets
en simulation toujours


apt-get -s remove --purge  mercurial mercurial-common python-libxml2 python-pil
 



tu a aptitude pour installer ou reinstaller

par exemple moi sur buster les dépendances avec aptitude


aptitude -s install mercurial mercurial-common python-libxml2 python-pil
 



Les NOUVEAUX paquets suivants vont être installés :    
  libimagequant0{a} mercurial mercurial-common python-libxml2 python-olefile{a} python-pil
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 3499 ko d'archives. Après dépaquetage, 16,8 Mo seront utilisés.
 



la réinstallation toujours avec aptitude et en simulation


aptitude -s reinstall mercurial mercurial-common python-libxml2 python-pil
 



mercurial is not currently installed, so it will not be reinstalled
mercurial-common is not currently installed, so it will not be reinstalled
python-libxml2 is not currently installed, so it will not be reinstalled
python-pil is not currently installed, so it will not be reinstalled
mercurial is not currently installed, so it will not be reinstalled
mercurial-common is not currently installed, so it will not be reinstalled
python-libxml2 is not currently installed, so it will not be reinstalled
python-pil is not currently installed, so it will not be reinstalled
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.
 



ce qui m' inquiète le plus c'est => 38 partiellement installés ou enlevés.

pour synaptic il est pratique , mais parfois la console c'est plus efficace
j'ai pas de stretch pour tester

cela risque de te donner des réponses sur ce qui coince
forcer l installation de "discord" pas la bonne solution
la priorité c'est de réparer le système

nota: discord je l'utilise sur windows10 , pas sur debian ( logiciel propriétaire )

Dernière modification par robert2a (05-11-2020 03:02:01)

Hors ligne

#4 05-11-2020 08:50:04

valdo
Administrateur
Lieu : Paris
Distrib. : Debian GNU/Linux 10 (buster) x86_64
Noyau : 4.19.0-6-amd64
(G)UI : MATE 1.20.4-2 Metacity (Marco)
Inscription : 04-10-2016

Re : [Résolu] 3 paquets dans un état incohérent

Un petit

apt -f install

pourrait ne pas faire de mal aussi


5js7qs5y.jpg ~# Where there is a shell, there is a way.

Hors ligne

#5 05-11-2020 20:29:25

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

Re : [Résolu] 3 paquets dans un état incohérent

Bonsoir, merci pour vos réponses.

À robert2a : est-ce que c'est moi qui doit faire les manips en simulations, ou toi sur ta machine ?
Dans le doute, j'ai reproduit les commandes que tu passes telles quelles, dis-moi si je dois supprimer les -s.

sudo apt -s clean


Del /var/cache/apt/archives/* /var/cache/apt/archives/partial/*
Del /var/lib/apt/lists/partial/*
Del /var/cache/apt/pkgcache.bin /var/cache/apt/srcpkgcache.bin


sudo apt update


Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org stretch/updates InRelease
Atteint:3 http://ftp.debian.org/debian stretch-backports InRelease                                                                                                    
Atteint:4 http://ftp.fr.debian.org/debian stretch-updates InRelease                                                                                                  
Atteint:5 http://ftp.fr.debian.org/debian stretch-proposed-updates InRelease                                                        
Atteint:6 http://ftp.fr.debian.org/debian stretch Release                                                                          
Atteint:7 http://www.geogebra.net/linux stable InRelease                                                                            
Lecture des listes de paquets... Fait                          
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
3 packages can be upgraded. Run 'apt list --upgradable' to see them.
 


sudo apt -s autoremove --purge


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  python-pil
Paquets suggérés :
  python-pil-doc python-pil-dbg
Les paquets suivants seront mis à jour :
  python-pil
1 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
41 partiellement installés ou enlevés.
Inst python-pil [4.0.0-4] (4.0.0-4+deb9u2 Debian-Security:9/oldstable [amd64])
Conf python-pil (4.0.0-4+deb9u2 Debian-Security:9/oldstable [amd64])
Conf python-webencodings (0.5-2 Debian:9.13/oldstable [all])
Conf python-sip (4.18.1+dfsg-2 Debian:9.13/oldstable [amd64])
Conf python-six (1.10.0-3 Debian:9.13/oldstable [all])
Conf libbcprov-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf python-yaml (3.12-1 Debian:9.13/oldstable [amd64])
Conf python-dnspython (1.15.0-1+deb9u1 Debian:9.13/oldstable [all])
Conf python-cssutils (1.0-4.1 Debian:9.13/oldstable [all])
Conf python-gi (3.22.0-2 Debian:9.13/oldstable [amd64])
Conf python-dbus (1.2.4-1+b1 Debian:9.13/oldstable [amd64])
Conf python-cssselect (1.0.1-1 Debian:9.13/oldstable [all])
Conf python-eyed3 (0.7.10-1 Debian:9.13/oldstable [all])
Conf python-pyflakes (1.3.0-1 Debian:9.13/oldstable [all])
Conf python-wxgtk3.0 (3.0.2.0+dfsg-4 Debian:9.13/oldstable [amd64])
Conf jackd2 (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.13/oldstable [amd64])
Conf eyed3 (0.7.10-1 Debian:9.13/oldstable [all])
Conf python-pyparsing (2.1.10+dfsg1-1 Debian:9.13/oldstable [all])
Conf python-lxml (3.7.1-1 Debian:9.13/oldstable [amd64])
Conf python-repoze.lru (0.6-6 Debian:9.13/oldstable [all])
Conf python-beautifulsoup (3.2.1-1 Debian:9.13/oldstable [all])
Conf libbcpkix-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf python-scour (0.32-2 Debian:9.13/oldstable [all])
Conf python-pygments (2.2.0+dfsg-1 Debian:9.13/oldstable [all])
Conf python-mechanize (1:0.2.5-3 Debian:9.13/oldstable [all])
Conf python-html5lib (0.999999999-1 Debian:9.13/oldstable [all])
Conf libbcmail-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf inkscape (0.92.1-1 Debian:9.13/oldstable [amd64])
Conf python-webob (1:1.6.2-2 Debian:9.13/oldstable [all])
Conf python-bs4 (4.5.3-1 Debian:9.13/oldstable [all])
Conf jackd (5 Debian:9.13/oldstable [all])
Conf ink-generator (0.4-2 Debian:9.13/oldstable [all])
Conf python-feedparser (5.1.3-3 Debian:9.13/oldstable [all])
Conf qjackctl (0.4.4-1 Debian:9.13/oldstable [amd64])
Conf jackd2-firewire (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.13/oldstable [amd64])
Conf ardour (1:5.5.0~dfsg-1+b1 Debian:9.13/oldstable [amd64])
Conf python-wxversion (3.0.2.0+dfsg-4 Debian:9.13/oldstable [all])
Conf gconf2 (3.2.6-4+b1 Debian:9.13/oldstable [amd64])
Conf python-markdown (2.6.8-1 Debian:9.13/oldstable [all])
Conf playonlinux (4.2.10-2 Debian:9.13/oldstable [all])


sudo apt-get -s remove --purge  mercurial mercurial-common python-libxml2 python-pil


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libjs-excanvas
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
Les paquets suivants seront ENLEVÉS :
  mercurial* mercurial-common* python-libxml2* python-pil*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 0 non mis à jour.
41 partiellement installés ou enlevés.
Purg mercurial-common [4.0-1+deb9u1]
Purg python-libxml2 [2.9.4+dfsg1-2.2+deb9u2]
Purg python-pil [4.0.0-4]
Purg mercurial
Conf python-webencodings (0.5-2 Debian:9.13/oldstable [all])
Conf python-sip (4.18.1+dfsg-2 Debian:9.13/oldstable [amd64])
Conf python-six (1.10.0-3 Debian:9.13/oldstable [all])
Conf libbcprov-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf python-yaml (3.12-1 Debian:9.13/oldstable [amd64])
Conf python-dnspython (1.15.0-1+deb9u1 Debian:9.13/oldstable [all])
Conf python-cssutils (1.0-4.1 Debian:9.13/oldstable [all])
Conf python-gi (3.22.0-2 Debian:9.13/oldstable [amd64])
Conf python-dbus (1.2.4-1+b1 Debian:9.13/oldstable [amd64])
Conf python-cssselect (1.0.1-1 Debian:9.13/oldstable [all])
Conf python-eyed3 (0.7.10-1 Debian:9.13/oldstable [all])
Conf python-pyflakes (1.3.0-1 Debian:9.13/oldstable [all])
Conf python-wxgtk3.0 (3.0.2.0+dfsg-4 Debian:9.13/oldstable [amd64])
Conf jackd2 (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.13/oldstable [amd64])
Conf eyed3 (0.7.10-1 Debian:9.13/oldstable [all])
Conf python-pyparsing (2.1.10+dfsg1-1 Debian:9.13/oldstable [all])
Conf python-lxml (3.7.1-1 Debian:9.13/oldstable [amd64])
Conf python-repoze.lru (0.6-6 Debian:9.13/oldstable [all])
Conf python-beautifulsoup (3.2.1-1 Debian:9.13/oldstable [all])
Conf libbcpkix-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf python-scour (0.32-2 Debian:9.13/oldstable [all])
Conf python-pygments (2.2.0+dfsg-1 Debian:9.13/oldstable [all])
Conf python-mechanize (1:0.2.5-3 Debian:9.13/oldstable [all])
Conf python-html5lib (0.999999999-1 Debian:9.13/oldstable [all])
Conf libbcmail-java (1.56-1+deb9u3 Debian-Security:9/oldstable [all])
Conf inkscape (0.92.1-1 Debian:9.13/oldstable [amd64])
Conf python-webob (1:1.6.2-2 Debian:9.13/oldstable [all])
Conf python-bs4 (4.5.3-1 Debian:9.13/oldstable [all])
Conf jackd (5 Debian:9.13/oldstable [all])
Conf ink-generator (0.4-2 Debian:9.13/oldstable [all])
Conf python-feedparser (5.1.3-3 Debian:9.13/oldstable [all])
Conf qjackctl (0.4.4-1 Debian:9.13/oldstable [amd64])
Conf jackd2-firewire (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.13/oldstable [amd64])
Conf ardour (1:5.5.0~dfsg-1+b1 Debian:9.13/oldstable [amd64])
Conf python-wxversion (3.0.2.0+dfsg-4 Debian:9.13/oldstable [all])
Conf gconf2 (3.2.6-4+b1 Debian:9.13/oldstable [amd64])
Conf python-markdown (2.6.8-1 Debian:9.13/oldstable [all])
Conf playonlinux (4.2.10-2 Debian:9.13/oldstable [all])


sudo aptitude -s install mercurial mercurial-common python-libxml2 python-pil


Les NOUVEAUX paquets suivants vont être installés :    
  mercurial
Les paquets suivants seront mis à jour :
  mercurial-common python-libxml2 python-pil
Les paquets partiellement installés suivants seront configurés :
  ardour eyed3 gconf2 ink-generator inkscape jackd jackd2 jackd2-firewire playonlinux python-beautifulsoup python-bs4 python-cssselect python-cssutils python-dbus python-dnspython
  python-eyed3 python-feedparser python-gi python-html5lib python-lxml python-markdown python-mechanize python-pyflakes python-pygments python-pyparsing python-repoze.lru python-scour
  python-sip python-six python-webencodings python-webob python-wxgtk3.0 python-wxversion python-yaml qjackctl
3 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 76,4 ko/2 620 ko d'archives. Après dépaquetage, 218 ko seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] Y
Charger/installer/enlever des paquets.
 


sudo aptitude -s reinstall mercurial mercurial-common python-libxml2 python-pil


mercurial is not currently installed, so it will not be reinstalled
mercurial is not currently installed, so it will not be reinstalled
Les paquets suivants seront RÉINSTALLÉS :
  mercurial-common python-libxml2 python-pil
Les paquets partiellement installés suivants seront configurés :
  ardour eyed3 gconf2 ink-generator inkscape jackd jackd2 jackd2-firewire playonlinux python-beautifulsoup python-bs4 python-cssselect python-cssutils python-dbus python-dnspython
  python-eyed3 python-feedparser python-gi python-html5lib python-lxml python-markdown python-mechanize python-pyflakes python-pygments python-pyparsing python-repoze.lru python-scour
  python-sip python-six python-webencodings python-webob python-wxgtk3.0 python-wxversion python-yaml qjackctl
0 paquets mis à jour, 0 nouvellement installés, 3 réinstallés, 0 à enlever et 0 non mis à jour.
E: Impossible de trouver une source de téléchargement de la version « 4.0.0-4 » de « python-pil:amd64 »
Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.


Je repère une erreur ici :

E: Impossible de trouver une source de téléchargement de la version « 4.0.0-4 » de « python-pil:amd64 »


et je me suis souvenu que j'avais installé certains paquets avec pip. J'ai retrouvé ça dans mon historique :

sudo pip3 install Pillow


Peut-être que des installations via pip et via synaptic se sont téléscopées ?
J'ai désinstallé ce paquet via pip :

sudo pip3 uninstall Pillow


Found existing installation: Pillow 8.0.1
Uninstalling Pillow-8.0.1:
  Would remove:
    /usr/local/lib/python3.6/site-packages/PIL/*
    /usr/local/lib/python3.6/site-packages/Pillow-8.0.1.dist-info/*
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libXau-312dbc56.so.6.0.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libXdmcp-e15573e7.so.6.0.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libfreetype-6ad068c6.so.6.17.4
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libjpeg-ba7bf5af.so.9.4.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/liblcms2-db671c5b.so.2.0.10
    /usr/local/lib/python3.6/site-packages/Pillow.libs/liblzma-99449165.so.5.2.5
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libopenjp2-b3d7668a.so.2.3.1
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libpng16-bedcb7ea.so.16.37.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libtiff-41910f6d.so.5.5.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libwebp-122bd20b.so.7.1.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libwebpdemux-2db559e5.so.2.0.6
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libwebpmux-ec1d5c76.so.3.0.5
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libxcb-2dfad6c3.so.1.1.0
    /usr/local/lib/python3.6/site-packages/Pillow.libs/libz-a147dcb0.so.1.2.3
Proceed (y/n)? y
  Successfully uninstalled Pillow-8.0.1

mais ça n'a rien changé a priori.

robert2a a écrit :

ce qui m' inquiète le plus c'est => 38 partiellement installés ou enlevés.

Je pense que ce sont des paquets qui dépendent des trois autres paquets.

robert2a a écrit :

pour synaptic il est pratique , mais parfois la console c'est plus efficace

Oui, je jongle souvent entre les deux (peut-être une erreur ?)

robert2a a écrit :

nota: discord je l'utilise sur windows10 , pas sur debian ( logiciel propriétaire )

Je sais, ça me chagrine d'utiliser un logiciel propriétaire, on me l'impose pour une formation.
Je vais essayer de voir si je peux me contenter d'ouvrir la session dans le navigateur.

À valdo :

sudo apt -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  python-pil
Paquets suggérés :
  python-pil-doc python-pil-dbg
Les paquets suivants seront mis à jour :
  python-pil
1 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
38 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 542 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 320899 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-pil_4.0.0-4+deb9u2_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-pil_4.0.0-4+deb9u2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Voilà, je ne sais pas ce que tout cela vous inspire... en tous cas, merci à vous deux et à èfpé qui a changé d'avis ;-)

Hors ligne

#6 05-11-2020 20:42:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] 3 paquets dans un état incohérent

Re-,

mth a écrit :

[...] et à èfpé qui a changé d'avis ;-)


Le temps de reproduire le problème en session Debian 9 Live ; j'ai réédité pendant que tu rédigeais.

Hors ligne

#7 05-11-2020 22:27:59

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

Re : [Résolu] 3 paquets dans un état incohérent

èfpé a écrit :

reproduire le problème en session Debian 9 Live

ouaaah, tu t'es cassé la tête !

Je suis donc la solution proposée sur ce post :
https://debian-facile.org/viewtopic.php … 09#p346809

file /usr/bin/python


/usr/bin/python: symbolic link to /etc/alternatives/python


sudo unlink /usr/bin/python
sudo ln -sv python2.7 /usr/bin/python


'/usr/bin/python' -> 'python2.7'


sudo apt-get --fix-broken install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
The following additional packages will be installed:
  python-pil
Paquets suggérés :
  python-pil-doc python-pil-dbg
Les paquets suivants seront mis à jour :
  python-pil
1 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
38 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 542 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 320899 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-pil_4.0.0-4+deb9u2_amd64.deb ...
Dépaquetage de python-pil:amd64 (4.0.0-4+deb9u2) sur (4.0.0-4) ...
Paramétrage de python-dnspython (1.15.0-1+deb9u1) ...
Paramétrage de python-eyed3 (0.7.10-1) ...
Paramétrage de python-repoze.lru (0.6-6) ...
Paramétrage de python-beautifulsoup (3.2.1-1) ...
Paramétrage de python-yaml (3.12-1) ...
Paramétrage de python-cssselect (1.0.1-1) ...
Paramétrage de python-feedparser (5.1.3-3) ...
Paramétrage de gconf2 (3.2.6-4+b1) ...
Paramétrage de eyed3 (0.7.10-1) ...
Paramétrage de python-mechanize (1:0.2.5-3) ...
Paramétrage de python-wxversion (3.0.2.0+dfsg-4) ...
Paramétrage de python-wxgtk3.0 (3.0.2.0+dfsg-4) ...
update-alternatives: utilisation de « /usr/lib/wx/python/wx3.0.pth » pour fournir « /usr/lib/wx/python/wx.pth » (wx.pth) en mode automatique
Paramétrage de python-webob (1:1.6.2-2) ...
dpkg: erreur de traitement du paquet mercurial-common (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de python-gi (3.22.0-2) ...
Paramétrage de python-six (1.10.0-3) ...
Paramétrage de python-cssutils (1.0-4.1) ...
Paramétrage de python-pygments (2.2.0+dfsg-1) ...
Paramétrage de python-bs4 (4.5.3-1) ...
Paramétrage de python-scour (0.32-2) ...
Paramétrage de python-pyflakes (1.3.0-1) ...
Paramétrage de python-lxml (3.7.1-1) ...
dpkg: erreur de traitement du paquet python-libxml2 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de playonlinux (4.2.10-2) ...
Paramétrage de python-dbus (1.2.4-1+b1) ...
Remove stale byte-compiled files...
Paramétrage de python-pil:amd64 (4.0.0-4+deb9u2) ...
Paramétrage de inkscape (0.92.1-1) ...
Paramétrage de python-webencodings (0.5-2) ...
Paramétrage de python-markdown (2.6.8-1) ...
Paramétrage de python-sip (4.18.1+dfsg-2) ...
Paramétrage de python-pyparsing (2.1.10+dfsg1-1) ...
Paramétrage de ink-generator (0.4-2) ...
Paramétrage de jackd2 (1.9.10+20150825git1ed50c92~dfsg-5) ...
Paramétrage de python-html5lib (0.999999999-1) ...
Paramétrage de jackd2-firewire (1.9.10+20150825git1ed50c92~dfsg-5) ...
Paramétrage de jackd (5) ...
Paramétrage de qjackctl (0.4.4-1) ...
Paramétrage de ardour (1:5.5.0~dfsg-1+b1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mercurial-common
 python-libxml2
E: Sub-process /usr/bin/dpkg returned an error code (1)


Puis

sudo apt-get update

et

sudo apt-get upgrade

et le problème est règlé !!
Merci infiniment èfpé !!
Ce n'est pas la première fois que tu fais de la magie pour me sortir du pétrin... Comment as-tu trouvé d'où venait le problème ?!
Et merci beaucoup à valdo et robert2a.
Décidément j'adore ce forum.

Dernière modification par mth (05-11-2020 22:28:44)

Hors ligne

#8 05-11-2020 22:38:37

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

Re : [Résolu] 3 paquets dans un état incohérent

èfpé a écrit :

Une alternative à tout ce bazar, est d'« Ouvrir Discord dans ton navigateur » (ne fais pas de chichi)

Ah oui, et merci aussi pour cette info, je vais m'empresser de ne pas installer Discord :-)

Hors ligne

#9 05-11-2020 23:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] 3 paquets dans un état incohérent

Re-,

mth a écrit :

file /usr/bin/python

/usr/bin/python: symbolic link to /etc/alternatives/python


Oups. Tu aurais dû passer par la commande update-alternatives du coup, comme ceci par exemple :

sudo update-alternatives --config python

Il existe 3 choix pour l'alternative python (qui fournit /usr/bin/python).

  Sélection   Chemin                    Priorité  État
------------------------------------------------------------
* 0            /usr/local/bin/python3.6   36        mode automatique
  1            /usr/bin/python2.7         27        mode manuel
  2            /usr/bin/python3.5         35        mode manuel
  3            /usr/local/bin/python3.6   36        mode manuel

Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez
le numéro sélectionné :1


D'ailleurs je ne sais pas quel paquet avait installé ce lien symbolique, mais ça risque de râler un jour.

mth a écrit :

Comment as-tu trouvé d'où venait le problème ?


La forte odeur de scripts Python m'a incité à tester des trucs du genre : 'python3 /usr/bin/pyclean'.

python2.7 /usr/bin/pyclean

Usage: pyclean [-p PACKAGE] [DIR_OR_FILE]


python3.5 /usr/bin/pyclean

  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax


python3.6 /usr/bin/pyclean

  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax


python2.7 /usr/bin/pycompile

Usage: pycompile [-V [X.Y][-][A.B]] DIR_OR_FILE [-X REGEXPR]
       pycompile -p PACKAGE


python3.5 /usr/bin/pycompile

Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'


python3.6 /usr/bin/pycompile

Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ModuleNotFoundError: No module named 'ConfigParser'


En fait, '/usr/bin/python' devait pointer vers python3.6, lequel t'avait permis d'installer Pillow 8.0.1.

Dernière modification par èfpé (07-11-2020 14:34:42)

Hors ligne

#10 06-11-2020 09:54:45

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

Re : [Résolu] 3 paquets dans un état incohérent

ça risque de râler un jour

Bof, si ça râle trop fort je reviendrai vous voir...

La forte odeur de scripts Python m'a incité à tester des trucs du genre : 'python3 /usr/bin/pyclean'.

Bravo encore pour le pif

PS : Pas mal l'astuce du gris pour les commentaires secondaires

Hors ligne

#11 06-11-2020 12:17:37

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] 3 paquets dans un état incohérent

mth a écrit :

PS : Pas mal l'astuce du gris pour les commentaires secondaires


Waouh !
On apprend toujours un truc à lire les posts des autres tongue, la preuve :
test de couleur
test de couleur
test de couleur
test de couleur
test de couleur
Et je n'ai pas mis yellow car jaune sur blanc c'est illisible.
yes.gif


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#12 06-11-2020 19:09:38

mth
Membre
Lieu : Toulouse (France)
Distrib. : Debian 9
Noyau : Linux 4.9.0-7-amd64
(G)UI : KDE Plasma 5.12.7
Inscription : 14-05-2017

Re : [Résolu] 3 paquets dans un état incohérent

mth a écrit :

èfpé a écrit :

Une alternative à tout ce bazar, est d'« Ouvrir Discord dans ton navigateur » (ne fais pas de chichi)

Ah oui, et merci aussi pour cette info, je vais m'empresser de ne pas installer Discord :-)



Pour info, ma version du navigateur (Firefox) ne permet pas semble-t-il de visualiser webcam et partage d'écran sous Discord, j'ai donc installé le client (sans aucun souci à présent grâce à vous) avec gdebi.

Hors ligne

Pied de page des forums