Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-11-2020 20:12:09

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

[Résolu] Mate-terminal codage des caractères

Bonjour,

y a t'il un moyen pour améliorer la chose. J'ai un programme qui tourne dans mon terminal "Streamripper"
Dans l'onglet -- Terminal -- Définir le codage de caractères, je suis sur Unicode UTF-8. Il faudrait que je rajoute quoi pour avoir quelque chose de plus joli que ça :

[ripping...    ] Danheim - Jörmungandr [  5,77M]
[ripping...    ] Cécile Corbel - Sans faire un bruit
 



smile

EDIT: Je n'ai que ce problème a mate-terminal et pas avec tous les programmes qui sont lancés dedans.


locale




LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
 



echo $LANG




fr_FR.UTF-8
 

Dernière modification par golgot200 (10-11-2020 20:40:16)

Hors ligne

#2 10-11-2020 20:35:44

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] Mate-terminal codage des caractères

C'est résolu, c'est le programme lancé dans mate-terminal en fait. Dans les options de streamripper, il faut modifier le --codeset smile



ISO-8859-15
[ripping...   ] Glaö - Real de catorce 2 [  193kb]
 




UTF-8
[ripping...   ] Glaö - Real de catorce 2 [  769kb]
 

Dernière modification par golgot200 (10-11-2020 20:39:50)

Hors ligne

#3 11-11-2020 09:16:27

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Mate-terminal codage des caractères

Ah ok super
J'avais quelque fichiers affiché pas trés clair
mais --codeset tout court j'ai pas vu dans le man
     

--codeset-filesys=codeset
           Tells streamripper what codeset to use for the file names when it writes to your hard drive.

       --codeset-id3=codeset
           Tells streamripper what codeset to use for the id3 information.

       --codeset-metadata=codeset
           Tells streamripper what codeset is being used for metadata in the stream coming from the network.

       --codeset-relay=codeset
           Tells streamripper what codeset to use for metadata that it sends to your player on the relay stream.



Du coup le premier non?

--codeset-filesys=UTF-8

Dernière modification par Croutons (11-11-2020 09:16:50)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#4 11-11-2020 09:41:19

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] Mate-terminal codage des caractères

@Croutons

Chez moi maintenant:


streamripper "$stream" -a -A -s -d "$folder/$time"  \
                  --codeset-filesys=UTF-8 \
                  --codeset-id3=UTF-8 \
                  --codeset-metadata=UTF-8 \
                  --codeset-relay=UTF-8 \
                  -u FreeAmp/2.x
 



PS: je post le script dans l'état dans la section adéquat wink

Hors ligne

Pied de page des forums