Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2020 19:31:54

moniroje
Membre
Lieu : Massy-les-flots
Distrib. : Debian-sid & Suse-Tumbleweed
(G)UI : KDE & xfce si KDE en panne
Inscription : 18-05-2008

[ Résolu] chmod ne fait rien!!

Bonsoir,
tout aujourd'hui, j'ai un problème curieux : je n'arrive pas à regarder le contenu d'un répertoire !
je fais clic-droite à ce répertoire et vérifie clic-droit-Propriétés-Droits d'accès et effectivement
seul le propriétaire peut consulter et modifier le contenu...
Ce proprio, c'est moi avec le système OpenSUSE; mais avant, rien que hier, tout marchait très bien !
Je coche donc: Peut consulter et modifier le contenu à Groupes et Autres...
Las, ça ne fait rien du tout... Donc je tape en console:

alain@siderante:~$ su -
Mot de passe :
root@siderante:~# chmod -R 777 /media/photos
root@siderante:~#
 



mais même comme ça, ça ne fonctionne pas!!!
sad

Dernière modification par moniroje (12-12-2020 22:23:14)


OpenSUSE-tumbleweed & Debian-sid
les deux habillées en KDE-Plasma avec xfce en cas de panne

Hors ligne

#2 12-12-2020 20:12:29

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [ Résolu] chmod ne fait rien!!

Ce répertoire correspond-il à un média amovible, comme une clé USB ou un disque dur externe ?
Dans ce cas il est possible que ce soient ses options de montage qui empêchent la lecture.

Jouer sous Debian ? Facile !

Hors ligne

#3 12-12-2020 20:23:32

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [ Résolu] chmod ne fait rien!!

Hello
Quel résultat si tu affiches le répertoire avec ls

ls -n /media/photos


Voir ce qu'affiche mount

mount

Dernière modification par Croutons (12-12-2020 20:24:32)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#4 12-12-2020 21:27:01

raleur
Membre
Inscription : 03-10-2014

Re : [ Résolu] chmod ne fait rien!!

moniroje a écrit :

ça, ça ne fonctionne pas


On peut voir le résultat ?

vv222 a écrit :

Ce répertoire correspond-il à un média amovible, comme une clé USB ou un disque dur externe ?
Dans ce cas il est possible que ce soient ses options de montage qui empêchent la lecture.


C'est plus le type de système de fichiers (FAT, NTFS notamment) que le type de support de stockage qui conditionne si les permissions sont définies au montage.


Il vaut mieux montrer que raconter.

Hors ligne

#5 12-12-2020 22:21:39

moniroje
Membre
Lieu : Massy-les-flots
Distrib. : Debian-sid & Suse-Tumbleweed
(G)UI : KDE & xfce si KDE en panne
Inscription : 18-05-2008

Re : [ Résolu] chmod ne fait rien!!

alain@siderante:~$ ls -n /media/photos/Francine
total 55408
-rwx------ 1 1000 1000  467498  2 avril  2004  200404-Jerome-X-Aurelie.jpg
-rwx------ 1 1000 1000  295730  7 juil.  2004 '200406- Francine.jpg'
.......................................................................................................
rwx------ 1 1000 1000 5810885 19 nov.   2012 '20121004-le soir.jpg'
alain@siderante:~$
 


Non, ce répertoire est une partition...
bon, là, je crois comprendre ce qui se passe. Mes images, je les regarde avec gwenview et donc, rien ... depuis aujourd'hui.
Par contre si je regarde avec feh... j'essaye avec imagemagik, ça marche!!
avec visionneur d'images, chouette!!
OK, c'est gwenview qui  dec... heu...
Mais que s'est-il passé pour que gwenview qui marchait bien  avant-hier, n'ouvre rien aujourd'hui ??
et je me souviens: ce matin, je faisais un apt-get distupgrade
et gwenview n'a pas supporté cette maj...
Bon, alors merci d'être venus à mon aide...
Là, je vais désinstaller ce gwenview pour le re-installer ensuite et ça devrait aller...
merci.gif


OpenSUSE-tumbleweed & Debian-sid
les deux habillées en KDE-Plasma avec xfce en cas de panne

Hors ligne

Pied de page des forums