Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-12-2020 02:25:38

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

[RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

Bonsoir.
j'essaye de mettre un wifi fonctionnel sur un macbook-pro 2012 avec debian en dual-boot à l'osx.

j'ai installé la debian 10 depuis une image multi-arch incluant les non-free.
pour le moment je suis en ethernet.

Après installation:
J'ai installé comme firmwares non-free : firmware-misc-nonfree, b43-fwcutter, firmware-b43-installer.
ainsi que les paquets: firmware-iwlwifi, wicd.
(me suis aidé entre autre de cette page: https://debian-facile.org/doc:materiel: … te-reseau)

ma carte réseau est un "Broadcom Limited BCM4331"

donc voici voilà
il n'y a toujours pas le wifi.

merci
a+

Dernière modification par crap0 (19-12-2020 11:53:01)

Hors ligne

#2 17-12-2020 13:55:16

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

que retourne

dmesg | egrep "error|fail|firmware"


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#3 17-12-2020 18:34:56

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

hello (merci aussi)

voici:

# dmesg | egrep "error|fail|firmware"
[    0.302688] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.373525] pci 0000:05:00.0: BAR 13: failed to assign [io  size 0x4000]
[    0.373532] pci 0000:05:00.0: BAR 13: failed to assign [io  size 0x4000]
[    0.373557] pci 0000:06:03.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373563] pci 0000:06:04.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373569] pci 0000:06:05.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373575] pci 0000:06:06.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373582] pci 0000:06:06.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373588] pci 0000:06:05.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373594] pci 0000:06:04.0: BAR 13: failed to assign [io  size 0x1000]
[    0.373600] pci 0000:06:03.0: BAR 13: failed to assign [io  size 0x1000]
[    5.699561] EXT4-fs (sda4): re-mounted. Opts: errors=remount-ro
[    6.799074] b43 bcma0:1: firmware: direct-loading firmware b43/ucode29_mimo.fw
[    6.803236] b43 bcma0:1: firmware: direct-loading firmware b43/ht0initvals29.fw
[    6.803369] b43 bcma0:1: firmware: direct-loading firmware b43/ht0bsinitvals29.fw
[    8.088234] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[    8.512170] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[  354.239131] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[  670.236016] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[  986.264831] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)

Hors ligne

#4 17-12-2020 19:00:33

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

que donne

nmcli




apt install rfkill




rfkill list


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#5 17-12-2020 19:32:53

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

yhep.

$ nmcli
wlp3s0b1: déconnecté
        "Broadcom and subsidiaries BCM4331"
        wifi (b43), 2A:83:B4:44:07:B1, hw, mtu 1500

enp2s0f0: non-géré
        "Broadcom and subsidiaries NetXtreme BCM57765"
        ethernet (tg3), C8:2A:14:5A:34:08, hw, mtu 1500

lo: non-géré
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

Utilisez « nmcli device show » pour obtenir des informations complètes sur les périphériques connus et « nmcli connection show » pour obtenir une vue d'ensemble des profils de connex

Consultez les pages de manuel nmcli(1) et nmcli-examples(5) pour les détails complets d'
utilisation.
 



# rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no




rfkill... je l'avais déjà installé et du faire en root, un: rfkill unblock all
(si je me souviens de la commande)
si je me souviens bien c'était pour le wireless (qui etait bloqué)
depuis, j'ai éteint et rallumé 2, 3 fois l'ordi...

Hors ligne

#6 17-12-2020 19:56:49

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

Essaie d'activer la connexion, voir ce qu'il raconte

nmcli device connect wlp3s0b1


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#7 18-12-2020 09:31:47

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

hiep: bon matin à tous et toutes

voici la réponse

$ nmcli device connect wlp3s0b1
Erreur : échec de l'ajout ou de l'activation de la nouvelle connexion : A 'wireless' setting is required if no AP path was given.

Hors ligne

#8 18-12-2020 16:22:12

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

excusez moi mais ...?

dois je modifier le fichier "/etc/modules" pour charger, au démarage automatiquement, le/les modules du noyau ?

Je pense à
b43
... et/ou
iwlwifi

ce fichier actuellement ne comporte que "firewire-sbp2"

sais pas ... voilà. J'ai juste vu ça sur un site...
a+

Hors ligne

#9 18-12-2020 16:38:25

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

Bonjour,
Et si tu débranches le câble ethernet, le WiFi ne prend pas le relais ?

Hors ligne

#10 18-12-2020 16:55:23

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

non même après reboot ethernet débranché...
... et essaye avec wicd gtk de relancer un-e recherche/relancement wifi

Hors ligne

#11 18-12-2020 23:16:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

Bonsoir,

crap0 a écrit :

nmcli device connect wlp3s0b1


La commande ne peut connecter, que si le périphérique a déjà été associé à un point d'accès donné.
Avant de tenter une connexion en spécifiant un point d'accès, il faut déjà l'identifier ; que retourne :

nmcli device wifi


Ensuite avoir installé plusieurs gestionnaires réseau (NM, Wicd) ne simplifie pas vraiment les choses.
Note enfin que si le pilote b43 ne fonctionne pas, tu peux encore installer broadcom-sta-dkms (wl).

Hors ligne

#12 18-12-2020 23:26:35

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

bonsoir & merci
je pense que le pilote b43 fonctionne...

nmcli device wifi


me donne les points d'accès
je peux voir le mien d'ailleurs
cool !!

Hors ligne

#13 18-12-2020 23:29:04

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

aussi non pour mon post #8

c'était rien à voir ce que je disais ?

Hors ligne

#14 19-12-2020 00:10:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

Re-,

crap0 a écrit :

je peux voir [mon point d'accès]


Et donc ? Es-tu parvenu à t'y connecter, via l'applet graphique NM, en fournissant le mot de passe ?
Et non, tu n'as rien à tripatouiller dans /etc/modules, le module/pilote b43 est chargé à la détection.

Hors ligne

#15 19-12-2020 11:52:33

crap0
Membre
Lieu : Bruxelles (Be)
Distrib. : debian 10
Noyau : Linux 4.19.0-9-amd64
(G)UI : Lxde & i3 (LxQt parfois - En test: Dwm)
Inscription : 27-09-2018
Site Web

Re : [RÉSOLU] wifi sur macbook-pro 2012 - Broadcom BCM4331

oui, voilà !! génial...
-
donc j'ai fais un

apt-get remove --purge wicd && apt-get autoremove



puis je me suis aidé de cette page:
https://debian-facile.org/doc:reseau:network-manager
au paragraphe: Configuration d'une connexion wifi
du chapitre: Exemples d'utilisation de nmcli

je pensais qu'ethernet de branché en même temps que le wifi, allait me poser un problème en plus
mais non, ça a l'air d'être cool.

donc merci ! à toutes ou/et tous

Dernière modification par crap0 (19-12-2020 11:53:46)

Hors ligne

Pied de page des forums