Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-04-2021 18:27:33

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Pas d'interface graphique aprés l'installation de Debian 10

Bonjour,

Je fonctionné très bien sur ma SurfacePro4 avec Debian, plus simplement tout marché a merveille.
Je viens d'acheter un Lenovo ThinkBook 13s-IML, j'ai installer Win10 après Debian qui démarre mais que la ligne de commande.
Mon niveau Linux est 3/10 (je pense que je me surestime) mais cela fait quand-même plusieurs années que je l'utilise.

Pour résumé :
- J'ai fait un update et un upgarde,
- J'ai essayé startx ce ne fonctionne pas.

Sur quelques forums on dit  qu'il y aurait un probleme avec ce modele de ThinkBook !!!

Merci par avance pour votre aide.

Adel.

Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#2 01-04-2021 19:06:55

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour Joker smile

Si je comprends bien tu ne démarre qu'en mode console tty ?

C'est peut-être un problème de firmware graphique à installer ?

Je ne sais plus si kde fonctionne avec wayland, mais je sais que par un moment il y avait des problèmes avec wayland !

En fonction de la marque de ta carte graphique, tu peux t'aider de ces tuto:https://debian-facile.org/doc:materiel: … -graphique

Dernière modification par Jean-Pierre Pinson (01-04-2021 19:12:57)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#3 02-04-2021 11:36:41

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour Jean Pierre et merci de ta réponse,

Je ne trouve pas dans le lien quelque chose qui pourrait m'aider.
La carte graphique dans mon ordi est une Intel (je viens de mettre à jour la config sur ma signature).

Je t’embête pas plus que ça car je n'est pas mon ordi sous la main.
Je met demain le retour de la commande startx.

Merci smile

Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#4 02-04-2021 11:37:21

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour,

Pourrais tu nous préciser la version de Debian qui a été installée (je suppose que ce n'est pas une Jessie tel qu'indiqué dans ton profil), quelle méthode d'installation avec quelles options (l'installation minimale n'installant pas d'interface graphique) et enfin ce que renvoit la commande startx.

Hors ligne

#5 03-04-2021 18:47:16

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour

vérifier le (ou les ) gpu


lspci
 


vérifier la présence du firmware pour intel/nvidia


apt policy firmware-misc-nonfree
 



wayland ou X si le gpu est bien configurer par le noyau ça devrait tourner

une question a ce poser ce matériel est bien supporté par debian 10 (buster ) ?

Hors ligne

#6 03-04-2021 19:01:24

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

tux12 a écrit :

Bonjour,

Pourrais tu nous préciser la version de Debian qui a été installée (je suppose que ce n'est pas une Jessie tel qu'indiqué dans ton profil), quelle méthode d'installation avec quelles options (l'installation minimale n'installant pas d'interface graphique) et enfin ce que renvoit la commande startx.



Bonjour Tux,

J'ai mis a jour les renseignement sur ma version dans mon profil.
la méthode d'installation était via une ISO netinst (minimal) mais a la fin j'ai téléchargé puis installé l’environnement KDE (l'installateur me l'a proposé a la fin de l'installation).
La commande startx donne :

xinit : giving up
xinit : unable to connect to X server: connection refused
xinit server error


bloc à supprimer si la commande n’affiche rien

Dernière modification par joker_dz (04-04-2021 18:01:05)


Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#7 03-04-2021 19:04:35

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

robert2a a écrit :

Bonjour

vérifier le (ou les ) gpu


lspci
 


vérifier la présence du firmware pour intel/nvidia


apt policy firmware-misc-nonfree
 



wayland ou X si le gpu est bien configurer par le noyau ça devrait tourner

une question a ce poser ce matériel est bien supporté par debian 10 (buster ) ?



Bonjour Robert,

lspci me donne : VGA intel compatible device 9b41
Et effectivement le ''apt policy firmware-misc-nonfree'' me donne :
Installed none
candidate none


Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#8 04-04-2021 21:34:24

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bon, j'ai passé des heures a biduler et a réinstaller ...
Je pense que mon nouvel ordi ne doit pas être trop compatible peace_flag.gif

Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#9 05-04-2021 00:05:32

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour
rien est perdu , tu a testing/sid a tester
voici le sources.list a appliquer ,  dans /etc/apt/sources.list


#bullseye11 http
deb http://security.debian.org/debian-security bullseye-security/updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye main contrib non-free

#sid
#deb http://deb.debian.org/debian/ sid main contrib non-free
 



pour le firmware


apt install firmware-misc-nonfree
 



lorsque tu a modifier ton sources.list


apt update
 



apt-get upgrade
 



apt-get dist-upgrade
 


et un reboot


reboot
 



de plus il faudrait le retour complet de la commande "lspci"

avec ceci il doit être possible de trouver le matériel  "device 9b41"

voila une autre solution =>  https://www.debian-fr.org/t/nouvelle-in … ge/82997/2

moi plutôt que d'utiliser les backports je préfère passer a testing , mais tu a les deux solutions a toi de décider

Dernière modification par robert2a (05-04-2021 00:09:43)

Hors ligne

#10 05-04-2021 09:11:30

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour,
oui je vais essayer encore avec ce que tu m'a envoyé.
quoique maintenant avec tout ce que j'ai fait le problème a changé.
Au démarrage je fait flèche bas j'ai 2 à 3 secondes de la page de démarrage Gnome3, après c'est écran noir et tiret clignotant.
J'arrive à démarrer en console seulement en mode maintenance.

Je vous tien au courant.

Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#11 05-04-2021 12:09:01

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Pas d'interface graphique aprés l'installation de Debian 10

Bonjour
si tu a le tiret clignotant , tu peu faire "Ctrl+Alt+F2" te connecter et entrer des commandes
au minimum il te faut le firmware-misc-nonfree et le noyau des backports , sinon migrer vers bullseye comme j'ai noter au dessus

tu a les deux méthodes sur mon #9 (le lien pour les backports )

Hors ligne

#12 05-04-2021 22:40:55

joker_dz
Membre
Lieu : Alger, ALGERIE
Distrib. : Debian 10 Buster
Noyau : 4.19.0-16-AMD64
(G)UI : KDE
Inscription : 13-02-2016

Re : Pas d'interface graphique aprés l'installation de Debian 10

robert2a a écrit :

Bonjour
rien est perdu , tu a testing/sid a tester
voici le sources.list a appliquer ,  dans /etc/apt/sources.list


#bullseye11 http
deb http://security.debian.org/debian-security bullseye-security/updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye main contrib non-free

#sid
#deb http://deb.debian.org/debian/ sid main contrib non-free
 



pour le firmware


apt install firmware-misc-nonfree
 



lorsque tu a modifier ton sources.list


apt update
 



apt-get upgrade
 



apt-get dist-upgrade
 


et un reboot


reboot
 



de plus il faudrait le retour complet de la commande "lspci"

avec ceci il doit être possible de trouver le matériel  "device 9b41"

voila une autre solution =>  https://www.debian-fr.org/t/nouvelle-in … ge/82997/2

moi plutôt que d'utiliser les backports je préfère passer a testing , mais tu a les deux solutions a toi de décider




YESSSSSSS big_smile
Ce bon vieux gnome est revenue.

Merci Robert ca a marché.
Maintenant le son, le wifi et tralala je vais pouvoir m'en occupé.

Merci encore.


Lenovo ThinkBook 13s-IML
Intel® Core™ i7-10510U, Intel® UHD 1536 Mo,
16GB DDR4, SSD 512GB.
Funk your life !

Hors ligne

#13 06-04-2021 04:00:24

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Pas d'interface graphique aprés l'installation de Debian 10

Pour le son --> PulseAudio : config, trucs et astuces: https://debian-facile.org/doc:media:pulseaudio

Pour le wi-fi --> Pas à pas : faire que sa carte Wi-Fi soit détectée et fonctionnelle: https://debian-facile.org/doc:materiel:wifi:detecter

Dernière modification par Jean-Pierre Pinson (06-04-2021 04:05:03)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#14 07-04-2021 18:29:46

iCreateur
Membre
Lieu : Alger
Distrib. : Debian GNU/Linux 9.6 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : KDE Plasma 5.8.6
Inscription : 07-12-2018

Re : Pas d'interface graphique aprés l'installation de Debian 10

Jean-Pierre Pinson a écrit :

Pour le son --> PulseAudio : config, trucs et astuces: https://debian-facile.org/doc:media:pulseaudio

Pour le wi-fi --> Pas à pas : faire que sa carte Wi-Fi soit détectée et fonctionnelle: https://debian-facile.org/doc:materiel:wifi:detecter



Bonjour,

Le wifi impec.
Le son je rame un peu mais j y suis presque.

smile


Surface pro 4
Dual boot : Debian 9 // Win 10 Pro

Funk your Life !

Hors ligne

Pied de page des forums