Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-04-2021 20:25:21

gieres
Membre
Inscription : 08-10-2017

Thunderbird - retrograder à la version 68 (Jessie !)

Bonsoir,
Pour des problèmes de compatibilité avec SoGo, j'aimerais bien rétrograder le paquet Thunderbird de Debian 10 Buster qui en est à la version 78 à la version 68.
La version 68 était celle de Jessie.

J'ai téléchargé le paquet Thunderbird thunderbird_68.9.0-1~deb8u2_amd64.deb
Mais l'installer pose des problèmes de dépendances que je ne sais pas maîtriser.
Au début, ça va : il ne demande qu'un paquet : libevent-2.0-5_2.0.21-stable-2+deb8u1_amd64.deb

Mais cela se complique assez vite...

N'y a-t-il pas une commande apt downgrade ... ? Je n'ai pas trouvé dans le man. Ou une commande autre part ?
Ou une autre méthode ?

D'avance merci.

Hors ligne

#2 07-04-2021 11:26:07

saitama-san
Membre
Inscription : 28-07-2019

Re : Thunderbird - retrograder à la version 68 (Jessie !)

SoGo, c'est pas un peu nul question.gif

Tu l'utilises avec quoi ?

Hors ligne

#3 08-04-2021 09:06:49

gieres
Membre
Inscription : 08-10-2017

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Bonjour,
On se sert de SoGo comme Webmail parce qu'il permet :
    - la synchronisation des agendas plus simplement (à notre avis !) ;
    - la gestion des étiquettes entre Thunderbird/SOGo / en synchronisation automatique.

Merci de ton attention.

Bonne journée.

Hors ligne

#4 08-04-2021 09:13:06

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Hello
serait il possible de résoudre ses problèmes de compatibilité ?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 18-04-2021 14:38:16

falke
Membre
Inscription : 10-04-2021

Re : Thunderbird - retrograder à la version 68 (Jessie !)

salut gières, ici Smh

pour rétrograder il est très probable que tu doives descendre toute la chaine des dépendances nécessitées par thunderbird_68.9.0-1~deb8u2_amd64.deb  voir si la , ou les versions actuelles (> 68 ) en avait
installé de plus récentes (de dépendances) et (et les rétrograder aussi en cas de besoin, si toutefois tes autres paquets n'en nécessitent pas une version bien précise). A priori ça marchera à coup de dpkg
pour l'install pour ne pas risquer d'installer des version de dépendances non souhaitées par accident.

Ce n'est pas forcément facile d'y voir clair dans qui dépend de quoi, mais j'ai trouvé un outils très pratique pour faire ce travail (d'investigation), capable de te faire
un schéma à partir d'une version de paquet (quels paquets en dépendent et quelles sont ces dépendances), avec le niveau d'arborescence que tu veux.

C'est Debtree , tu peux aller voir ce sujet ici.

https://forum-francophone-linuxmint.fr/ … ee#p194239

et un tuto de Debtree :

https://qastack.fr/ubuntu/261772/how-to … -a-package


par exple, il suffit de mettre ton archive dans le cache d'apt . (/var/cache/apt/archives) et tu vois les paquets qui en dépendent , et les versions nécessaire de ses dépendances.

En fonction de ça tu visualisera et saura exactement qu'elle dépendances installer (et comment , elle s'enchainent les une les autres) pour t'y prendre sans casser ton système.

A priori si sur ton système tu possède LA bonne version qui réponde au critère nécessaire (=, >=, > ) a priori c'est gagné, tu peux installer ce paquet avec la commande dkpg -i (qui a l'avantage de ne
pas t'installer de dépendances, qui pourraient être incompatible contrairement à apt , si je n'est pas le cas, il faudra , avec le graphe étudier l'étendue des des mise à jours nécessaire sur les dépendances
et si ça ne cassera pas ton système

Dernière modification par falke (18-04-2021 14:42:14)

Hors ligne

#6 18-04-2021 15:24:28

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Laisse tomber dpkg, ici c’est apt l’outil approrié.

1. Ajoute les lignes suivantes à tes sources de paquets, par exemple dans /etc/apt/sources.list.d/thunderbird-68.list :

# Dépôts Debian Stretch, pour Thunderbird 68
deb http://deb.debian.org/debian/              stretch         main
deb http://security.debian.org/debian-security stretch/updates main


2. Mets à jour tes listes de paquets :

apt update


3. Installe la version Stretch de Thunderbird et sa traduction en français :

apt install thunderbird/stretch thunderbird-l10n-fr/stretch


Jouer sous Debian ? Facile !

Hors ligne

#7 18-04-2021 15:35:52

falke
Membre
Inscription : 10-04-2021

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Bonjour vvv222,

et avec ça, on est certain qu'aucun autre paquet ne sera cassé ?  par rapport à sa version de distro actuelle ? Pas précisé ..

Et gières nous dit que cette version était dans Jessie, pas stretch, plus maintenue certes.

Ne faudrait-il pas prendre la précaution de commenter ce dépôt sitôt l'installation faite ?

je m'interroge ? Pourrais-tu expliciter ton raisonnement ?

Dernière modification par falke (18-04-2021 16:22:25)

Hors ligne

#8 18-04-2021 16:08:49

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Bonjour
teste comme ceci


aptitude -s install thunderbird/stretch thunderbird-l10n-fr/stretch
 


ps: aptitude te demande confirmation , te propose des solutions et le "-s"  utilise uniquement la simulation (rien de modifier sur le système)
je modifie mon sources.list et je te dis ce que ça donne sous bullseye (toi tu peu tenter sous buster sans risque )

le retour


aptitude -s install thunderbird/stretch thunderbird-l10n-fr/stretch
 



Les NOUVEAUX paquets suivants vont être installés :    
  libevent-2.0-5{a} libffi6{a} libjson-c3{a} thunderbird thunderbird-l10n-fr
0 paquets mis à jour, 5 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 50,8 Mo d'archives. Après dépaquetage, 199 Mo seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?]
 



pour ta question


Ne faudrait-il pas prendre la précaution de commenter ce dépôt sitôt l'installation faite ?
 


je laisse répondre les barbus smile
il fut un temps ou j'utilisais un sources.list , oldstable , stable et ou testing/sid sans soucis (mais il y a les "pour" et les "contre" )
par exemple il peu y avoir un correctif de sécurité sur thunderbird version oldstable
bref attend une réponse sur la question ne tien pas compte de ma remarque smile

remarque : thunderbird  n'est pas installé sur mon système , donc pas de conflit de paquet a priori

mon sources.list comme indiqué par vv222


deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security/updates main contrib non-free
# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free

# Dépôts Debian Stretch, pour Thunderbird 68
deb http://deb.debian.org/debian/              stretch         main
deb http://security.debian.org/debian-security stretch/updates main
 



tu a les versions ici => https://packages.debian.org/fr/jessie/thunderbird

Dernière modification par robert2a (18-04-2021 16:31:37)

Hors ligne

#9 18-04-2021 16:32:23

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Thunderbird - retrograder à la version 68 (Jessie !)

falke a écrit :

et avec ça, on est certain qu'aucun autre paquet ne sera cassé ?  par rapport à sa version de distro actuelle ? Pas précisé ..


Je l’aurais précisé si ça avait des risques d’avoir des effets de bord.

falke a écrit :

Et gières nous dit que cette version était dans Jessie, pas stretch, plus maintenue certes.


En effet, j’avais manqué cette info, il va falloir adapter mes instructions pour aller piocher la version de Jessie.
Contrairement à la version de Stretch, je n’ai pas regardé si celle-ci va s’installer sans effet de bord.

falke a écrit :

Ne faudrait-il pas prendre la précaution de commenter ce dépôt sitôt l'installation faite ?


Non, on ne fait jamais ça, sauf si on veut s’assurer de se retrouver avec un système cassé.
Et pas légèrement cassé, on parle de ce genre de souci qui peut demander des semaines de boulot pour être corrigé : Migration Debian 9 vers 10 (Buster) : pkgProblem paquets devant etre gardes en l’etat.

Quand quelqu’un te conseille ce genre de manœuvre (ajouter un dépôt le temps d’installer un paquet, puis le retirer), fuis. Ça veut dire que cette personne n’a aucune idée du fonctionnement du système de paquets de Debian, et sera probablement incapable de t’aider le jour où ses conseils auront mis en vrac ton système.


Jouer sous Debian ? Facile !

Hors ligne

#10 18-04-2021 17:06:06

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Thunderbird - retrograder à la version 68 (Jessie !)

pas mal le lien  sur la migration tongue
comme dit raleur "faut montrer" , je comprends l'inquiétude de falke.

Hors ligne

#11 18-04-2021 17:21:50

falke
Membre
Inscription : 10-04-2021

Re : Thunderbird - retrograder à la version 68 (Jessie !)

vv222 a écrit :


Quand quelqu’un te conseille ce genre de manœuvre (ajouter un dépôt le temps d’installer un paquet, puis le retirer), fuis. Ça veut dire que cette personne n’a aucune idée du fonctionnement du système de paquets de Debian, et sera probablement incapable de t’aider le jour où ses conseils auront mis en vrac ton système.



Bonjour, je questionnais , je n'affirmais rien, hein ? Sans doute sais tu pertinemment ce que tu fais,  La manip n'est pas courante non plus, tu en conviendras ?

D'ailleurs, et c'est toute l'ambiguité du titre du Forum, car Debian n'est certainement pas "facile".
J'ai une expérience d'une quinzaine d'année sur linux et je me méfie autant que toi de la propension des débutants à prendre la ligne de commande à la légère,

Donc oui, je m'interrogeais sur le cheminement que tu faisais,

Contrairement à la version de Stretch, je n’ai pas regardé si celle-ci va s’installer sans effet de bord.



bah ça par exple tu vois, c'est intéressant, comment fais-tu pour le vérifier ? Là on gagnerait en compréhension et en autonomie. Personnellement j'avais exposé une démarche, sans doute y a-t-il mieux ?


Je pensais que Debian deviendrait facile pour moi et les autres, et d'ailleurs, je n'ai toujours pas de réponse , mais c'est sans doute intéressant wink

Dernière modification par falke (18-04-2021 17:30:55)

Hors ligne

#12 18-04-2021 17:31:56

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Thunderbird - retrograder à la version 68 (Jessie !)

falke a écrit :

Contrairement à la version de Stretch, je n’ai pas regardé si celle-ci va s’installer sans effet de bord.


bah ça par exple tu vois, c'est intéressant, comment fais-tu ?



Pour la version de Debian Stretch, j’en ai tout simplement simulé l’installation, en vérifiant qu’aucun paquet utilisé par d’autres programmes ne soit descendu dans une version de Stretch :

apt --simulate install thunderbird/stretch thunderbird-l10n-fr/stretch


NOTE: Ceci n'est qu'une simulation !
      apt a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Version choisie « 1:68.10.0-1~deb9u1 » (Debian:9.13/oldstable [amd64]) pour « thunderbird »
Version choisie « 1:6.3.0-18+deb9u1 » (Debian:9.13/oldstable [amd64]) pour « libgcc1 » à cause de « thunderbird »
Version choisie « 1:68.10.0-1~deb9u1 » (Debian:9.13/oldstable [all]) pour « thunderbird-l10n-fr »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libbotan-2-17 libtspi1
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libevent-2.0-5 libffi6 libjsoncpp1
Paquets recommandés :
  lightning
Les NOUVEAUX paquets suivants seront installés :
  libevent-2.0-5 libffi6 libjsoncpp1
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  thunderbird thunderbird-l10n-fr
0 mis à jour, 3 nouvellement installés, 2 remis à une version inférieure, 0 à enlever et 7 non mis à jour.
Inst libevent-2.0-5 (2.0.21-stable-3 Debian:9.13/oldstable [amd64])
Inst libffi6 (3.2.1-9 Debian:10.9/stable, Debian:unstable [amd64])
Inst libjsoncpp1 (1.7.4-3.1 Debian:unstable [amd64])
Inst thunderbird-l10n-fr [1:78.9.0-1] (1:68.10.0-1~deb9u1 Debian:9.13/oldstable [all]) []
Inst thunderbird [1:78.9.0-1] (1:68.10.0-1~deb9u1 Debian:9.13/oldstable [amd64])
Conf libevent-2.0-5 (2.0.21-stable-3 Debian:9.13/oldstable [amd64])
Conf libffi6 (3.2.1-9 Debian:10.9/stable, Debian:unstable [amd64])
Conf libjsoncpp1 (1.7.4-3.1 Debian:unstable [amd64])
Conf thunderbird-l10n-fr (1:68.10.0-1~deb9u1 Debian:9.13/oldstable [all])
Conf thunderbird (1:68.10.0-1~deb9u1 Debian:9.13/oldstable [amd64])


Jouer sous Debian ? Facile !

Hors ligne

#13 19-04-2021 09:45:42

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Hello
c'est la version de jessie qu'il faut , la 68
enfin le principe est le même il faut juste mettre jessie au lieu de stretch

Dernière modification par Croutons (19-04-2021 09:52:14)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 19-04-2021 10:12:33

nam1962
Membre
Distrib. : Manjaro, Debian, Xubuntu, Yunohost
Noyau : Ca dépend
(G)UI : Xfce
Inscription : 02-08-2017
Site Web

Re : Thunderbird - retrograder à la version 68 (Jessie !)

gieres a écrit :

Bonsoir,
Pour des problèmes de compatibilité avec SoGo,



...Et remplacer SoGo par Nextcloud ? https://project-management.zone/system/nextcloud,sogo


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Manjaro Xfce - Debian Xfce - Yunohost - Xubuntu Et vous ?
59 convertis  IRL (n'ont pas eu le choix...).

Hors ligne

#15 27-04-2021 22:05:26

gieres
Membre
Inscription : 08-10-2017

Re : Thunderbird - retrograder à la version 68 (Jessie !)

Bonsoir à tous,
Un grand merci à tous, échange très intéressant pour un novice comme moi.
Je crois qu'on va creuser la piste de Nextcloud !!
A une prochaine...

Hors ligne

#16 28-04-2021 21:48:48

nam1962
Membre
Distrib. : Manjaro, Debian, Xubuntu, Yunohost
Noyau : Ca dépend
(G)UI : Xfce
Inscription : 02-08-2017
Site Web

Re : Thunderbird - retrograder à la version 68 (Jessie !)

yes.gif

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Manjaro Xfce - Debian Xfce - Yunohost - Xubuntu Et vous ?
59 convertis  IRL (n'ont pas eu le choix...).

Hors ligne

Pied de page des forums