Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-07-2021 12:45:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

[Résolu] Avoir le caractère e_dans_o directement au clavier

Re-bonjour,

Dans mon ancienne machine, j'appuie sur la touche petit-2, la première à gauche de la rangée des chiffres sur mon clavier Azerty tout ce qu'il y a de plus banal, juste sous la touche Echap, et j'ai un joli œ.

Dans la nouvelle machine, tout ce que je gagne c'est un petit 2 en exposant, et la doc sur le sujet chez Debian.org est grave périmée (janvier 2004) puisqu'on y parle de fichiers que je ne possède pas, genre xserver-xfree86 et quand je fais apt show xserver-xfree86 ça me dit "aucun paquet n'a été trouvé".

Quelqu'un sait comment faire ? D'avance merci,

Dernière modification par jpt (09-07-2021 13:52:50)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#2 09-07-2021 12:52:38

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Hello,

Pour avoir ces caractères œ æ etc ...
Il te faut configurer ton clavier avec une disposition Français et une variante Occitan.
Du moins, c'est ainsi que j'ai fait.

Ensuite ces caractères sont accessibles avec la touche "Compose" + o (relâche o) + e = œ.

Au plaisir smile

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#3 09-07-2021 12:54:13

arpinux
CA Debian-Facile
Lieu : Montréal d'aude
Distrib. : nakeDeb
Noyau : 5.10-amd64
(G)UI : i3wm - fluxbox
Inscription : 30-06-2016
Site Web

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

salut,

alors soit tu as un mappage clavier inadéquate, dans ce cas, un ptit

dpkg-reconfigure keyboard-configuration


devrait arranger ça
et pour avoir un preview, tu peux utiliser 'setxkbmap' (plus d'info dans le wikiDF https://debian-facile.org/doc:materiel: … s:claviers )

et si vraiment tu ne peux pas configurer ton clavier par défaut, alors tu peux envisager d'utiliser 'xev' pour identifier ta touche, et changer le mappage à la main avec xbindkeys et xbindkeys-config (le GUI)

et oui, sinon, méthode classique : AltGr+o=œ , merci Tawal smile

Dernière modification par arpinux (09-07-2021 12:56:09)


nous sommes tous différents ... c'est notre point commun ...
Association Debian-Facile - Les cahiers du débutant - ISO Debian-Facile - 3hg - nakeDeb

En ligne

#4 09-07-2021 13:00:12

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

arpinux a écrit :

AltGr+o=œ


Non pas chez moi, AltGr+o=ó
"Touche Windows" + o + e = œ
AltGr+p=ò, AltGr+m=ö, AltGr+l=ô etc ... wink


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#5 09-07-2021 13:21:07

arpinux
CA Debian-Facile
Lieu : Montréal d'aude
Distrib. : nakeDeb
Noyau : 5.10-amd64
(G)UI : i3wm - fluxbox
Inscription : 30-06-2016
Site Web

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

donc oui, une configuration du clavier + .... des tests lol

nous sommes tous différents ... c'est notre point commun ...
Association Debian-Facile - Les cahiers du débutant - ISO Debian-Facile - 3hg - nakeDeb

En ligne

#6 09-07-2021 13:42:48

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Tawal a écrit :

"Touche Windows" + o + e = œ

J'en ai choisi une autre, la touche Windows (le "logo") étant affectée à autre chose (je ne sais pas où ni par qui), toujours est-il que l'appui sur e m'affiche l'explorateur, pas glop !

arpinux a écrit :

et oui, sinon, méthode classique : AltGr+o=œ , merci Tawal smile

sans action.

Et pour faire court et simple, je n'y arrive pas -- on va laisser tomber, je n'ai pas envie de passer des heures à faire des tests pour un résultat aléatoire et risquer de tout casser.
C'est malheureux mais c'est comme ça.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#7 09-07-2021 13:48:50

arpinux
CA Debian-Facile
Lieu : Montréal d'aude
Distrib. : nakeDeb
Noyau : 5.10-amd64
(G)UI : i3wm - fluxbox
Inscription : 30-06-2016
Site Web

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

jpt a écrit :

J'en ai choisi une autre, la touche Windows (le "logo") étant affectée à autre chose (je ne sais pas où ni par qui), toujours est-il que l'appui sur e m'affiche l'explorateur, pas glop !


c'est un raccourci LXDE/OpenBox, ça se configure depuis lxconf ou obconf

jpt a écrit :

sans action.

Et pour faire court et simple, je n'y arrive pas -- on va laisser tomber, je n'ai pas envie de passer des heures à faire des tests pour un résultat aléatoire et risquer de tout casser.
C'est malheureux mais c'est comme ça.



c'est toujours un plaisir de donner du temps pour répondre roll


nous sommes tous différents ... c'est notre point commun ...
Association Debian-Facile - Les cahiers du débutant - ISO Debian-Facile - 3hg - nakeDeb

En ligne

#8 09-07-2021 13:51:47

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

j'ai trouvé, ici : https://forum.ubuntu-fr.org/viewtopic.p … 68#p672068

Pour avoir les caractères spéciaux avec AltGr, dans /etc/X11/xorg.conf / section  "InputDevice" sous la ligne :
    Option        "XkbLayout"    "fr"        ajouter la ligne :
    Option        "XkbVariant"    "latin9"


Le fichier à modifier c'est /etc/X11/xorg.conf.d/00-keyboard.conf puis hop !, un coup de logoff/logon et c'est good !
œœœœœ simplement en appuyant sur ma touche petit-2, cool

Merci à vous deux, yes.gif

Dernière modification par jpt (09-07-2021 13:55:39)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#9 09-07-2021 14:18:35

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Oui avec la variante Latin9 tu as les caractères œ æ ... mais peut-être pas les ñ ß ©®Ñ etc ...

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#10 09-07-2021 15:27:29

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Te répondrai un peu plus tard, la machine est éteinte et il faut que je file, là.

AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#11 09-07-2021 15:52:20

Kiki
Adhérent(e)
Distrib. : Debian 10
Noyau : 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 07-08-2019

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

avec clavier Français (variante obsolète)
file-R970b174a923a80ba76f16be4f3aa50d6

"Apprendre va de paire avec désapprendre." E Klein
"Si vous ne vous sentez pas bien, faites vous sentir par un autre." F Blanche

Hors ligne

#12 09-07-2021 18:31:39

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Bonsoir,

@Tawal : grâce à l'image de Kiki, je peux faire les codes que tu demandais, étant entendu que dans l'immense majorité de mes travaux, je n'en aurai pas besoin. Et si jamais, en cas de besoin j'ai un papier qui reprend les codes Unicode avec Ctrl-Shift-U_le_code_qui_va_bien et même certains je les connais par cœur, cool

@Kiki : merci pour cette image et l'info, en ce qui me concerne j'ai Français - Français (variante). Quelle variante ? On ne sait pas.
J'ai vérifié mon clavier avec ton image (pas tout, hein), et on dirait bien que c'est tout pareil. Merci à toi, où as-tu trouvé cette image ?

AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#13 09-07-2021 20:13:38

Kiki
Adhérent(e)
Distrib. : Debian 10
Noyau : 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 07-08-2019

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

jpt a écrit :

où as-tu trouvé cette image ?


Avec Gnome, dans Paramètres / Pays et Langue, on peut visualiser la disposition du clavier.


"Apprendre va de paire avec désapprendre." E Klein
"Si vous ne vous sentez pas bien, faites vous sentir par un autre." F Blanche

Hors ligne

#14 10-07-2021 11:15:30

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Bonjour,

Kiki a écrit :

Avec Gnome

Aïe ! J'ai pas.
Bah, ça ira bien comme ça.

La chose qui m'aurait intéressé, c'est la différence entre Français (variante obsolète) et Français (variante).
Une idée ?
Bonne journée,


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#15 10-07-2021 12:30:02

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Bjr,

Un exemple de variante obsolète. Le fichier /etc/default/keyboard:

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="oss"
XKBOPTIONS="lv3:ralt_switch,terminate:ctrl_alt_bksp"

Sinon tu mets "oss" dans ton xorg.conf


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#16 10-07-2021 12:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Bonjour,

jpt a écrit :

La chose qui m'aurait intéressé, c'est la différence entre Français (variante obsolète) et Français (variante).


La disposition fr(oss) est une évolution de la disposition fr(latin9) (dite obsolète) apparue en 2006 :

640px-KB_France_Linux.svg.png
Source : commons.wikimedia.org

C'est la disposition par défaut du projet DFiso. L'article de référence de Nicolas Mailhot, mainteneur.

Hors ligne

#17 10-07-2021 12:48:05

Kiki
Adhérent(e)
Distrib. : Debian 10
Noyau : 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 07-08-2019

Re : [Résolu] Avoir le caractère e_dans_o directement au clavier

Français (variante) --> https://fr.wikipedia.org/wiki/Dispositi … sie#AZERTY

edit : redondant envoyé simultanément à réponse précédente

Dernière modification par Kiki (10-07-2021 12:52:30)


"Apprendre va de paire avec désapprendre." E Klein
"Si vous ne vous sentez pas bien, faites vous sentir par un autre." F Blanche

Hors ligne

Pied de page des forums