Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-08-2021 10:22:00

crob
Membre
Inscription : 24-08-2021

captvty avec wine sous debian bullseye

Bonjour,

J'utilise captvty (http://captvty.fr/) sous debian depuis des années.
Le tuto https://debian-facile.org/doc:media:captvty fonctionne très bien avec debian buster.
Mais en passant à debian bullseye en 64bit, il y a quelques jours, je me suis retrouvé bloqué par des pb de dépendances:

dpkg --add-architecture i386 && apt-get update
apt install wine wine32 wine64 libwine libwine:i386 fonts-wine


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
fonts-wine est déjà la version la plus récente (5.0.3-3).
fonts-wine passé en « installé manuellement ».
libwine est déjà la version la plus récente (5.0.3-3).
libwine passé en « installé manuellement ».
wine est déjà la version la plus récente (5.0.3-3).
wine passé en « installé manuellement ».
wine64 est déjà la version la plus récente (5.0.3-3).
wine64 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libwine : Dépend: libfaudio0 (>= 19.06.07) mais ne sera pas installé
           Dépend: libglib2.0-0 (>= 2.12.0) mais ne sera pas installé
           Dépend: libgphoto2-6 (>= 2.5.10) mais ne sera pas installé
           Dépend: libgstreamer-plugins-base1.0-0 (>= 1.0.0) mais ne sera pas installé
           Dépend: libgstreamer1.0-0 (>= 1.4.0) mais ne sera pas installé
           Dépend: libxml2 (>= 2.9.0) mais il n'est pas installable
           Recommande: libsane1 (>= 1.0.27) mais ne sera pas installé
           Recommande: libxslt1.1 (>= 1.1.25) mais ne sera pas installé
           Recommande: libasound2-plugins mais ne sera pas installé
           Recommande: gstreamer1.0-plugins-good mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Le noyau debian est:
Linux clevo 5.10.0-8-amd64 #1 SMP Debian 5.10.46-4 (2021-08-03) x86_64 GNU/Linux

Comment résoudre le pb de dépendances?
Le message à propos d'*incoming* signifie-t-il que des mises à jour à venir règleront le pb?

Une mise à jour du tuto
https://debian-facile.org/doc:media:captvty
est-elle envisagée?

Merci.

Bien cordialement
--
Stephane

Hors ligne

#2 24-08-2021 14:19:17

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : captvty avec wine sous debian bullseye

Bonjour
moi ça fonctionne en simulation


0 mis à jour, 204 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 148 Mo dans les archives.
Après cette opération, 768 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 




apt -s install wine wine32 wine64 libwine libwine:i386 fonts-wine
 



essaie avec aptitude


aptitude -s install wine wine32 wine64 libwine libwine:i386 fonts-wine
 



voir ce qu'il te propose
ps: mince tester sur "testing" , je regarde sur bullseye on sait jamais  smile

re, idem correct sur bullseye


0 mis à jour, 206 nouvellement installés, 0 à enlever et 0 non mis à jour.
 



la mise a jour de buster vers bullseye a été correcte ?
ton sources.list est correct , pas de dépôt tier ? (extérieur a debian)
ce n'est pas un problème de debian 11 bullseye , mais un souci de ton installation
il va falloir réparer

Dernière modification par robert2a (24-08-2021 14:37:43)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 24-08-2021 19:16:22

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : captvty avec wine sous debian bullseye

Hello
Pour l'instant ça passe aussi sur ma VM mais c'est lent j'ai arreté
déja pas mal de paquets sont installé en meme temps que winetricks
la je suis sur une erreur qui tourne en boucle sur le script winetricks quand j’installe dotnet40
je  referais un essai (en VM sur mon vieux double cœur cela prend des plombs)

edit: ça a l'etre de fonctionner
malgres flash player qui n'a jamais voulu démarrer son installation et dotnet40 qui ne se termine pas

Dernière modification par Croutons (25-08-2021 09:09:31)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 25-08-2021 14:27:23

crob
Membre
Inscription : 24-08-2021

Re : captvty avec wine sous debian bullseye

Bonjour,

J'ai viré les dépots tiers (teamviewer, qarte et virtualbox), mais cela ne change rien:

# apt -s install wine wine32 wine64 libwine libwine:i386 fonts-wine
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
fonts-wine est déjà la version la plus récente (5.0.3-3).
fonts-wine passé en « installé manuellement ».
libwine est déjà la version la plus récente (5.0.3-3).
libwine passé en « installé manuellement ».
wine est déjà la version la plus récente (5.0.3-3).
wine passé en « installé manuellement ».
wine64 est déjà la version la plus récente (5.0.3-3).
wine64 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libwine : Dépend: libfaudio0 (>= 19.06.07) mais ne sera pas installé
           Dépend: libglib2.0-0 (>= 2.12.0) mais ne sera pas installé
           Dépend: libgphoto2-6 (>= 2.5.10) mais ne sera pas installé
           Dépend: libgstreamer-plugins-base1.0-0 (>= 1.0.0) mais ne sera pas installé
           Dépend: libgstreamer1.0-0 (>= 1.4.0) mais ne sera pas installé
           Dépend: libxml2 (>= 2.9.0) mais il n'est pas installable
           Recommande: libsane1 (>= 1.0.27) mais ne sera pas installé
           Recommande: libxslt1.1 (>= 1.1.25) mais ne sera pas installé
           Recommande: libasound2-plugins mais ne sera pas installé
           Recommande: gstreamer1.0-plugins-good mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



# dpkg -l|egrep "(libfaudio0|libglib2.0-0|libgphoto2-6|libgstreamer-plugins-base1.0-0|libgstreamer1.0-0|libxml2|libsane1|libxslt1.1|libasound2-plugins|gstreamer1.0-plugins-good)"


ii  gstreamer1.0-plugins-good:amd64           1.18.4-2                                         amd64        GStreamer plugins from the "good" set
ii  libasound2-plugins:amd64                  1.2.2-2                                          amd64        ALSA library additional plugins
rc  libasound2-plugins:i386                   1.1.8-1                                          i386         ALSA library additional plugins
ii  libfaudio0:amd64                          21.02-1                                          amd64        XAudio sound processing reimplementation - library
ii  libglib2.0-0:amd64                        2.66.8-1                                         amd64        GLib library of C routines
rc  libglib2.0-0:i386                         2.58.3-2+deb10u3                                 i386         GLib library of C routines
ii  libgphoto2-6:amd64                        2.5.27-1                                         amd64        gphoto2 digital camera library
ii  libgstreamer-plugins-base1.0-0:amd64      1.18.4-2                                         amd64        GStreamer libraries from the "base" set
ii  libgstreamer1.0-0:amd64                   1.18.4-2.1                                       amd64        Core GStreamer libraries and elements
ii  libsane1:amd64                            1.0.31-4.1                                       amd64        API library for scanners
ii  libxml2:amd64                             2.9.12+dfsg-0+0~20210621.9+debian10~1.gbp43e861  amd64        GNOME XML library
ii  libxml2-utils                             2.9.12+dfsg-0+0~20210621.9+debian10~1.gbp43e861  amd64        XML utilities
ii  libxslt1.1:amd64                          1.1.34-4                                         amd64        XSLT 1.0 processing library - runtime library
ii  python3-libxml2:amd64                     2.9.12+dfsg-0+0~20210621.9+debian10~1.gbp43e861  amd64        Python3 bindings for the GNOME XML library



Les versions installées ont l'air ok.

J'ai tenté la désinstallation de wine et j'ai refait:

dpkg --add-architecture i386 && apt-get update &&
apt install wine wine32 wine64 libwine libwine:i386 fonts-wine
 



mais sans plus de succès:(

Merci

Hors ligne

#5 25-08-2021 17:38:02

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : captvty avec wine sous debian bullseye

Bonjour
inutile de refaire cette commande , si le i386 est pris en charge


dpkg --add-architecture i386 && apt-get update
Atteint :1 https://deb.debian.org/debian bullseye InRelease
Atteint :2 https://deb.debian.org/debian bullseye-updates InRelease
Atteint :3 https://security.debian.org/debian-security bullseye-security InRelease
Réception de :4 https://deb.debian.org/debian bullseye/main i386 Packages [8117 kB]
Réception de :5 https://security.debian.org/debian-security bullseye-security/main i386 Packages [27,5 kB]
Réception de :6 https://deb.debian.org/debian bullseye/contrib i386 Packages [45,3 kB]
Réception de :7 https://deb.debian.org/debian bullseye/non-free i386 Packages [76,7 kB]
8267 ko réceptionnés en 5s (1517 ko/s)              
Lecture des listes de paquets... Fait
 


donc ok pour l'architecture i386
pour les paquets je t'ai conseiller "aptitude" , du paquet du même nom


aptitude -s install wine wine32 wine64 libwine libwine:i386 fonts-wine
 




aptitude -s install wine wine32 wine64 libwine libwine:i386 fonts-wine
Note: selecting "wine32:i386" instead of the virtual package "wine32"
Les NOUVEAUX paquets suivants vont être installés :
 
0 paquets mis à jour, 268 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 199 Mo d'archives. Après dépaquetage, 963 Mo seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] n
 


bon pour moi pas de proposition puisque tout va bien

si tu fais un "remove --purge , ça va te casser "wine" (32 et 64)


apt -s remove --purge  wine wine32 wine64 libwine libwine:i386 fonts-wine
 


tu regarde bien ce qui est enlever (simulation) et si ok tu le fait en vrai .
ensuite un nettoyage idem bien regarder ce qu'il se passe


apt-get -s autoremove --purge
 


si ok tu le fais
un autoclean et un update


apt autoclean
 



apt update
 


tu simule avec la même commande que moi


apt-get -s --reinstall install  wine wine32 wine64 libwine libwine:i386 fonts-wine
 


si encore des soucis avec aptitude


aptitude -s install  wine wine32 wine64 libwine libwine:i386 fonts-wine
 


et tu regarde les propositions
tu peu aller jusqu'au bout , il est en mode simulation (il faut répondre par "y" ou "n" )

pour la liste des paquets qui posent problème


Les paquets suivants contiennent des dépendances non satisfaites :
 libwine : Dépend: libfaudio0 (>= 19.06.07) mais ne sera pas installé
           Dépend: libglib2.0-0 (>= 2.12.0) mais ne sera pas installé
           Dépend: libgphoto2-6 (>= 2.5.10) mais ne sera pas installé
           Dépend: libgstreamer-plugins-base1.0-0 (>= 1.0.0) mais ne sera pas installé
           Dépend: libgstreamer1.0-0 (>= 1.4.0) mais ne sera pas installé
           Dépend: libxml2 (>= 2.9.0) mais il n'est pas installable
           Recommande: libsane1 (>= 1.0.27) mais ne sera pas installé
           Recommande: libxslt1.1 (>= 1.1.25) mais ne sera pas installé
           Recommande: libasound2-plugins mais ne sera pas installé
           Recommande: gstreamer1.0-plugins-good mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



juste après le "remove --purge" et le "autoremove"
tu vérifie que libwine n'est plus installé
par exemple avec un apt policy


apt policy libwine
 


et tu fais la même chose pour "libfaudio0" , "libgphoto2-6"  "libgstreamer-plugins-base1.0-0" etc jusqu a libxml2
idem pour les 4 derniers (libsane1 , libxslt1.1, libasound2-plugins et gstreamer1.0-plugins-good

par exemple celui la


apt policy gstreamer1.0-plugins-good
gstreamer1.0-plugins-good:
  Installé : 1.18.4-2
  Candidat : 1.18.4-2
 Table de version :
 *** 1.18.4-2 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 


il est bien en version bullseye (correct)
idem pour le reste
certain paquet ne peuvent être retirer , mais réparer oui
et toujours en simulation pour ne pas endommager plus ta debian
si un paquet pose problème aptitude te donnera des solutions

quand tout est propre tu pourra lancer l'installation (simulation puis en vrai )
un autre exemple


apt policy libfaudio0
libfaudio0:
  Installé : (aucun)
  Candidat : 21.02-1
 Table de version :
     21.02-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
 


la version doit être 21.02-1
ce paquet a mon avis peut être désinstaller etc    ...........    smile
tu a des outils comme "remove" et "autoremove" et un "apt-get upgrade" par exemple pour voir si des paquets sont en attente de suppression .
il y a synaptic (graphique) qui est pratique aussi comme outil
et dans le doute en simulation "-s" pour éviter les catastrophes

dernière chose pour éviter cela


wine64 est déjà la version la plus récente (5.0.3-3).
wine64 passé en « installé manuellement ».
 


utiliser l'option "--reinstall install" , ça va éviter ceci "wine64 passé en « installé manuellement"

une dernière chose mon sources.list


deb https://deb.debian.org/debian/ bullseye main contrib non-free
deb https://security.debian.org/debian-security bullseye-security main contrib non-free
deb https://deb.debian.org/debian/ bullseye-updates main contrib non-free
 


je n'ai aucun autre dépôt sur debian11 (que ceux officiel de debian)

ta remarque pour les dépôts tiers


J'ai viré les dépots tiers (teamviewer, qarte et virtualbox), mais cela ne change rien:
 


il reste des paquets qui ne sont pas en version debian11 sûrement
c'est le risque quand on utilise ce genre de choses de casser sa debian

Dernière modification par robert2a (25-08-2021 18:44:26)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 25-08-2021 19:44:17

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : captvty avec wine sous debian bullseye

par exemple ceci


ii  libxml2:amd64                             2.9.12+dfsg-0+0~20210621.9+debian10~1.gbp43e861  amd64        GNOME XML library
 


ce serait un paquet de buster10  => https://bugs.debian.org/cgi-bin/bugrepo … bug=990716
moi j'ai ceci pour debian11


libxml2:
  Installé : 2.9.10+dfsg-6.7
  Candidat : 2.9.10+dfsg-6.7
 


voir ce que aptitude va te répondre
ps: sur ton #4 tu a déjà relever toutes versions des paquets installer .
idem pour libxml2-utils , pas la bonne version

etc pour tous les paquets lister

avec synaptic tu a tous les paquets obsolètes , plus pratique pour détecter ce qui ne va pas , et tu a une fonction "forcer la version" (si pas de dépendances)
il y a une commande en console aussi , pour faire l'état des paquets de la debian installer , dont je me souvient jamais  tongue

il demande une mise a jour => https://debian-facile.org/doc:media:captvty
c'est lourd comme installation sur GNU Linux  hmm

Dernière modification par robert2a (25-08-2021 20:29:05)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums