Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-10-2021 17:04:38

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

debian 11 + iredmail -> mariadb issue ?

Bonjour,

Je viens taper à votre porte parce que je me sens bien seul sur le forum iredmail : https://forum.iredmail.org/topic18514-d … issue.html

En plus je vais pouvoir écrire en français, et ça, ça fait du bien smile

Je refais l'histoire : j'ai un serveur mail (debian+iredmail) depuis un bout de temps.

Cet été, le support iredmail annonce la compatibilité iredmail 1.4.2 avec bullseye et fournit la procédure de mise à niveau. Comme d'habitude, c'est plutôt fait sérieusement et on sait ce qu'on a à faire.

Donc cet été, je me lance dans la procédure :

  • mise à niveau de iredmail vers 1.4.2

  • mise à niveau de debian

  • procédure post upgrade



Tout semble bien se passer. Sauf que... au bout de quelques jours, impossible d'envoyer des emails et je remarque que je n'en ai pas reçu depuis quelque temps. Je fais des tests d'envoi et de réception, je constate que ça ne marche pas, je me connecte sur le serveur et fouille les logs et trouve plein d'erreur d'accès mariadb. Après plusieurs tentatives de réparation qui échouent, je reboote et pof... ça remarche.

Quelques jours plus tard, rebelote.

Bref, au bout de 2 semaines à effectuer des reboots au bout d'un temps aléatoire, ça m'énerve et je réinstalle un dump de mon serveur d'avant mise à jour : donc retour vers buster.

Pendant ces vacances (je suis prof), je me dis qu'il est temps de m'y recoller. En plus j'ai un pote qui a la même configuration que moi et chez qui c'est passé comme une lettre à la poste. Du coup je me lance et là, on arrive sur mon post iredmail : https://forum.iredmail.org/topic18514-d … issue.html

Bref au bout de deux jours à batailler, ça marche. Moi content smile Mais deux jours plus tard : mêmes symptômes que cet été. Moi fatigué...kernal_panic.gif

Alors c'est peut-être pas un soucis avec mariadb, je ne sais pas, en tout cas au bout d'un certain temps, smtpd et postfix refusent toutes connexions et je ne peux plus ni envoyer ni recevoir des mails.

Est-ce que ces logs vous donnent des idées de pistes à explorer ?

Oct 28 13:39:13 mail postfix/postscreen[83315]: CONNECT from [209.85.221.41]:40916 to [192.168.132.104]:25
Oct 28 13:39:19 mail postfix/postscreen[83315]: PASS NEW [209.85.221.41]:40916
Oct 28 13:39:19 mail postfix/smtpd[83318]: connect from mail-wr1-f41.google.com[209.85.221.41]
Oct 28 13:39:19 mail postfix/smtpd[83318]: Anonymous TLS connection established from mail-wr1-f41.google.com[209.85.221.41]: TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256
Oct 28 13:39:19 mail postfix/smtpd[83318]: 4Hg3Vv4KByzyY7: client=mail-wr1-f41.google.com[209.85.221.41]
Oct 28 13:39:19 mail postfix/cleanup[83323]: 4Hg3Vv4KByzyY7: message-id=<52216655-b507-3eb6-0d3b-d3fb39a572e0@gmail.com>
Oct 28 13:39:19 mail postfix/cleanup[83323]: 4Hg3Vv4KByzyY7: prepend: header Content-Language: fr from mail-wr1-f41.google.com[209.85.221.41]; from=<XXXXXX@gmail.com> to=<XXXX@XXXXX.XXX> proto=ESMTP helo=<mail-wr1-f41.google.com>: List-Unsubscribe: <unsubscribe@XXXXX.XXX>
Oct 28 13:39:19 mail postfix/qmgr[83244]: 4Hg3Vv4KByzyY7: from=<XXXXXX@gmail.com>, size=2856, nrcpt=1 (queue active)
Oct 28 13:39:19 mail postfix/amavis/smtp[83324]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Oct 28 13:39:19 mail postfix/smtpd[83318]: disconnect from mail-wr1-f41.google.com[209.85.221.41] ehlo=2 starttls=1 mail=1 rcpt=1 bdat=1 quit=1 commands=7
Oct 28 13:39:19 mail postfix/amavis/smtp[83324]: 4Hg3Vv4KByzyY7: to=<XXXX@XXXXX.XXX>, relay=none, delay=0.18, delays=0.17/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Oct 28 13:39:37 mail mariadbd[81679]: 2021-10-28 13:39:37 27 [Warning] Aborted connection 27 to db: 'vmail' user: 'vmailadmin' host: 'localhost' (Got an error reading communication packets)
Oct 28 13:40:01 mail CRON[83333]: (root) CMD (/bin/bash /usr/local/bin/fail2ban_banned_db unban_db)
Oct 28 13:40:17 mail mariadbd[81679]: 2021-10-28 13:40:17 46 [Warning] Aborted connection 46 to db: 'vmail' user: 'vmailadmin' host: 'localhost' (Got an error reading communication packets)
Oct 28 13:41:01 mail CRON[83360]: (root) CMD (/bin/bash /usr/local/bin/fail2ban_banned_db unban_db)



Et surtout, une piste de résolution ? J'ai pensé à faire un dump de la base, désinstaller complètement mariadb, réinstaller mariadb et restaurer la base : est-ce idiot comme idée ? J'avoue que je pédale un peu dans la semoule...

Hors ligne

Pied de page des forums