Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-03-2022 17:35:48

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

startpar : service(s) returned failure : plymouth

Bonjour, après avoir démarré mon pc, j'ai vu ce message, ci dessus :

J'ai regardé sur le net et je suis tombé entre autre sur le forum mx parce que quelqu'un avait ce problème:

https://forum.mxlinux.org/viewtopic.php … d092feb998

J'ai essayé la solution indiquée  en supprimant le mot « splash » et en mettant « nomodeset ». En fait j'ai vu « quiet splash » et j'ai seulement  enlever « splash » et non   « quiet splash ». J'ai appuyé sur F10 mais le démarrage se fait à l'identique:  écran noir avec ce message et invite de commande qui me demande mon identifiant et mon mot de passe:

J'ai essayé ceci : https://www.youtube.com/watch?v=FqUioYE6 sans résultat.

Que faire du coup ?

Merci d'avance

Nico

Il n'y a pas de mauvaises questions...

Hors ligne

#2 09-03-2022 18:12:46

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : startpar : service(s) returned failure : plymouth

Je n’ai pas regardé la vidéo YouTube que tu as partagée, donc je ne sais pas si ce que je propose fait doublon.

---

La méthode la plus simple pour se débarrasser des soucis liés à plymouth est, tout bêtement, de le désinstaller :

apt remove plymouth

C’est ce que j’ai fait dès mon premier problème avec plymouth, sur Ubuntu il y a une quinzaine d’années. Et j’en suis pleinement satisfait depuis wink


Jouer sous Debian ? Facile !

Hors ligne

#3 09-03-2022 18:14:52

raleur
Membre
Inscription : 03-10-2014

Re : startpar : service(s) returned failure : plymouth

calixtus06 a écrit :

après avoir démarré mon pc, j'ai vu ce message, ci dessus


Et que s'est-il passé avant de redémarrer ?

calixtus06 a écrit :

J'ai essayé la solution indiquée  en supprimant le mot « splash » et en mettant « nomodeset ».


La "solution"dont il est indiqué qu'elle n'a rien donné ?
Supprimer le paramètre "splash" de la ligne de commande du noyau ne désactive pas complètement plymouth, seulement le splash screen graphique. Pour désactiver complètement plymouth autremement qu'en le désinstallant, il faut remplacer "splash" par "nosplash". Mais je parle du plymouth qui se lance dès l'initramfs, pas du service plymouth mentionné dans le message, qui se lance après et qui est probablement géré par ton gestionnaire d'init comme tous les autres services. Quant à nomodeset, je ne vois pas en quoi ça pourrait améliorer quoi que ce soit.

Je n'irai pas voir la vidéo, question de principe.


Il vaut mieux montrer que raconter.

Hors ligne

#4 10-03-2022 10:23:40

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : startpar : service(s) returned failure : plymouth

Bonjour et merci pour vos réponses.

J'ai remplacé splash par nosplash

J'ai désormais  un invite de commande me demandant mon identifiant et mon mot de passe mais aucun "bureau". J'ai tout de même  supprimé plymouth par apt remove plymouth

Comment retrouver mon bureau habituel ?

Il n'y a pas de mauvaises questions...

Hors ligne

#5 10-03-2022 11:01:08

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : startpar : service(s) returned failure : plymouth

Bonjour
pas de splash et de nosplash , bien purger plymouth


apt remove --purge plymouth*
 



vérifier si rien a supprimer sur les dépendances de plymouth
en simulation


apt -s autoremove --purge
 


si retour "0" paquets a supprimer c'est que c'est ok

et un redémarrage pour prendre en compte

mais je sais pas si ton problème vient de la

sinon pour vérifier ceci


apt policy plymouth*
 


ps: il y a des librairie de plymouth aussi (libplymouth )
mais je vois pas le rapport avec le fait que tu n'a plus de bureau


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#6 10-03-2022 11:09:08

calixtus06
Membre
Distrib. : Librazik 4
Noyau : 5.10.0-14-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : startpar : service(s) returned failure : plymouth

J'ai appliqué les commandes de purge et avec apt policy plymouth* je n'ai plus rien d'installé autour de plymouth après redémarrage.

Il n'y a pas de mauvaises questions...

Hors ligne

#7 10-03-2022 11:51:49

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : startpar : service(s) returned failure : plymouth

donc ton souci , plus de serveur graphique et plus de bureau
il te reste que la console pure (écran noir) ou tu peu te logger en user ou root ?

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#8 10-03-2022 11:56:10

raleur
Membre
Inscription : 03-10-2014

Re : startpar : service(s) returned failure : plymouth

robert2a a écrit :

donc ton souci , plus de serveur graphique et plus de bureau


Ou plus de gestionnaire de connexion. Mais je suis d'accord, aucun rapport avec plymouth.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums