Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-06-2022 19:54:04

Chris
Membre
Lieu : Bourgogne
Distrib. : Buster 64
Noyau : Linux 4.19.0-6-amd64
(G)UI : KDE
Inscription : 15-11-2008

installation bullseyes avec nvidia 3070 impossible (contourné)

Bonjour à tous, smile

Tous les 10 ans, je renouvelle mon matériel.

Cette fois-ci, laptop sans OS, coreI7 de 11ème génération, et une carte nvidia 3070. (probablement soudée).
Début d'installation par live usb (envie de tester une LMDE) : message d’erreur quasi immédiat : "unknown chipset (b74000a1). mad
J'essaie une net install classique avec l'iso de base de deb : idem. mad
La seule iso qui passe est une linux mint cinnamon edge roll

Linux Mint 20.3
Release:    20.3
Codename : una

Echange avec l'assembleur,qui reçoit les kits intel. il me dit

En recherchant, j'ai vu qu'un Kernel 5.13 pourrait être la solution, mais j'imagine que Debian doit déjà être installé pour ça ? (mes compétences en linux s'arrête à peu près par-là).
Et pour info c'est bien la carte graphique Nvidia qui n'est pas encore compatible avec LMDE.


Quelqu'un entrevoit une solution ?

Pas possible d'installer une Debian en live usb, puis des dépôts de SID.
Bien sûr, je peux patienter en restant sous mint que la prochaine distribution de Debian intègre un noyau 5.13.
Mais s'il y a une solution pour installer une deb, (mint peut-être, mais Debian edition) ça m'arrange big_smile

Ne me dites pas que personne ne peut actuellement installer une bullseyes avec une nvidia 3070 ?

A vous lire

Merci. smile

Dernière modification par Chris (23-06-2022 16:12:23)

Hors ligne

#2 20-06-2022 21:01:30

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

Bonjour

Pas possible d'installer une Debian en live usb, puis des dépôts de SID.


C'est quel iso de debian que tu as utilisé ?
Tu dis install de debian impossible, même avec l'installateur en mode texte ?
Si tu arrives à l'installer en mode texte, n'installe aucun environnement de bureau.
Quand l'install est finie, tu ajoutes les backports à ton sources.list afin d'installer le noyau 5.16
Et ensuite installe le bureau de ton choix.

Hors ligne

#3 20-06-2022 23:25:52

Chris
Membre
Lieu : Bourgogne
Distrib. : Buster 64
Noyau : Linux 4.19.0-6-amd64
(G)UI : KDE
Inscription : 15-11-2008

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

smile Merci de m'avoir répondu.

J'ai utilisé

lmde-5-cinnamon-64bits.iso

, mais aussi

debian-11.3.0-amd64-netinst.iso


Je ne sais pas si l'installateur ne commence pas par faire le tour du matériel installé (au moins la carte réseau, pour aller chercher les paquets qui lui manquent). Même si j'arrêtais l'install au moment où il me demande si je veux installer un bureau, il n'irait pas au-delà du premier tour du propriétaire. mad

Mais si tu as une autre iso à suggérer, je tenterais bien sûr.
J'ai même essayé une Kaella (version francisée de la mythique knoppix). (cela ne nous rajeunit pas). Mais à l'époque de sa conception et de sa diffusion, l'UEFI nexistait pas. mad

Je me demande s'il existe une iso "server" qui passerait outre un chipset graphique inconnu, et pour lui inutile.
Perso, je me drigerai d'avantage sur une iso contenant un noyau 5.13 et ultérieur, comme cela semble être le cas des Mint 20.3

A suivre.... smile

Hors ligne

#4 21-06-2022 00:28:39

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

J'y avais pas pensé mais il existe des iso de debian testing (bookworm) là normalement l'installation devrait pourvoir se faire, et le noyau est en version 5.18 : https://cdimage.debian.org/cdimage/weekly-builds/amd64/

Hors ligne

#5 21-06-2022 05:54:16

Chris
Membre
Lieu : Bourgogne
Distrib. : Buster 64
Noyau : Linux 4.19.0-6-amd64
(G)UI : KDE
Inscription : 15-11-2008

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

smile Merci de ton implication

Bon. Va comprendre...
Quand je boot sur l'iso Debian net install, le système se lance, et l’installation commence normalement, avec son look d'Allemagne de l'Est auquel nous sommes habitués. smile
Du coup, j'ai laissé faire. C'est arrivé au partitionnement que les ennuis ont recommencé : espace disque trop petit (2To, c'es trop petit ? roll) Le partitionnement automatique refuse d'installer un OS . De mémoire, l'OS s'installe en prévenant que cela formatera les partitions, que cette opération est irréversible,...Là, je sais pas ce qu'il veut : la clé USB est considérée comme un disque
J'ai l'impression d'être un pur newbie,avec un système obscur et hostile. Bref. Découragé. (LMDE s'arrête toujours au bout de 2 secondes).
Bref. Je crois que je vais prendre mon portable sous le bras, et retourner à une install partie à mon club d'utilisateurs de logiciels libres régional. Je n'ai tellement pas fait d'installation ces dernières années que je ne sais pas ce qu'est UEFI, s'il faut y mettre un point de montage, quel système de fichier...
Je vais quand même télécharger l'iso testing que tu me suggères. merci.gif
Je vous tiens au courant (réunion de coagul demain soir).

Hors ligne

#6 23-06-2022 16:35:11

Chris
Membre
Lieu : Bourgogne
Distrib. : Buster 64
Noyau : Linux 4.19.0-6-amd64
(G)UI : KDE
Inscription : 15-11-2008

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

smile
Bonjour à tous,
Mon portable tout neuf tourne, avec une RTX 3070, les drivers propriétaires disponibles et fonctionnels, même si on a vu plus fonctionnel (il faut se déconnecter de sa session pour avoir recours à la carte graphique en plus du chipset d'origine prévu sur le processeur, ce qui tire sur la batterie).
Mais ce n'est pas sous Debian... roll
C'est mint (la version basée sur ubuntu, pas celle basée sur SID (la LMDE) qui détecte le chipset nvidia, et installe les drivers idoines.
J'ai passé la soirée d'hier avec un administrateur système, qui n'est pas un perdreau de l'année, qui a compilé module après module, avec différents noyaux, sans éviter des erreurs de compilations.

En deux mots, mais je n'apprends rien à personne : Debian, c'est exceptionnel de stabilité, de propreté de code, d'ethique. Mais il faut vraiment ne pas tenter de l'utiliser sur du matériel trop récent, avec des spécificités dévoilées seulement du côté de Redmond.
Bref. Je réinstallerai probablement une Debian d'ici quelques temps. Mais dans l'immédiat, j'ai besoin d'un système fonctionnel avec du matériel juste sorti d'usine. Et ce n'est pas quelque chose que Debian sait faire. Ni ce qu'on lui demande réellement en fait. smile

Hors ligne

#7 24-06-2022 13:12:12

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

Tu as essayé la debian testing ?
Bon l'essentiel c'est que ça marche

Hors ligne

#8 24-06-2022 15:44:43

Chris
Membre
Lieu : Bourgogne
Distrib. : Buster 64
Noyau : Linux 4.19.0-6-amd64
(G)UI : KDE
Inscription : 15-11-2008

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

Oui et non.
Oui, les seules iso qui se chargent sont celles de testing, ubuntu et mint (pas LMDE).
Une fois le noyau testing installé, on a essayé de compiler le module, changé de noyau, etc... Erreur de compilation à chaque fois. Les pilotes nouveau fonctionnent. On n'a sûrement pas essayé toutes les pistes, mais Marco touche sérieusement sa bille, donc...
En fait, les équipes de mint et de ubuntu sont quand même nettement plus étoffées que 6 amateurs admirant silencieusement un pro qui se décarcasse. J'ai baissé les bras à la maison, et ai provisoirement installé une mint, avec les pilotes nvidia fonctionnels, en attendant.

Non, parce que Debian est la mother distribution,et qu'elle est un garde fou contre les abus et dérives des uns et des autres. Que c'est des installations faites pour durer, qu'on choisit quand c'est dans un cadre professionnel, où les défaillances coûtent cher. Et enfin parce que c'est très formateur, que ça donne de bonnes bases et de bons réflexes, sans que l’investissement en temps ne soit démesuré (comme LFS par exemple). Et que c'est un lobbie assez prestigieux pour tousser dans les bronches des GAFAM, AMHA
Anyway, merci de ton aide smile

A charge de revanche smile

Hors ligne

#9 24-06-2022 19:39:37

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : installation bullseyes avec nvidia 3070 impossible (contourné)

OK, merci pour le retour

Hors ligne

Pied de page des forums