Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-07-2022 17:15:24

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

[Résolu] Je n'arrive plus à faire de mises à jour

Bonjour,

Depuis que j'ai installé ruby il y a quelques mois, je ne peux plus faire de mise à jour, plus rien installer ou désinstaller, je ne sais plus quoi faire.

Et même par exemple :

> apt --fix-broken install

J'optiens des erreurs bloquantes :

/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:93:in `singleton class': undefined method `default_specifications_dir' for class `Module' (NameError)
    from /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:67:in `<top (required)>'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `require'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `<top (required)>'
    from <internal:gem_prelude>:1:in `require'
    from <internal:gem_prelude>:1:in `<compiled>'
E: Le sous-processus /usr/bin/apt-listbugs apt a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listbugs apt


J'ai cherché un peu sur le forum, j'ai trouvé ce post : https://debian-facile.org/viewtopic.php?id=12166
mais je n'arrive pas à m'en sortir.

Je viens de créer un compte, je suis nouveau donc smile

Merci pour votre aide, et vive Linux ! smile

Juan

Dernière modification par juaito (01-08-2022 16:13:07)

Hors ligne

#2 31-07-2022 17:58:47

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

juaito a écrit :

Bonjour,

Depuis que j'ai installé ruby il y a quelques mois, je ne peux plus faire de mise à jour, plus rien installer ou désinstaller, je ne sais plus quoi faire.

Juan




Mais pas sur que ce soit l'install de ruby non plus.
J'avais un peu galérer à l'époque, j'avais debian 9, et pas sur d'avoir fait la mise à jour en version 11 dans les règles de l'art kernal_panic.gif


Là je viens de le test de réinstall de dpkg :
> apt-get install dpkg

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
dpkg est déjà la version la plus récente (1.20.9).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  argyll argyll-ref python3-distutils python3-lib2to3 vlc-l10n vlc-plugin-samba
Veuillez utiliser « apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 27 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:93:in `singleton class': undefined method `default_specifications_dir' for class `Module' (NameError)
    from /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:67:in `<top (required)>'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `require'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `<top (required)>'
    from <internal:gem_prelude>:1:in `require'
    from <internal:gem_prelude>:1:in `<compiled>'
E: Le sous-processus /usr/bin/apt-listbugs apt a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listbugs apt


Toujours ce pb de apt-listbugs


J'ai essayé de commenter le déclenchement :

... solution qui consiste à éditer /etc/apt/apt.conf.d/10apt-listbugs

// Before installing packages, check whether they have release-critical bugs.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/bin/apt-listbugs apt";};
DPkg::Tools::Options::/usr/bin/apt-listbugs "";
DPkg::Tools::Options::/usr/bin/apt-listbugs::Version "3";
DPkg::Tools::Options::/usr/bin/apt-listbugs::InfoFD "20";
AptListbugs::Severities "critical,grave,serious";
// AptListbugs::IgnoreRegexp "FTBFS";



et à commenter la ligne  DPkg::Pre-Install-Pkgs {"/usr/bin/apt-listbugs apt";};

(Post https://debian-facile.org/viewtopic.php?id=5348)


mais sans mieux, j'ai oublié un truc ?
merci smile

Dernière modification par juaito (31-07-2022 19:02:52)

Hors ligne

#3 31-07-2022 18:58:47

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

juaito a écrit :

Bonjour,

Depuis que j'ai installé ruby il y a quelques mois, je ne peux plus faire de mise à jour, plus rien installer ou désinstaller, je ne sais plus quoi faire.

Juan




Pour ruby :

> apt-cache policy ruby-locale

ruby-locale:
  Installé : 2.1.2-1.1
  Candidat : 2.1.2-1.1
Table de version :
*** 2.1.2-1.1 100
        100 /var/lib/dpkg/status
     2.1.2-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        500 http://deb.debian.org/debian stretch/main i386 Packages

Hors ligne

#4 31-07-2022 20:05:01

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Bonjour,
je ne sais pas si apt-list-bugs est vraiment le problème, ou s'il n'est que la conséquence d'un autre problème ...
je suis pas sûr que de trifougnier dedans soit une super idée ...

Quelques remarques de ce que je voit :

j'avais debian 9, et pas sur d'avoir fait la mise à jour en version 11 dans les règles de l'art


peut -être pas, effectivement:

ruby-locale:
500 http://deb.debian.org/debian stretch/main amd64 Packages
        500 http://deb.debian.org/debian stretch/main i386 Packages


t'as installé ruby avant ou après ta migration ?
de toute façon, on peut voir qu'il y a un couac ...
Peut-être vérifier ce qu'il y a dans le fichier sources.list et dans sources.list.d

27 non mis à jour.
1 partiellement installés ou enlevés.


et aussi dans le fichier qui se nomme preference (il me semble) ou preference.d
qui contient la liste des paquets épinglés ...
..et voir ce qu'est ce paquet "partiellement installé"
  c'était une idée et des remarques;
je crois pas non plus que ça va aider de s'en prendre à dpkg ...
Après, si vraiment aptlist-bugs t'embête, te suffi de le virer, c'est pas d'une super utilité sur une stable

En ligne

#5 31-07-2022 22:01:57

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

merci ubub smile


effectivement les mises à jour ne sont font plus depuis un moment.

je vais désactiver aptlist-bugs peut etre deja pour tester (je peux le désactiver ? j'ai essayé dans le fichier paramètre /etc/apt/apt.conf.d/10apt-listbugs (mais peut-être fallait-il modifier ailleurs aussi ? je ne sais pas comment le supprimer, apt-remove ne fonctionne pas)


pour les sources :

je viens de le mettre à jour :

deb http://deb.debian.org/debian/ bullseye main contrib non-free
#deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
#deb-src http://security.debian.org/debian-security bullseye main

deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ bullseye-updates main



Et dans sources.list.d :
-rw-r--r-- 1 root root  189  7 déc.   2017 google-chrome.list
-rw-r--r-- 1 root root  149 25 mai    2021 protonvpn-stable.list
-rw-r--r-- 1 root root   56 10 juin   2021 skype-stable.list
-rw-r--r-- 1 root root   50 18 nov.   2017 spotify.list
-rw-r--r-- 1 root root 1201 22 oct.   2020 teamviewer.list
-rw-r--r-- 1 root root  203  8 févr.  2021 vscode.list

je peux les enlever du dossier ? (comme je ne peux pas les supprimer avec apt)
(effectivement ils font des erreurs sur apt-update)


Et sinon, rien dans preferences.d :
> ls -l /etc/apt/preferences*
total 0




merci beaucoup, je n'ai plus trop l'occasion de toucher en ligne de commande finalement, c'est vraiment le coeur linux, depuis plus de 10 ans ça ronronne smile

Dernière modification par juaito (31-07-2022 22:08:13)

Hors ligne

#6 31-07-2022 22:23:15

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Re,

pour les sources :
je viens de le mettre à jour :


c'est à dire ? y'avait quoi écrit dedans avant de le "mettre à jour" ?
...je croyais que le sujet étai qu'il n'y avai pas de mise à jour possible ?

Et dans sources.list.d :
je peux les enlever du dossier ?



tu peux aussi mettre un # au début de la ligne, ça les "désactivera" le temps que tu réfléchisse posément à ce que tu veux garder ou nettoyer

et dans preference.d ?

ls /etc/apt/preferences.d


pour voir ce qu'il y a dedans, voir s'il y a un fichier aptlist-bugs et ce qu'il y a dedans

Dernière modification par ubub (31-07-2022 22:28:24)

En ligne

#7 31-07-2022 22:37:35

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

j'ai mis à jour le sources.list parcequ'il n'était pas bon

j'avais :

deb http://deb.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free

alors que j'étais en version 11 (grosse betise j'imagine)



Pour preferences : je n'ai pas de fichier preferences, et rien dans le répertoire preferences.d/



Là, en commentant les appel à deb, dans les fichiers de sources.list.d/

je retenté une mise à jour :

> apt-get update && apt-get upgrade && apt-get dist-upgrade -y

Atteint :1 http://security.debian.org/debian-security bullseye-security InRelease
Atteint :2 http://deb.debian.org/debian bullseye InRelease
Atteint :3 http://deb.debian.org/debian bullseye-updates InRelease
Lecture des listes de paquets... Fait
N: « :n » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il n'utilise pas d'extension
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait

.../...

66 mis à jour, 0 nouvellement installés, 0 à enlever et 908 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/34,5 Mo dans les archives.
Après cette opération, 452 ko d'espace disque supplémentaires seront utilisés.
N: « :n » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il n'utilise pas d'extension
Souhaitez-vous continuer ? [O/n] O
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:93:in `singleton class': undefined method `default_specifications_dir' for class `Module' (NameError)
    from /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:67:in `<top (required)>'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `require'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `<top (required)>'
    from <internal:gem_prelude>:1:in `require'
    from <internal:gem_prelude>:1:in `<compiled>'
E: Le sous-processus /usr/bin/apt-listbugs apt a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listbugs apt

Dernière modification par juaito (31-07-2022 23:34:24)

Hors ligne

#8 31-07-2022 22:44:08

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Je viens de tout commenter dans /etc/apt/apt.conf.d/10apt-listbugs

et là c'est allé beaucoup plus loin :

mais toujours ces erreurs ruby (et je ne me souviens plus s'il était installé avant ou pendant ou après?)



> apt-get update && apt-get upgrade && apt-get dist-upgrade -y

Atteint :1 http://security.debian.org/debian-security bullseye-security InRelease
Atteint :2 http://deb.debian.org/debian bullseye InRelease
Atteint :3 http://deb.debian.org/debian bullseye-updates InRelease
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait

.../...


Paramétrage de apt-listbugs (0.1.35) ...
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:93:in `singleton class': undefined method `default_specifications_dir' for class `Module' (NameError)
    from /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:67:in `<top (required)>'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `require'
    from /usr/lib/ruby/2.1.0/rubygems.rb:1195:in `<top (required)>'
    from <internal:gem_prelude>:1:in `require'
    from <internal:gem_prelude>:1:in `<compiled>'
dpkg: erreur de traitement du paquet apt-listbugs (--configure) :
installed apt-listbugs package post-installation script subprocess returned error exit status 1
Paramétrage de libxengnttab1:amd64 (4.14.5+24-g87d90d511c-1) ...
Paramétrage de nano (5.4-2+deb11u1) ...

.../...

Des erreurs ont été rencontrées pendant l'exécution :
apt-listbugs
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par juaito (31-07-2022 23:35:59)

Hors ligne

#9 31-07-2022 23:03:55

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

alors que j'étais en version 11

absolument pas,
mais, c'est pas comme ça qu'il est recommandé de faire....
faire debian9 --> debian10, puis debian10 à debian 11
pas de 9 à 11 ...
du coup, je sais pas trop ...
avant de faire tout ça, tu aurais pu virer apt-listbugs, c'est déjà imbuvable à lire, ça aurait fait de l'erreur en moins à lire ...

En ligne

#10 31-07-2022 23:09:18

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

pour voir où ton système en est, tu pourrais envoyer le retour de :

cat /etc/debian_version

En ligne

#11 31-07-2022 23:27:53

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

en enlevant apt-listbugs, l'install s'est faite
mais j'ai perdu gnome (?) : j'ai l'écran de connexion debian 11 qui a changé, puis apres j'ai la souris, le fond bleu de bureau, mais rien, pas de clic droit, bizarre)


en terminal (ctrl alt F6), dans debian_version :
11.4

Hors ligne

#12 31-07-2022 23:43:51

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

mais j'ai perdu gnome (?) : j'ai l'écran de connexion debian 11 qui a changé, puis apres j'ai la souris, le fond bleu de bureau, mais rien, pas de clic droit, bizarre)


l'écran de connexion a du passer de debian 9 à debian 11 ; vu qu'avant cette manip, t'as jamais été sous debian 11 semble-t-il ...

que veut tu dire par perdu gnome ?
m'a semblé voir dans la liste de tout à l'heure, dans paquets conservés (?), mis à jour (?) me rapelle plus, pas mal de paquets gnome ...

et du coup, si maintenant tu fais

apt update


(uniquement, sans le upgrade), il se passe quoi, enfin, ça dit quoi ?

En ligne

#13 01-08-2022 09:50:59

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Donc là maintenant, apt update fonctionne sans erreur.
Tous les paquets sont à jour.

Mais pour le lancer je dois faire Ctrl+Alt+F6 pour avoir la ligne de commande, car je ne peux plus lancer de fenetre (terminal, ou autre)

Hors ligne

#14 01-08-2022 10:01:22

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Je n'arrive plus à faire de mises à jour

apt install gnome



Et après tu regardes si tu peux lancer le terminal

Dernière modification par Jean-Pierre Pinson (01-08-2022 10:08:56)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#15 01-08-2022 10:07:00

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Merci et bravo pour votre aide.

Effectivement, apt install gnome a fonctionné

J'ai mon lanceur d'application, les fenetres, le web, spotify, merci beaucoup beaucoup smile


Ma debian semble à jour, c'est reparti pour 10 ans smile


merci.gif

Hors ligne

#16 01-08-2022 10:12:48

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Ta FrankenDebian est à jour tu veux dire wink
out.gif

Dernière modification par Croutons (01-08-2022 10:13:05)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#17 01-08-2022 15:20:57

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Effectivement, un peu franken big_smile


merci beaucoup en tout cas


Comment je fais maintenant pour indiquer que c'est [RESOLU] ?

merci smile

Hors ligne

#18 01-08-2022 15:57:42

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Je n'arrive plus à faire de mises à jour

juaito a écrit :

Comment je fais maintenant pour indiquer que c'est [RESOLU] ?


il faut que tu édites ton message#1 et tu changes dans le titre


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#19 01-08-2022 16:14:36

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

Croutons a écrit :

juaito a écrit :

Comment je fais maintenant pour indiquer que c'est [RESOLU] ?


il faut que tu édites ton message#1 et tu changes dans le titre



woohoo.gif

Hors ligne

#20 01-08-2022 16:30:02

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Je n'arrive plus à faire de mises à jour

hello,

Ma debian semble à jour, c'est reparti pour 10 ans smile



au minimum ....   big_smile

tant que t'y es,et vu où t'en es, tu peux aussi faire

apt update
apt full-upgrade



full-upgrade (apt-get(8))
           La commande full-upgrade remplit la même fonction que upgrade mais
           supprimera des paquets actuellement installés si cela est
           nécessaire pour mettre à jour le système dans son ensemble.
 



Gardes en mémoire que tant que tu auras des trucs commentés dans le sources.list.d, ils ne bénéficieront pas de mises à jour (spotify, par exemple)
Mais décommente les après avoir fait full-upgrade... C'est plus sûr ..   wink

En ligne

#21 01-08-2022 16:47:12

juaito
Membre
Lieu : Marseille
Distrib. : Debian GNU/Linux 11 (bullseye)
Noyau : Linux 4.19.0-17-amd64
(G)UI : gdm3
Inscription : 31-07-2022

Re : [Résolu] Je n'arrive plus à faire de mises à jour

ok merci Ubub, j'ai effectivement réactivé ce que j'avais commenté dans le sources.list.d/

et j'ai bien eu une mise à jour de spotify wink


j'ai essayé de réactiver teamviewer aussi mais ça plante (pb de clé, de PGP), je verrai pour le supprimer et le remettre propre.

merci beaucoup

Hors ligne

Pied de page des forums