Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-08-2022 22:27:36

simedon
Membre
Inscription : 02-08-2022

[RESOLU] pilote linux trop vieux

bonjour,
je voudrais installé une imprimante xp30 EPSON  sur une nouvelle installation : emmabuntus DE4 xfce
quand j'essaye d'installer le pilote (epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb), j'ai le message suivant:
Erreur: le dépendance ne peut être satisfaire: lsb (>=3.2)

simde4@simde4-systemproductname:~/Bureau$ sudo apt update
[sudo] Mot de passe de simde4 :        
Atteint :1 [url]http://security.debian.org/debian-security[/url] bullseye-security InRelease
Atteint :2 [url]http://deb.debian.org/debian[/url] bullseye InRelease            
Ign :3 [url]http://liveusb.info/multisystem/depot[/url] all InRelease            
Réception de :4 [url]http://deb.debian.org/debian[/url] bullseye-updates InRelease [44,1 kB]
Atteint :5 [url]http://liveusb.info/multisystem/depot[/url] all Release      
44,1 ko réceptionnés en 1s (60,3 ko/s)                            
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.
simde4@simde4-systemproductname:~/Bureau$
 


simde4@simde4-systemproductname:~/Bureau$ uname -a
Linux simde4-systemproductname 5.10.0-16-amd64 #1 SMP Debian 5.10.127-2 (2022-07-23) x86_64 GNU/Linux
simde4@simde4-systemproductname:~/Bureau$
 


Merci de votre aide.

Dernière modification par simedon (06-08-2022 13:02:33)

Hors ligne

#2 03-08-2022 14:05:09

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] pilote linux trop vieux

Bonjour
tu a tenter sans driver avec cups ? (si imprimante pas trop vielle , compatible "bonjour" par exemple ) , cela risque de fonctionner sous bullseye .
il faut juste installer les bon paquets de cups et dépendances.
a partir de bullseye , debian n'a plus besoin de drivers constructeur pour l'impression , en usb il te faut le paquet ipp-usb en plus


apt policy ipp-usb
ipp-usb:
  Installé : 0.9.22-1
  Candidat : 0.9.22-1
 Table de version :
 *** 0.9.22-1 500
        500 https://deb.debian.org/debian bookworm/main amd64 Packages
        100 /var/lib/dpkg/status
 


ps: ici la version de debian bookworm


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#3 03-08-2022 23:26:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] pilote linux trop vieux

Bonsoir simedon, et bienvenue !

simedon a écrit :

quand j'essaye d'installer le pilote (epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb), j'ai le message suivant :

Erreur : la dépendance ne peut être satisfaite : lsb (>= 3.2)


Le paquet binaire lsb n'est plus disponible à partir de Debian 9 Stretch (pas de souci sous Ubuntu).
Trois pistes : impression sans pilote, reconstruction du paquet, installation du paquet lsb-compat :

wget https://deb.debian.org/debian/pool/main/l/lsb/lsb-compat_9.20161125_amd64.deb


md5sum lsb-compat_9.20161125_amd64.deb

b9a19aa059ed032fabb04752615966dd  lsb-compat_9.20161125_amd64.deb


sudo apt install ./lsb-compat_9.20161125_amd64.deb

sudo apt install ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb


Cette méthode a été testée sous Debian 11, par Tawal (mais aussi sous LMDE 4 Debbie/Debian 10).

Hors ligne

#4 04-08-2022 18:40:26

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

èfpé a écrit :

Bonsoir simedon, et bienvenue !


Trois pistes : impression sans pilote, reconstruction du paquet, installation du paquet lsb-compat :

.


Bonjour et merci,
je ne suis pas certain de bien comprendre; cela  veut il dire que j'ai le choix parmi les lignes de codes proposée:

en 1:impression sans pilote:


wget https://deb.debian.org/debian/pool/main/l/lsb/lsb-compat_9.20161125_amd64.deb


ou en 2: reconstruction du paquet

md5sum lsb-compat_9.20161125_amd64.deb

b9a19aa059ed032fabb04752615966dd  lsb-compat_9.20161125_amd64.deb



ou en 3, installation du paquet lsb-compat :

sudo apt install ./lsb-compat_9.20161125_amd64.deb


sudo apt install ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb



que dois je comprendre?

Dernière modification par simedon (04-08-2022 18:43:22)

Hors ligne

#5 04-08-2022 19:00:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] pilote linux trop vieux

Re-,

simedon a écrit :

que dois-je comprendre ?


Les commandes postées en #3/citées en 4 concernent l'installation préalable du paquet lsb-compat.
On commence par le télécharger, puis on vérifie une somme de contrôle, enfin on installe le paquet.

Hors ligne

#6 04-08-2022 19:22:11

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

Au fait, j'ai oublié de préciser( je ne sais si cela est important) que l'imprimante est branché au serveur d'impression de la freebox V6; lors de l'installation, il me manquer le pilote. celui évoqué plus haut conviendra?

Hors ligne

#7 04-08-2022 19:35:17

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

un petit souci:

simde4@simde4-systemproductname:~/Bureau$ sudo apt install ./lsb-compat_9.20161125_amd64.deb
[sudo] Mot de passe de simde4 :        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Note : sélection de « lsb-compat » au lieu de « ./lsb-compat_9.20161125_amd64.deb »
Les NOUVEAUX paquets suivants seront installés :
  lsb-compat
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/28,3 ko dans les archives.
Après cette opération, 70,7 ko d'espace disque supplémentaires seront utilisés.
Réception de :1 /home/simonetde4/Bureau/lsb-compat_9.20161125_amd64.deb lsb-compat amd64 9.20161125 [28,3 kB]
Sélection du paquet lsb-compat précédemment désélectionné.
(Lecture de la base de données... 349289 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../lsb-compat_9.20161125_amd64.deb ...
Dépaquetage de lsb-compat (9.20161125) ...
Paramétrage de lsb-compat (9.20161125) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.4-2) ...
N: Le téléchargement est effectué en dehors du bac à sable en tant que « root » car le fichier « /home/simde4/Bureau/lsb-compat_9.20161125_amd64.deb » n'est pas accessible par l'utilisateur « _apt ». - pkgAcquire::Run (13: Permission non accordée)
simde4@simde4-systemproductname:~/Bureau$


et quand je veux installer le pilote:

simde4@simde4-systemproductname:~/Bureau$ sudo apt install ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb
Lecture des listes de paquets... Fait
E: Le fichier donné ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb n'est pas compris sur la ligne de commande
simde4@simde4-systemproductname:~/Bureau$

Dernière modification par simedon (04-08-2022 19:35:58)

Hors ligne

#8 04-08-2022 20:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] pilote linux trop vieux

Re-,

simedon a écrit :

sudo apt install ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb

Lecture des listes de paquets... Fait
E: Le fichier donné ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb
   n'est pas compris sur la ligne de commande


Le paquet epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb n'est donc pas sur le Bureau...
Il faut, soit adapter la commande, soit utiliser GDebi (ce que tu avais tenté initialement, semble-t-il).

Dernière modification par èfpé (04-08-2022 20:16:54)

Hors ligne

#9 04-08-2022 20:44:05

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

ou est mon erreur dans la ligne?:

simde4@simde4-systemproductname:~/Bureau$ sudo apt install  /media/DATA/sim/téléchargements/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64
Lecture des listes de paquets... Fait
E: Le fichier donné /media/DATA/sim/téléchargements/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64 n'est pas compris sur la ligne de commande
simde4@simde4-systemproductname:~/Bureau$


il est pourtant stocké à cet endroit.

Hors ligne

#10 04-08-2022 21:18:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] pilote linux trop vieux

Re-,

simedon a écrit :

sudo apt install /media/DATA/sim/téléchargements/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64

Lecture des listes de paquets... Fait
E: Le fichier donné /media/DATA/sim/téléchargements/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64
   n'est pas compris sur la ligne de commande


Tu as tronqué le nom du fichier-paquet (epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb).

Hors ligne

#11 05-08-2022 09:29:29

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] pilote linux trop vieux

hello
Le bon réflexe toujours utiliser l'autocompletion pour compléter les commandes
https://debian-facile.org/doc:programma … completion

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#12 06-08-2022 12:37:11

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

Bonjour,
après un autre essai, j'ai copié le fichier sur le bureau est lancer la commande, voici le retour;

simde4@simde4-systemproductname:~/Bureau$ sudo apt install ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb
[sudo] Mot de passe de simde4 :        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Note : sélection de « epson-inkjet-printer-201202w » au lieu de « ./epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb »
Les NOUVEAUX paquets suivants seront installés :
  epson-inkjet-printer-201202w
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/1579 ko dans les archives.
Après cette opération, 2781 ko d'espace disque supplémentaires seront utilisés.
Réception de :1 /home/simonetde4/Bureau/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb epson-inkjet-printer-201202w amd64 1.0.0-1lsb3.2 [1579 kB]
Sélection du paquet epson-inkjet-printer-201202w précédemment désélectionné.
(Lecture de la base de données... 349301 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb ...
Dépaquetage de epson-inkjet-printer-201202w (1.0.0-1lsb3.2) ...
Paramétrage de epson-inkjet-printer-201202w (1.0.0-1lsb3.2) ...
N: Le téléchargement est effectué en dehors du bac à sable en tant que « root » car le fichier « /home/simonetde4/Bureau/epson-inkjet-printer-201202w_1.0.0-1lsb3.2_amd64.deb » n'est pas accessible par l'utilisateur « _apt ». - pkgAcquire::Run (13: Permission non accordée)
simde4@simde4-systemproductname:~/Bureau$
 


normal cette histoire en dehors du bac à sable?
eu le même message lors de l'installde la commande lsb3.2, voir post#7
pilote toujours pas disponible lors de la tentative d'installation de l'imprimante.

Dernière modification par simedon (06-08-2022 12:44:05)

Hors ligne

#13 06-08-2022 13:01:14

simedon
Membre
Inscription : 02-08-2022

Re : [RESOLU] pilote linux trop vieux

je viens de redémarrer le système est là , OK; pilote présent; j'ai pu réaliser l'installation de l'imprimante.
imprimante en réseau fonctionnelle.
MERCI de votre aide (et à tout les intervenants);
je passe en RESOLU.

Dernière modification par simedon (06-08-2022 19:02:21)

Hors ligne

Pied de page des forums