Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-09-2022 17:21:40

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

[Résolu] Problème de dépendances non configurée

Bonjour,

Je suis bloqué sur un problème de gestion de paquet, j'arrive pas à m'en sortir.

Je suis à un point ou je ne peux plus faire de apt upgrade et je ne comprends pas ce que je peux faire pour revenir à la normale.


sudo apt upgrade
sudo apt autoremove
sudo apt --fix-broken install
 


échouent tous les trois à cause de problèmes de dépendances - laissé non configuré (voir log complet plus bas) 

et le pire est

sudo dpkg --configure -a


qui me donne un message d'erreur qui glace le sang et qui finit par un L'exécution a été arrêtée car il y avait trop d'erreurs.

J'ai tourné sur divers forums et je ne trouve aucune solution qui fonctionne.

Pour info :

* Je suis sur une Debian GNU/Linux bookworm/sid (unstable)
* Ma partition racine n'est pas pleine.
* Je pense savoir le moment ou les ennuis ont commencé : J'ai interrompu (CTRL-C) un apt upgrade par erreur. Je suis pas sûr que ce soit exactement ça qui ait causé les problèmes mais voilà.

Les erreurs :

sudo apt upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  bogofilter bogofilter-bdb bogofilter-common dleyna-server filezilla filezilla-common fwupd gnome-todo gstreamer1.0-pipewire inkscape libayatana-appindicator3-1 libfwupd2 libgslcblas0 libpipewire-0.3-0 libpipewire-0.3-modules librygel-renderer-2.6-2
  librygel-renderer-gst-2.6-2 librygel-server-2.6-2 libsane-common libsane1 libsane1:i386 libspa-0.2-modules libvkd3d1 libvkd3d1:i386 libwine libwine:i386 php-common pipewire pipewire-bin pipewire-pulse rygel rygel-playbin rygel-tracker sane-utils wine wine32:i386
  wine64
0 mis à jour, 0 nouvellement installés, 0 à enlever et 37 non mis à jour.
130 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
dpkg: des problèmes de dépendances empêchent la configuration de libffi8:amd64 :
 libffi8:i386 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:amd64 (3.4.3-1) fournit libffi8ubuntu1.

dpkg: erreur de traitement du paquet libffi8:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 libffi8:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
 




sudo dpkg --configure -a



dpkg: des problèmes de dépendances empêchent la configuration de libffi8:amd64 :
 libffi8:i386 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:amd64 (3.4.3-1) fournit libffi8ubuntu1.

dpkg: erreur de traitement du paquet libffi8:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libffi8:i386 :
 libffi8:amd64 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:i386 (3.4.3-1) fournit libffi8ubuntu1.

dpkg: erreur de traitement du paquet libffi8:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libgirepository-1.0-1:amd64 :
 libgirepository-1.0-1:amd64 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgirepository-1.0-1:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de firefox-esr :
 firefox-esr dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet firefox-esr (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libgjs0g:amd64 :
 libgjs0g:amd64 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.
 libgjs0g:amd64 dépend de libgirepository-1.0-1 (>= 1.71.0) ; cependant :
 Le paquet libgirepository-1.0-1:amd64 n'est pas encore configuré.
 libgjs0g:amd64 dépend de libgirepository-1.0-1-with-libffi8 (>= 1.64) ; cependant :
  Le paquet libgirepository-1.0-1-with-libffi8 n'est pas installé.
  Le paquet libgirepository-1.0-1:amd64 qui fournit libgirepository-1.0-1-with-libffi8 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgjs0g:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libruby3.0:amd64 :
 libruby3.0:amd64 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libruby3.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de firefox :
 firefox dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet firefox (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gjs :
 gjs dépend de libgjs0g (= 1.73.1-2) ; cependant :
 Le paquet libgjs0g:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gjs (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gobject-introspection :
 gobject-introspection dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.
 gobject-introspection dépend de libgirepository-1.0-1 (= 1.74.0-2) ; cependant :
 Le paquet libgirepository-1.0-1:amd64 n'est pas encore configuré.
 gobject-introspection dépend de libgirepository-1.0-1-with-libffi8 (>= 1.62.0-4~) ; cependant :
  Le paquet libgirepository-1.0-1-with-libffi8 n'est pas installé.
  Le paquet libgirepository-1.0-1:amd64 qui fournit libgirepository-1.0-1-with-libffi8 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gobject-introspection (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libffi-dev:amd64 :
 libffi-dev:amd64 dépend de libffi8 (= 3.4.3-1) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libffi-dev:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpython3.10-stdlib:amd64 :
 libpython3.10-stdlib:amd64 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libpython3.10-stdlib:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de pandoc :
 pandoc dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet pandoc (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libgirepository1.0-dev:amd64 :
 libgirepository1.0-dev:amd64 dépend de libgirepository-1.0-1 (= 1.74.0-2) ; cependant :
 Le paquet libgirepository-1.0-1:amd64 n'est pas encore configuré.
 libgirepository1.0-dev:amd64 dépend de gobject-introspection (= 1.74.0-2) ; cependant :
 Le paquet gobject-introspection n'est pas encore configuré.
 libgirepository1.0-dev:amd64 dépend de libffi-dev (>= 3.4) ; cependant :
 Le paquet libffi-dev:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgirepository1.0-dev:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libjna-jni :
 libjna-jni dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libjna-jni (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpython3.10-dev:amd64 :
 libpython3.10-dev:amd64 dépend de libpython3.10-stdlib (= 3.10.7-1) ; cependant :
 Le paquet libpython3.10-stdlib:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libpython3.10-dev:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-glib-2.0:amd64 :
 gir1.2-glib-2.0:amd64 dépend de libgirepository-1.0-1 (>= 1.72.0) ; cependant :
 Le paquet libgirepository-1.0-1:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-glib-2.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de ruby3.0 :
 ruby3.0 dépend de libruby3.0 (>= 3.0.0~preview1) ; cependant :
 Le paquet libruby3.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet ruby3.0 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libllvm14:amd64 :
 libllvm14:amd64 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libllvm14:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libllvm14:i386 :
 libllvm14:i386 dépend de libffi8 (>= 3.4) ; cependant :
 Le paquet libffi8:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libllvm14:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de python3.10-dev :
 python3.10-dev dépend de libpython3.10-dev (= 3.10.7-1) ; cependant :
 Le paquet libpython3.10-dev:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet python3.10-dev (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-evince-3.0:amd64 :
 gir1.2-evince-3.0:amd64 dépend de gir1.2-glib-2.0 (>= 1.0) ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-evince-3.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-va-drivers:amd64 :
 mesa-va-drivers:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-va-drivers:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-va-drivers:i386 :
 mesa-va-drivers:i386 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-va-drivers:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gnome-sushi :
 gnome-sushi dépend de gir1.2-evince-3.0 ; cependant :
 Le paquet gir1.2-evince-3.0:amd64 n'est pas encore configuré.
 gnome-sushi dépend de gjs ; cependant :
 Le paquet gjs n'est pas encore configuré.
 gnome-sushi dépend de gir1.2-glib-2.0 ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gnome-sushi (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-nm-1.0:amd64 :
 gir1.2-nm-1.0:amd64 dépend de gir1.2-glib-2.0 ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-nm-1.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-ibus-1.0:amd64 :
 gir1.2-ibus-1.0:amd64 dépend de gir1.2-glib-2.0 ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-ibus-1.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpython3-stdlib:amd64 :
 libpython3-stdlib:amd64 dépend de libpython3.10-stdlib (>= 3.10.6-1~) ; cependant :
 Le paquet libpython3.10-stdlib:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libpython3-stdlib:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libosmesa6:amd64 :
 libosmesa6:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libosmesa6:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libosmesa6:i386 :
 libosmesa6:i386 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libosmesa6:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de ruby-sdbm:amd64 :
 ruby-sdbm:amd64 dépend de libruby3.0 (>= 3.0.0~preview1) ; cependant :
 Le paquet libruby3.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet ruby-sdbm:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-vulkan-drivers:amd64 :
 mesa-vulkan-drivers:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-vulkan-drivers:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-vulkan-drivers:i386 :
 mesa-vulkan-drivers:i386 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-vulkan-drivers:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-vdpau-drivers:amd64 :
 mesa-vdpau-drivers:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-vdpau-drivers:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mesa-vdpau-drivers:i386 :
 mesa-vdpau-drivers:i386 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mesa-vdpau-drivers:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpython3.10:amd64 :
 libpython3.10:amd64 dépend de libpython3.10-stdlib (= 3.10.7-1) ; cependant :
 Le paquet libpython3.10-stdlib:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libpython3.10:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-freedesktop:amd64 :
 gir1.2-freedesktop:amd64 dépend de gir1.2-glib-2.0 (= 1.74.0-2) ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-freedesktop:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpython3-dev:amd64 :
 libpython3-dev:amd64 dépend de libpython3.10-dev (>= 3.10.6-1~) ; cependant :
 Le paquet libpython3.10-dev:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libpython3-dev:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de python3.10 :
 python3.10 dépend de libpython3.10-stdlib (= 3.10.7-1) ; cependant :
 Le paquet libpython3.10-stdlib:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet python3.10 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-gdkpixbuf-2.0:amd64 :
 gir1.2-gdkpixbuf-2.0:amd64 dépend de gir1.2-glib-2.0 (>= 0.9.3) ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-gdkpixbuf-2.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-atk-1.0:amd64 :
 gir1.2-atk-1.0:amd64 dépend de gir1.2-glib-2.0 ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-atk-1.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libgl1-mesa-dri:amd64 :
 libgl1-mesa-dri:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgl1-mesa-dri:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libgl1-mesa-dri:i386 :
 libgl1-mesa-dri:i386 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libgl1-mesa-dri:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-gtk-3.0:amd64 :
 gir1.2-gtk-3.0:amd64 dépend de gir1.2-atk-1.0 (>= 2.35.1) ; cependant :
 Le paquet gir1.2-atk-1.0:amd64 n'est pas encore configuré.
 gir1.2-gtk-3.0:amd64 dépend de gir1.2-freedesktop (>= 1.39.0) ; cependant :
 Le paquet gir1.2-freedesktop:amd64 n'est pas encore configuré.
 gir1.2-gtk-3.0:amd64 dépend de gir1.2-gdkpixbuf-2.0 (>= 2.40.0) ; cependant :
 Le paquet gir1.2-gdkpixbuf-2.0:amd64 n'est pas encore configuré.
 gir1.2-gtk-3.0:amd64 dépend de gir1.2-glib-2.0 (>= 1.39.0) ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-gtk-3.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de python3 :
 python3 dépend de python3.10 (>= 3.10.6-1~) ; cependant :
 Le paquet python3.10 n'est pas encore configuré.
 python3 dépend de libpython3-stdlib (= 3.10.6-1) ; cependant :
 Le paquet libpython3-stdlib:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet python3 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de obs-studio :
 obs-studio dépend de python3:any ; cependant :
 Le paquet python3 n'est pas encore configuré.
 obs-studio dépend de python3 (<< 3.11) ; cependant :
 Le paquet python3 n'est pas encore configuré.
 obs-studio dépend de python3 (>= 3.10~) ; cependant :
 Le paquet python3 n'est pas encore configuré.
 obs-studio dépend de python3.10 ; cependant :
 Le paquet python3.10 n'est pas encore configuré.
 obs-studio dépend de libpython3.10 (>= 3.10.0) ; cependant :
 Le paquet libpython3.10:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet obs-studio (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-atspi-2.0:amd64 :
 gir1.2-atspi-2.0:amd64 dépend de gir1.2-freedesktop ; cependant :
 Le paquet gir1.2-freedesktop:amd64 n'est pas encore configuré.
 gir1.2-atspi-2.0:amd64 dépend de gir1.2-glib-2.0 ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-atspi-2.0:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de gir1.2-gegl-0.4:amd64 :
 gir1.2-gegl-0.4:amd64 dépend de gir1.2-glib-2.0 (>= 1.32.0) ; cependant :
 Le paquet gir1.2-glib-2.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet gir1.2-gegl-0.4:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libibus-1.0-dev:amd64 :
 libibus-1.0-dev:amd64 dépend de gir1.2-ibus-1.0 (= 1.5.27-2) ; cependant :
 Le paquet gir1.2-ibus-1.0:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libibus-1.0-dev:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libxatracker2:amd64 :
 libxatracker2:amd64 dépend de libllvm14 ; cependant :
 Le paquet libllvm14:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet libxatracker2:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de steam:i386 :
 steam:i386 dépend de libgl1-mesa-dri (>= 17.3) ; cependant :
 Le paquet libgl1-mesa-dri:i386 n'est pas encore configuré.

dpkg: erreur de traitement du paquet steam:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: trop d'erreurs, arrêt
Des erreurs ont été rencontrées pendant l'exécution :
 libffi8:amd64
 libffi8:i386
 libgirepository-1.0-1:amd64
 firefox-esr
 libgjs0g:amd64
 libruby3.0:amd64
 firefox
 gjs
 gobject-introspection
 libffi-dev:amd64
 libpython3.10-stdlib:amd64
 pandoc
 libgirepository1.0-dev:amd64
 libjna-jni
 libpython3.10-dev:amd64
 gir1.2-glib-2.0:amd64
 ruby3.0
 libllvm14:amd64
 libllvm14:i386
 python3.10-dev
 gir1.2-evince-3.0:amd64
 mesa-va-drivers:amd64
 mesa-va-drivers:i386
 gnome-sushi
 gir1.2-nm-1.0:amd64
 gir1.2-ibus-1.0:amd64
 libpython3-stdlib:amd64
 libosmesa6:amd64
 libosmesa6:i386
 ruby-sdbm:amd64
 mesa-vulkan-drivers:amd64
 mesa-vulkan-drivers:i386
 mesa-vdpau-drivers:amd64
 mesa-vdpau-drivers:i386
 libpython3.10:amd64
 gir1.2-freedesktop:amd64
 libpython3-dev:amd64
 python3.10
 gir1.2-gdkpixbuf-2.0:amd64
 gir1.2-atk-1.0:amd64
 libgl1-mesa-dri:amd64
 libgl1-mesa-dri:i386
 gir1.2-gtk-3.0:amd64
 python3
 obs-studio
 gir1.2-atspi-2.0:amd64
 gir1.2-gegl-0.4:amd64
 libibus-1.0-dev:amd64
 libxatracker2:amd64
 steam:i386
L'exécution a été arrêtée car il y avait trop d'erreurs.
 



Merci pour votre lecture !

Dernière modification par cdrom (22-09-2022 20:20:53)

Hors ligne

#2 22-09-2022 17:37:48

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

Bonjour,

bogofilter bogofilter-bdb bogofilter-common dleyna-server filezilla filezilla-common fwupd gnome-todo gstreamer1.0-pipewire inkscape libayatana-appindicator3-1 libfwupd2 libgslcblas0 libpipewire-0.3-0 libpipewire-0.3-modules librygel-renderer-2.6-2
  librygel-renderer-gst-2.6-2 librygel-server-2.6-2 libsane-common libsane1 libsane1:i386 libspa-0.2-modules libvkd3d1 libvkd3d1:i386 libwine libwine:i386 php-common pipewire pipewire-bin pipewire-pulse rygel rygel-playbin rygel-tracker sane-utils wine wine32:i386
  wine64

u
tout ça, ce sont des paquets épinglés je suppose,

et 37 non mis à jour.


Peut-être que d'y faire du ménage et en désépingler certains débloquera la situation ...

Hors ligne

#3 22-09-2022 17:44:43

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

Re : [Résolu] Problème de dépendances non configurée

Merci pour ta réponse rapide !

Je ne sais pas ce qu'est un paquet épinglés ni comment désépingler des paquets...

Je veux bien une petite explication rapide ou la traduction en anglais que je puisse faire des recherches.

Hors ligne

#4 22-09-2022 18:09:46

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

aarf, j'ai ma casserole sur le feu ...
les paquets "épinglés" sont ceux qui ne seront pas mis à jour, suite au choix en général de l'utilisateur parce que par exemple, tel upgrade de paquet peut présenter un bogue, signalé par aptlist-bug
"épinglé" avec l'option p lors de la mise à jour ....
Tu peux retrouver leur liste dans un fichier du répertoire sources.list, un qui se nomera préfrence quelquechose me semble de mémoire...
en anglais épinglage = pining
La non mise à niveau de tel paquet peut entrainer la non mise à niveau de tel autre paquet mais malgré tout celle quand même d'un paquet tiers, ce qui fait qu'au bout d'un moment, des problèmes de dépendances peuvent subvenir..;
Les paquets épinglés "pinned" devraient être recensés là :
/etc/apt/preferences.d/apt-listbugs

Dernière modification par ubub (22-09-2022 18:13:59)

Hors ligne

#5 22-09-2022 18:31:48

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

Re : [Résolu] Problème de dépendances non configurée

Merci encore, j'espère que tu n'a pas fait cramé ton dîner par ma faute.

J'ai exploré un peu cette piste mais ça ne me mène nulle part.

apt-listbugs n'est pas installé sur ma machine, /etc/apt/preferences.d/ est vide, /etc/apt/preferences n'éxiste pas...

Hors ligne

#6 22-09-2022 18:38:49

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

cdrom a écrit :


sudo apt upgrade
sudo apt autoremove
sudo apt --fix-broken install



échouent tous les trois à cause de problèmes de dépendances - laissé non configuré (voir log complet plus bas)


peut-être essayer apt full-upgrade , mais ça risque débloquer des bugs ...

.. mais ça peut faire du bien:

130 partiellement installés

Dernière modification par ubub (22-09-2022 18:48:05)

Hors ligne

#7 22-09-2022 19:13:23

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Problème de dépendances non configurée

Hello

cdrom a écrit :

Je suis sur une Debian GNU/Linux bookworm/sid (unstable)


et pourquoi on voit des paquets ubuntu a l'upgrade?
peux tu afficher le résultat de la commande suivante

find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;

Dernière modification par Croutons (22-09-2022 19:13:47)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 22-09-2022 19:25:45

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

Re : [Résolu] Problème de dépendances non configurée

Essayé apt full-upgrade et je suis toujours dans la même situation...

J'ai pas une compréhension assez claire de ce qu'il se passe avec ces histoires de dépendances. Mais depuis que j'ai ce problème certaines de mes applications se comportent bizarrement ou refusent de se lancer... J'aimerai bien ne pas passer par une réinstallation complète de mon système. Est ce que, avec un peu de chance, ce genre de soucis de dépendances peut se régler tout seul si dans quelques jours je refait un retente un apt update ; apt full-upgrade ??

sudo apt full-upgrade



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcurl3-gnutls:i386 libecal-2.0-1 libedataserverui-1.2-3 libfaudio0 libfaudio0:i386 libgdbm-compat4:i386 libgdbm6:i386
  libglu1-mesa:i386 libgnome-todo libieee1284-3:i386 libindicator3-7 libldap-2.4-2 libldap-2.4-2:i386 libodbc1
  libodbc1:i386 libodbccr2 libodbccr2:i386 libpci3:i386 libperl5.34:i386 libpoppler-glib8:i386 libpoppler102
  libpoppler123:i386 librest-0.7-0 libsane1:i386 libsnmp40:i386 libstb0 libstb0:i386 libxslt1.1:i386 sane-airscan:i386
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  gnome-todo-common libapache2-mod-php7.4 libappindicator3-1 libfilezilla22 libfwupdplugin5 libgsl25 libgupnp-av-1.0-2
  libgupnp-dlna-2.0-3 php7.4 php7.4-cli php7.4-common php7.4-json php7.4-opcache php7.4-readline pipewire-pulse
Les NOUVEAUX paquets suivants seront installés :
  endeavour endeavour-common lib2geom1.1.0 libfilezilla-common libfilezilla31 libfwupdplugin7 libgsl27 libgupnp-av-1.0-3
  libgupnp-dlna-2.0-4 libvkd3d-shader1 libvkd3d-shader1:i386 libz-mingw-w64 python3-cssselect sane-airscan:i386
  vkd3d-compiler:i386
Les paquets suivants seront mis à jour :
  bogofilter bogofilter-bdb bogofilter-common dleyna-server filezilla filezilla-common fwupd gnome-todo
  gstreamer1.0-pipewire inkscape libayatana-appindicator3-1 libfwupd2 libgslcblas0 libpipewire-0.3-0
  libpipewire-0.3-modules librygel-renderer-2.6-2 librygel-renderer-gst-2.6-2 librygel-server-2.6-2 libsane-common libsane1
  libsane1:i386 libspa-0.2-modules libvkd3d1 libvkd3d1:i386 libwine libwine:i386 php-common pipewire pipewire-bin rygel
  rygel-playbin rygel-tracker sane-utils wine wine32:i386 wine64
36 mis à jour, 15 nouvellement installés, 15 à enlever et 0 non mis à jour.
129 partiellement installés ou enlevés.
Il est nécessaire de prendre 220 Mo dans les archives.
Après cette opération, 707 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://ftp.fr.debian.org/debian sid/main amd64 libpipewire-0.3-modules amd64 0.3.58-1 [531 kB]
Réception de :2 http://ftp.fr.debian.org/debian sid/main amd64 gstreamer1.0-pipewire amd64 0.3.58-1 [56,8 kB]
Réception de :3 http://ftp.fr.debian.org/debian sid/main amd64 libpipewire-0.3-0 amd64 0.3.58-1 [287 kB]
Réception de :4 http://ftp.fr.debian.org/debian sid/main amd64 libspa-0.2-modules amd64 0.3.58-1 [527 kB]
Réception de :5 http://ftp.fr.debian.org/debian sid/main amd64 pipewire amd64 0.3.58-1 [15,8 kB]
Réception de :6 http://ftp.fr.debian.org/debian sid/main amd64 pipewire-bin amd64 0.3.58-1 [311 kB]
Réception de :7 http://ftp.fr.debian.org/debian sid/main amd64 gnome-todo all 42.0-4 [5028 B]
Réception de :8 http://ftp.fr.debian.org/debian sid/main amd64 endeavour-common all 42.0-4 [183 kB]
Réception de :9 http://ftp.fr.debian.org/debian sid/main amd64 endeavour amd64 42.0-4 [187 kB]
Réception de :10 http://ftp.fr.debian.org/debian sid/main amd64 libayatana-appindicator3-1 amd64 0.5.91-1 [25,9 kB]
Réception de :11 http://ftp.fr.debian.org/debian sid/main amd64 filezilla amd64 3.61.0-1 [2038 kB]
Réception de :12 http://ftp.fr.debian.org/debian sid/main amd64 filezilla-common all 3.61.0-1 [2324 kB]
Réception de :13 http://ftp.fr.debian.org/debian sid/main amd64 libfilezilla-common all 0.39.1-2 [72,2 kB]
Réception de :14 http://ftp.fr.debian.org/debian sid/main amd64 libfilezilla31 amd64 0.39.1-2 [239 kB]
Réception de :15 http://ftp.fr.debian.org/debian sid/main amd64 fwupd amd64 1.8.4-2 [2978 kB]
Réception de :16 http://ftp.fr.debian.org/debian sid/main amd64 libfwupd2 amd64 1.8.4-2 [113 kB]
Réception de :17 http://ftp.fr.debian.org/debian sid/main amd64 libfwupdplugin7 amd64 1.8.4-2 [216 kB]
Réception de :18 http://ftp.fr.debian.org/debian sid/main amd64 bogofilter amd64 1.2.5-1+b2 [1344 B]
Réception de :19 http://ftp.fr.debian.org/debian sid/main amd64 bogofilter-bdb amd64 1.2.5-1+b2 [140 kB]
Réception de :20 http://ftp.fr.debian.org/debian sid/main amd64 bogofilter-common amd64 1.2.5-1+b2 [216 kB]
Réception de :21 http://ftp.fr.debian.org/debian sid/main amd64 inkscape amd64 1.2.1+ds-1+b1 [20,7 MB]
Réception de :22 http://ftp.fr.debian.org/debian sid/main amd64 libgslcblas0 amd64 2.7.1+dfsg-3+b1 [116 kB]                
Réception de :23 http://ftp.fr.debian.org/debian sid/main amd64 libgsl27 amd64 2.7.1+dfsg-3+b1 [948 kB]                    
Réception de :24 http://ftp.fr.debian.org/debian sid/main amd64 lib2geom1.1.0 amd64 1.2-1 [369 kB]                          
Réception de :25 http://ftp.fr.debian.org/debian sid/main amd64 librygel-renderer-2.6-2 amd64 0.40.4-1 [58,5 kB]            
Réception de :26 http://ftp.fr.debian.org/debian sid/main amd64 rygel-playbin amd64 0.40.4-1 [22,4 kB]                      
Réception de :27 http://ftp.fr.debian.org/debian sid/main amd64 rygel-tracker amd64 0.40.4-1 [71,9 kB]                      
Réception de :28 http://ftp.fr.debian.org/debian sid/main amd64 rygel amd64 0.40.4-1 [575 kB]                              
Réception de :29 http://ftp.fr.debian.org/debian sid/main amd64 librygel-server-2.6-2 amd64 0.40.4-1 [206 kB]              
Réception de :30 http://ftp.fr.debian.org/debian sid/main amd64 librygel-renderer-gst-2.6-2 amd64 0.40.4-1 [32,7 kB]        
Réception de :31 http://ftp.fr.debian.org/debian sid/main amd64 dleyna-server amd64 0.6.0-3 [57,5 kB]                      
Réception de :32 http://ftp.fr.debian.org/debian sid/main amd64 libgupnp-av-1.0-3 amd64 0.14.1-1 [75,4 kB]                  
Réception de :33 http://ftp.fr.debian.org/debian sid/main amd64 libgupnp-dlna-2.0-4 amd64 0.12.0-3 [57,1 kB]                
Réception de :34 http://ftp.fr.debian.org/debian sid/main i386 libsane1 i386 1.1.1-5 [2603 kB]                            
Réception de :35 http://ftp.fr.debian.org/debian sid/main amd64 libsane1 amd64 1.1.1-5 [2516 kB]                          
Réception de :36 http://ftp.fr.debian.org/debian sid/main amd64 sane-utils amd64 1.1.1-5 [237 kB]                          
Réception de :37 http://ftp.fr.debian.org/debian sid/main amd64 libsane-common all 1.1.1-5 [1302 kB]                      
Réception de :38 http://ftp.fr.debian.org/debian sid/main i386 libvkd3d-shader1 i386 1.2-14 [95,6 kB]                      
Réception de :39 http://ftp.fr.debian.org/debian sid/main amd64 libvkd3d-shader1 amd64 1.2-14 [92,9 kB]                    
Réception de :40 http://ftp.fr.debian.org/debian sid/main i386 libvkd3d1 i386 1.2-14 [119 kB]                              
Réception de :41 http://ftp.fr.debian.org/debian sid/main amd64 libvkd3d1 amd64 1.2-14 [113 kB]                            
Réception de :42 http://ftp.fr.debian.org/debian sid/main amd64 libwine amd64 7.0~repack-7 [90,8 MB]                        
Réception de :43 http://ftp.fr.debian.org/debian sid/main amd64 wine all 7.0~repack-7 [143 kB]                              
Réception de :44 http://ftp.fr.debian.org/debian sid/main i386 libwine i386 7.0~repack-7 [87,7 MB]                          
Réception de :45 http://ftp.fr.debian.org/debian sid/main amd64 wine64 amd64 7.0~repack-7 [318 kB]                          
Réception de :46 http://ftp.fr.debian.org/debian sid/main i386 wine32 i386 7.0~repack-7 [310 kB]                            
Réception de :47 http://ftp.fr.debian.org/debian sid/main amd64 libz-mingw-w64 all 1.2.12+dfsg-2 [152 kB]                  
Réception de :48 http://ftp.fr.debian.org/debian sid/main amd64 php-common all 2:92 [16,6 kB]                              
Réception de :49 http://ftp.fr.debian.org/debian sid/main amd64 python3-cssselect all 1.1.0+ds-3 [19,9 kB]                  
Réception de :50 http://ftp.fr.debian.org/debian sid/main i386 sane-airscan i386 0.99.27-1+b1 [134 kB]                      
Réception de :51 http://ftp.fr.debian.org/debian sid/main i386 vkd3d-compiler i386 1.2-14 [14,6 kB]                        
220 Mo réceptionnés en 1min 46s (2071 ko/s)                                                                                
Lecture des fichiers de modifications (« changelog »)... Terminé
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg: des problèmes de dépendances empêchent la configuration de libffi8:amd64 :
 libffi8:i386 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:amd64 (3.4.3-1) fournit libffi8ubuntu1.

dpkg: erreur de traitement du paquet libffi8:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 libffi8:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hors ligne

#9 22-09-2022 19:27:59

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

Re : [Résolu] Problème de dépendances non configurée

Salut Croutons,

Pour les paquets ubuntu, aucune idée...

Sinon voici le résultat de ta commande.

find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;
 



/etc/apt/sources.list
     1  # deb cdrom:[Debian GNU/Linux 10.8.0 _sid_ - Official amd64 NETINST 20210206-10:34]/ sid main
     2  # deb cdrom:[Debian GNU/Linux 10.8.0 _sid_ - Official amd64 NETINST 20210206-10:34]/ sid main
     3 
     4 
     5 
     6  deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
     7  deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free
     8 
     9  # deb http://security.debian.org/debian-security sid/updates main
    10  # deb-src http://security.debian.org/debian-security sid/updates main
    11 
    12  # sid-updates, previously known as 'volatile'
    13  # deb http://ftp.fr.debian.org/debian/ sid-updates main
    14  # deb-src http://ftp.fr.debian.org/debian/ sid-updates main
    15 
    16  # see the sources.list(5) manual.

/etc/apt/sources.list.d/atom.list
     1  deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main

/etc/apt/sources.list.d/sublime-text.list
     1  deb https://download.sublimetext.com/ apt/dev/

/etc/apt/sources.list.d/spotify.list
     1  deb http://repository.spotify.com stable non-free


 

Hors ligne

#10 22-09-2022 19:51:15

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

tu pourrais installer apt-listbugs aussi .... des fois, ça aide ....
T'as vraiment besoin de la double architecture ????

 des problèmes de dépendances empêchent la configuration de libffi8:amd64 :
 libffi8:i386 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:amd64 (3.4.3-1) fournit libffi8ubuntu1.


tu pourrais essayer , aussi, ??, d'épingler libffi8:i386

Dernière modification par ubub (22-09-2022 19:52:55)

Hors ligne

#11 22-09-2022 20:06:46

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

Hors ligne

#12 22-09-2022 20:20:13

cdrom
Membre
Lieu : Marseille
Inscription : 11-09-2019
Site Web

Re : [Résolu] Problème de dépendances non configurée

Suite et fin de ce topic :

J'ai voulu installer apt-listbugs mais c'était pas possible. apt install était lui aussi bloqué sur :

 des problèmes de dépendances empêchent la configuration de libffi8:amd64 :
 libffi8:i386 (3.4.3-1) casse libffi8ubuntu1 et est dépaqueté mais non configuré.
libffi8:amd64 (3.4.3-1) fournit libffi8ubuntu1.



Ça m'a ennervé, j'ai un peu perdu mes moyens et j'ai apt remove libffi8:i386 sur un coup de tête.

Je ne me suis pas renseigné sur ce qu'était, libffi8, ni sur pourquoi j'avais cette librairie(?) en i386 et en amd64, ni sur qu'est ce qui dépendant de libffi8:i386. Je le regretterai peut être un jour.

Mais pour l'instant tout est résolu. Toutes les erreurs ont disparues !

Je vais installer apt-listbugs, et aussi enquêter quand j'aurai du temps su ce qu'il se passe avec ces "37 paquets non mis à jour"

Mais en attendant, je marque le sujet en [Résolu].

Encore merci pour votre aide.

Hors ligne

#13 22-09-2022 20:25:25

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Résolu] Problème de dépendances non configurée

cdrom a écrit :

Je ne me suis pas renseigné sur ce qu'était, libffi8


dommage, c'est par là qu'il fallait commencer, de là, lire les rapports de bogues, et là bingo !
...la soluce !
le fait d'épingler le paquet plutôt que de l'éradiquer t'aurais permis de le conserver à une version antérieure....jusqu'à ce que ça pose problème de dépendances ...

apt-mark hold libffi8

Dernière modification par ubub (22-09-2022 20:29:51)

Hors ligne

#14 22-09-2022 20:27:10

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [Résolu] Problème de dépendances non configurée

Il s’agit du bug décrit ici : libffi8: Fail to install.
Un correctif devrait être fourni avec la version 3.4.3-2 de libffi.

Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums