Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-11-2022 20:09:36

Descourvieres
Membre
Inscription : 09-05-2018

problème d'acces à mon NAS

Je viens d'installer "Debian version 11 (bullseye) 64-bit bureau mate" grâce à une version live et je n'arrive pas à accéder à mon NAS (adresse IP 192.168.1.12) sur lequel j'ai tous mes fichiers de donner.
J'ai fait la même procédure que sur un autre PC debian version10,
1-Mise en place d'un point de montage (descjmfdiskstation) sous le dossier "media"   (ça marche puisque descjmfdiskstation apparait bien dans le gestionnaire de fichier)
2-Installation de cifs-utils
3-Mise en place dans "root" du fichier smbcredentials pour donner un nom d'utilisateur et un mot de pass et un domaine
4-Ajout dans le fstab une ligne pour monter le NAS au démarrage:

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,gid=100,uid=1000, iocharset=utf8  0 0



Quand je clique sur descjmfdiskstation , j'ai un message d'erreur :

Impossible de monter descjmfdiskstation erreur 13 (Permission denied) opening credential file/root/.smbcredentials

.

Je dois avoir une syntaxe qui ne convient pas dans le fstab , en effet quand je lance :

"sudo mount -a"



j’ai le message suivant :

"mount error(22):Invalid argument
"refer to mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)"



Pour moi c’est de l’hébreu . Pourriez-vous me guider pour corriger ce défaut ?
Merci

Hors ligne

#2 24-11-2022 15:34:37

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : problème d'acces à mon NAS

Bonjour,

Sans aucune certitude, mais se pourrait-il que l'erreur de montage soit liée au caractère " " (espace) entre "uid=1000," et "iocharset=utf8" dans la ligne ajoutée au fstab ?

Dans le cas contraire il serait sans doute utile de nous faire part de ce que tu peux trouver avec dmesg comme suggéré par le dernier message.

Tout est un sauf zéro. - Wau Holland

Hors ligne

#3 24-11-2022 16:30:34

Descourvieres
Membre
Inscription : 09-05-2018

Re : problème d'acces à mon NAS

Merci pour cette première réponse; mais ça ne provient pas de celà.
J'ai complété la ligne

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,iud=1001,sec=ntlmv2,_netdev,vers=1.0 0 0


mais j'ai toujours le même problème.
Je ne comprends pas "nous faire part de ce que tu peux trouver avec dmesg comme suggéré par le dernier message". Quel message, et que veut dire dmeg? "est-ce une commande?

Hors ligne

#4 24-11-2022 19:43:13

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : problème d'acces à mon NAS

Hello
oui comme suggéré , tu peux utiliser la commande dmesg en mode monitoring (-w) juste avant de monter ton NAS , de cette maniére tu verras les nouvelles lignes arriver concernant ton serveur

dmesg -w


vérifie que le paquet cifs-utils est bien installé

apt policy cifs-utils

Dernière modification par Croutons (24-11-2022 19:46:14)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 25-11-2022 09:50:51

choops
Membre
Distrib. : Debian sid
(G)UI : XFCE
Inscription : 07-05-2017

Re : problème d'acces à mon NAS

Descourvieres a écrit :

Merci pour cette première réponse; mais ça ne provient pas de celà.
J'ai complété la ligne

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,iud=1001,sec=ntlmv2,_netdev,vers=1.0 0 0


mais j'ai toujours le même problème.
Je ne comprends pas "nous faire part de ce que tu peux trouver avec dmesg comme suggéré par le dernier message". Quel message, et que veut dire dmeg? "est-ce une commande?



Bonjour

Je vais démarrer par du pinaillage, parce que ça peut éviter de se disperser... Entre la ligne présentée là et celle du 1er post, tu change les gid et uid. As-tu une justification à celà ?

Par ailleurs, vu que tu définis un user dans ton '.smbcredentials', le fait de mentionner un gid et un uid dans ta ligne de /etc/fstab peut générer des problèmes:
1. utilisant un '.smbcredential' qui définit déjà un user, la mention du user dans la ligne de /etc/fstab fait doublon
2. le user ciblé par le '.smbcredential' pouvant ne pas avoir les uid et gid que tu mentionnes sur une des machines (serveur ou client), en admettant qu'il existe sur les 2, les informations sont alors contradictoires

Hors ligne

#6 30-11-2022 15:47:36

Descourvieres
Membre
Inscription : 09-05-2018

Re : problème d'acces à mon NAS

Grand merci à vous.
Le problème est résolu.
J'ai executé les commandes

dmesg -w

, et

apt policy cifs-utils

. Je n'ai pas compris grand chose mais ça a suffit. Cifs-utils est bien installé. Mais il y avait du rouge avec dmesq (pb de version de version de smb à priori. J'ai donc supprimé vers=1.0 ,le gid et le uid comme vous le proposiez. ça ne marchait toujours pas, Toujours pb de version. J'ai rajouté vers=1.0 et ça a marche.

J'ai donc:

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,iocharset=utf8,sec=ntlmv2,_netdev,vers=1.0 0 0


d'enregistrement de fichiers
Donc grand merci à vous.. Je n'ai plus qu'un petit problème: le systeme me refuse d'enregistrer les fichiers dans mon nas, . Il ne me reconnait pas .

Pouvez-vous également me dire comment mettre RESOLU pour cette question.

Hors ligne

#7 30-11-2022 22:01:40

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : problème d'acces à mon NAS

Bonjour,

Content que la communauté ait pû t'aider à trouver la solution, ou au moins à avancer dans ta problématique. smile

Par contre vu ce que tu nous dis maintenant, il me semble qu'on est toujours dans une problématique d'accès à ton NAS. Je suis donc d'avis de continuer sur ce fil qui nous donne déjà des éléments de départ avec la ligne indiquant les options de montage dans ton message précédent. Tu peux peut-être expliciter d'avantage la situation actuelle.
N'ayant jamais utilisé SMB/CIFS je laisse la suite aux initiés. tongue

Tout est un sauf zéro. - Wau Holland

Hors ligne

#8 01-12-2022 15:30:12

Descourvieres
Membre
Inscription : 09-05-2018

Re : problème d'acces à mon NAS

bonjour,
Je ne comprends plus rien. J'ai fait quelques manipulations:
1-lancement de

sudo chown jmf:jmf descjmfdiskstation.

afin de remettre les droits normaux à l'utilisateur (jmf)
2-des modifs de iud et du gid

J'avais toujours acces à descjmfdiskstation mais pour certains fichiers j'avais une ouverture en "lecture seule" et si je les modifiais, avec un changement de nom, je ne pouvais plus les rentrer dans le répertoire d'origine ....

J'ai tout fermé et je rouvre mon PC ce matin, et tout (ou presque). est bon.

Il ne reste qu'un défaut : Pour les fichiers nouveaux que je sauvegarde dans mon NAS, je suis bien le propriétaire (jmf) avec un acces en ecriture et lecture, et au niveau du groupe il porte le nom du propriétaire mais un accès uniquement en lecture.

voici mon fstab:

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1001,uid=1000,sec=ntlmv2,_netdev,vers=1.0 0 0


les num de gid et de uid sont ceux que me renvoie la commande

id

.
nb: j'ai un autre PC debian 10 mat donc très semblable à celui ci, et je suis en lecture et ecriture pour le propriétaire et le groupe.

Donc merci pour votre aide. J'attends un ou 2 jours pour mettre RESOLU.... afin qu'éventuellement vous me répondiez pour mettre le groupe en lecture ecriture...

Hors ligne

#9 01-12-2022 15:44:44

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : problème d'acces à mon NAS

Descourvieres a écrit :

Il ne reste qu'un défaut : Pour les fichiers nouveaux que je sauvegarde dans mon NAS, je suis bien le propriétaire (jmf) avec un acces en ecriture et lecture, et au niveau du groupe il porte le nom du propriétaire mais un accès uniquement en lecture.


c'est normale c'est le mask par défaut pour tout fichier créé
essai dans ton terminale la création d'un fichier et regarde les droits attribués

touch test


ls -l test


-rw-r--r-- 1 jmf jmf 7105  1 déc.  14:45 test

Dernière modification par Croutons (01-12-2022 15:45:12)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums