Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-12-2022 19:44:31

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

[Résolu] Version de Ruby >=2.7.6 sous bullseye

Yo,
je voudrai installer un agenda du libre pour un projet. Mon serveur est sous bullseye. Quand je veux installer le projet, on me demande Ruby >=2.7.6. Bullseye ne propose que Ruby 2.7.4.

Je suis allé voir côté ruby-build mais à priori y a pas ce qu'il faut non plus. Ni en backport. Je suis obligé de frankendebianiser ?

rbenv install  -l


1.8.5-p113
1.8.5-p231
[...]
2.6.0-preview3
2.6.3
2.7.0-preview3
 



ruby -v


ruby 2.7.4p191 (2021-07-07 revision a21a3b7d23) [arm-linux-gnueabihf]

Dernière modification par otyugh (19-12-2022 14:01:51)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#2 17-12-2022 20:04:21

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 6.1.4 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [Résolu] Version de Ruby >=2.7.6 sous bullseye

Tu peux tenter un backport local, cf. Rétroportage.
J’essaie en ce moment-même de reconstruire Ruby 3.0 de Bookworm sur Bullseye, je te dirai ce que ça donne.

---

Testé et approuvé, à l’aide de Debian backports builder. Que j’ai lancé avec :

./build-backport.sh bullseye ruby-webrick ruby-sdbm ruby3.0


Jouer sous Debian ? Facile !

Hors ligne

#3 18-12-2022 01:25:55

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Version de Ruby >=2.7.6 sous bullseye

Yay !
...

À ce propos, problème auxilliaire ; mon serveur à 500Mo de RAM donc peut pas faire l'opération ; comment temporairement désactiver le montage de /tmp en RAM ? T_T

tmpfs              497M       0  497M   0% /tmp


Ce que j'ai essayé

systemctl disable tmp.mount
#supprime un lien symbolique mais est actif au redémarrage
systemctl mask tmp.mount
#retourne Failed to mask unit: File /etc/systemd/system/tmp.mount already exists.
 


(bien entendu que je redémarre hein, pas d'entrée dans fstab... Ptéte que je vais virer le service sans passer par systemd, mais je pige pas le souci pour commencer T_T)
EDIT : ...J'ai juste déplacé le fichier /etc/systemd/system/tmp.mount ailleurs, ça marche T_T
EDIT2 : du coup c'est installé mais j'arrive pas à changer de version de ruby !

rbenv global 3.0.4


rbenv: version `3.0.4' not installed

Dernière modification par otyugh (18-12-2022 05:04:11)


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

#4 19-12-2022 11:23:12

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 6.1.4 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [Résolu] Version de Ruby >=2.7.6 sous bullseye

Je ne connais pas rbenv, qui ne semble pas disponible sur mon système.

Chez moi /usr/bin/ruby est un lien symbolique vers la version de Ruby à utiliser :

ls -l /usr/bin/ruby

lrwxrwxrwx 1 root root 7 29 nov.  18:35 /usr/bin/ruby -> ruby3.1


Jouer sous Debian ? Facile !

Hors ligne

#5 19-12-2022 14:01:34

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] Version de Ruby >=2.7.6 sous bullseye

Oh merci ! J'ai complètement oublié de mettre à jour le sujet, mais je m'en suis aperçu aussi, et ça a réglé le souci en changeant ce raccourci.
Par contre je suis un peu emmerdé de garder ruby2.7 que... J'arrive pas à supprimer sans virer mon backport de ruby3.0. Boh quelques Mo tu me dira !

root@a20-micro:~# apt remove ruby2.7
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-lato javascript-common libgmp-dev libgmpxx4ldbl libjs-jquery
  ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby-xmlrpc
  ruby2.7-doc rubygems-integration sudo
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  bundler libruby2.7 libruby3.0 libruby3.0-dbgsym rake rbenv ruby ruby-bundler
  ruby-dev ruby-rubygems ruby-sdbm ruby-sdbm-dbgsym ruby2.7 ruby2.7-dev
  ruby3.0 ruby3.0-dbgsym ruby3.0-dev
0 mis à jour, 0 nouvellement installés, 17 à enlever et 0 non mis à



Problème résolu quand même, grand merci pour ton script smile


virtue_signaling.png
Pas de repos pour les oppresseurs ! (/me inclus)

En ligne

Pied de page des forums