Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 04-03-2021 21:09:42

Bonjour,

J'ai finalement réussi à faire fonctionner le son sur mon E200HA avec LMDE 4   !!!  big_smile  big_smile  big_smile
Donc fort probable que ça fonctionne également sur Debian ! Solution sur ce site :
https://forums.linuxmint.com/viewtopic. … 5#p1981395

==================
Je copie/colle la solution ici :
==================

J'ai trouvé mon bonheur sur ce lien :
https://github.com/heikomat/linux/tree/ … and_manual

Ce que j'ai fait :
==============

1) J'ai installé le noyau 5.10 via Synaptic (désolé je débute... j'ai pris la méthode la plus facile).

Donc j'ai installé les 4 fichiers suivants :
   linux-headers-5.10.0-0.bpo.3-amd64
   linux-headers-5.10.0-0.bpo.3-common
   linux-image-5.10.0-0.bpo.3-amd64
   linux-kbuild-5.10


Qui vont remplacer les fichiers suivants existants (je ne les ai pas supprimés) :
   linux-headers-4.19.0-14-amd64
   linux-headers-4.19.0-14-common
   linux-image-4.19.0-14-amd64
   linux-kbuild-4.19

2) J'ai mis à jour GRUB (je ne sais pas si c'est indispensable ou pas mais c'est conseillé) :
   sudo update-grub

3) J'ai appliqué bêtement la méthode décrite sous :
https://github.com/heikomat/linux/tree/ … and_manual

J'ai fait :

sudo apt install pulseaudio

sudo apt install firmware-intel-sound (LMDE est basée sur Debian donc me convient)
     sinon si Linux Mint base Ubuntu , taper : sudo apt install linux-firmware

sudo mkdir --parents /usr/share/alsa/ucm/bytcht-cx2072x
cd /usr/share/alsa/ucm/bytcht-cx2072x
sudo wget "https://raw.githubusercontent.com/heiko … /HiFi.conf"
sudo wget "https://raw.githubusercontent.com/heiko … 2072x.conf"

J'ai ouvert en admin le fichier : sudo xed /etc/pulse/daemon.conf

Remplacer
; realtime-scheduling = yes

par
realtime-scheduling = no

IMPORTANT : il faut supprimer le ; qui est en début de ligne.

4) On reboot :
systemctl reboot

Et voilà !!!  big_smile  big_smile  big_smile

Karibou1312

#2 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 04-03-2021 04:08:49

Bonjour,
J'ai trouvé ce lien sur le Pb du son sur les E200HA.
https://bugzilla.kernel.org/show_bug.cgi?id=115531#c115

Je dois faire quoi ?
Installer un noyau 5.3.x ou supérieur et installer "alsa ucm files" ? Comme le dit le Post 115 ?

Ou
comme le dit le Post 125 ?
https://bugzilla.kernel.org/show_bug.cgi?id=115531#c125

I fixed my problem from last comment, here's how I did it:
For the backstory, I have a E200HA Asus Notebook/EEePC.

1. Get kernel with cx2072x support, enable it and update grub to boot into it.
2. Get alsa-lib-1.2.2 (or any stable release I guess) from https://github.com/alsa-project/alsa-lib
3. ./gitcompile --libdir=/usr/lib/x86_64-linux-gnu (or ./configure --libdir=/usr/lib/x86_64-linux-gnu if it didn't work) followed by make && make install
4. Get alsa-ucm-conf from https://github.com/alsa-project/alsa-ucm-conf (again, matching the release number of alsa-lib you compiled, in our case it's 1.2.2)
5. Rename your /usr/share/alsa/ucm into ucm.old directory and create /usr/share/alsa/ucm2 directory
6. Copy ucm2 directory from cloned alsa-ucm-conf git repo into /usr/share/alsa/
7. Reboot



Je dois télécharger et compiler ?
Je n'ai jamais fait sad

Vous pouvez m'expliquer SVP ce que je dois faire ?

Le plus facile pour moi, c'est de réussir à exécuter le script que m'a proposé X230   "e200ha_with_sound.sh"   qu'on trouve sous :
https://forum.ubuntu-fr.org/viewtopic.php?id=2013441
qui renvoit vers Github :
https://github.com/Grippy98/Asus-E200HA … all-Script

Merci pour votre aide...

#3 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 02-03-2021 16:48:08

Bonjour et merci !

J'ai exécuté la commande : 
apt-get --reinstall install pulseaudio pavucontrol
apt-get install alsa-utils
alsa-info

J'ai ça :


# lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
 



Et ça :


# aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: bytchtcx2072x [bytcht-cx2072x], périphérique 0: Audio (*) []
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: bytchtcx2072x [bytcht-cx2072x], périphérique 1: Deep-Buffer Audio (*) []
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
 



Toujours pas de son... scratchhead.gif

Merci

#4 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 02-03-2021 15:52:50

Bonjour,
Debian commence à me taper sur le système...
J'ai installé le noyau 5.10 et toujours pas de son ! mad pourtant j'ai supprimé le noyau 4 19...
Je n'y comprends rien...
Alors que les autres distrib Manjaro ou Linux Mint 20.1 le son fonctionne très bien...
Je me demande si je n'ai pas intérêt à tout réinstaller mais en la mettant en Sid dès le départ...
Merci pour votre aide.

#5 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 01-03-2021 23:10:58

Tawal a écrit :


Mais heuu ... je l'aime bien mon bureau



Tu as quoi comme Bureau ? Et Distrib ? Ca a l'air joli ! big_smile
.
.

#6 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 01-03-2021 21:14:25

Bonjour ! big_smile

x230 a écrit :


... désolé du terme mais quelle m*rde !!



J'ai bien rigolé quand j'ai lu ton Post ! Content de voir quelqu'un qui connait ce PC ! big_smile
Crois moi, le PLUS POURRI que j'ai vu pour linux est le X205TA... J'ai laissé tomber... Ma fille en a un. Je l'ai laissé avec Windows10 32bit.
Je ne désespère pas installer un Linux dessus un jour...


x230 a écrit :


... (en espérant que tu n'es pas comme j'ai eu c'est à dire des problèmes de son).




Suite à ton message, j'ai téléchargé Debian Cinnamon via le lien que tu m'as envoyé (Merci ! smile )
Et là... Pb de son... mad

J'ai suivi la méthode que tu m'as indiquée. Et j'ai ce message d'erreur !


$ ./e200ha_with_sound.sh
./e200ha_with_sound.sh: ligne 7: erreur de syntaxe près du symbole inattendu « newline »
./e200ha_with_sound.sh: ligne 7: `<!DOCTYPE html>'
 



Puis j'ai regardé le fichier "e200ha_with_sound.sh" , et la ligne 7 est la première avec caractères... "<!DOCTYPE html>"

Ca donne ça (début du fichier) :


<!DOCTYPE html>
<html lang="en" >
  <head>
    <meta charset="utf-8">
  <link rel="dns-prefetch" href="https://github.githubassets.com">
  <link rel="dns-prefetch" href="https://avatars.githubusercontent.com">
  <link rel="dns-prefetch" href="https://github-cloud.s3.amazonaws.com">
  <link rel="dns-prefetch" href="https://user-images.githubusercontent.com/">
 



Il y a un Pb avec l'exécutable ... ou ???
Je ne sais pas comment faire... sad


x230 a écrit :


Tu as bien désactivé le secure boot dans le BIOS ?



Oui ! Secureboot désactivé ! smile

x230 a écrit :


Depuis elle a tourner le dos à Linux pour Windows 10 et ne veut plus changer Grrr sad



Sincèrement, j'aurais préféré LMDE 4 ... Car plus convivial... Mais malheureusement, je dois trouver une solution Bis ou réussir à contourner le Pb...

Pour ton info, (je débute sur Linux) : J'ai installé plusieurs Distrib qui fonctionnent SUPER BIEN sur ce E200HA !!! Ca tournais très vite et j'étais impressionné par la convivialité et la rapidité, et AUCUN Pb de son ou AUCUN Pb de quoi que ce soit !!!
Distrib qui fonctionnent très bien ET un PC qui tourne vite : Artix Cinnamon ; Manjaro Cinnamon ; PCLinuxOC Mate ; PCLinuxOS XFCE
Distrib qui fonctionnent très bien MAIS un PC un peu lent : Fedora Gnome, Fedora Cinnamon, Debian Cinnamon, Linux Mint 20.1

Si tu veux réconcilier ta compagne avec Linux, installe lui Manjaro Cinnamon, et elle va s'éclater avec (si tu as une bonne connexion internet) ! Surtout que le GUI PAMAC facilite bien la vie... J'ai activé les Flatpak et les dépots AUR dans PAMAC.
J'ai laissé tomber Artix car c'est pour des Geeks comme toi big_smile ! Il faut s'y connaitre dans Linux pour travailler avec Artix. Mais Artix est très rapide ! Vive OpenRC big_smile

Je n'ai pas gardé Manjaro ni Artix à cause des install d'imprimantes et scanners (pour ma fille), car on trouve des *.deb et des *.rpm , mais jamais les fichiers d'install pour Arch ou Manjaro... Donc il me faut une base Debian (DEB) ou CentOS (RPM)...

Et toutes ces distrib avait le noyau 5.4 ou plus récent !!!
Alors que Debian a le noyau 4.19 ... roll

Question :
=======

Comment puis je changer le noyau de Debian ? J'aimerais bien installer le noyau LTS 5.4 ou 5.10 pour régler le Pb de son... neutral
J'ai regardé sur Google et j'ai vu des trucs ahurissants ! Qu'il fallait télécharger puis compiler un noyau... roll  Je n'ai pas le niveau...

x230 a écrit :


- Pourquoi une installation Debian fonctionnerait mieux qu'une version modifié de chez Mint ? Je pense que le problème est contournable et qu'il faut chercher la solution...



Je ne comprends toujours pas pourquoi j'arrive à installer Linux Mint 20.1, et Debian, et pas LMDE 4 ??? Ca reste un mystère... roll
J'aimerais bien avoir LMDE4 avec un noyau 5.4 ou 5.10...

x230 a écrit :


- Est-ce que tu tiens vraiment à mettre Linux Mint Debian Edition ou peut importe tant que ça fonctionne ?



Si je n'arrive pas à installer LMDE4, j'installerai Debian Facile XFCE MAIS à condition que j'arrive à avoir un noyau 5.4 ou 5.10... pour ne pas galérer avec le son...
Je n'ai pas réussi à  exécuter "e200ha_with_sound.sh" ... sad

Mais je préfère Cinnamon, sinon Mate, sinon XFCE.

capdefradeb a écrit :


Je pense aussi que vouloir Cinnamon sur une config aussi modeste, ça n'est pas du tout une bonne solution. Si elle s'installe, je mettrais tout simplement la Debian Facile XFCE.



Merci pour ton conseil. Je vais l'essayer. Mais il faut que j'arrive à installer le noyau 5.4 ou 5.10 pour ne pas avoir de Pb de son ou matériel. Le 4.19 ne me convient pas.

Tawal a écrit :


Par principe, je préfère m'orienter vers un bureau léger même avec une bonne config.
Cela laisse plus de marge pour les applis.
...
Après, intervient aussi les goûts et les couleurs ....



Vous êtes nombreux à me conseiller XFCE... Le seul XFCE que je trouve digeste est celui de Manjaro... Je vais essayer celui de Debian Facile...
Je préfère Cinnamon, sinon Mate, sinon XFCE.

Mais il faut que j'arrive à installer le noyau 5.4 ou 5.10... Pour régler le Pb de son qui existe avec le noyau 4.19

Merci beaucoup pour votre aide !!! big_smile

Questions :
========

- Comment puis je changer le noyau de Debian ? J'aimerais bien installer le noyau LTS 5.4 ou 5.10 pour régler le Pb de son... neutral
- Si j'installe Debian XFCE, et que je n'aime pas... Coment je fais pour instalelr Cinnamon proprement et désinstaler proprement XFCE ? Je ne veux pas avoir 2 DE...
- Lors de la fenêtre Login je suis en clavier QWERTY, mais dès que je me logue j'ai un clavier AZERTY. Comment faire pour avoir AZERTY tout le temps ?

Merci pour votre aide !!!
.
.

#7 Re : Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 27-02-2021 14:08:17

Bonjour et merci pour ce conseil.

J'ai en effet essayé d'installer LMDE 4. Elle m'a beaucoup plu en Live USB.
Mais impossible à installer...

Cf le lien ci-dessous :
https://forums.linuxmint.com/viewtopic. … ead#unread

Il semble que le problème est connu. Impossible d'installer LMDE 4 sur certains PC qui ont des eMMC. Je ne sais pas pourquoi...

Bonne journée.

Karibou1312

#8 Cinnamon » Install Debian Facile : Install Cinnamon puis Désinstall XFCE ??? » 27-02-2021 01:56:09

Karibou1312
Réponses : 17
Bonjour,
Je débute sur Linux.
J'ai bien lu votre procédure d'installation de Cinnamon et merci pour la Doc !

Installer Cinnamon sur Debian Jessie :
https://debian-facile.org/doc:environne … e:cinnamon

ou ???

Installer Cinnamon sur Debian Wheezy avec Gnome 3.4 :
https://debian-facile.org/doc:environne … n-gnome3.4

ou ???
Autre méthode car nosu sommes sur Debian Buster ?

Je dois utiliser quelle méthode ?

Comme j'ai envie d'avoir une Install propre de Debian Facile Cinnamon, comment faire pour :
- Installer Cinnamon proprement (je pense que je dois suivre un des liens ci-dessus) --> Donc pas de soucis à priori
- Désinstaller XFCE ? et tous ses composants qui ne seront plus utiles à Cinnamon ?
- Dois je supprimer aussi Thunar en même temps que XFCE ? Que dois je supprimer en plus pour avoir un Cinnamon propre ?
- Dois je installer Nemo  ? ou il va venir avec Cinnamon ?

Merci pour votre aide.

Cordialement,

Karibou1312

#9 Re : Contribution à Debian, packaging, traductions, bugs, etc. » [BUG] Thème illisible lors de la mise à jour de GRUB » 03-09-2020 19:46:02

Merci beaucoup à vous et à Adrien !
Je suis en train d'installer Debian-Facile sur VirtualBox avant d'installer en dur et de supprimer Windows smile
Je vais débuter mon expérience Linux avec Debian-Facile et lire les tutoriels !
Je vais commencer à me former yikes
Je vais galérer quelques semaines... Mais ça sera avec plaisir !

#10 Re : Contribution à Debian, packaging, traductions, bugs, etc. » [BUG] Installation UEFI non fonctionnelle » 03-09-2020 19:45:17

Merci beaucoup à vous et à Adrien !
Je suis en train d'installer Debian-Facile sur VirtualBox avant d'installer en dur et de supprimer Windows smile
Je vais débuter mon expérience Linux avec Debian-Facile et lire les tutoriels !
Je vais commencer à me former yikes
Je vais galérer quelques semaines... Mais ça sera avec plaisir !

Pied de page des forums

Propulsé par FluxBB