Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-06-2018 09:07:32

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

[résolu : contournement] keepassxc

Bonjour,

J'utilise keepassx depuis un bout de temps mais comme j'ai ouïe dire que le projet était en stand by et que son successeur était keepassxc, cela fait un mois que j'essaie de temps en temps d'installer keepassxc, mais toujours en vain à cause de problèmes de dépendances. J'ai essayé keepass2, mais outre le fait que je le trouve moins beau (oui, je sais...), il ne récupère pas toutes les clefs et les groupes de mes trousseaux générés avec keepassx, ce qui est assez ennuyeux...

Sous debian stretch, voilà ce que j'obtiens :

#

apt install keepassxc


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 keepassxc : Dépend: libqt5core5a (>= 5.9.0~beta) mais 5.7.1+dfsg-3+b1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



Et depuis unstable, c'est pareil :

#

apt install -t unstable keepassxc


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libkf5coreaddons5 : Casse: libkf5auth5 (< 5.46) mais 5.28.0-2 devra être installé
                     Casse: libkf5globalaccel-bin (< 5.46) mais 5.28.0-1 devra être installé
 libkf5crash5 : Casse: libkf5globalaccel-bin (< 5.46) mais 5.28.0-1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.



Est-ce un problème local sur ma machine ou général ? D'autres ont-il installé keepassxc depuis l'arbre des paquets debian ?

Mon source.list :

# deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 NETINST 20171013-13:07]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.2.1 _Stretch_ - Official amd64 NETINST 20171013-13:07]/ stretch main

deb http://debian.mirrors.ovh.net/debian/ stretch main contrib
deb-src http://debian.mirrors.ovh.net/debian/ stretch main contrib

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://debian.mirrors.ovh.net/debian/ stretch-updates main contrib
deb-src http://debian.mirrors.ovh.net/debian/ stretch-updates main contrib

# vlc libdvdcss
deb http://download.videolan.org/pub/debian/stable/ /
deb-src http://download.videolan.org/pub/debian/stable/ /

#deb http://www-fourier.ujf-grenoble.fr/~parisse/debian/ stable main
# deb-src http://www-fourier.ujf-grenoble.fr/~parisse/debian/ stable main
deb http://debian.mirrors.ovh.net/debian/ stretch-backports main contrib



Merci pour votre aide.

Edit à toto : Mis en ordre l'utilisation des BBcodes avec les commandes root pour une meilleure lisibilité par tous.

Dernière modification par mazkagaz (02-06-2018 00:56:11)

Hors ligne

#2 01-06-2018 11:14:37

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [résolu : contournement] keepassxc

Pourquoi ne pas utiliser les serveurs debian directement ?
voici les sources stretch non libre avec les backports :
https://debian-facile.org/doc:systeme:a … -backports smile

Pour les paquets unstables que tu as tentés, avais-tu ajouter les dépots unstable aux sources ?
Et si oui, avais-tu préservé la stabilité de ton système avec un pinning efficace ?

Dernière modification par smolski (01-06-2018 11:18:42)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 01-06-2018 11:31:02

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

smolski a écrit :

Pourquoi ne pas utiliser les serveurs debian directement ?
voici les sources stretch non libre avec les backports :
https://debian-facile.org/doc:systeme:a … -backports smile



J'utilise les miroirs OVH parce que :
- j'y suis attaché sentimentalement depuis longtemps...
- c'est mon FAI et j'ai pensé (pendant 2 secondes au moment de l'install) que les routes vers ces miroirs seraient plus directes (ça reste à vérifier...)
- ils font parti des miroirs officiels qu'on peut sélectionner pendant l'install (donc je vois pas où serait le soucis de les choisir, puisqu'ils sont assez fiables pour que debian les ai choisis officiellement)
- je me dis que les serveurs de base doivent être choisis par la majorité et donc : potentiellement plus chargés.
Bref, que des fausses bonnes raisons mais comme ça n'est pas sensé changer quoi que ce soit...

Sinon, si je comprends le sens de ta réponse, mon soucis réside dans le fait de ne pas avoir ajouté les backports. Je vais les activer et voir ce qu'il se passe. Merci.

Hors ligne

#4 01-06-2018 11:43:14

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

pourquoi ne pas installer keepassxc en utilisant appimage, snap ou flatpak ?
https://keepassxc.org/download/#linux
https://flathub.org/apps/details/org.ke … .KeePassXC

#5 01-06-2018 11:44:53

deuchdeb
Moderato ma non troppo
Lieu : Sud-ouest
Distrib. : Debian 10 Buster KDE et LinuxMintCinnamon
Noyau : Noyau stable
(G)UI : KDE Plasma 5.14
Inscription : 13-01-2010
Site Web

Re : [résolu : contournement] keepassxc


Une fleur, c'est magique non? smile
Association Debian Facile

Hors ligne

#6 01-06-2018 11:55:16

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Non, en fait j'ai mal compris ta réponse du coup puisque les backports sont activés chez moi. Pour plus de cohérence, j'ai modifié mon source.list pour qu'il les récupère aussi sur le miroir OVH, et un apt install -t stretch-backports renvoie un message similaire :

# apt install -t stretch-backports keepassxc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 keepassxc : Dépend: libqt5core5a (>= 5.9.0~beta) mais 5.7.1+dfsg-3+b1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#7 01-06-2018 11:57:57

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Certe, il y a la solution appimage que j'utilise déjà pour d'autre logiciels. Je vais peut-être faire comme ça. Mais j'aime bien avoir une gestion centralisée des install/update et pour le moment je n'utilise les appimages que pour des logiciels qui n'ont pas de paquet debian. Là le paquet existe et j'aurais bien aimé l'utiliser.

Hors ligne

#8 01-06-2018 12:09:04

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

il y a bien un paquet mais dans une version supérieure à celle que tu utilises.
mélanger les paquets entre les versions n'est pas recommandé.

#9 01-06-2018 15:23:01

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Sauf erreur de ma part, je n'ai pas mélangé de paquet ET je n'ai pas de version déjà installée. Donc je ne comprends pas le sens de ton propos scratchhead.gif

Hors ligne

#10 01-06-2018 16:05:05

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

keepassx est uniquement disponible pour buster et sid alors que d'après ton sources.list tu utilises stretch.
donc ce que tu essaies de faire, c'est de mélanger des paquets de plusieurs versions de debian

#11 01-06-2018 16:28:36

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [résolu : contournement] keepassxc

Un petit tuto tranquillou est là pour expliquer le sens des interventions qui te sont proposées : https://debian-facile.org/doc:systeme:a … hes-debian smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 01-06-2018 20:53:38

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Concernant le système des branches, depuis 20 ans que j'utilise debian, je pensais avoir compris. Mon source.list ne contient que des sources stretch (donc a priori stable) mais effectivement, lorsque je fais une recherche dans les packages debian, je vois bien que keepassxc n'existe pas en version stable : https://packages.debian.org/search?sear … =keepassxc

Du coup je m'interroge sur le résultat de la commande "apt install keepassxc" (sans le "-t unstable") qui devrait me retourner un message du style "paquet non trouvé" (en franglais dans le texte) au lieu de me renvoyer un problème de dépendance.

Je pense que j'ai mal saisi l'impact des backports dans le source.list que j'ai dû ajouter un jour pour un besoin ponctuel : c'est un pont vers les packages sid et testing ? Je vais aller me documenter.

Et du coup, comme l'appli n'est pas gérée par la branche stable (et mal gérée par les backports si j'ai bien compris ce qu'il se passe), je vais utiliser une version type appinstall.

Hors ligne

#13 01-06-2018 20:59:38

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

faut regarder s'il n'y a pas quelque chose dans /etc/sources.list.d/
je ne vois pas d'autres explications

keepassxc n'est pas dans les backports, sinon tu n'aurais pas eu de difficultés pour l'installer.

je ne sais pas si appimage permet les mises à jour du paquet. en tout cas, c'est géré par snap.
sinon, la page du projet propose un paquet .deb non officiel pour stretch.

#14 01-06-2018 21:18:31

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Anonyme-8 a écrit :

faut regarder s'il n'y a pas quelque chose dans /etc/sources.list.d/
je ne vois pas d'autres explications



En effet, c'est ça... Je suis couillon, je ne me rappelais plus que j'avais rajouté une source unstable pour avoir un firefox plus récent, celui que j'ai sous les yeux en répondant. Si je vire la source en question, je n'ai plus keepassxc qui m'est proposé. Par contre, je ne pensais pas que sans lui spécifier le "-t unstable" il irait piocher des paquets dans unstable : ça ne me plait pas trop... J'ai peut-être mal réglé le pinning que j'ai modifié il y a peu parce que justement, je n'avais pas de mises à jour de firefox. J'ai peut-être fait une boulette, je vais y jeter un oeil.

Et je vais jeter un oeil à snap, qui pourra peut-être aussi prendre le relai pour gérer mon firefox afin de virer ma source sid une bonne fois pour toutes.

Dernière modification par mazkagaz (01-06-2018 21:21:46)

Hors ligne

#15 01-06-2018 23:02:53

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Bon, ça avance avec snap.

J'ai testé l'installation de firefox via snap. Il m'a fallu un petit moment pour comprendre que tout se passe dans /snap et non dans /home/user/snap comme j'avais cru le comprendre sur la doc. Heureusement locate était là pour m'aiguiller. Par contre, la localisation fr, on la gère comment sur un paquet snap ? Et c'est dommage qu'il ne crée pas automatiquement les lanceurs : j'ai dû me paramétrer le mien à la main et du coup, à part la gestion centralisée des mises à jours, quel est l'apport par rapport à une appimage ? Je remarque aussi que le binaire est estampillé ubuntu quand je vais chercher la version de firefox : ça manque de neutralité pour un système qui se veut hors distributions. J'ai une appimage du client nextcloud qui parait plus neutre (même si ça n'est qu'une apparence).

Concernant keepassxc installé via snap, là, je n'ai pas su trouver l'exécutable adéquat.

$ /snap/keepassxc/current/usr/bin/keepassxc
/snap/keepassxc/current/usr/bin/keepassxc: error while loading shared libraries: libykpers-1.so.1: cannot open shared object file: No such file or directory


Un peu déçu pour le coup, ça avait l'air simple sur le papier... Et avec keepassxc-cli, pas mieux :

$ /snap/keepassxc/current/usr/bin/keepassxc-cli
/snap/keepassxc/current/usr/bin/keepassxc-cli: error while loading shared libraries: libargon2.so.0: cannot open shared object file: No such file or directory


Avec les command*.wrapper à la racine du répertoire /snap/keepassxc/current, pas mieux : un soucis de path on dirait.

Qqun utilise la version de snap et elle fonctionne chez lui ? Sinon, je vais tester l'appimage. L'idée avec ce type d'install, c'est quand même que ça marche sans trop se fatiguer. Sinon autant télécharger les sources...

Edit : Bon, après un moment de réflexion, snap ne me convient pas, tout comme Flatpak.
Concernant firefox, je vais installer directement l'archive firefox depuis le site de mozilla. Cela va me demander un peu de travail d'install supplémentaire mais ça ne risque pas de casser mon arbre de dépendances lors d'une mise à jour et l'archive est directement gérée par les équipes mozilla en lesquelles j'ai suffisamment confiance.
Concernant keepassxc, puisqu'ils génèrent une appimage, je vais faire comme pour le client nextcloud : je prends l'appimage.
Et tant pis pour la gestion centralisée des mises à jour. Je ferais comme les windaubiens, je mettrai le logiciel à jour quand il me dira qu'il y en a une.
Au moins mon système de base restera clean quand je l'aurai nettoyé.
Et à propos de nettoyage, vous avez des conseils à me donner pour expurger les paquets sid de ma stretch ? Je vois comment enlever firefox, et comment faire un autoremove ensuite, mais qu'en est-il des paquets qui auraient été mis à jour pour firefox et qui sont utilisés par d'autre paquets ? Comment les repérer et les réinstaller en version stable ?

Edit 2 : c'est fait pour les désinstallation et un début de nettoyage. Le firefox de mozilla fonctionne au poil avec le fichier .desktop qui va bien pour avoir le raccourcis et pour l'appimage de keepassxc, c'est du gâteau puisque la première utilisation propose l'intégration automatique au bureau : parfait.

Dernière modification par mazkagaz (02-06-2018 00:59:59)

Hors ligne

#16 02-06-2018 01:17:10

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

pour snap et cie, faut lire un peu mais il y a des différences.
snap est une idée d'ubuntu mais ça se porte sur les autres distributions.
un raccourci devrait être dispo, c'est le cas avec firefox, sinon snap list
et snap run <app>

l'essentiel, c'est que tu puisses utiliser l'application big_smile

edit: snap fonctionne très bien chez moi
quelques infos sur le wiki https://debian-facile.org/doc:systeme:keepassxc

#17 02-06-2018 01:34:34

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Un dernier message juste au cas où, après j’arrête d'alimenter ce sujet avec d'autres sujets, c'est promis big_smile (en plus là c'est même pas un sujet debian...)

J'ai découvert avec keepassxc une fonctionnalité intéressante qui est de pouvoir paramétrer la saisie automatique. C'est utile parce si la plupart des sites fonctionnent avec deux champs de saisie séparés d'une tabulation, d'autres fonctionnent avec deux pages consécutives (donc deux champs séparés d'une validation). Du coup j'ai profité de cette nouvelle fonctionnalité pour paramétrer certains identifiants avec une validation à la place de la tabulation mais problème : sans timer après la validation, une partie du password s'écrit à la suite du login et donc, ça plante l'authentification. J'ai cherché dans la doc mais n'ai pas trouvé comment mettre un timer après la validation. Il est possible de mettre un timer avant la première saisie via les paramètres de l'appli, ou entre les saisies des caractères, mais je n'ai rien trouver pour l'insérer entre les deux saisies. Voilà, c'est ma bouteille à la mer : si qqun la trouve, comprend ce que je dis et connais une solution, il rendra mon application plus ergonomique, sinon, tant pis, je ferai comme j'ai toujours fait : alt tab copier, alt tab coller, valider, alt tab copier, alt tab coller, valider.

Hors ligne

#18 02-06-2018 01:54:08

Anonyme-8
Invité

Re : [résolu : contournement] keepassxc

quand tu parles de saisie automatique, tu parles d'un truc comme ça: https://blog.niqnutn.com/index.php?arti … saisieauto
si ça ressemble à l'authentification de google.com

regarde là: https://keepass.info/help/base/autotype.html
{DELAY=X}
je sais pas si c'est la même chose avec keepassxc ?

#19 02-06-2018 02:00:32

mazkagaz
Membre
Distrib. : Debian buster essentiellement
Noyau : Ça dépend...
(G)UI : Je migre petit à petit vers KDE.
Inscription : 13-05-2018

Re : [résolu : contournement] keepassxc

Parfait !!! woohoo.gif

En plus d'avoir une version maintenue, j'ai gagné en ergonomie !

woohoo.gif

Maintenant je peux aller me coucher big_smile

Hors ligne

Pied de page des forums