Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-01-2019 05:20:51

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

bluetooth ne s'active pas

bonjours tous le monde,

voila des heures que je me bat avec mon Bluetooth qui ne fonctionne pas. ou plutôt ne s'active pas a chaque fois que je clique sur activer dans la fenêtre graphique de gnome-bluetooth le petit bouton bascule sur le bleu mais ça reste écrit Bluetooth désactiver.. alors je me suis lancer dans de folle recherche quand je fais un

hcitool scan


Device is not available: No such device
 



puis j'ai aussi ses messages bizarre ..

dmesg | grep bluetooth
 


[    7.143600] bluetooth hci0: firmware: failed to load rtl_bt/rtl8821a_config.bin (-2)
[    7.143676] bluetooth hci0: Direct firmware load for rtl_bt/rtl8821a_config.bin failed with error -2
[    7.143755] bluetooth hci0: firmware: failed to load rtl_bt/rtl8821a_fw.bin (-2)
[    7.143821] bluetooth hci0: Direct firmware load for rtl_bt/rtl8821a_fw.bin failed with error -2
 



simplement je ne sais pas comment telecharger les firmware manquants .. j'ai demander a notre cher amis google qui ne sait pas quoi me repondre bref quelqun a une idée dans tout ce jolie bordel ?

Hors ligne

#2 02-01-2019 07:58:08

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : bluetooth ne s'active pas

Bonjour
si tu utilise gnome , tu a synaptic , tu fais une recherche du paquet "firmware-realtek"
il te faut un sources.list avec "main contrib non-free" pour utiliser les paquets non-free
exemple :


nano /etc/apt/sources.list
 



#stretch9
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://deb.debian.org/debian/ stretch main contrib non-free
 



puis un apt update (ou si tu utilise synaptic recharger )


apt update
 



nota: si ton matériel est très récent , il te faut peut être utiliser les backports de stretch

un lien vers la description du paquet => https://packages.debian.org/fr/stretch/firmware-realtek

a priori celui la doit convenir

Realtek RTL8821A Bluetooth firmware (rtl_bt/rtl8821a_fw.bin)



pour vérifier si il est installé (dans mon exemple non , et en plus je suis sous buster mais la commande reste identique)


apt-cache policy firmware-realtek
 


retour (pour moi )


firmware-realtek:
  Installé : (aucun)
  Candidat : 20180825+dfsg-1
 Table de version :
     20180825+dfsg-1 500
        500 http://deb.debian.org/debian buster/non-free amd64 Packages
        500 http://deb.debian.org/debian buster/non-free i386 Packages
 

Dernière modification par robert2a (02-01-2019 08:08:33)

Hors ligne

#3 02-01-2019 15:27:27

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : bluetooth ne s'active pas

gedit /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch main

deb http://ftp.fr.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main non-free contrib
deb-src http://security.debian.org/debian-security stretch/updates main non-free contrib

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main non-free contrib



je sais utiliser la ligne de commande ..

sudo apt-get install firmware-realtek
 


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-linuxlibertine fonts-sil-gentium fonts-sil-gentium-basic hyphen-en-us libapache2-mod-dnssd libbsh-java libreoffice libreoffice-help-en-us libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher mythes-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  firmware-realtek
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 342 ko dans les archives.
Après cette opération, 1 148 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://ftp.fr.debian.org/debian stretch/non-free amd64 firmware-realtek all 20161130-4 [342 kB]
342 ko réceptionnés en 0s (1 866 ko/s)  
Sélection du paquet firmware-realtek précédemment désélectionné.
(Lecture de la base de données... 164942 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../firmware-realtek_20161130-4_all.deb ...
Dépaquetage de firmware-realtek (20161130-4) ...
Paramétrage de firmware-realtek (20161130-4) ...
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-8-amd64
 




apt-cache policy firmware-realtek
 


firmware-realtek:
  Installé : 20161130-4
  Candidat : 20161130-4
 Table de version :
 *** 20161130-4 500
        500 http://ftp.fr.debian.org/debian stretch/non-free amd64 Packages
        100 /var/lib/dpkg/status
 




sudo apt-get update
 


Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://ftp.fr.debian.org/debian stretch-updates InRelease                            
Atteint:3 http://packages.microsoft.com/repos/vscode stable InRelease                          
Atteint:4 http://security.debian.org/debian-security stretch/updates InRelease                                
Atteint:5 http://ftp.fr.debian.org/debian stretch Release                                                      
Lecture des listes de paquets... Fait    



1 - donc c'est tous ? je n'ai pas a le copier au bonne endroit ?? tous se fait automatiquement ??
2- ou as tu trouver la solution ?
3- je reboot et j'édit si ca a marcher.

EDIT: ca na pas fonctionner.

Dernière modification par saw (02-01-2019 15:36:30)

Hors ligne

#4 02-01-2019 17:00:35

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : bluetooth ne s'active pas

Bonjour,
et tu as toujours les mêmes messages d'erreurs ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

En ligne

#5 04-01-2019 04:09:10

saw
Membre
Distrib. : Debian GNU/Linux 9.5 (stretch)
Noyau : Linux 4.9.0-8-amd64
(G)UI : gnome
Inscription : 25-10-2018

Re : bluetooth ne s'active pas

Salut,

Désolé pour mon absence mais oui tjrs

Hors ligne

#6 05-01-2019 07:23:24

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : bluetooth ne s'active pas

Bonjour
commence par nous donner le retour de lspci


lspci
 


le retour de ta commande précédente


dmesg | grep bluetooth
 


retour (pour moi clé usb usb-bt400 bluetooth asus)


[  523.887308] bluetooth hci0: firmware: failed to load brcm/BCM20702A1-0b05-17cb.hcd (-2)
[  523.887316] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0b05-17cb.hcd failed with error -2
 


sur gnome dans "parametres" tu a un menu bluetooth (actif ou mode avion(désactivé) )
quand il est activé en haut a droite sur le bureau classique de gnome j"ai "activé"

nota:  a priori c'est du broadcom et il me manque un firmware

je le retrouve sur lsusb (toi sur lspci (en interne ) )


lsusb
 


pour le bluetooth


Bus 005 Device 003: ID 0b05:17cb ASUSTek Computer, Inc. Broadcom BCM20702A0 Bluetooth
 


redonne donc les retours demandés (par exemple le firmware ne convient peut être pas )

donne aussi le retour de ceci


journalctl -r -p err
 



sur buster gnome les fichier (.bin) pour le bluetooth dans /lib/firmware/rtl_bt/

rtl8192ee_fw.bin  rtl8723a_fw.bin  rtl8723d_config.bin    rtl8761a_fw.bin   rtl8821a_fw.bin      rtl8821c_fw.bin        rtl8822b_fw.bin
rtl8192eu_fw.bin  rtl8723b_fw.bin  rtl8723d_fw.bin    rtl8812ae_fw.bin  rtl8821c_config.bin  rtl8822b_config.bin



tu a besoin de deux fichier

failed to load rtl_bt/rtl8821a_config.bin
failed to load rtl_bt/rtl8821a_fw.bin


qui sont présent dans le firmware (du moins sur buster , pour ma machine )

tu a le même paquet que buster dans les backports de stretch si besoin  =>  https://packages.debian.org/fr/stretch- … re-realtek

nota: je tente d'expliquer alors que je suis pas foutu de faire fonctionner ma clé bluetooth asus  roll  tongue  lol

Dernière modification par robert2a (05-01-2019 08:08:32)

Hors ligne

Pied de page des forums