Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-01-2019 13:53:51

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

[resolu]perte des droits sur utilisateur admin

Bonjour, j'ai un accès root en mode graphique via le gestionnaire de fenêtre et tout va bien mais impossible de passer root par le Terminal

yole@yole-SATELLITE:~$ su
Mot de passe :
su : Échec d'authentification
yole@yole-SATELLITE:~$ sudo
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
            [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-T timeout] [-u user] file ...
yole@yole-SATELLITE:~$






contenu du fichier ~etc/sudoers

Defaults  env_reset
Defaults  mail_badpass
Defaults  secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin"

# User privilege specification
root  ALL=(ALL:ALL) ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d

yole  ALL=(ALL)       ALL
 






Voiçi mon appartenance aux groupes

yole@yole-SATELLITE:~$ id
uid=1000(yole) gid=1000(yole) groupes=1000(yole),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),115(lpadmin),128(sambashare)
yole@yole-SATELLITE:~$

Dernière modification par yole1 (13-01-2019 20:25:34)

Hors ligne

#2 13-01-2019 13:56:30

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : [resolu]perte des droits sur utilisateur admin

Essaye :

sudo -i


Et entre le mot de passe de ton compte user.

Hors ligne

#3 13-01-2019 14:05:37

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

$ su -i
su : option invalide -- 'i'
Syntaxe : su [options] [IDENTIFIANT]

Options :
  -c, --command COMMANDE        passer la commande COMMANDE à
                                l'interpréteur de commande appelé ;
  -h, --help                    afficher ce message d'aide et quitter ;
  -, -l, --login                utiliser un interpréteur de commandes
                                initial (« login shell ») ;
  -m, -p,
  --preserve-environment        ne pas réinitialiser les variables
                                d'environnement et conserver le même
                                interpréteur de commandes ;
  -s, --shell SHELL             utiliser SHELL comme interpréteur de
                                commandes à la place de celui défini
                                par défaut dans le fichier passwd.




oui c'est bon

~$ sudo -i
[sudo] Mot de passe de yole :
root@yole-SATELLITE:~#

Dernière modification par yole1 (13-01-2019 14:12:55)

Hors ligne

#4 13-01-2019 14:34:06

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

j'ai un accès root en mode graphique via le gestionnaire de fenêtre et tout va bien


Un gestionnaire de fenêtres (openbox pour LXDE, mutter pour Gnome...) n'a rien à voir avec l'accès root.
Si tu veux parler du gestionnaire de connexion (lightdm, gdm3...), tu veux dire que tu tapes ou sélectionnes "root" comme identifiant et le mot de passe du compte root ? Dans ce cas le même mot de passe root devrait être accepté par la commande su.
Si tu utilise un autre identifiant dans le gestionnaire de connexion, alors tu n'as pas un "accès root" mais une session normale avec un compte utilisateur normal.

Dernière modification par raleur (13-01-2019 14:34:49)

Hors ligne

#5 13-01-2019 14:49:12

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

Sur le PC il n'y a qu'un utilisateur qui s'appelle yole et le mot de passe admin est le même, c'est à dire yole aussi

En mode graphique j'ai l'accès root avec le mot de passe yole en passant par les dossiers du gestionnaire de fenêtre, c'est à dire en se positionnant sur un dossier et "ouvrir en tant qu'utilisateur root" à l'aide de la souris.




dans un terminal si on tapes sudo ou su
le MDP est demandé et l'on est root


yole@yole-SATELLITE:~$ su
Mot de passe :
su : Échec d'authentification
yole@yole-SATELLITE:~$




Comment faire pour etre root avec sudo ou même su dans un Terminal?

Edit modération : pas judicieux de mettre son mot de passe

Dernière modification par yole1 (13-01-2019 15:20:24)

Hors ligne

#6 13-01-2019 15:01:37

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : [resolu]perte des droits sur utilisateur admin

Si tu n’as pas créé de mot de passe root à l’installation du système, le premier utilisateur a les droits d’admin avec sudo et pour « passer root »

sudo -i


Si tu as créé un mot de passe root à l’installation, pour passer root

su -


le wiki :
https://debian-facile.org/doc:systeme:su
https://debian-facile.org/doc:systeme:sudo


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#7 13-01-2019 15:08:48

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

la commande sudo -i fonctionne pour passer root et la commande su ne fonctionne pas pour passer root et idem avec la commande sudo

A l'installation j'ai bien crée un mot de passe root

(je sais pourquoi ça déconne car le DD est défaillant et merci à e2fsck pour réparer mais cette fois çi juste après fsck l'accès root est modifié)
Mais peu-importe ce qui s'est passé car je souhaite pouvoir ouvrir root en utilisant sudo

[# apt get install sudo] ne change pas grand-chose et visudo paraît correct

Dernière modification par yole1 (13-01-2019 15:18:51)

Hors ligne

#8 13-01-2019 15:22:22

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

Sur le PC il n'y a qu'un utilisateur


Evite de raconter n'importe quoi sinon on ne va pas s'entendre.

wc -l /etc/passwd


33 /etc/passwd


Il doit y avoir à peu près autant d'utilisateur sur ton système. La plupart sont des comptes système.

yole1 a écrit :

à l'installation j'ai créer un mot de passe root


Faut croire que non, sinon su accepterait ce mot de passe.
Ne pas confondre utilisateur normal avec privilèges sudo et compte superutilisateur root.

D'autre part, le compte utilisateur créé à l'installation ne reçoit les privilèges sudo que si on n'a pas défini de mot de passe root. Pour avoir à la fois un mot de passe root et un compte sudo, il faut au choix :
- installer sans définir de mot de passe root et en créer un après l'installation avec sudo passwd
- ou installer en définissant un mot de passe root puis accorder les privilèges sudo à l'utilisateur normal après l'installation (après avoir installé sudo le cas échéant).

As-tu fait l'un ou l'autre ? Sinon, tu n'as pas de mot de passe root.

Dernière modification par raleur (13-01-2019 15:25:23)

Hors ligne

#9 13-01-2019 15:37:28

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

$ wc -l /etc/passwd
44 /etc/passwd

oui j'ai bien un MDP root qui est yole et qui fonctionnait avec sudo

en tapant sudo ou su dans un terminal puis le mot de passe yole à l'invite de commande tout était ok pour devenir root

peu importe de croire ou ne pas croire mais comment récupérer sudo
visudo est bon?

Dernière modification par yole1 (13-01-2019 15:42:08)

Hors ligne

#10 13-01-2019 16:20:17

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [resolu]perte des droits sur utilisateur admin

bonjour yole1  big_smile

pour sudo , une fois installé , reste à faire

adduser yole sudo


pour ajouter l'utilisateur "yole" au groupe "sudo"



puis redémarrer

et enfin tester avec , par exemple ,

sudo apt update


normalement rien à signaler , l'update doit se faire tout seul

Dernière modification par Debian Alain (13-01-2019 16:21:35)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#11 13-01-2019 16:26:10

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

J'y avais pensé effectivement ca devrait être bon pour retrouver sudo avec yole

edit
L'utilisateur « yole » appartient déjà au groupe « sudo ».

Sinon j'ai recrée un utilisateur nouveau puis avec les droits root et c'est pareil il ne fonctionne pas dans le terminal

Dernière modification par yole1 (13-01-2019 16:31:43)

Hors ligne

#12 13-01-2019 16:45:14

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

oui j'ai bien un MDP root qui est yole et qui fonctionnait avec sudo


Non, tu mélanges tout. Tu as un mot de passe de yole qui fonctionne avec sudo. Le mot de passe de root ne fonctionnerait pas avec sudo. Si le mot de passe ne fonctionne pas avec su, ce n'est pas le mot de passe de root.

yole1 a écrit :

peu importe de croire ou ne pas croire mais comment récupérer sudo


Il n'est pas question de croire ou ne pas croire mais de savoir.
Il n'y a rien à récupérer. sudo fonctionne avec le mot de passe de yole, c'est ainsi qu'il doit fonctionner.
Si tu veux définir le mot de passe de root pour l'utiliser avec su, tu peux utiliser

sudo passwd

Hors ligne

#13 13-01-2019 19:45:00

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

Avant je tapais en user, sudo en ligne de commande et quand j'entrais le mot de passe à l'aveugle "yole" je retrouvais le # au prompt.
Idem avec su.

Plus maintenant pourquoi?juste me dire les lignes de commandes à faire pour fonctionner en tapant su ou bien sudo pour être en root dans le terminal.

sudo su ça marche
yole@yole-SATELLITE-P500:~$ sudo su
[sudo] Mot de passe de yole :
root@yole-SATELLITE:/home/yole#

Dernière modification par yole1 (13-01-2019 19:54:07)

Hors ligne

#14 13-01-2019 19:54:02

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [resolu]perte des droits sur utilisateur admin

Bonjour
Je ne veux pas mettre de l'huile sur le feu ...mais message #3

yole1 a écrit :

oui c'est bon
~$ sudo -i
[sudo] Mot de passe de yole :
root@yole-SATELLITE:~#


on ne peux te venir en aide si tu postes des messages contradictoire

Edit: si tu fais

sudo apt update


il se passe quoi?

Dernière modification par Croutons (13-01-2019 19:55:56)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#15 13-01-2019 19:56:54

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

J'avoue que je ne comprends pas les interventions pour venir en aide.

Est-ce que c'est posssible de taper sudo puis entrer le mot de passe et se trouver en root comme çi-dessous?si oui comment faire.

$ sudo
[sudo] Mot de passe de yole :
root@yole-SATELLITE:/home/yole#



parce-que [sudo] donne ça

yole@yole-SATELLITE:~$ sudo
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
            [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-T timeout] [-u user] file ...

Dernière modification par yole1 (13-01-2019 20:01:33)

Hors ligne

#16 13-01-2019 20:04:21

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [resolu]perte des droits sur utilisateur admin

oui tu as déja eu la réponse mainte fois dans ton poste
La commande attend autre chose dérrière

sudo -i


Ton prompt change et tu reste en root

sudo tacommande

...seul la commande derriére sudo est en root et tu as le prompte user $


je comprend pas le soucis, c'est le -i que tu trouve trop long , cela fait 2 touches a appuyer
au pire tu peux te créer un alias

Dernière modification par Croutons (13-01-2019 20:09:06)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#17 13-01-2019 20:11:55

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

Est-ce que c'est posssible de taper sudo puis entrer le mot de passe et se trouver en root comme çi-dessous?


Non. Tu le vois bien quand tu essaies : sudo demande des arguments, comme -i ou -s pour lancer un shell root ou une commande pour la lancer en root.

yole1 a écrit :

sudo su ça marche


Mais ça ne sert à rien, c'est idiot. On obtient le même résultat avec sudo -s ou -i.

Hors ligne

#18 13-01-2019 20:16:01

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

le -i ne gêne pas ce n'est pas trop long mais j'aurais souhaité pouvoir faire fonctionner ce PC comme le deuxième
après j'ai bien compris que sudo -i permet root puisque c'est le message #2 de Beta-Pictoris
c'est pas grave je ferais sudo -i ou sudo su et il faudra juste informer les autres utilisateurs physique de cette différence pour l'utilisation du PC

Edit
Non. Tu le vois bien quand tu essaies : sudo demande des arguments, comme -i ou -s pour lancer un shell root ou une commande pour la lancer en root.
J'ai bien compris faut pas pousser mémé dans les orties
Merci je passe en résolu

Dernière modification par yole1 (13-01-2019 20:20:09)

Hors ligne

#19 13-01-2019 20:19:55

raleur
Membre
Inscription : 03-10-2014

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

j'aurais souhaité pouvoir faire fonctionner ce PC comme le deuxième


C'est-à-dire ? Utiliser sudo tout seul ? Ce n'est pas possible, il ne s'utilise pas comme ça.
Le deuxième quoi ?

Hors ligne

#20 13-01-2019 20:24:51

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

merci raleur je passe en résolu c'est pas essentiel

Hors ligne

#21 13-01-2019 21:10:24

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : [resolu]perte des droits sur utilisateur admin

je crois que tu dois être fatigué , yole1 ;  big_smile

tu te mélange les pinceaux .  lol

retiens ceci :  tongue

pour passer en root , il y a 2 solutions :  cool

su -    (+  M.D.P. root)


sudo -i (+ M.D.P. user)



pour passer une commande en root tout en restant user :  cool

sudo <commande> (+ M.D.P. user)



Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

Dernière modification par Debian Alain (13-01-2019 21:20:41)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#22 20-01-2019 13:51:55

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

je ne suis plus la conversation mais ayant utilisé timeshift et ayant rétrogradé le sudo n'e'st plus un problème mais ayant touché à pas mal de choses il est probable que je me sois emméles les pinceaux dans une propre logique et sur ubuntu

Hors ligne

#23 09-02-2019 15:40:05

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

ça recommence cette fois-çi tout le Home est passé en mode root après avoir tenté d'ouvrir /usr/lib/gvfs/gvfsd-network.
Mais celà n'a peut-être pas de rapport car au reboot c'est page noire avec initframs
su -
ça fonctionnait ce matin pour être root et maintenant non
il faut su - i
pour être root
et puis deux fois il a fallut passer la commande e2fsck /dev/sda1 pour trouver un système fonctionnel puis rétrograder de noyau

Timeshift devrait sauver la mise...

Dernière modification par yole1 (09-02-2019 15:41:18)

Hors ligne

#24 09-02-2019 16:12:10

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [resolu]perte des droits sur utilisateur admin

yole1 a écrit :

il faut su - i


Un peu de lecture technique s'impose on dirait. wink
Voici les deux tutos traitant chacun de la commande su et de la commande sudo :
https://debian-facile.org/doc:systeme:su
https://debian-facile.org/doc:systeme:sudo

Et peut-être cette page-ci :
https://debian-facile.org/doc:systeme:superutilisateur

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#25 09-02-2019 16:34:24

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : [resolu]perte des droits sur utilisateur admin

Merci pour la lecture.
Mais
su - pour passer root était possible ou su uniquement et un mot de passe root qui est le même que celui de l'utilisateur par ailleurs.
La commande ne fonctionne plus, elle fonctionnait.

Dernière modification par yole1 (09-02-2019 16:41:08)

Hors ligne

Pied de page des forums