Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-01-2019 10:22:29

autrekrikri
Membre
Distrib. : Debian 9
Noyau : Linux 4.9.0-8-amd64
(G)UI : wmii
Inscription : 26-01-2016

[résolu]debian 9 et vieux conkyrc

Bonjour à tous,
suite à quelques problèmes de stabilité sur ma vieille debian, j'ai décidé de faire une installation propre.
Jusque là, tout va bien.
Par contre, lors du lancement de conky, en console chez moi, j'ai des retour bizarres :

conky: Syntax error (/home/pitou/.conkyrc:2: unexpected symbol near '#') while reading config file.
conky: Assuming it's in old syntax and attempting conversion.
conky: desktop window (28b) is root window
conky: drawing to desktop window
 



Il me manque donc des "trucs" et la mise à jour de conky est trèèèèès lente, à peu près toutes les 50s voir quelques minutes ...

Voici mon conkyrc

# Paramètres de la fenêtre
#own_window no
#own_window_type normal
#own_window_type desktop
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
#own_window_type override
#own_window_argb_visual yes
#own_window_argb_value 100
# undecorated
#own_window_transparent yes
#alignment top_right
out_to_console yes
#background no
#gap_x 10
#gap_y 55

# Paramètres de la police
#use_xft yes
#xftfont Arial:size=16
#override_utf8_locale yes

# Paramètres de configuration
update_interval 1
# double_buffer yes

# Nombre d'échantillons
cpu_avg_samples 4
net_avg_samples 4

TEXT
Uptime : $uptime  CPU Total : ${cpu cpu0}%
#${time %H:%M}

#CPU Total : ${cpu cpu0}%
#${cpugraph cpu0 50,250}
#CPU Core :
#1 : ${cpubar cpu1 10,200} ${cpu cpu1}%
CPU Core :1 :${cpu cpu1}% 2 :${cpu cpu2}%  3 :${cpu cpu3}%   4 :${cpu cpu4}%
#2 : ${cpubar cpu2 10,200} ${cpu cpu2}%
#2 : ${cpu cpu2}%
#3 : ${cpubar cpu3 10,200} ${cpu cpu3}%
#3 : ${cpu cpu3}%
#4 : ${cpubar cpu4 10,200} ${cpu cpu4}%
#4 : ${cpu cpu4}%
RAM : $mem / $memmax ($memperc%)
#${membar 10,250}

#Activitée HDD : ${diskio /dev/sda}
#${diskiograph /dev/sda 50,250}
Linux : ${fs_used /} / ${fs_size /} (${fs_used_perc /}%)
#${fs_bar 10,250 /}

#CPU1:${hwmon 1 temp 1}°C  CPU2:${hwmon 1 temp 2}°C  CPU3:${hwmon 1 temp 3}°C  CPU4:${hwmon 1 temp 4}°C
#Température CPU 2 : ${hwmon 1 temp 2}°C
#Température CPU 3 : ${hwmon 1 temp 3}°C
#Température CPU 4 : ${hwmon 1 temp 4}°C
Température GPU   : ${exec nvidia-settings -q GPUCoreTemp -t| head -n1}°C
#Température GPU   : ${exec nvidia-settings -q gpucoretemp | grep '):' | awk '{print $4}'}°C
#${execi 60 nvidia-settings -query GPUCoreTemp | perl -ne 'print $1 if /GPUCoreTemp.*?: (\d+)./;'}°C
#Température HDD : ${hddtemp /dev/sda1}°C

Down : ${downspeedf eth1}Ko/s     Up : ${upspeedf eth1}Ko/s
#${downspeedgraph eth0D 50,250}
#Upload : ${upspeedf eth1}Ko/s ($totalup)
#${upspeedgraph eth0 50,250}



Merci d'avance.
P.S. si je ne suis pas à la bonne place, merci au modérateur de faire ce qu'il faut :-)

Edit à toto : Mis au clair l'utilisation du BBCode sur le forum avec le bouton Autre code plutôt que Commande user.

Dernière modification par autrekrikri (20-01-2019 22:03:53)

Hors ligne

#2 20-01-2019 13:21:22

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.2.0-3-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : [résolu]debian 9 et vieux conkyrc

Salut!

Pour les retours, sur les deux premières lignes, conky te prévient juste que sa syntaxe à changée,
tu peux jeter un œil à la nouvelle syntaxe sur le répertoire officiel : https://github.com/brndnmtthws/conky/wiki
Cependant, il reconnaît très bien l'ancienne et peut parfaitement la gérer (dans la plus part des cas).

Chez moi ton conkyrc se lance parfaitement et se met à jour toute les secondes. (Je n'ai pas pu tester la commande nvidia-setting)

essaie de voir si l'une des commandes ralenti l’exécution en les activant une à une,
ou voir si l'ordinateur est globalement ralenti.
Tu peux préciser ta configuration pour nous aider à mieux identifier le problème.

Dernière modification par David5647 (20-01-2019 13:24:01)

Hors ligne

#3 20-01-2019 14:55:52

autrekrikri
Membre
Distrib. : Debian 9
Noyau : Linux 4.9.0-8-amd64
(G)UI : wmii
Inscription : 26-01-2016

Re : [résolu]debian 9 et vieux conkyrc

David5647 a écrit :

Salut!

Pour les retours, sur les deux premières lignes, conky te prévient juste que sa syntaxe à changée,
tu peux jeter un œil à la nouvelle syntaxe sur le répertoire officiel : https://github.com/brndnmtthws/conky/wiki
Cependant, il reconnaît très bien l'ancienne et peut parfaitement la gérer (dans la plus part des cas).

Chez moi ton conkyrc se lance parfaitement et se met à jour toute les secondes. (Je n'ai pas pu tester la commande nvidia-setting)

essaie de voir si l'une des commandes ralenti l’exécution en les activant une à une,
ou voir si l'ordinateur est globalement ralenti.
Tu peux préciser ta configuration pour nous aider à mieux identifier le problème.


Bonjour,
et merci de ta réponse.
En effet, le conky "fonctionne" mais plus comme avant : il ne s'affiche plus dans la console où je le lance, mais sur le bureau, ce qui ne m'arrange pas :-)
Ainsi, il ne se met plus à jour dans la console mais sur le bureau...
Comme j'utilise wmii, le bureau est tout le temps caché ...
Je ne vois pas comment remettre le conky qu'en console.

Edit : après une petite recherche, avec un "out_to_x no"
le premier problème est réglé, il ne reste plus qu'à sortir les températures des processeurs et des disques durs car ceci ne semble plus fonctionner :

CPU1:${hwmon 1 temp 1}°C  CPU2:${hwmon 1 temp 2}°C  CPU3:${hwmon 1 temp 3}°C  CPU4:${hwmon 1 temp 4}°C


Oh, et sensors est bien installé et fonctionne :

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +38.0°C  (high = +80.0°C, crit = +98.0°C)
Core 0:         +32.0°C  (high = +80.0°C, crit = +98.0°C)
Core 1:         +37.0°C  (high = +80.0°C, crit = +98.0°C)
Core 2:         +35.0°C  (high = +80.0°C, crit = +98.0°C)
Core 3:         +37.0°C  (high = +80.0°C, crit = +98.0°C)
 

Dernière modification par autrekrikri (20-01-2019 15:06:34)

Hors ligne

#4 20-01-2019 22:03:19

autrekrikri
Membre
Distrib. : Debian 9
Noyau : Linux 4.9.0-8-amd64
(G)UI : wmii
Inscription : 26-01-2016

Re : [résolu]debian 9 et vieux conkyrc

Bon, ben trouvé je colle ça ici des fois que ça puisse aider quelqu'un

out_to_x no
out_to_console yes

update_interval 1
# double_buffer yes

# Nombre d'échantillons
cpu_avg_samples 4
net_avg_samples 4

TEXT
Uptime : $uptime  CPU Total : ${cpu cpu0}%

CPU Core :1 :${cpu cpu1}% 2 :${cpu cpu2}%  3 :${cpu cpu3}%   4 :${cpu cpu4}%
RAM : $mem / $memmax ($memperc%)
Linux : ${fs_used /} / ${fs_size /} (${fs_used_perc /}%)
${execi 60 sensors | grep temp2 | cut -c15-16}
#CPU1:${hwmon 1 temp 1}°C  CPU2:${hwmon 1 temp 2}°C  CPU3:${hwmon 1 temp 3}°C  CPU4:${hwmon 1 temp 4}°C
CPU1: ${execpi 30 cat /sys/devices/platform/coretemp.0/hwmon/hwmon0/temp1_input|cut -b1-2}°C  CPU2: ${execpi 30 cat /sys/devices/platform/coretemp.0/hwmon/hwmon0/temp2_input|cut -b1-2}°C  CPU3: ${execpi 30 cat /sys/devices/platform/coretemp.0/hwmon/hwmon0/temp3_input|cut -b1-2}°C  CPU4: ${execpi 30 cat /sys/devices/platform/coretemp.0/hwmon/hwmon0/temp4_input|cut -b1-2}°C
#CPU1:${hwmon 1 temp 1}°C  CPU2:${hwmon 1 temp 2}°C  CPU3:${hwmon 1 temp 3}°C  CPU4:${hwmon 1 temp 4}°C
#Température CPU 2 : ${hwmon 1 temp 2}°C
#Température CPU 3 : ${hwmon 1 temp 3}°C
#Température CPU 4 : ${hwmon 1 temp 4}°C
Température GPU   : ${exec nvidia-settings -q GPUCoreTemp -t| head -n1}°C
#Température GPU   : ${exec nvidia-settings -q gpucoretemp | grep '):' | awk '{print $4}'}°C
#${execi 60 nvidia-settings -query GPUCoreTemp | perl -ne 'print $1 if /GPUCoreTemp.*?: (\d+)./;'}°C
#Température HDD : ${hddtemp /dev/sdc}°C

Down : ${downspeedf eth1}Ko/s     Up : ${upspeedf eth1}Ko/s
 

Hors ligne

Pied de page des forums