Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 02-02-2019 13:42:57

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : Quelle carte graphique utiliser ? [résolu]

Je suis perdue aussi avec debianun et bis tongue
La Nvidia n’est pas mise à la place de la Radeon sur le vieux PC ?

statis a écrit :

message du nom du truc à installer


(suis sur mon PC Fedora donc aucune capture)


Ça fait deux trois lignes, tu aurais pu les recopier ou les prendre en photo car ce que tu fais ensuite me laisse perplexe scratchhead.gif
Tu installes à la fois nvidia-legacy-304xx-driver et nvidia-driver. Normalement c’est un seul paquet à installer
Il faudrait que sur ce PC tu nous donnes le retour de

lspci -nnk | grep -iA3 vga

Hors ligne

#27 02-02-2019 14:15:25

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Quelle carte graphique utiliser ? [résolu]

Bonjour

le serveur X gère tous les drivers nonfree proposé par debian sur stretch par exemple (sinon ils sont retirés des dépôts )
il faut uniquement le paquet nvidia-driver (qui porte un autre nom en version legacy" et commencé en simulation avec "-s"
installer les headers avant pour éviter les problèmes .

mais déjà que donne cette carte avec le driver libre nouveau ?

utiliser l' utilitaire "nvidia-detect" pour la version du driver a utiliser.
quelques conseils en vrac roll

Hors ligne

#28 02-02-2019 14:37:24

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Quelle carte graphique utiliser ? [résolu]

Alors stretch te propose 3 drivers

nvidia
nvidia-legacy-340xx
nvidia-legacy-304xx

par exemple pour le 304 une commande du genre (en simulation)


apt-get -s install nvidia-legacy-304-driver
 



ps: normalement il n'y a pas besoin de xorg.conf , et le driver est modifié pour fonctionner avec la version du serveur X de stretch
sur une installation propre en 5 minutes c'est fait

cette commande doit appeler toutes les dépendances nécessaires a vérifier avec la simulation si besoin

Hors ligne

#29 02-02-2019 18:26:23

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

Merci chalu,

Debian9Un est le disque de départ quand je suis arrivé sur le forum et qui t'a demandé pas mal de boulot d'aide...
Debian9Bis est un deuxième disque monté à partir d'une netinstall sur CD.
D9Un était en SDA dans un emplacement de la tour.
D9Bis en SDB via un rack qui permet de mettre et enlever un disque https://www.ldlc.com/fiche/PB00038291.html
C'est grace à ce rack que j'ai pu installer et essayer différente distribution.

Problème, Ubuntu 18 installé en SDB sur el rack, a touché à D9Un en SDA et a cassé son Grub...
Dans la nuit j'ai récupéré ce disque pour installer un W10.

L'installation des trucs Nvidia a rendu D9Bis inutilisable avec un kernel erreur.

C'est en suivant le wiki que j'ai installé nvdia-driver, quand j'ai dit qu'il n'était pas clair pour moi, effectivement s'il fallait installer uniquement "nvidia-legacy-304xx-driver" je ne l'ai pas compris..

La à l'intant T j'ai viré la GeForce (qui était en place) et re-tente une net-install.
Pareil que l'autre fois, 1 heure à partir du choix d'installation de logiciels pour arriver à un message d'erreur qui dit que les logiciels n'ont pu être installés (avec ftp.debian.org qui répondait cette fois-ci).
J'ai relancé le truc, toujours avec le FTP debian.org car aucune garantie que les autres serveurs soient réellement bien dupliqués, et on verra...
Concernant les serveurs FTP, chaque "demandeur" a un chemin dépendant de son provider, le mien (SFR) est moisi

Saut  Nom d'hôte Adresse IP  Temps 1
1 _gateway  192.168.1.254 1.172
1 _gateway  192.168.1.254 0.953
2 _gateway  192.168.1.254 1.032
2 06men1-r0b0-0.dip.gaoland.net 84.96.165.226 49.226
3 65.171.96.84.rev.sfr.net  84.96.171.65  48.770
4 53.171.96.84.rev.sfr.net  84.96.171.53  48.659
5 37.171.96.84.rev.sfr.net  84.96.171.37  48.663
6 v4071.par1-co-2.n9uf.net  62.39.148.94  49.157
7 22.128.136.77.rev.sfr.net 77.136.128.22 52.894
8 v3555.snz1-sec-2.gaoland.net  84.96.244.198 64.045
9 94.10.136.77.rev.sfr.net  77.136.10.94  64.060
10  ae2.jnr02.Asd002A.surf.net  80.249.208.34 72.858
11  utwente-router.customer.surf.net  145.145.4.46  83.328
12  klecker2.snt.utwente.nl 130.89.148.12 77.122


A l'instant T le traceroute paraît donner de pas trop mauvais temps mais avec d'autres outils que ceux sur Linux il serait possible de voir que certains nœuds intermédiaires ont des temps de réponse qui font planter les requêtes FTP et s'il y a un échec de chargement l'installateur va être perturbé, c'est pou cela que je n'était pas passé par ftp.debian.org mais cette fois-ci pas question que j'utilise un autre serveur !!!
Et bien sur cela va demander un temps de fou d'arriver à "tout charger d'un coup".
Normalement sur internet quand on doit charger un package via un FTP et qu'il y a un échec, la procédure doit tenter de récupérer les fichiers manquants et non repartir à 0...
Bien sur tout comme pour les machines, nos gentils créateur de "systèmes libres" pensent que nous avons tous de la fibre.
Quand on a les moyens, on peut prétendre à la liberté...
Et pourtant il y a bien plus de personnes que l'on peut croire qui ont encore des machines bien plus vieilles que la mienne, ainsi que beaucoup d'autres qui ont des accès internet à moins de 6mégas...

Tout refaire et encore refaire...
C'est pour çà que j'avais tellement insisté sur l'importance de cloner un disque...
C'est plus facile de cloner un disque que de refaire installation sur installation.

Je reviendrais quand j'aurais un stock de clones "à casser"...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#30 02-02-2019 19:18:28

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

je lui ai expliqué la procédure à suivre … il a pas suivi
je peux plus rien à ce niveau

rG2wVBb.jpg

Dernière modification par TechDesk (02-02-2019 19:51:09)


Le matériel c'est pas éternel

Hors ligne

#31 02-02-2019 19:25:12

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

robert2a a écrit :

Bonjour

le serveur X gère tous les drivers nonfree proposé par debian sur stretch par exemple (sinon ils sont retirés des dépôts )
il faut uniquement le paquet nvidia-driver (qui porte un autre nom en version legacy" et commencé en simulation avec "-s"
installer les headers avant pour éviter les problèmes .

mais déjà que donne cette carte avec le driver libre nouveau ?

utiliser l' utilitaire "nvidia-detect" pour la version du driver a utiliser.
quelques conseils en vrac roll



pas besoin de nvidia-detect, j'ai fais les recherches nécessaires pour savoir quel pilote exactement il fallait installer


Le matériel c'est pas éternel

Hors ligne

#32 02-02-2019 19:56:56

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Quelle carte graphique utiliser ? [résolu]

Bonsoir

nvidia-xconfig est déprécié , ne plus l'utiliser
le xorg.conf n'est plus utile sur un serveur X récent (sauf dans le cas d une config spécifique , et il y a un utilitaire graphique (nvidia-settings) ou manuellement  )

Hors ligne

#33 02-02-2019 19:59:37

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

en effet, mais je n'ai fais que reporter ce que dis le wiki,
je pense qu'une modification de cette partie est nécessaire

Le matériel c'est pas éternel

Hors ligne

#34 02-02-2019 21:03:27

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

merci à tous,

Ce n'est pas que je ne suis pas...
Quand un OS ne démarre plus, il démarre plus voir #19 quand je dis inutilisable je pense avoir assez précisé...
Cette fois-ci je n'ai pas dit tel ou tel soft ne fonctionne plus mais disque inutilisable !
Donc à moins d'avoir un ingénieur à la maison pour "réparer", c'est ré-installation.
Là je n'en suis plus à vouloir installer le bon driver mais à essayer d'installer le système via le ftp.debian.org avec une connexion internet pourrie.
J'en suis à la 3eme tentative qui me reporte en finalité à chaque fois au stade "partitionner le disque" puisque l'installateur n'est pas capable de voir les fichiers qu'il n'a pu charger et d'esayer de les récupérer au lieu d'obliger à tout recommencer.
Et tant que je n'ai pas un OS qui démarre JE NE PEUX FAIRE AUCUNE DE VOS MANIPULATIIONS QUI DEJA ME PERDENT AVANT MEME D'AVOIR COMMENCE...
J'explique tout mais c'est vrai que je suis dur à lire...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#35 02-02-2019 21:24:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Quelle carte graphique utiliser ? [résolu]

perso , statis , j'affectionne AMD .

les pilotes par défaut fonctionnent bien et c'est beaucoup moins compliqué à mettre en place que N.VIDIA et ses pilotes propriétaires .

enfin , tu me dira , y a le pilote "NOUVEAU" pour N.VIDIA , par défaut .

il est basique mais il fonctionne bien sur certaines machines .

je te laisse choisir .

voilà mon avis et ma réponse à ta question "Quelle carte graphique utiliser ?"

maintenant faut savoir que chez AMD , faut faire gaffe aux cartes trop récentes : souvent problématiques .
non pas la carte mais la prise en charge logicielle  par défaut (pilotes, drivers) ...
souvent ceux ci ne sont pas prêts à temps .

En ligne

#36 02-02-2019 21:31:11

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

si tout le monde se contredit on va pas y arriver ...

Le matériel c'est pas éternel

Hors ligne

#37 02-02-2019 21:36:05

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Quelle carte graphique utiliser ? [résolu]

je contredis qui , TechDesk ?

je ne fais que donner mon avis .

en espérant recentrer une discussion qui part un peu dans tous les sens ...

je me trompe ?

j'ai mal agi ?

j'aurai dû fermer ma grande gu***** et laisser dériver la discussion ?

Dernière modification par Debian Alain (03-02-2019 10:38:49)

En ligne

#38 02-02-2019 23:13:03

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

merci Debian Alain,

Ton apport était tout à fait justifiée car effectivement le sujet de départ est

Quelle carte graphique utiliser ?



En cours de sujet je suis passé de la Radeon x1950 à la GeForce 7300GT en "essai" ce qui reste dans le sujet malgré que cela fasse un détour sur de la résolution de problème.

A ce stade du sujet il y a dans la recherche d'une carte graphique du AMD vs Nvidia et c'est normal que chacun ait une préférence.
L'expert aura peut-être une préférence pour la Nvidia mais cela demande un niveau de Linux bien "pointu".
Le "qui veut pas se prendre la tête" optera pour une AMD et je comprend cette position.

Le sujet a effectivement dérivé parce que dans mon cas, je répète bien DANS MON CAS, la Nividia de test m'a emmené en galère.
J'ai dormi 2 heures cette nuit, il est 23h00 et je n'ai pas encore dîné.
Après avoir essayé x serveurs (avec à chaque fois un retour par la case départ) pour ré-installer mon Debian, cela ne vient de se finaliser que maintenant sur la Radéon que je voulais changer.
Ré-installation que j'ai du faire car n'étant pas expert et incapable de suivre un wiki pour les non-nuls mon OS est mort suite aux manipulations qu j'ai faites pour essayer d'activer une Nvidia.
Contre une Radeon x1950 Pro sur laquelle tous mes softs tournent sauf que "Flashprint" clignote quand on bouge les objets 3D.
Cela m'a coûté trop de temps et ce n'est pas fini car il faut que j'installe une enième fois tous les softs dont j'ai besoin sur mon nouveau disque Debian...

Dernière modification par statis (02-02-2019 23:16:02)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#39 03-02-2019 00:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : Quelle carte graphique utiliser ? [résolu]

Bon{soir|ne nuit|jour},

en #27, robert2a a écrit :

mais déjà que donne cette carte [GeForce 7300 GT] avec le pilote libre nouveau ?

en #34, statis a écrit :

je n'en suis plus à vouloir installer le bon pilote mais à essayer d'installer le système [...].


Vu... je poste malgré tout un retour concernant la GeForce GT 610 (2012), sur un PC fixe de 2007.
Il est à noter que la GeForce GT 610, de la famille NVC0 (Fermi), est une GT 520 (2011) rebrandée !


Pas eu la nausée ni la rétine arrachée... pas de projet 3D, non plus ; Debian 9 GNOME et nouveau :

glxinfo -B

name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NVD9 (0x104a)
    Version: 13.0.6
    Accelerated: yes
    Video memory: 1013MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVD9
OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
 


La prise en charge de la 7300 GT (2006), famille NV40, sera inférieure (cf. freedesktop.org, ici et ).
Bref, n'hésite pas à tester une petite carte GF100 ou supérieure (un bond technologique de 5 ans).

Une petite carte Radeon contemporaine de la GT 520, la HD 6450 (Caicos) mais je ne l'ai pas testée.

Hors ligne

#40 03-02-2019 00:40:45

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

c'est complètement faux, car une avec une vielle ati il te faudra une version de xorg antérieure, alors qu'avec une nvidia non, beaucoup plus simple et j'ai indiqué toute la procédure et démarche d'installation

Le matériel c'est pas éternel

Hors ligne

#41 03-02-2019 02:15:27

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

Merci beaucoup èfpé,

Avoir testé mes deux softs sur ta carte c'est vraiment sympa car cela indique que je n'aurais pas de problème de ce côté là avec la GeForce GT 610.
En plus on en trouve encore des neuves à un prix très abordable.
Je ne peux mettre trop d'argent sur ce vieux PC car il commence à me faire des problèmes sur les ports SATA (heureusement il y en a 4).

Comme je suis un têtu, je suis en train d'installer encore Debian sur un nouveau disque mais cette fois-ci avec la GeForce GT7300 montée.
Cela va plus vite car maintenant je sais quel serveur utiliser pour la "net-install" wink
Peut-être avec un peu de chance je pourrais dormir un peu cette nuit...

Merci TechDesk,
La procédure https://wiki.debian.org/fr/NvidiaGraphi … anciens.29 est comme le wiki https://debian-facile.org/doc:materiel: … ia:accueil communiqué par chalu, c'est à dire pour les non-nuls...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#42 03-02-2019 03:33:36

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

Bon après install sur nouveau disque avec Geforce montée, galère pour activer le non-free, activation du firmware legacy et redémarrage

lspci -nnk | grep -iA3 vga


01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G73 [GeForce 7300 GT] [10de:0393] (rev a1)
  Kernel driver in use: nvidia
  Kernel modules: nvidia
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8132 Fast Ethernet [1969:1062] (rev c0)
 


Il s'est passé quelque chose car flashprint se lançait mais il manquait des éléments (les boutons de travail) et avec le legacy plus rien il ne s'ouvre même pas...

YENAMARRE, je vais me coucher bien énervé...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#43 03-02-2019 07:33:24

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

as-tu regardé ce que requiert flashprint en caractéristiques techniques matérielles ?
j'ai fais une recherche vite fait et visiblement l'OpenGL en est une
et ta carte semble trop vieille
https://groups.google.com/forum/#!topic … wZqZzNTmrg

Dernière modification par TechDesk (03-02-2019 08:07:46)


Le matériel c'est pas éternel

Hors ligne

#44 03-02-2019 09:51:01

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Quelle carte graphique utiliser ? [résolu]

ton programme flashprint , statis , il est pas  chinois ? 
tu as posé la question pour trouver un (des) remplaçant(s) ?
je crois que ça existe .

tu as ausi -- makerbot -- mais je sais pas ce qu'il vaut .

-- 24 logiciels 3D --

Dernière modification par Debian Alain (03-02-2019 10:24:01)

En ligne

#45 03-02-2019 14:13:55

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

c'est dommage, j'avais une GeForce GT520 en stock y'a pas longtemps, mais vendue, elle avait l'OpenGL 4, avec ça t'aurais pu avancer
il me reste une ATI Radeon HD4350, mais c'est de l'OpenGL 2.0 aussi, donc ça n'avancera en rien sur le problème je crains
ce que je peux faire de mon côté, c'est un test, j'installe debian sur une machine avec cette carte et on voit ce que ça donne smile
ça te va ?

Dernière modification par TechDesk (03-02-2019 14:16:33)


Le matériel c'est pas éternel

Hors ligne

#46 03-02-2019 14:22:55

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Quelle carte graphique utiliser ? [résolu]

j'ai failli avoir deux  RX550 (AMD) (open CL) mais c'est trop tard .

https://www.materiel.net/produit/201703280401.html

RX550 prix Materiel.NEt

Dernière modification par Debian Alain (03-02-2019 14:26:16)

En ligne

#47 03-02-2019 14:41:17

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

merci TechDesk,

Oui c'est certainement un problème OpenGl côté drivers et OS, aussi bien pour la Radeon x1950 Pro que pour la GeForce 7300GT.
Les deux cartes sont OpenGl2.0 et le soft Flashprint est compatible 2.0/2.1

You need to check out your video drivers. Flashprint uses OpenGL and needs at least 2.0 or 2.1


Quand j'ai monté Debian9 avec le noyeau 4.0.x Flashprint fonctionnait sur la Radeon c'est d'ailleurs la compatibilité avec ce soft qui m'a fait m'investir sur cet OS.
C'est le bogue rencontré avec Kisslicer qui m'a lancé dans l'aventure d'essayer une nouvelle carte graphique pendant que l'OS montait en version de noyeau.
Avec Ubuntu 16.04 "avant mises à jour obligatoires" les deux softs fonctionnaient correctement avec la GPU intégrée (Intel GMA X4500).
Un OS qui se prétend libre devrait pouvoir laisser la liberté d'utilsier du vieux matériel sinon c'est du Windows ou du MacDevil mais c'est un autre sujet...

Je sais que le sujet est long mais comme dit en étape intermédiaire la 7300GT était un test qui m'a d'ailleurs permis de voir la galère que représente un changement de carte graphique pour un non-expert...

La GeForce GT610 indiquée par èfpé ne rencontrera pas de problème OpenGL (sera aussi compatible w10).
https://www.geforce.com/hardware/deskto … ifications

A ce stade du sujet "quelle carte graphique utiliser" il faudrait une deuxième question en en-tête "et comment nettoyer l'OS des traces d'installation de l'ancienne carte".

Merci Debian Alain,
J'aurais aimé pouvoir utiliser MakerBot car dans ses profils (vu sur Windows) il est possible d'adapter le tranchage (opération de conversion objet 3D en couches d'impression) pour que le GCode (commandes machine) corresponde aux capacités de l'imprimante, exemple si on lance un déplacement de 0.123mm et que la résolution est de 0.021mm pas besoin de sortir d'une grande école pour voir que cela ne sera pas au top. Avec une résolution de 0.01mm (peut d'imprimantes grand public ont une résolution métrique, c'est un autre problème que j'ai pu résoudre sur la mienne en kit), si le trancheur travaille en concordance la qualité d'impression est déjà meilleure.
Mais Makerbot n'est pas compatible Linux et sur Windows n'est pas compatible avec ma Flashforge Dreamer.

La Flashforge Dreamer n'est pas une imprimante "libre", quand on achète une machine on ne sait pas tout et on peut avoir de mauvaises surprises.
Cette imprimante ne fonctionne qu'avec le soft propriétaire ou Simplify3D...
Simplify3D est un soft "adulé" par beaucoup d'utilisateurs d'imprimante 3D mais il est trop cher et pas si génial que çà sur une Dreamer, j'ai beaucoup regretté son achat.

Le lien sur les logiciels d'impression 3D est incomplet.
Il manque par exemple IdeaMaker (une même pièce tranchée ratée avec Simplify3D à 150 euros alors que réussie avec ce soft en version gratuite qui tourne bien sur toutes mes cartes graphiques et tous les versions de noyeau) et Crafware (pas pu l'installer sur Ubuntu masi serait intéressant).
J'aurais aimé essayer IceSL mais je n'ai pu l'installer sur Ubuntu à l'époque...
L'impression 3D c'est comme Linux, beaucoup d'informations mais pas toujours utilisables pour les "non-initiés".

Voilà après cette pause "impression 3D", retour au sujet car la mise en place d'une carte graphique peut introduire une autre question "que faire si on a fait un mauvais choix de carte graphique ?".
Le flemmard serais tenté de dire "tant pis, il faut en acheter une autre".
Je vais encore perdre du temps pour voir s'il y a une solution pour contourner la version d'OS.
Et il se trouve que Flashforge laisse à disposition les plus vieilles versions de Flashprint.
Comme c'est des chinois (et oui Debian Alain on est loin de l'art de la dynastie Ming) leurs différentes versions n'apportent pas grand chose de l'une à l'autre donc si une "vieille" tourne cela peut dépanner le temps de galérer pour mettre en place une nouvelle carte graphique wink


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#48 03-02-2019 14:49:38

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : Quelle carte graphique utiliser ? [résolu]

pour ce qui est du nettoyage logiciel, il suffit de désinstaller ce qui a été installé tout simplement

Le matériel c'est pas éternel

Hors ligne

#49 03-02-2019 14:59:55

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Linux deb64 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : Quelle carte graphique utiliser ? [résolu]

merci TechDesk,

Evident pour toi mais pas pour moi, si le paquet installe d'autres paquets mon cerveau n'est pas assez rapide et n'a pas assez de capacité de mémorisation pour me souvenir lesquels enlever par la suite.

@tous
réponse à la question

"que faire si on a fait un mauvais choix de carte graphique ?".



Voir si une version ancienne d'un des logiciels en bogue ne serait pas plus adaptée...
C'est le cas de FlashPrint smile
J'ai désinstallé la dernière et mis la plus ancienne sur mon disque "GeForce 7300GT" et Bingo cela fonctionne big_smile

Maintenant reste à savoir entre la Radeon X1950 Pro et la GeForce 7300GT, quelle est celle qui fera monter Flashprint le plus haut en version...
Et aussi avec un disque "GPU intégrée", pour voir si celle qui paraissait être la plus nulle tiendrait la course.

Dernière modification par statis (03-02-2019 15:22:39)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#50 03-02-2019 15:03:06

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Quelle carte graphique utiliser ? [résolu]

si tu veux dépenser des sous , voilà des cartes pas trop chères .

c'est de l'entrée de gamme :

-- PULSE RADEON RX 550  -- 4 GB -- celle que j'utilise : très bien .

-- GEFORCE 1030 -- 2 GB -- (vieille carte remise à jour)

-- GEFORCE 1050 -- 2GB -- meilleure que la précédente (au niveau de la radeon , à peu près)

En ligne

Pied de page des forums