Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-02-2019 18:59:11

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

pas d'imprimante vue dans matériel [résolu]

Bonjour,

Je suis sur une nouvelle installation donc je remet les composants.
Je bloque sur la partie imprimante.
J'ai une HP et je pensais qu'il suffisait d'installer HPlip...
Le paquet et ses dépendances c'est bien chargé mais pas d'imprimante vue dans "matériel" ni HPlip vu quelque part dans tous les menus...
J'ai redémarré sans effet...

Petite note, je n'ai pas activé le serveur d'impression à l'installation et je n'avais pas eu ce problème sans utiliser le "net-install"...

Suite à installation du paquet hplip-gui j'ai accès à hplip toolbox, là ou on peut installer l'imprimante.
Une fois l'imprimante détectée il m'est demandé le login et password pour ouvrir les droits et cela échoue...
Message "printer queue setup failed error successful-ok-ignored-or-substitued-attributes"

Et ce n'est pas un soucis de matériel car j'ai encore un disque avec une installation précédente dans ma tour, j'ai donc démarré D9 avec lui et aucun problème pour activer l'imprimante !!!

Je déteste les imprimantes HP mais je les choisis pour le pas avoir de problème avec Linux et c'est la première fois que je rencontre ce genre de problème...
Pourquoi les choses sont-elles si compliquées...

Dernière modification par statis (12-02-2019 19:11:17)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#2 10-02-2019 20:59:14

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

Bonsoir smile

Et ce n'est pas un soucis de matériel car [...]


Ok mais tu peux quand même donner le modèle de l’imprimante.

Pourquoi les choses sont-elles si compliquées...


Je crois que tu as répondu

Petite note, je n'ai pas activé le serveur d'impression à l'installation et je n'avais pas eu ce problème sans utiliser le "net-install"...


Bon je n’ai pas vraiment compris cette dernière phrase mais ça semble une piste si tu n’as pas fait une installation standard.
Regarde si system-config-printer est installé

apt policy system-config-printer

Hors ligne

#3 10-02-2019 21:14:32

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

Merci Chalu,

Installation standard...
J'ai pas besoin d'un serveur d'impression et sur l'autre disque D9 je ne l'avais pas activé non-plus...

Si j'ai dit que c'était une HP, mais bon si le modèle est important c'est une vieille 6280 qui fonctionne sur le même PC, la même version D9 installée avec netinstall il y a plusieurs jours donc peut-être un peu différente.

apt policy system-config-printer


system-config-printer:
  Installé : (aucun)
  Candidat : 1.5.7-3
 Table de version :
     1.5.7-3 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages



Je regarde si sur l'autre D9 le paquet system-config-printer est installé (pas sur celle-ci)

Dernière modification par statis (10-02-2019 21:17:15)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#4 10-02-2019 21:19:05

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

il suffit juste d'installer le serveur d'impression cups et de le lancer

Le matériel c'est pas éternel

Hors ligne

#5 10-02-2019 21:23:49

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

Merci TechDesk,
Hplip installe cups...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#6 10-02-2019 21:29:41

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

A partir de l'autre disque avec HPlip fonctionnel et imprimante activable :

deb64@deb64:~$ apt policy system-config-printer


system-config-printer:
  Installé : (aucun)
  Candidat : 1.5.7-3
 Table de version :
     1.5.7-3 500
        500 http://debian.proxad.net/debian stretch/main amd64 Packages



Comme dit auparavant HPlip fait son bricolage à la c.. (je déteste le matos HP) et sur un D9 çà fonctionne alors que pas sur l'autre plus récent.
D'ailleurs maintenant je me rappelle que j'avais du rajouter hplip-gui sur le premier donc même manip...
Par contre il ne m'est pas demandé d'entrer un login/password sur le premier disque...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#7 10-02-2019 21:36:21

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

localhost:631

Dernière modification par TechDesk (10-02-2019 21:37:02)


Le matériel c'est pas éternel

Hors ligne

#8 10-02-2019 21:42:33

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

Par contre il ne m'est pas demandé d'entrer un login/password sur le premier disque...


Oui ce point n’est pas normal. Tu ne devrais pas avoir besoin de saisir un login et mot de passe.

Hors ligne

#9 10-02-2019 21:42:51

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

franchement je sais pas ce que vous fabriquez avec apt policy ….mais il suffit de lancer le service et ensuite d'aller conf l'imprimante, rien d'autre

Le matériel c'est pas éternel

Hors ligne

#10 10-02-2019 21:55:23

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

Voui TechDesk... c'est à se demander ce que l'on fabrique avec du matos HP...

Là on est sur du système HP...
Bien sûr quand on est bon on peut arriver à installer de la vraie imprimante...

Hplip donne quand même la possibilité d'utiliser cups et même problème demande de login et password puis "accès forbidden".
C'est peut-être un problème de droits qui ne doit pas donner accès à l'écriture sur le port ethernet  (tu as bien fait de demander le modèle chalu car la 6280 est en ethernet) comme cela arrive en impression 3D sur le port USB quand l'utilisateur n'a pas les droits...

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#11 10-02-2019 22:48:12

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

dans cups il faut mettre le password root

Le matériel c'est pas éternel

Hors ligne

#12 11-02-2019 08:00:34

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

scratchhead.gif
Je ne peux pas comparer car j’ai system-config-printer qui est installé et se lance quand je connecte en usb mon imprimante mais pour l’installer je n’ai pas à donner le mot de passe administrateur, mon modèle d’imprimante ne nécessite pas l’installation du plugin propriétaire.
Comme statis indique qu’il n’en a pas eu besoin sur la première installation (du moins à ce que j’ai compris) je pense qu’il n’en a pas besoin.
(Édit : je viens de vérifier sur le site de hplip et son modèle n’a pas besoin du plugin propriétaire)

Et ce n'est pas un soucis de matériel car j'ai encore un disque avec une installation précédente dans ma tour, j'ai donc démarré D9 avec lui et aucun problème pour activer l'imprimante !!!


C’est un seul et même PC avec deux disques durs , chacun ayant un système Debian 9 installé ?
Pour la deuxième installation (celle qui pose souci) tu as choisi un home « tout ensemble » comme c’est coché par défaut dans l’installateur ou tu as fait un autre choix ?
Tu administres le système avec sudo ou un mot de passe root ? Et l’autre système qui marche ?

Dans le système qui marche pas, que donne

id


Tu dois apparaître dans le groupe lpadmin

Édit : si c’est le cas, donne le retour complet de

hp-setup -i


c’est la commande pour installer l’imprimante, ça fait la même chose quand graphique mais tu pourras copier coller ce qui est écrit dans le terminal et ça nous permettra de mieux voir ce qui se passe.

Hors ligne

#13 11-02-2019 12:02:32

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

Merci chalu,

Oui, c'est le même PC avec un disque en fixe dans la tour avec le D9 de juste avant les problèmes que j'ai eu avec la carte graphique.
Sur ce PC j'ai un tiroir SATA qui me permet de démarrer avec un autre système/disque via le BIOS (je n'aime pas le dual boot).
Les deux disques ont été installés à partir du même CD "net-install" Debian 9.
Toujours de la même manière :
- pas de mot de passe root
Dans la liste d'options du net-install
- options activation de MATE
- désactivations de l'option serveur d'impression (que je ne saurais pas désinstaller pour que HPlip, qui monte son propre serveur, puisse fonctionner)
Auto-login activé.
Paquet activé non-free pour avoir HPlip.

Je confirme que la paquet system-config-printer n'est pas installé sur le disque D9 "ancien" et que HPlip permet l'installation d'une imprimante.
Contrairement au nouveau D9 avec demande de login/password en echec pour installer l'imprimante.
J'ai essayé de ne pas remplir les champs, de rentrer le login de l'utilisateur qui à l'installation a prit les droits root et d'autres combinaisons improbables, toujours pareil, il n'y a pas les droits pour installer l'imprimante...

Quand j'aurais accès à mon PC, je donnerai le retour des commandes

J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#14 11-02-2019 13:31:10

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

Tu as deux home différents ou il est commun aux deux systèmes ?
Oui on attend le retour des commandes quand tu pourras wink

Hors ligne

#15 11-02-2019 15:08:42

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

l'utilitaire HP fournis avec le pilote hplip est loin d'être aussi bien que cups, je comprends pas pourquoi vous vous prenez la tête avec ça, y'en a pas besoin

Le matériel c'est pas éternel

Hors ligne

#16 11-02-2019 15:55:31

Debian Alain
Adhérent(e)
Lieu : zone 51
Distrib. : W$10 / stable / ubuntu / F29 / testing
Noyau : Linux 4.19.0-1 amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : pas d'imprimante vue dans matériel [résolu]

euuuhhh les  gars , rectifiez moi si je me trompe mais hplip installe le pilote linux pour cups , non pas cups le logiciel ....

sauf erreur .

scratchhead.gif

Dernière modification par Debian Alain (11-02-2019 15:57:00)


1498812139.jpg Modern Talking - Brother Louie (Official Music Video)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#17 11-02-2019 17:24:45

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

TechDesk a écrit :

franchement je sais pas ce que vous fabriquez avec apt policy ….mais il suffit de lancer le service et ensuite d'aller conf l'imprimante, rien d'autre
[…]
dans cups il faut mettre le password root


il semble qu’il ait testé sans succès :

statis a écrit :

possibilité d'utiliser cups et même problème demande de login et password puis "accès forbidden".


Sois plus précis peut-être dans tes conseils d’aide wink je te laisse faire. J’utilise system-config-printer pour ma part.

Pour les outils hp, perso je les utilise pour avoìr des infos comme le niveau d’encre.

Debian Alain a écrit :

rectifiez moi si je me trompe mais hplip installe le pilote linux pour cups , non pas cups le logiciel ....


le paquet cups est une dépendance de hplip si c’est ta question ?

Hors ligne

#18 11-02-2019 18:16:51

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

le niveau d'encre se voit dans cups aussi
alors je vais résumer
il faut installer cups, lancer le service, le mettre en démarrage auto
ensuite le pilote hplip
ouvrir le navigateur et aller sur http://localhost:631
renseigner le compte root
ajouter une imprimante
choisir le moyen de connexion
indiquer le pilote à utiliser
configurer si besoin les options (recto/verso, couleurs, qualité, format papier)
et voilà

Le matériel c'est pas éternel

Hors ligne

#19 11-02-2019 18:26:41

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

id


uid=1000(deb64) gid=1000(deb64) groupes=1000(deb64),20(dialout),24(cdrom),25(floppy),27(sudo),29(audio),30(dip),44(video),46(plugdev),108(netdev)



lpadmin ?

J'ai quand même lancé l'autre commande :

hp-setup -i


HP Linux Imaging and Printing System (ver. 3.16.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                              
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)
  2         par         Parallel Port (LPT:)                                      

Enter number 0...2 for connection type (q=quit, enter=usb*) ? 1

Using connection type: net

error: No device selected/specified or that supports this functionality.


Cette commande ne détecte pas l'imprimante en ethernet alors que HPlip oui...

Pas assez précis dans mon descriptif ?
Je me suis fait prêter une imprimante très récente qui bien sur fonctionne que sur mon disque D9 "ancienne installation" et aussi sur mon autre PC Fedora HPlipé lui aussi...

hplip110.png
hplip210.png
hplip310.png
hplip410.png
hplip610.png
hplip710.png
Tentative de passer par cups
hplip810.png
hplip910.png
hplip111.png
Désolé je n'ai pas fait la capture avec le login et le password rentré dans la boîte de dialogue mais cela a été rentré
hplip112.png
pareil "forbidden"...

A chaque fois c'est le password "root-user" qui est entré.
Je n'ai aucun problème avec le login "root-user" et le password "root-user" dans toutes les opérations demandant d'être en sudo..

@techdesk
Je me prend la tête parce que je n'ai pas ton niveau pour me lancer dans des installs de truc compliqués alors que je fais déjà assez de bêtises avec des trucs pour gamin de 7 ans...
Et puis je ne comprends pas pourquoi HPlip fonctionnerait très bien sur un autre Debian9 et pas sur celui-ci...

@chalu
HPlip a d'autres fonctions que regarder le niveau d'encre même si je n'aime pas HP leur utilitaire est bien
2 home's ?
Comme déjà dit, je ne suis pas en dual boot, j'ai monté une fois une config comme çà et j'ai tout perdu, plus jamais...
Quand un disque est déclaré comme celui qui sera booté dans le Bios l'autre apparaît comme un simple disque de données.
Bien sûr si je le lis, je vois un dossier Home en tant que "donnée" et non pas en tant qu’élément du système...

Dernière modification par statis (11-02-2019 18:30:03)


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#20 11-02-2019 18:31:55

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

dans cups tu rentres bien le root ?

Le matériel c'est pas éternel

Hors ligne

#21 11-02-2019 18:36:16

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

To perform administrative tasks from the web interface authentication is required. Authenticate either as root or make sure your user is member of a group with printer administration privileges, see #Configuration.
tu es dans le groupe lp et sys ?

Dernière modification par TechDesk (11-02-2019 18:36:34)


Le matériel c'est pas éternel

Hors ligne

#22 11-02-2019 19:02:27

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

TechDesk a écrit :

To perform administrative tasks from the web interface authentication is required. Authenticate either as root or make sure your user is member of a group with printer administration privileges, see #Configuration.
tu es dans le groupe lp et sys ?



??? désolé mais ce n'est pas compréhensible pour moi...

Bien sûr que j'ai rentré le mot de passe root, comme déjà dit je suis sur une config user-root, je n'ai qu'un mot de passe.


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#23 11-02-2019 19:09:17

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : pas d'imprimante vue dans matériel [résolu]

TechDesk a écrit :


tu es dans le groupe lp et sys ?


Le retour de la commande id a été donné wink

 uid=1000(deb64) gid=1000(deb64) groupes=1000(deb64),20(dialout),24(cdrom),25(floppy),27(sudo),29(audio),30(dip),44(video),46(plugdev),108(netdev)


pas de lp

Hors ligne

#24 11-02-2019 19:25:31

statis
Membre
Distrib. : Debian-9 64 bits stretch
Noyau : Noyau Linux 4.9.0-8-amd64 x86_64/Linux 4.9.0-8-amd
(G)UI : Mate 1.16.2
Inscription : 19-12-2018

Re : pas d'imprimante vue dans matériel [résolu]

Et oui bien vu chalu (un jour les chats régnerons sur terre).

Pas de lp sur Debian 9 nouveau

Mais sur l'ancien :

id


uid=1000(deb64) gid=1000(deb64) groupes=1000(deb64),20(dialout),24(cdrom),25(floppy),27(sudo),29(audio),30(dip),44(video),46(plugdev),108(netdev),113(lpadmin),117(scanner)


Il y a un lpadmin...


J'ai un QI de surimi et je peux faire de grosses bêtises...

Peux-tu combattre ta propre nature ? Si oui, cela fait partie de ta nature… Mépriser ceux qui n’ont pas ta chance, Est une grave insulte à la providence…
Julius Korlang

Hors ligne

#25 11-02-2019 19:38:27

TechDesk
Membre
Distrib. : ArchLinux x86_64 GNU/Linux
Noyau : Linux 4.20.5-arch1-1-ARCH
(G)UI : Enlightenment 0.22.99.23445
Inscription : 19-03-2012

Re : pas d'imprimante vue dans matériel [résolu]

bah ajoute ton utilisateur au groupe lp et sys

Le matériel c'est pas éternel

Hors ligne

Pied de page des forums