Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-02-2019 22:13:10

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour à tous,

Avant toute chose, j'ai bien fait une recherche concernant mon problème sur le forum. J'ai trouvé d'anciens postes (2015 voir plus anciens), mais les solutions proposées ne m'ont pas permis de me débloquer sad.

Un peu de contexte tout d'abord : mon problème est apparu récemment sur un NAS que j'ai assemblé avec comme configuration :
- un i5 7600K
- 16 go de ram
- 5 disques Seagate de 4 To en Raid5
- 1 SSD de 256 Go avec le système sur une partition, et une seconde partition qui me sert pour les fichiers de quelques VMs

J'ai installé sur ce NAS Open Media Vault 4 par dessus une installation propre de Debian 9.

J'ai voulu faire une maj des paquets hier, mais j'ai alors eu un message d'erreur et je n'arrive depuis plus ni à mettre à jour, ni à désinstaller de paquets, ni même à en installer de nouveau...En parallèle j'ai  un deuxième NAS (un HP Proliant N54L) sur lequel j'ai également installé la même version d'OMV et de Debian, et sur laquelle les mises à jour n'ont posé aucun problème...

Voilà les commandes que j'ai essayé, et les résultats de ces dernières (exécutées en root) :

apt-get update

Parfois cette commande ne renvoie rien d'anormal, mais 1 fois sur 2 ou sur 3 la commande se termine sur ceci :

Atteint:31 http://download.webmin.com/download/repository sarge Release
Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f0275efb840>
Traceback (most recent call last):
  File "/usr/lib/python3.5/weakref.py", line 117, in remove
TypeError: 'NoneType' object is not callable
Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f0275efb840>
Traceback (most recent call last):
  File "/usr/lib/python3.5/weakref.py", line 117, in remove
TypeError: 'NoneType' object is not callable
 



apt-get upgrade ou apt-get dist-upgrade (même message renvoyé)

Cette commande renvoie invariablement l'erreur suivante :

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



Je tente alors la commande proposée : apt --fix-broken install, qui renvoie le message suivant :

apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
The following additional packages will be installed:
  python-dnspython python-samba
Paquets suggérés :
  python-gpgme
Les paquets suivants seront mis à jour :
  python-dnspython python-samba
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
28 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 464 ko dans les archives.
Après cette opération, 4 096 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
 



J'accepte et obtiens le (long) message d'erreur suivant :

Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 111426 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-dnspython_1.15.0-1+deb9u1_all.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-dnspython_1.15.0-1+deb9u1_all.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Préparation du dépaquetage de .../python-samba_2%3a4.5.16+dfsg-1_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-samba_2%3a4.5.16+dfsg-1_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-dnspython_1.15.0-1+deb9u1_all.deb
 /var/cache/apt/archives/python-samba_2%3a4.5.16+dfsg-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



Pour information, mon fichier sources.list est le suivant :

# Les dépôts officiels Debian Stretch :
deb http://deb.debian.org/debian/ stretch main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch main

# Debian Stretch, mises-à-jour de sécurité :
deb http://security.debian.org/ stretch/updates main contrib non-free
#deb-src http://security.debian.org/ stretch/updates main contrib non-free

# Debian Stretch, mises-à-jour "volatiles" :
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free

# Debian Stretch, dépôt de rétroportages ("backports") :
deb http://deb.debian.org/debian stretch-backports main contrib non-free
#deb-src http://deb.debian.org/debian stretch-backports main

 



Ce n'est pas le fichier d'origine cependant, je l'ai modifié lors de mes essais pour régler ce problème. Auparavant j'avais :

#

# deb cdrom:[Debian GNU/Linux 9.7.0 _Stretch_ - Official amd64 NETINST 20190123-19:36]/ stretch main

#deb cdrom:[Debian GNU/Linux 9.7.0 _Stretch_ - Official amd64 NETINST 20190123-19:36]/ stretch main

deb http://ftp.fr.debian.org/debian/ stretch main
deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main
deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
 



Après avoir lu que dpkg --configure -a pourrait aider, j'ai également essayé, mais j'obtiens :

dpkg --configure -a
dpkg: erreur de traitement du paquet python-dnspython (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
Paramétrage de docker-ce (5:18.09.2~3-0~debian-stretch) ...
update-alternatives: utilisation de « /usr/bin/dockerd-ce » pour fournir « /usr/                                                                                                                                                                                                                                             bin/dockerd » (dockerd) en mode automatique
Paramétrage de linux-headers-amd64 (4.19+102~bpo9+1) ...
dpkg: des problèmes de dépendances empêchent la configuration de python-samba :
 python-samba dépend de libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) ; cependant :
  La version de libwbclient0:amd64 sur le système est 2:4.5.16+dfsg-1.
 python-samba dépend de samba-libs (= 2:4.5.12+dfsg-2+deb9u4) ; cependant :
  La version de samba-libs:amd64 sur le système est 2:4.5.16+dfsg-1.

dpkg: erreur de traitement du paquet python-samba (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de gnupg (2.1.18-8~deb9u4) ...
Paramétrage de gnupg2 (2.1.18-8~deb9u4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) .                                                                                                                                                                                                                                             ..
dpkg: des problèmes de dépendances empêchent la configuration de samba :
 samba dépend de python-dnspython ; cependant :
 Le paquet python-dnspython n'est pas encore configuré.
 samba dépend de python-samba ; cependant :
 Le paquet python-samba n'est pas encore configuré.

dpkg: erreur de traitement du paquet samba (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de samba-common-bi                                                                                                                                                                                                                                             n :
 samba-common-bin dépend de python-samba ; cependant :
 Le paquet python-samba n'est pas encore configuré.

dpkg: erreur de traitement du paquet samba-common-bin (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de postfix (3.1.9-0+deb9u2) ...

Postfix (main.cf) configuration was untouched.  If you need to make changes,
edit /etc/postfix/main.cf (and others) as needed.  To view Postfix
configuration values, see postconf(1).

After modifying main.cf, be sure to run 'service postfix reload'.

Running newaliases
Paramétrage de libwayland-server0:amd64 (1.12.0-1+deb9u1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) ...
Des erreurs ont été rencontrées pendant l'exécution :
 python-dnspython
 python-samba
 samba
 samba-common-bin
 




J'ai également essayé à plusieurs reprises apt-get clean, apt-get -f install etc, mais sans succès. J'ai passé plusieurs heures à chercher les noms et versions des paquets indiqués comme posant problème dans le message suivant apt-get upgrade, mais je n'ai rien trouvé non plus sad.

Je suis un peu perdu et ne vois pas quoi essayer (et je n'ai pas non plus les connaissances pour, je débute en linux)... Auriez-vous une idée de ce que je pourrai tenter pour corriger ce problème ?

Je vous remercie par avance !

Dernière modification par kingsokar (19-02-2019 23:12:45)

Hors ligne

#2 20-02-2019 18:48:51

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour à tous,

En cherchant un peu plus je suis tombé sur un article de Korben qui indiquait un set de commandes à tester, ce que j'ai fait :

sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo rm /var/lib/dpkg/lock-frontend
sudo dpkg --configure -a
sudo apt clean
sudo apt update --fix-missing
sudo apt install -f
sudo dpkg --configure -a
sudo apt upgrade
sudo apt dist-upgrade
sudo reboot



Malheureusemlent sans succès, les mêmes erreurs sont apparues.

Dernière modification par kingsokar (20-02-2019 18:49:01)

Hors ligne

#3 20-02-2019 19:23:35

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour
tu a un mélange de version
ceci par exemple  roll


Atteint:31 http://download.webmin.com/download/repository sarge Release
 


modifié tongue
tu n'a rien dans /etc/apt/apt.conf.d/  comme fichier sources.list ?

si tu regarde ceci


dpkg: des problèmes de dépendances empêchent la configuration de python-samba :
 python-samba dépend de libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) ; cependant :
  La version de libwbclient0:amd64 sur le système est 2:4.5.16+dfsg-1.
 



la version de stretch est celle la 2:4.5.16+dfsg-1 , celle ci ne correspond pas  => 2:4.5.12+dfsg-2+deb9u4

tu devrais utiliser aptitude plutôt que apt-get .
je sais pas si le système peut être récupéré , mais la solution est de remettre les bonnes versions de paquets
que renvoie la commande apt update ?


apt update
 

Dernière modification par robert2a (20-02-2019 19:39:59)

Hors ligne

#4 20-02-2019 19:33:45

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour robert2a smile. Dans le dossier /etc/apt je n'ai pas de sous dossier apt.d. En revanche j'ai tout un tas d'autres dossiers :
- apt.conf.d
- post-invoke.d
-preferences.d
-pre-invoke.d
-sources.list.d
-trusted.gpg.d
-update-post-invoke.d
-update-post-invoke-success.d
-update-pre-invoke.d

J'ai également plusieurs fichiers :
-listchanges.conf
-sources.list (celui dont j'ai copié le contenu dans mon premier post)
-sources.list.old (une sauvegarde du sources.list original après installation d'Open Media Vault)
-sources.list~
-trusted.gpg
-trusted.gpg~

Hors ligne

#5 20-02-2019 19:39:03

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

désolé dans /etc/apt/apt.conf.d/  (me suis trompé  hmm  )

pour celui ci  , il est correct


# Les dépôts officiels Debian Stretch :
deb http://deb.debian.org/debian/ stretch main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch main

# Debian Stretch, mises-à-jour de sécurité :
deb http://security.debian.org/ stretch/updates main contrib non-free
#deb-src http://security.debian.org/ stretch/updates main contrib non-free

# Debian Stretch, mises-à-jour "volatiles" :
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free

# Debian Stretch, dépôt de rétroportages ("backports") :
deb http://deb.debian.org/debian stretch-backports main contrib non-free
#deb-src http://deb.debian.org/debian stretch-backports main
 



nota: pour le mettre en couleur utilise la balise code "code=apt_sources"

Dernière modification par robert2a (20-02-2019 19:43:49)

Hors ligne

#6 20-02-2019 19:40:50

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

J'avais répondu partiellement avant que tu ne mettes à jour ta réponse robert2a, pour répondre à tes autres indications :

Je ne savais pas que apt-get et apt étaient différents pour être honnête (comme je l'ai indiqué, je débute en linux smile). J'avais bien compris qu'il y avait un problème de version installée ne correspondant pas à l'attendu, mais comme je passe par l'interface open media vault pour lancer les update je ne sais pas pourquoi ces incohérences sont apparues.

Je viens de lancer la commande apt update, j'ai obtenu le résultat suivant (dans le doute je vous ai copié l'intégralité du retour) :

Réception de:1 file:/var/cache/openmediavault/archives  InRelease
Ign:1 file:/var/cache/openmediavault/archives  InRelease
Réception de:2 file:/var/cache/openmediavault/archives  Release
Ign:2 file:/var/cache/openmediavault/archives  Release
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Ign:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Ign:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Ign:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Ign:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Ign:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Réception de:3 file:/var/cache/openmediavault/archives  Packages
Réception de:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Ign:4 file:/var/cache/openmediavault/archives  Translation-fr_FR
Réception de:5 file:/var/cache/openmediavault/archives  Translation-en
Ign:5 file:/var/cache/openmediavault/archives  Translation-en
Réception de:6 file:/var/cache/openmediavault/archives  Translation-fr
Ign:6 file:/var/cache/openmediavault/archives  Translation-fr
Atteint:7 http://security.debian.org stretch/updates InRelease
Ign:8 http://deb.debian.org/debian stretch InRelease
Atteint:9 http://deb.debian.org/debian stretch-updates InRelease
Atteint:10 http://deb.debian.org/debian stretch-backports InRelease
Atteint:11 http://deb.debian.org/debian stretch Release
Atteint:12 http://packages.openmediavault.org/public arrakis InRelease
Atteint:13 https://download.docker.com/linux/debian stretch InRelease
Atteint:14 https://openmediavault.github.io/packages arrakis InRelease
Ign:15 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch I                                       nRelease
Ign:16 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-plex stre                                       tch InRelease
Atteint:17 https://downloads.plex.tv/repo/deb ./public InRelease
Ign:18 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker st                                       retch InRelease
Réception de:19 https://dl.bintray.com/openmediavault-plugin-developers/arrakis                                        stretch Release [4 389 B]
Atteint:19 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stret                                       ch Release
Ign:20 http://webmin.mirror.somersettechsolutions.co.uk/repository sarge InRelea                                       se
Atteint:22 http://webmin.mirror.somersettechsolutions.co.uk/repository sarge Rel                                       ease
Réception de:23 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-                                       plex stretch Release [3 540 B]
Atteint:23 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-plex                                        stretch Release
Réception de:24 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-                                       docker stretch Release [3 540 B]
Atteint:24 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docke                                       r stretch Release
Ign:30 http://download.webmin.com/download/repository sarge InRelease
Atteint:29 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
Atteint:31 http://download.webmin.com/download/repository sarge Release
Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at                                        0x7fab6bcf18c8>
Traceback (most recent call last):
  File "/usr/lib/python3.5/weakref.py", line 117, in remove
TypeError: 'NoneType' object is not callable
Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at                                        0x7fab6bcf18c8>
Traceback (most recent call last):
  File "/usr/lib/python3.5/weakref.py", line 117, in remove
TypeError: 'NoneType' object is not callable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
 



Je ne sais d'ailleurs pas pourquoi webmin apparaît, je n'ai pas souvenir de l'avoir installé...A moins qu'il ne fasse partie du package d'open media vault.

Dans /etc/apt/apt.conf.d j'ai plein de fichiers, mais aucun intitulé sources.list :
1550684595-screen.png

Dernière modification par kingsokar (20-02-2019 19:43:30)

Hors ligne

#7 20-02-2019 19:47:31

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

suis vraiment fatigué ce soir  roll

dans /etc/apt/sources.list.d/

fichiers en xxx.list

Dernière modification par robert2a (20-02-2019 19:48:23)

Hors ligne

#8 20-02-2019 19:48:50

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

big_smile Pas de soucis ! Dans /etc/apt/sources.list.d/ j'ai ça :

1550684906-screen.png

Hors ligne

#9 20-02-2019 20:05:27

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

oui dur dur , en plus je répond sur plusieurs fils

tu peu renommer ces fichiers en txt temporairement (tous) et refaire un "apt update"
nota: tu a bien un webmin.list  wink

Hors ligne

#10 20-02-2019 20:12:18

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Oui effectivement j'ai bien un webmin.list, je ne sais juste pas pourquoi big_smile. J'ai bien renommé les fichiers et lancé apt update. J'obtiens :

Ign:1 http://deb.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org stretch/updates InRelease
Atteint:3 http://deb.debian.org/debian stretch-updates InRelease
Atteint:4 http://deb.debian.org/debian stretch-backports InRelease
Atteint:5 http://deb.debian.org/debian stretch Release
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: « webmin.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault-local.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « omv-extras-org.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « plexmediaserver.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault-kernel-backports.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
 



Par curiosité j'ai lancé comme suggéré apt list --upgradable, ce qui renvoie :

En train de lister... Fait
python-dnspython/stable 1.15.0-1+deb9u1 all [upgradable from: 1.15.0-1]
python-samba/stable 2:4.5.16+dfsg-1 amd64 [upgradable from: 2:4.5.12+dfsg-2+deb9u4]
N: « webmin.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault-local.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « omv-extras-org.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « plexmediaserver.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault-kernel-backports.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
N: « openmediavault.list.txt » dans le répertoire « /etc/apt/sources.list.d/ » a été ignoré car il utilise une extension non valable
 



Il liste bien les 2 paquets qui posent problème.

Dernière modification par kingsokar (20-02-2019 20:13:35)

Hors ligne

#11 20-02-2019 20:53:24

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

donc tu peu déplacer ces fichiers vers ton home provisoirement


mv /etc/apt/apt.conf.d/nomdufichier /home/user/Documents/nondufichier
 



réparer debian avec aptitude

faire le tri de ces .list (je pourrai pas t'aider ) si tous utiles
et les remettre en place par un "mv" dans l'autre sens

pour ces deux paquets qui posent problème  aptitude va te proposer des solutions , sinon tu a aussi synaptic pour revenir a la bonne version

Hors ligne

#12 20-02-2019 21:01:31

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Par "réparer debian avec aptitude" qu'entends-tu exactement ? Si je lance apt upgrade, j'ai toujours le même message d'erreur indiquant les dépendances posant problème.

Hors ligne

#13 20-02-2019 21:08:15

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

installer le paquet


apt-get --reinstall install aptitude
 




aptitude update
 



le man


man aptitude
 



pour un upgrade


aptitude upgrade
 

Dernière modification par robert2a (20-02-2019 21:09:47)

Hors ligne

#14 20-02-2019 21:17:50

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Ouch, dés la première ligne (apt-get --reinstall install aptitude) j'ai de nouveaux paquets problématiques sad :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 aptitude : Dépend: aptitude-common (= 0.8.7-1) mais ne sera pas installé
            Dépend: libboost-filesystem1.62.0 mais ne sera pas installé
            Dépend: libboost-iostreams1.62.0 mais ne sera pas installé
            Dépend: libboost-system1.62.0 mais ne sera pas installé
            Dépend: libcwidget3v5 mais ne sera pas installé
            Dépend: libsigc++-2.0-0v5 (>= 2.8.0) mais ne sera pas installé
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 

Hors ligne

#15 21-02-2019 00:18:27

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir,
Tu as essayé

apt --reinstall install python-dnspython


comme indiqué dans le retour plus haut de dpkg --configure -a ?


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

En ligne

#16 21-02-2019 01:27:12

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir

tu a testé apt-get check


check - Vérifie qu'il n'y a pas de rupture de dépendances
 




apt-get check
 


pour moi retourne


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
 


devrait te donner la liste des paquets cassés (j'utilise plutôt synaptic mais cela devrait être équivalent )
ensuite il faut remettre en état
par exemple


python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
 


deux paquets qui n'ont pas la bonne version de stretch

tu peu utiliser dist-upgrade et simuler avec "-s" (la simulation fonctionne avec toutes les commandes )
par exemple


apt-get -s dist-upgrade
 



quand tu pourra installer aptitude tu a cette commande aussi , pour les soucis de paquets cassés


aptitude search ~b
 



il y a aussi le paquet  "wajig" mais je connais pas


Il s’agit d’une enveloppe en ligne de commande autour d’apt, apt-cache,
dpkg, aptitude, entre autres. Son but est de faciliter la gestion de paquets
en rassemblant les principales fonctions de ces outils sous une même
interface.

Pour un bref guide d’utilisation, exécutez cette commande : $ wajig help
 



le retour de ceci


wajig commands
 


la liste est longue .........

pour l'instant tu va devoir te contenter de "apt-get"  wink

Dernière modification par robert2a (21-02-2019 02:04:52)

Hors ligne

#17 21-02-2019 18:45:38

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir,
Tu as essayé
apt --reinstall install python-dnspython

comme indiqué dans le retour plus haut de dpkg --configure -a ?



Bonsoir Chalu wink. Je n'avais pas essayé, mais je viens de le faire et j'ai de nouveau le retour suivant :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



@robert2a apt-get check et apt-get -s dist-upgrade me renvoient exactement le même message sad. Je ne comprends pas comment le système peut être bloqué à ce point, j'ai pourtant mis un point d'honneur à bidouiller le moins possible l'install de l'OS principal de mon NAS (quasi tout tourne sur des VM que je fais tourner sur ce NAS et non pas sur l'OS principal).

Hors ligne

#18 21-02-2019 21:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir,

kingsokar a écrit :

Je ne comprends pas comment le système peut être bloqué à ce point, [...].


Une hypothèse plausible est que la dernière mise à jour a été interrompue : 28 paquets de traviole !
Certains ont pu être reconfigurés, semble-t-il, mais l'arbre des dépendances ne va pas bien du tout.

dpkg -l python-dnspython python-samba libwbclient0 samba-libs

et

apt-get check


Comme suggéré par robert2a (#16), devraient/pourraient permettre de mieux comprendre le souci.
Apparemment le paquet python-samba installé dépend strictement de paquets ayant été mis à jour.

Reste en dernier recours le tripatouillage de fichiers postinst/prerm (raleur a aidé là-dessus, le fil ici).

Hors ligne

#19 21-02-2019 23:59:21

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir èfpé,

Pour les commandes que tu indiques, voilà ce que j'obtiens :

dpkg -l python-dnspython python-samba libwbclient0 samba-libs renvoie :

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                                   Version                         Architecture                    Description
+++-=====================================================-===============================-===============================-===============================================================================================================
ii  libwbclient0:amd64                                    2:4.5.16+dfsg-1                 amd64                           Samba winbind client library
iFR python-dnspython                                      1.15.0-1                        all                             DNS toolkit for Python
iFR python-samba                                          2:4.5.12+dfsg-2+deb9u4          amd64                           Python bindings for Samba
ii  samba-libs:amd64                                      2:4.5.16+dfsg-1                 amd64                           Samba core libraries
 



En root, apt-get check renvoie :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 

Hors ligne

#20 22-02-2019 01:44:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Re-,

kingsokar a écrit :


dpkg -l python-dnspython python-samba libwbclient0 samba-libs

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                                   Version                         Architecture
+++-=====================================================-===============================-==================
ii  libwbclient0:amd64                                    2:4.5.16+dfsg-1                 amd64
iFR python-dnspython                                      1.15.0-1                        all
iFR python-samba                                          2:4.5.12+dfsg-2+deb9u4          amd64
ii  samba-libs:amd64                                      2:4.5.16+dfsg-1                 amd64


Donc c'est bien ça : python-samba a été laissé non configuré, et dans une version non mise à jour !
Le paquet python-dnspython est dans le même pytheux état (pardon roll), mais sans casser l'arbre.

apt-cache policy python-dnspython python-samba libwbclient0 samba-libs


La réinstallation échoue... peut-être tenter la réinstallation des dépendances en version inférieure ?

apt-get install libwbclient0=2:4.5.12+dfsg-2+deb9u4 samba-libs=2:4.5.12+dfsg-2+deb9u4


Tu peux bien sûr commencer par une simulation avec l'option -s ; impossible de reproduire le souci !

Dernière modification par èfpé (22-02-2019 01:54:42)

Hors ligne

#21 22-02-2019 08:40:48

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

apt-cache policy python-dnspython python-samba libwbclient0 samba-libs renvoyait une erreur si exécuté en tant qu'utilisateur simple, je l'ai donc lancé en tant que root ce qui renvoie :

ibwbclient0 samba-libs
python-samba:
  Installé : 2:4.5.12+dfsg-2+deb9u4
  Candidat : 2:4.5.16+dfsg-1
 Table de version :
     2:4.5.16+dfsg-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
 *** 2:4.5.12+dfsg-2+deb9u4 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
libwbclient0:
  Installé : 2:4.5.16+dfsg-1
  Candidat : 2:4.5.16+dfsg-1
 Table de version :
 *** 2:4.5.16+dfsg-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.5.12+dfsg-2+deb9u4 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
samba-libs:
  Installé : 2:4.5.16+dfsg-1
  Candidat : 2:4.5.16+dfsg-1
 Table de version :
 *** 2:4.5.16+dfsg-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.5.12+dfsg-2+deb9u4 500
        500 http://security.debian.org stretch/updates/main amd64 Packages



apt-get install libwbclient0=2:4.5.12+dfsg-2+deb9u4 samba-libs=2:4.5.12+dfsg-2+deb9u4 ne fonctionne pas malheureusement, comme je crois à chaque fois que j'ai tenté d'installer/réinstaller ou supprimer des paquets depuis que le problème est apparu.

Hors ligne

#22 22-02-2019 09:24:53

robert2a
Membre
Lieu : France
Distrib. : debian 10
Noyau : 4.19
(G)UI : Gnome
Inscription : 15-11-2014

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour

a tu essayé le mode dépannage a partir de grub , et entrer directement le mot de passe root (ne pas continuer jusqu'au loging ).
le minimum de paquet sera utilisé (et le bureau inactif ) , tu sera en console pure
si tu utilise un fichier "interfaces" (pas network manager) , une commande de ce type peu même te donner la connexion sur le net


service networking start
 


tu teste avec


apt-get update
 


tu peu tenter


apt-get dist-upgrade
 


noter les messages en retour (si toujours le même blocage)

tu peu tenter ceci si blocage


apt --fix-broken install
 



comme les paquets ne sont pas utilisés peut être que cela se passe mieux

remarque: toujours avec un sources.list propre ,  uniquement sur les dépôts debian

Dernière modification par robert2a (22-02-2019 09:34:20)

Hors ligne

#23 22-02-2019 22:21:44

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Je viens d'essayer en recovery mode, et les messages d'erreur renvoyés par les commandes que tu m'as indiqué sont exactement les mêmes qu'avant.

Hors ligne

#24 22-02-2019 23:54:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Re-,

kingsokar a écrit :


# apt-get install libwbclient0=2:4.5.12+dfsg-2+deb9u4 samba-libs=2:4.5.12+dfsg-2+deb9u4

ne fonctionne pas malheureusement, comme je crois à chaque fois que j'ai tenté d'installer/réinstaller ou supprimer des paquets depuis que le problème est apparu.


Le retour eût été intéressant. Et as-tu tenté les options --force-machins (dpkg) lors de tes essais ?

dpkg --no-act --force-remove-reinstreq --remove python-samba


Par exemple (voir man dpkg), il y a aussi l'option --force-all, un peu bête. Virer --no-act si ça passe.

Hors ligne

#25 23-02-2019 00:05:30

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir èfpé,

Désolé je n'avais pas copié le retour, apt-get install libwbclient0=2:4.5.12+dfsg-2+deb9u4 samba-libs=2:4.5.12+dfsg-2+deb9u4 donne ceci :

 apt-get install libwbclient0=2:4.5.12+dfsg-2+deb9u4                                                                                                                                                                                                                                              samba-libs=2:4.5.12+dfsg-2+deb9u4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 samba : Dépend: libwbclient0 (= 2:4.5.16+dfsg-1) mais 2:4.5.12+dfsg-2+deb9u4 de                                                                                                                                                                                                                                             vra être installé
         Dépend: samba-libs (= 2:4.5.16+dfsg-1) mais 2:4.5.12+dfsg-2+deb9u4 devr                                                                                                                                                                                                                                             a être installé
 samba-common-bin : Dépend: samba-libs (= 2:4.5.16+dfsg-1) mais 2:4.5.12+dfsg-2+                                                                                                                                                                                                                                             deb9u4 devra être installé
 samba-vfs-modules : Dépend: samba-libs (= 2:4.5.16+dfsg-1) mais 2:4.5.12+dfsg-2                                                                                                                                                                                                                                             +deb9u4 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



En ce qui concerne dpkg --no-act --force-remove-reinstreq --remove python-samba j'avoue que je ne sais plus si je l'ai tenté, mais le retour ne me dit rien donc j'ai du passer à côté:

dpkg: un problème de dépendance empêche la suppression de python-samba :
 samba-common-bin dépend de python-samba.
 samba dépend de python-samba ; cependant :
  Le paquet python-samba doit être supprimé.

dpkg: erreur de traitement du paquet python-samba (--remove) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 python-samba
 

Hors ligne

Pied de page des forums