Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-05-2019 13:11:45

robert2a
Membre
Inscription : 15-11-2014

Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour

une machine en gnome (buster) sur un raven ridge 2200G fonctionne parfaitement sur tous les bureaux de gnome .
si j' installe mate , arrivé sur le bureau j'ai une corruption de l'affichage , aucun menu ne fonctionne. ( le problème est ancien mais toujours présent )
le seul moyen de sortir c'est un Ctrl + Alt + F3 , connexion en root et arrêt de la machine ( ou redémarrer ) .
comme toutes mes buster + mate + lightdm fonctionne bien .
le seul point différent c'est l'apu amd et gdm3 .
pour bien cerner le problème il faudrait que j' installe buster + mate + lightdm sur cette machine . (pour écarter un souci sur gdm3)
je le signale ici si quelqu'un rencontre ce problème

Hors ligne

#2 02-05-2019 13:20:37

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour,
Merci pour le retour. Tu pourrais installer lightdm pour voir si en l’utilisant c’est mieux... comme tu es en période de test , je n’hésite pas big_smile

Hors ligne

#3 02-05-2019 14:12:06

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

sous stretch , mate + lightdm correct


journalctl -r -p err
-- Logs begin at Thu 2019-05-02 14:02:08 CEST, end at Thu 2019-05-02 14:06:10 CEST. --
mai 02 14:03:26 debian20 pulseaudio[1087]: [pulseaudio] pid.c: Daemon already running.
mai 02 14:02:11 debian20 kernel: sp5100_tco: I/O address 0x0cd6 already in use
mai 02 14:02:08 debian20 kernel: AMD-Vi: Unable to write to IOMMU perf counter.
 


comme le matériel est inconnu ça passe bien (disque de récupération , a jour , avec firmware et amdgpu )
le driver est basic


glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 3.9, 128 bits) (0xffffffff)
    Version: 13.0.6
    Accelerated: no
    Video memory: 14028MB
    Unified memory: no
 



je dist-upgrade vers buster  roll

Hors ligne

#4 02-05-2019 14:35:06

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

c'est bien sur le PC dont il est question post #1 qui bogue avec gdm3+mate ?

Hors ligne

#5 02-05-2019 15:36:45

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

oui , en fait c'est mate qui bug
gnome + gdm3 c'est ok
xfce4 + lightdm c'est ok
mate + gdm3 ou lightdm c'est mauvais

la je poste sous xfce4 + lightdm

la machine c'est celle ci


glxinfo -B
 


retour


name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD RAVEN (DRM 3.27.0, 4.19.0-4-amd64, LLVM 7.0.1) (0x15dd)
    Version: 18.3.4
    Accelerated: yes
    Video memory: 2048MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 1994 MB, largest block: 1994 MB
    VBO free aux. memory - total: 3062 MB, largest block: 3062 MB
    Texture free memory - total: 1994 MB, largest block: 1994 MB
    Texture free aux. memory - total: 3062 MB, largest block: 3062 MB
    Renderbuffer free memory - total: 1994 MB, largest block: 1994 MB
    Renderbuffer free aux. memory - total: 3062 MB, largest block: 3062 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 2048 MB
    Total available memory: 5120 MB
    Currently available dedicated video memory: 1994 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RAVEN (DRM 3.27.0, 4.19.0-4-amd64, LLVM 7.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 18.3.4
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



mais aucune idée de ce qui provoque ce comportement , sur les autres buster je suis en mate + lightdm avec un driver nvidia nonfree
alors que sur cette machine je suis en driver libre amdgpu
sur le log de X je vois rien de spécial
sur l'invite de connexion tout est correct , le souci survient au chargement du bureau  roll

j'ai testé avec un disque d une autre machine (sdb )  , sda et sdc c'est ma config d'origine (avec gnome en EFI (ssd M2) et un DD pour les archives )


fdisk -l
 


retour


Disque /dev/sdb : 74,5 GiB, 80026361856 octets, 156301488 secteurs
Modèle de disque : ST380815AS      
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x6cb8160c

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sdb1    *             2048 149874687 149872640  71,5G 83 Linux
/dev/sdb2             149876734 156301311   6424578   3,1G  5 Étendue
/dev/sdb5             149876736 156301311   6424576   3,1G 82 partition d'échange Linux / Solaris


Disque /dev/sda : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : ST3500413AS    
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x7a3d7b98

Périphérique Amorçage Début       Fin  Secteurs Taille Id Type
/dev/sda1              2048 976773119 976771072 465,8G 83 Linux


Disque /dev/sdc : 256,2 GiB, 275064201216 octets, 537234768 secteurs
Modèle de disque : Crucial_CT275MX3
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : F34266B1-A457-48C7-9D46-034DF80320DF

Périphérique     Début       Fin  Secteurs Taille Type
/dev/sdc1         2048   1050623   1048576   512M Système EFI
/dev/sdc2      1050624 503943167 502892544 239,8G Système de fichiers Linux
/dev/sdc3    503943168 537233407  33290240  15,9G Partition d'échange Linux
 



donc je boute sur sdb (DD de 80Go ) pour pas toucher a ma configuration actuelle , en MBR

le bug c'est plein de carré multicolore de 1cmx1cm environ ,en escalier , et menu et icones inactif , je peu rien faire a part sortir avec Ctrl+Alt+F3 .

actuellement sur ce disque j'ai xfce4 et mate avec lightdm , le premier correct , le second bug .
sur deux installation différentes , mate a un bug sur la même machine , que je n'ai pas sur d'autres buster+mate en driver nonfree

aucune idée , mesa est dans le coup peut être aussi  hmm  ( pas utilisé sur un driver nonfree ).
mais bon gnome et xfce4 sont parfait .

Dernière modification par robert2a (02-05-2019 15:54:28)

Hors ligne

#6 02-05-2019 16:01:28

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

et quand tu compares la commande

lspci -nnk |grep -iA3 vga


sur ce PC d'une part sur Stretch+mate et d'autre part sur Buster Mate, ça donne quoi ?
Edit : question idiote, ça marche sur buster xfce roll
Il te reste à signaler le bug peut-être ?

Hors ligne

#7 02-05-2019 16:29:07

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

signaler un bug jamais fait .
pour la commande


lspci -nnk |grep -iA3 vga
 



08:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd] (rev c8)
  Subsystem: ASUSTeK Computer Inc. Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1043:876b]
  Kernel driver in use: amdgpu
  Kernel modules: amdgpu
 



voir si je peu prendre une photo de l'écran avec mate
je vais essayer de retrouver la date ou pour la première fois j'ai eu ce souci sur cette machine

le membre est en xfce (une machine similaire a la mienne avec un apu amd )  =>  https://debian-facile.org/viewtopic.php?id=21384
le membre Mimoza utilise aussi un bureau xfce avec ce matériel
je ne trouve plus ou j'ai noté ce problème sous mate ......

Dernière modification par robert2a (02-05-2019 16:44:02)

Hors ligne

#8 02-05-2019 19:51:15

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.14.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

testé mate (vite fait) sur mon R7 buster kernel 4.19.0-4 (gdm3) : R.ien A. S.ignaler

testé mate toute la journée sur mon hp 6005 desktop athlon XII 215 (lightdm) : R.A.S.

j'aurai bien essayé de t'aider mais je n'arrive pas à reproduire ta panne .

enfin , pour l'instant .

Dernière modification par Debian Alain (02-05-2019 19:56:56)

En ligne

#9 04-05-2019 10:41:18

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour

voila ce que ça donne sous Mate  =>  https://pix.toile-libre.org/?img=1556959680.jpg

en fait les carrés c'est mon menu "mate" , ça se dégrade jusqu'a ce que plus aucun click ne fonctionne .
j'ai bien nettoyé buster des paquets obsoletes , pas trouvé la cause .
actuellement uniquement le bureau xfce qui fonctionne parfaitement .
j'ai même purgé , nettoyé mon /home

Hors ligne

#10 04-05-2019 12:57:27

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

C’est le menu standard de Mate ?

Hors ligne

#11 04-05-2019 13:51:19

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour
@chalu
oui
mais je me demande si une installation neuve de debian 10 ne serait pas mieux sur cette machine pour écarter un problème du système .
si je devais installer buster sur une machine neuve , je pense que a partir de l'iso d'installation serait bien mieux qu une migration  roll
sinon les bugs renvoyés par apt-listbugs a la migration
bug sous buster
avec l'upgrade


278 Mo réceptionnés en 3min 24s (1 362 ko/s)                                                                                                                                    
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité grave sur fontconfig (2.11.0-6.7+b1 → 2.13.1-2) <En attente de traitement>
 b1 - #927153 - fontconfig: fc-cache with -y option is broken
bogues de gravité serious sur autoconf (2.69-10 → 2.69-11) <En attente de traitement>
 b2 - #907277 - autoconf: AC_SEARCH_LIBS for __atomic_foo fails with AC_LANG([C++]) and g++-8
bogues de gravité serious sur tar (1.29b-1.1 → 1.30+dfsg-6) <Transférés>
 b3 - #901952 - xdelta: expected from file (/tmp/pristine-tar.SljdkfANnj/recreatetarball) of length 7557120 bytes
bogues de gravité serious sur keyboard-configuration (1.164 → 1.191) <Transférés>
 b4 - #924657 - kbdnames are generated with incorrect translations
bogues de gravité serious sur libfreetype6 (2.6.3-3.2 → 2.9.1-3) <Transférés>
 b5 - #866960 - libfreetype6: ABI/API change yielding a blank line between characters due to different rounding for TrueType fonts
bogues de gravité serious sur libfontconfig1 (2.11.0-6.7+b1 → 2.13.1-2) <Transférés>
 b6 - #909750 - applications tries to write to /usr/* directories via libfontconfig1
Résumé :
 tar(1 bogue), keyboard-configuration(1 bogue), libfreetype6(1 bogue), libfontconfig1(1 bogue), autoconf(1 bogue), fontconfig(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]
 


bug sur le dist-upgrade (buster)


702 Mo réceptionnés en 7min 17s (1 603 ko/s)                                                                                                                
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité grave sur libpoppler-glib8 (0.48.0-2+deb9u2 → 0.71.0-3) <En attente de traitement>
 b1 - #922397 - libevdocument3-4: Evince passes NULL pointer to poppler_date_parse
   Fusionné avec : 922398 924029 927764
bogues de gravité grave sur grub2-common (2.02~beta3-5+deb9u1 → 2.02+dfsg1-16) <En attente de traitement>
 b2 - #924151 - grub2-common: wrong grub.cfg for efi boot and fully encrypted disk
   Fusionné avec : 926689
bogues de gravité serious sur libc6-dev (2.24-11+deb9u4 → 2.28-8) <En attente de traitement>
 b3 - #924712 - crypt() not available _XOPEN_SOURCE is defined
bogues de gravité serious sur e2fsprogs (1.43.4-2 → 1.44.5-1) <En attente de traitement>
 b4 - #924591 - fastboot format:ext4 misses /usr/lib/android-sdk/platform-tools/mke2fs
bogues de gravité serious sur libmypaint-common (→ 1.3.0-2.1) <En attente de traitement>
 b5 - #906144 - libmypaint-common: drop Conflicts: mypaint-data
bogues de gravité serious sur libio-socket-ssl-perl (2.044-1 → 2.060-3) <En attente de traitement>
 b6 - #914034 - libio-socket-ssl-perl: TLSv1.3 connection deadlock
bogues de gravité critical sur libgl1-mesa-dri (13.0.6-1+b2 → 18.3.4-2) <Résolus dans une version donnée>
 b7 - #922346 - eog: Opened an image and my display server crashed (Corrigé : mesa/18.3.6-1)
bogues de gravité serious sur openjdk-11-jre (→ 11.0.3+1-1) <Résolus dans une version donnée>
 b8 - #925071 - openjdk-11-jre: please add Breaks: eclipse-platform (<< 3.8.1-11) (Corrigé : openjdk-11/11.0.3+7-3 openjdk-12/12.0.1+12-2)
Résumé :
 libgl1-mesa-dri(1 bogue), libc6-dev(1 bogue), e2fsprogs(1 bogue), openjdk-11-jre(1 bogue), libpoppler-glib8(1 bogue), libmypaint-common(1 bogue), grub2-common(1 bogue), libio-socket-ssl-perl(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à niveau les paquets ci-dessus ? [Y/n/?/...]
 

Hors ligne

#12 04-05-2019 16:56:05

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Essaie si tu as le temps, tu as le bug si tu supprimes le paquet firmware-amd-graphics s’il est installé ?

Hors ligne

#13 05-05-2019 06:02:36

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonsoir

non sans firmware sous buster  la machine ne fonctionne pas .
sous stretch oui , le noyau ne détecte pas le gpu , c'est en mode vesa mais correct , mais mate est pas en version 1.20 .
la je tourne toujours en xfce sous buster le bureau est bon (avec le DD ).
pas d'erreur sur le système , ni sur le log de X
quand buster passe stable je teste une installation neuve avec mate , sur un autre DD.
il me reste 3 logiciels gdebi ,gedit et synaptic a retirer , sinon xfce est propre . (le système aussi )
a ce propos sur xfce quoi comme équivalent a gedit ? ( pas trouvé ) libreoffice a été retiré aussi   , cups , gimp etc ..... , un xfce de base  wink
pour moi c'est un des paquets de mate qui provoque ce bug , mais trouvé le fautif pas évident  hmm

Hors ligne

#14 05-05-2019 08:54:10

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Comment ça elle ne fonctionne pas ?
Le système démarre pas ? Ou l’affichage n’est pas optimisé ?

Libreoffice retiré de Buster ? T’es sur ?
Le traitement de texte par défaut sur Xfce, c’est mousepad.

Ça n’existe pas des iso live de Buster mate pour tester juste en live ?

Hors ligne

#15 06-05-2019 14:31:20

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

chalu a écrit :

Comment ça elle ne fonctionne pas ?
Le système démarre pas ? Ou l’affichage n’est pas optimisé ?
Libreoffice retiré de Buster ? T’es sur ?
Le traitement de texte par défaut sur Xfce, c’est mousepad.
Ça n’existe pas des iso live de Buster mate pour tester juste en live ?



@chalu

sans firmware sous buster (avec le noyau 4.19) je tombe sur une console pure , pas de bureau ( ou le système plante )
pour libreoffice c'est moi  qui l'est retiré (ainsi que tous les paquets inutiles pour les tests ) , je travaille sur DD pour trouver la raison de ce bug
je vais installé mousepad , merci wink
pour le live pas penser et je sais pas si cela existe actuellement pour buster.

sinon j'ai pensé au paquet "marco" qui est la base du bureau mate , mais utilisé une vieille version du bureau sur buster , pas réussi pour l'instant.
lors du passage a buster sur cette machine , le bureau mate a fonctionné pendant pas mal de temps .
je dirai fin 2018 début 2019 ce bug est apparu , comme un boulet j'ai pas noté . roll


aptitude search ?obsolete
 


ne renvoie rien


journalctl -r -p err
 


retour


-- Logs begin at Mon 2019-05-06 14:05:32 CEST, end at Mon 2019-05-06 14:20:37 CEST. --
mai 06 14:05:38 debian20 kernel: [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector ind
mai 06 14:05:35 debian20 kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
mai 06 14:05:32 debian20 kernel: AMD-Vi: Unable to write to IOMMU perf counter.
 


rien d'anormal pour moi

je vais pourvoir installer a nouveau mate-core (minimal) et tester
il me semble qu'il y a eu 3 versions , 1.16 (stretch) , 1.18 et 1.20 (buster).

externe a xfce , il me reste aptitude , tous le reste a été supprimé purgé .

avec aptitude sous buster , la version de mate-core 1.16 de stretch fonctionne parfaitement


apt-cache policy mate-core
 


retour


mate-core:
  Installé : 1.16.0+1
  Candidat : 1.16.0+1
 Table de version :
     1.20.0+5~bpo9+1 100
        100 http://ftp.fr.debian.org/debian stretch-backports/main amd64 Packages
 *** 1.16.0+1 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
 



tenter la version des backports me semble périlleux  tongue


PRETTY_NAME="Debian GNU/Linux buster/sid"
NAME="Debian GNU/Linux"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
 



Linux debian20 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 GNU/Linux
 


trouver le paquet qui pose problème me semble difficile aussi  roll

après avoir réactivé le sources.list stretch + buster


apt list --upgradable
 



En train de lister... Fait
bluebird-gtk-theme/testing 1.3-1 all [pouvant être mis à jour depuis : 1.2-1]
caja-common/testing 1.20.3-1 all [pouvant être mis à jour depuis : 1.16.6-1+deb9u1]
caja/testing 1.20.3-1+b1 amd64 [pouvant être mis à jour depuis : 1.16.6-1+deb9u1]
debian-mate-default-settings/testing 1.20.2-1 all [pouvant être mis à jour depuis : 1.16.1-1]
gir1.2-gtk-3.0/testing 3.24.5-1 amd64 [pouvant être mis à jour depuis : 3.22.11-1]
gir1.2-pango-1.0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
greybird-gtk-theme/testing 3.22.10-1 all [pouvant être mis à jour depuis : 3.22.0-1]
gtk2-engines-murrine/testing 0.98.2-2 amd64 [pouvant être mis à jour depuis : 0.98.1.1-6]
gtk2-engines-pixbuf/testing 2.24.32-3 amd64 [pouvant être mis à jour depuis : 2.24.31-2]
gtk2-engines/testing 1:2.20.2-5 amd64 [pouvant être mis à jour depuis : 1:2.20.2-3]
libcaja-extension1/testing 1.20.3-1+b1 amd64 [pouvant être mis à jour depuis : 1.16.6-1+deb9u1]
libexo-1-0/testing 0.12.4-1 amd64 [pouvant être mis à jour depuis : 0.10.7-1]
libexo-helpers/testing 0.12.4-1 amd64 [pouvant être mis à jour depuis : 0.10.7-1]
libgail-3-0/testing 3.24.5-1 amd64 [pouvant être mis à jour depuis : 3.22.11-1]
libgail-common/testing 2.24.32-3 amd64 [pouvant être mis à jour depuis : 2.24.31-2]
libgail18/testing 2.24.32-3 amd64 [pouvant être mis à jour depuis : 2.24.31-2]
libgimp2.0/testing 2.10.8-2 amd64 [pouvant être mis à jour depuis : 2.8.18-1+deb9u1]
libgtk-3-0/testing 3.24.5-1 amd64 [pouvant être mis à jour depuis : 3.22.11-1]
libgtk-3-bin/testing 3.24.5-1 amd64 [pouvant être mis à jour depuis : 3.22.11-1]
libgtk2.0-0/testing 2.24.32-3 amd64 [pouvant être mis à jour depuis : 2.24.31-2]
libgtk2.0-bin/testing 2.24.32-3 amd64 [pouvant être mis à jour depuis : 2.24.31-2]
libmarco-private1/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-desktop-2-17/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.2-2]
libmate-menu2/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
libmate-panel-applet-4-1/testing 1.20.5-1 amd64 [pouvant être mis à jour depuis : 1.16.2-1]
libmate-slab0/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-window-settings1/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmatekbd-common/testing 1.20.2-1 all [pouvant être mis à jour depuis : 1.16.0-2]
libmatekbd4/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
libmatemixer-common/testing 1.20.1-1 all [pouvant être mis à jour depuis : 1.16.0-2]
libmatemixer0/testing 1.20.1-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
libmateweather-common/testing 1.20.2-1 all [pouvant être mis à jour depuis : 1.16.1-2]
libmateweather1/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.1-2]
libpango-1.0-0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
libpango1.0-0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
libpangocairo-1.0-0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
libpangoft2-1.0-0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
libpangomm-1.4-1v5/testing 2.42.0-2 amd64 [pouvant être mis à jour depuis : 2.40.1-3]
libpangoxft-1.0-0/testing 1.42.4-6 amd64 [pouvant être mis à jour depuis : 1.40.5-1]
libwnck22/testing 2.30.7-6 amd64 [pouvant être mis à jour depuis : 2.30.7-5.1]
marco-common/testing 1.20.3-1 all [pouvant être mis à jour depuis : 1.16.1-1]
marco/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-backgrounds/testing 1.20.0-2 all [pouvant être mis à jour depuis : 1.16.0-1]
mate-control-center-common/testing 1.20.4-2 all [pouvant être mis à jour depuis : 1.16.1-1]
mate-control-center/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
mate-desktop-common/testing 1.20.4-2 all [pouvant être mis à jour depuis : 1.16.2-2]
mate-desktop-environment-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
mate-desktop/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.2-2]
mate-icon-theme/testing 1.20.3-1 all [pouvant être mis à jour depuis : 1.16.2-1]
mate-menus/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
mate-panel-common/testing 1.20.5-1 all [pouvant être mis à jour depuis : 1.16.2-1]
mate-panel/testing 1.20.5-1 amd64 [pouvant être mis à jour depuis : 1.16.2-1]
mate-polkit-common/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
mate-polkit/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
mate-session-manager/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-settings-daemon-common/testing 1.20.4-1 all [pouvant être mis à jour depuis : 1.16.2-1]
mate-settings-daemon/testing 1.20.4-1 amd64 [pouvant être mis à jour depuis : 1.16.2-1]
mate-terminal-common/testing 1.20.2-2 all [pouvant être mis à jour depuis : 1.16.3-1]
mate-terminal/testing 1.20.2-2 amd64 [pouvant être mis à jour depuis : 1.16.3-1]
mate-themes/testing 3.22.18-1 all [pouvant être mis à jour depuis : 3.22.11-1+deb9u1]
mate-user-guide/testing 1.20.2-1 all [pouvant être mis à jour depuis : 1.16.0-1]
menu-xdg/testing 0.6 all [pouvant être mis à jour depuis : 0.5]
python-mate-menu/testing 1.20.2-1 amd64 [pouvant être mis à jour depuis : 1.16.0-2]
thunar-data/testing 1.8.4-1 all [pouvant être mis à jour depuis : 1.6.11-1]
thunar/testing 1.8.4-1 amd64 [pouvant être mis à jour depuis : 1.6.11-1]
xfce4-settings/testing 4.12.4-1 amd64 [pouvant être mis à jour depuis : 4.12.1-1]
xfdesktop4-data/testing 4.12.4-2 all [pouvant être mis à jour depuis : 4.12.3-3]
xfdesktop4/testing 4.12.4-2 amd64 [pouvant être mis à jour depuis : 4.12.3-3]
 



bon xfce est cassé mais pas grave

la je suis bloqué , la version des backports de stretch est identique a buster et et sid , donc inutile de tenter l'upgrade , je vais tomber sur le même souci .
donc il y a bien un souci avec cette configuration matérielle et uniquement la version de mate de testing .
je vois pas trop comment je peu m'en sortir ou déterminer qui ou quoi pose problème .
et lors de la mise a jour des paquets de mate , j'ai pas noté les quel qui ont provoqué cette corruption de l'affichage.
rappel : Mate + lightdm + Buster + Asus Prime B350M-A + Raven Ridge R3 2200G (driver libre amdgpu + mesa 18 )


apt-cache policy mate-core
 


retour


mate-core:
  Installé : 1.16.0+1
  Candidat : 1.20.0+5
 Table de version :
     1.20.0+5 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
     1.20.0+5~bpo9+1 100
        100 http://ftp.fr.debian.org/debian stretch-backports/main amd64 Packages
 *** 1.16.0+1 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
 



si quelqu'un a une idée   hmm

Dernière modification par robert2a (06-05-2019 15:50:12)

Hors ligne

#16 06-05-2019 16:48:42

èfpé
Membre
Inscription : 10-07-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour [en passant] !

robert2a a écrit :

pour le live, pas pensé, et je ne sais pas si cela existe actuellement pour buster.


Oui ça existe ; les constructions hebdomadaires automatiques ont repris il y a déjà un bon moment.

Hors ligne

#17 06-05-2019 17:12:33

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour

ok je regarde pour mettre a jour mon live de stretch sur clé usb en live buster + mate , mais sans firmware ça risque de coincer .
=> https://cdimage.debian.org/images/buste … so-hybrid/
ps: voir sur les iso non officiel avec le nonfree si je trouve mon bonheur .
a priori oui  =>  https://cdimage.debian.org/images/unoff … so-hybrid/

sinon actuellement je suis dans cet état avec un apt ugrade (bureau fonctionnel )
le sources.list de buster uniquement (situation normale )


apt -s upgrade
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libexempi3 libgtop-2.0-10 libpango1.0-0 libpangox-1.0-0 libunique-3.0-0 mate-backgrounds
Veuillez utiliser « apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  fonts-cantarell libamd2 libayatana-appindicator3-1 libayatana-ido3-0.4-0 libayatana-indicator3-7 libbabl-0.1-0 libcamd2 libccolamd2 libcholmod3 libcolamd2 libdbusmenu-glib4
  libdbusmenu-gtk3-4 libexempi8 libgegl-0.4-0 libgegl-common libgexiv2-2 libilmbase23 libmetis5 libopenexr23 libraw19 librda-common librda0 libsdl1.2debian
  libsuitesparseconfig5 libumfpack5 libxpresent1
Les paquets suivants seront mis à jour :
  bluebird-gtk-theme caja caja-common debian-mate-default-settings gir1.2-gtk-3.0 gir1.2-pango-1.0 greybird-gtk-theme gtk2-engines gtk2-engines-murrine libcaja-extension1
  libgail-3-0 libgimp2.0 libgtk-3-0 libgtk-3-bin libmarco-private1 libmate-desktop-2-17 libmate-menu2 libmate-panel-applet-4-1 libmate-slab0 libmate-window-settings1
  libmatekbd-common libmatekbd4 libmatemixer-common libmatemixer0 libmateweather-common libmateweather1 libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libpangomm-1.4-1v5 libpangoxft-1.0-0 libwnck22 marco marco-common mate-backgrounds mate-control-center mate-control-center-common mate-core mate-desktop mate-desktop-common
  mate-desktop-environment-core mate-icon-theme mate-menus mate-panel mate-panel-common mate-polkit mate-polkit-common mate-session-manager mate-settings-daemon
  mate-settings-daemon-common mate-terminal mate-terminal-common mate-themes mate-user-guide menu-xdg python-mate-menu
57 mis à jour, 26 nouvellement installés, 0 à enlever et 0 non mis à jour.
 

Hors ligne

#18 07-05-2019 15:27:50

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour
le bureau toujours correct , voici ce qui me reste a mettre a jour (l'iso live nonfree pas testé encore )


apt list --upgradable
 



En train de lister... Fait
libmarco-private1/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-slab0/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-window-settings1/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmatekbd-common/testing 1.20.2-1 all [pouvant être mis à jour depuis : 1.16.0-2]
libwnck22/testing 2.30.7-6 amd64 [pouvant être mis à jour depuis : 2.30.7-5.1]
marco-common/testing 1.20.3-1 all [pouvant être mis à jour depuis : 1.16.1-1]
marco/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-control-center-common/testing 1.20.4-2 all [pouvant être mis à jour depuis : 1.16.1-1]
mate-control-center/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
mate-desktop-environment-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
 



"A propos de Mate" me dit version 1.20.4
il manque surtout les  "core" et "marco" en mise a jour , pour aujourd'hui ça suffira , il va peut être rentrer des mises a jours de Mate prochainement . roll
ps: a moins que le bug ne soit plus présent , mais je ne pense pas  hmm

=>  https://pix.toile-libre.org/?img=1557237370.jpg
=>  https://mate-desktop.org/it/blog/2019-0 … -released/


The MATE panel has gotten a crazy amount of rework to make it work with Wayland display backend
 


pour Buster , la 1.20  =>  https://mate-desktop.org/it/blog/2018-0 … -released/
pour les paquets je suis bloqué ( dépendances ) , sinon de mettre a jour l'ensemble .


libmarco-private1/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-slab0/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
libmate-window-settings1/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
marco-common/testing 1.20.3-1 all [pouvant être mis à jour depuis : 1.16.1-1]
marco/testing 1.20.3-1 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-control-center-common/testing 1.20.4-2 all [pouvant être mis à jour depuis : 1.16.1-1]
mate-control-center/testing 1.20.4-2 amd64 [pouvant être mis à jour depuis : 1.16.1-1]
mate-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
mate-desktop-environment-core/testing 1.20.0+5 all [pouvant être mis à jour depuis : 1.16.0+1]
 

Dernière modification par robert2a (07-05-2019 16:10:34)

Hors ligne

#19 18-05-2019 15:20:34

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour

un paquet date de novembre 2015 , uniquement sur testing Mate pour moi (absent de stretch + mate)
libxpresent1  =>  https://tracker.debian.org/pkg/libxpresent

=>  https://packages.debian.org/sid/libxpresent1

j'ai pas trouvé comment ne pas installé ce paquet , il est lié au bureau mate

la machine est propre


aptitude search ?obsolete
 



i A linux-headers-4.19.0-4-amd64                                   - Header files for Linux 4.19.0-4-amd64                                    
i A linux-headers-4.19.0-4-common                                  - Common header files for Linux 4.19.0-4                                  
i A linux-image-4.19.0-4-amd64                                     - Linux 4.19 for 64-bit PCs (signed)  
 



voila la liste des paquets qui peuvent poser problème


apt-get -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libmarco-private1 libmate-slab0 libmate-window-settings1 marco marco-common mate-control-center mate-core mate-desktop-environment-core
Les paquets suivants seront mis à jour :
  mate-control-center-common
1 mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à jour.
Inst mate-control-center-common [1.16.1-1] (1.20.4-2 Debian:testing [all])
Conf mate-control-center-common (1.20.4-2 Debian:testing [all])
 



un "apt-get dist-upgrade" a tout mit a jour + installé le paquet "libxpresent1"
le bug (corruption du bureau ) est de nouveau présent .

Dernière modification par robert2a (18-05-2019 15:31:17)

Hors ligne

#20 19-05-2019 06:54:31

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Tu as testé un Live, s’il y en a un récemment construit ?

Hors ligne

#21 28-08-2019 04:31:56

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour
je suis toujours en testing avec cette machine , bureau xfce4
mais maintenant j'ai un bel écran vert comme bureau (il y a eu des paquets de xfce4 qui ont été mit a jour , mais pas noté ).
donc retour a mate-core qui fonctionne maintenant correctement  smile
je me suis retrouvé avec "weston" comme choix de bureau (defaut , xfce4 , mate ,weston )
donc j'ai voulu purgé wayland , a priori on peu pas sans casser les bureaux. (j'ai pu enlever quelques paquets quand même )
A suivre tongue

Hors ligne

#22 28-08-2019 12:41:56

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonjour
ce matin mise a jour de quelques paquets xfce4 (version 4.14) et a priori je suis passé de gtk2 a gtk3 . (a la fin de la mise a jour , il m'a demandé de retirer les paquets gtk2).
on verra au prochain reboot.
j'ai pas préciser mais le gestionnaire de connexion fonctionne bien (lightdm) , le serveur X aussi , c'est a l'entrée sur le bureau , une belle page verte uniforme .

Hors ligne

#23 18-11-2020 03:20:20

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

Bonsoir
une petite remarque sur le R3 2200G  ( la première version )
j'ai enfin le gpu qui est bien reconnu dans le log de X  smile


[     9.885] (--) AMDGPU(0): Chipset: "AMD Radeon(TM) Vega 8 Graphics" (ChipID = 0x15dd)
 



ps: sur buster il est inconnu
comme warning il reste ceci


nov. 18 02:00:25 raven2200g kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
 


qui correspond a ce matériel


00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
 



nota:
le noyau doit prendre en charge les alimentations Corsair par l' USB pour donner diverses informations  (sûrement sur le prochain noyau 5.10 ou supérieur )

plus de soucis d'affichage depuis le passage de buster en stable sur mate (actuellement je suis en bullseye )

Hors ligne

#24 18-11-2020 04:08:38

robert2a
Membre
Inscription : 15-11-2014

Re : Bug affichage sur mate+gdm3+buster Raven Ridge

a propos de l'alimentation Corsair , le module est pris en charge par le noyau


Bus 001 Device 002: ID 1b1c:1c00 Corsair Controller for Corsair Link
 



reste a savoir pour le logiciel propriétaire sous windows10 comment cela va être géré sous debian (ou sous GNU Linux en général )

cela existe => https://snapcraft.io/install/opencorsairlink/debian
mais je testerai pas , ce n'est pas dans les dépôts debian

nota: j'ai trouvé des traces de l'utilitaire "corsairlink" depuis 2014 pour linux (certain matériel ) , mais le constructeur ne fournit aucun support a par pour windows10
a priori pas que pour les alimentations .
je n'est jamais testé , même sous windows  tongue

Dernière modification par robert2a (18-11-2020 04:39:59)

Hors ligne

Pied de page des forums