Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-05-2019 10:48:28

davidson_lvr
Membre
Inscription : 19-05-2019

APT-GET update ne fonctionne plus

Bonjour,

j'ai un problème au niveau de ma commande apt-get upgrade; quand je la lance un message d'erreur apparait :

W: Duplicate sources.list entry http://security.debian.org/  jessie/updates/main i386 Packages (/var/lib/apt/lists/security.debian.org_dists_jessie_updates_main_binary-i386_Packages)

W: Duplicate sources.list entry http://deb.debian.org/debian/  jessie/main i386 Packages (/var/lib/apt/lists/security.debian.org_debian_dists_jessie_main_binary-i386_Packages)


W: Vous pouvez lancer "apt-get update" pour corriger ces problèmes.


ET quand je lance "apt-get update" :

W : Impossible de récupérer http://ftp.debian.org/debian/dists/jess … /InRelease
Impossible de trouver l'entrée "main/source/Sources" attendue dans le fichier "Release" : ligne non valable dans sources.list ou fichier corrompu

E : Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.


SVP j'ai vraiment besoin d'aide parce que c'est un projet que je dois réussir pour mon BTS... Merci d'avance

Hors ligne

#2 19-05-2019 11:04:42

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

Bonjour et Bienvenue smile

Comme souvent en informatique, tu as toutes les réponses dans les retours du système wink

W: Duplicate sources.list entry ...


et

ligne non valable dans sources.list ou fichier corrompu



Si tu as eu quelques cours sur Debian, il y a d'assez fortes chances que tu ais entendu parler du (des) fichier(s) sources.list. Or, les retours t'indiquent qu'un problème existe dans ce/ces fichiers ... que tu ne nous montres pas tongue


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#3 19-05-2019 11:22:36

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

mon fichier nano /etc/apt/sources.list contient ça :


# deb cdrom : [Debian GNU/Linux 7.6.0 _Wheezy_ - Official i386 CD  Binary-1 20140712-13:02]/ wheezy main

# deb cdrom : [Debian GNU/Linux 7.6.0 _Wheezy_ - Official i386 CD  Binary-1 20140712-13:02]/ wheezy main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for you mirror of choice

deb http://deb.debian.org/debian/ jessie main
deb-src http://ftp.debian.org/debian/ jessie-updates main

#paquet non free
deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free

Hors ligne

#4 19-05-2019 11:28:00

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

Y a des doublons comme c'était indiqué dans le message d'erreur.

Tes deux dernières lignes, en fait.

Dernière modification par otyugh (19-05-2019 11:29:27)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#5 19-05-2019 11:31:43

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

Comment je pourrais modifier cela pour que ça fonctionne svp ??

Hors ligne

#6 19-05-2019 12:01:24

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

Comme tu es un futur technicien, je vais te répondre comme je réponds aux apprentis (même si je ne bosse pas dans l'informatique, le principe reste le même tongue ). Pour le coup, c'est purement une question de mode d'emploi, la question se trouve donc dans le mode d'emploi wink On pourrait donc te répondre Read The Famous Manual

man sources.list


Tu as aussi l possibilité d'écumer les wikis. On en a un ici, qui te renverait là https://debian-facile.org/doc:systeme:apt:sources.list smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#7 19-05-2019 12:09:12

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

(J'ai toujours trouvé le sources.list assez "logique" pour être compris de manière empirique - mais c'est un mauvais conseil à donner je suppose tongue)

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#8 19-05-2019 12:18:55

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

avant de créer ce topic, j'ai déjà cherché partout et à l'heure actuelle je suis vraiment au bout du rouleau... est-ce possible que vous m'aidiez svp ?
Qu'est-ce que je dois modifier pour que ma commande fonctionne ? ( A la finalité je dois installer SNORT )

Dernière modification par davidson_lvr (19-05-2019 12:19:50)

Hors ligne

#9 19-05-2019 12:32:01

fiche
Membre
Lieu : Paris
Distrib. : Debian stable Buster
Noyau : Linux 4.19.0-6-686
(G)UI : Xfce
Inscription : 11-07-2016

Re : APT-GET update ne fonctionne plus

Bonjour,

Le bon fichier sources.list doit contenir ces lignes (https://debian-facile.org/doc:systeme:a … ist:jessie) :

Pour éditer le fichier sources.list :
sudo apt edit-sources
puis taper 1 pour l'éditer avec nano
faire les modifications
Ctrl X
répondre O (oui)
Valider avec Entrée


# Debian Jessie, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free

Ce que je trouve étonnant, c'est que Debian modifie les adresses des dépôts de Jessie sans avertir personne.
Dans le meilleur des mondes, une mise à jour aurait transformer le fichier sources.list pour le rendre compatible avec les nouvelles adresses !

Il ne faut pas s'étonner que l'on voit plusieurs sujets sur ce thème depuis quelque temps.

Dernière modification par fiche (19-05-2019 12:42:11)

Hors ligne

#10 19-05-2019 12:42:56

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

Merci pour l'aide, du coup j'ai mis en commentaire les autres lignes et j'ai laissé les 2 telles qu'elles étaient.

Du coup j'ai lancé apt-get update il dit ça :

Ign http://deb.debian.org jessie InRealease

et je lance apt-get upgrade je n'ai pas de MàJ, 0 nouvellement installés et 0 à enlever

du coup je lance apt-get install snort il me dit :
E: Impossible de trouver le paquet snort...

Que faire svp ? sad

Hors ligne

#11 19-05-2019 12:49:13

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

Package: snort on amd64 -- buster: 2.9.7.0-5; sid: 2.9.7.0-5; stretch: 2.9.7.0-5


Snort n'existe pas pour jessie. Y a pas de backport officiel disponible on dirait, donc c'est mal barré pour être facile, ton histoire... :x

Tu peux le compiler toi-même (mais aucune garantie)

#Ajouter les sources stretch
echo "deb-src http://deb.debian.org/debian/ stretch main contrib non-free" >> /etc/apt/sources.list
#Télécharger les sources que je viens d'ajouter
apt update
#construire les dépendances de construction de snort
apt-get build-dep snort
#construire snort
apt-get -b source snort



Si tout se passe bien tu obtiendra un .deb installable en faisant "dpkg -i XXX.deb".

Dernière modification par otyugh (19-05-2019 12:54:41)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#12 19-05-2019 12:52:14

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

@fiche : je ne vois pas la différence ( et diff non plus une fois les commentaires supprimés) entre ton sources.list et les 2 dernières lignes de celui de davidson_lvr scratchhead.gif

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#13 19-05-2019 12:55:11

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

Ah merde... et c'est possible que je retourne sur wheezy pour installer snort ou c'est impossible ?

Hors ligne

#14 19-05-2019 13:03:16

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

davidson_lvr a écrit :

Ah merde... et c'est possible que je retourne sur wheezy pour installer snort ou c'est impossible ?


Comme tu peux le voir dans ma citation, y a pas wheezy dans la liste. Snort n'est arrivé dans les dépots officiels debian qu'à partir de stretch, la version précédant jessie.


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#15 19-05-2019 13:11:18

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

ah je vois. mais je comprends pas : je viens de tester l'installation du paquet libssl-deb et il me dit qu'il ne trouve pas le paquet.. Ce serait pas un problème qui vient d'ailleurs ? scratchhead.gif

Hors ligne

#16 19-05-2019 13:37:03

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : APT-GET update ne fonctionne plus

Bonjour,

Snort est un renifleur/enregistreur de paquets basé sur libpcap qui peut être utilisé comme un système de détection d'intrusion réseau léger. Il dispose d'une journalisation basée sur des règles et peut effectuer une recherche de contenu/appariement en plus de détecter une variété d'autres attaques et sondes, telles que les débordements de tampon, les analyses de ports furtifs, les attaques CGI, les sondes SMB, et bien plus encore. Snort a une capacité d'alerte en temps réel, avec des alertes envoyées à syslog, un fichier d'alerte séparé, ou même à un ordinateur Windows via Samba.


C’est quel BTS qui te demande d’utiliser snort ?
C’est ton portable/ordinateur personnel ?
Si c’est oui le mieux serait de migrer vers stretch
Si c’est le portable prêté par ta formation, il faut contacter l’enseignant et/ou le responsable informatique pour qu’il fasse la mîse à niveau.


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#17 19-05-2019 14:05:12

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

Ou alors démarres sur un live de tails ?

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#18 19-05-2019 14:14:35

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

otyugh a écrit :

la version précédant jessie

Suivant Jessie plutôt wink


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#19 19-05-2019 14:19:12

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

C’est quel BTS qui te demande d’utiliser snort ? ---
dans le cadre du BTS on a une épreuve qui se tourne sur un projet et mon projet dois favoriser l'utiliser l'utilisation de snort

C’est ton portable/ordinateur personnel ?

Oui c'est le mien
Si c’est oui le mieux serait de migrer vers stretch
Comment je pourrais faire ? si je le fais, est-ce que ça fonctionnera ?
Si c’est le portable prêté par ta formation, il faut contacter l’enseignant et/ou le responsable informatique pour qu’il fasse la mîse à niveau.

En fait, les machines virtuelles ( c'est un routeur dans ce cas) sont fournies par mon prof de la formation, au début d'année ça fonctionnait correctement. Et depuis qu'il a décidé de passer sur jessie, RIEN ne fonctionne et mon évaluation est pour jeudi donc si rien ne fonctionne je peux clairement assuré que je n'aurais pas le diplôme parce qu'elle est coef 4..

Bien évidemment j'ai demandé de l'aide à mon prof mais il m'a clairement fait comprendre que ce n'était pas son problème et que je devais me débrouiller...

Hors ligne

#20 19-05-2019 14:34:30

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : APT-GET update ne fonctionne plus

Je vois pas trop l'intêret de se "faire fournir une image VM" pour une ancienne version de debian...Quand installer un debian en VM à partir de l'installateur officiel sous stretch prend cinq minutes chrono.

Sinon sans faire de migration compliquée, tu as essayé mes instructions de compiler le paquet toi-même ? C'est une bonne solution si le prof a mis des trucs spéciaux dans la VM qu'il a fourni...

Dernière modification par otyugh (19-05-2019 14:37:25)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#21 19-05-2019 14:57:16

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

Bah franchement le fait qu'il m'aide prendrait 15 min top chrono parce qu'il a déjà régler ce problème. Mais bon... je commenterais pas mais je n'en pense pas moins dans ma tête smile

J'ai essayé de compiler moi-même; la 1ère commande marche nickel, mais quand je fais "apt update" j'ai plein de messages d'erreurs... du genre "impossible de resoudre "deb.debian.org" ou encore impossible de récupérer http://deb.debian.org/debian/dists/jessie/InRelease

j'en ai plein comme ça... J'suis au bout du rouleau et au bord du gouffre...

Hors ligne

#22 19-05-2019 15:16:29

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

davidson_lvr a écrit :

j'ai plein de messages d'erreurs... du genre "impossible de resoudre "deb.debian.org"

Et résoudre un nom de domaine ne t'évoque rien ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#23 19-05-2019 15:28:01

davidson_lvr
Membre
Inscription : 19-05-2019

Re : APT-GET update ne fonctionne plus

Non, ça ne m'évoque rien... Qu'est-ce que je devrais faire ?

Hors ligne

#24 19-05-2019 15:39:29

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.2.0-3 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : APT-GET update ne fonctionne plus

tapes tout ce bloc en root :
(copier - coller)

cat > /etc/apt/sources.list  << EOF
# Debian Jessie, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ jessie main contrib non-free
# Debian Jessie, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
EOF


et poste nous le retour de la commande suivante

cat -n /etc/apt/sources.list


puis :

apt update


et poste le retour



arf ! je  crois que j'ai pris le sujet en cours de route , là

pardon pour le cafouillage .

Dernière modification par Debian Alain (19-05-2019 16:30:08)


1498812139.jpg Nightwish - Last Ride Of The Day (With Lyrics)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#25 19-05-2019 15:47:24

bendia
Chadministrateur
Distrib. : Buster, Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : APT-GET update ne fonctionne plus

Je dirais que ta machine a au moins un problème de résolution DNS. Dans mon contexte d'informatique domestique,la cause la plus fréquente est que j'ai un problème de connexion internet (la box est tombée ou un truc du genre).

Je n'ai pas bien pigé l'environnement dans lequel tu te trouves (une Debian dans une VM sur ton portable perso qui lui, n'a pas de soucis de connexion ?), mais avec de telles messages, je me poserais la question de ma connexion internet wink

La réponse précise va dépendre du contexte précis, et ne pourra pas être donnée sans toutes les données (les commandes passées précisément, et les retours complet des commandes, entre des balises codes histoire qu'on y vois plus clair tongue )

Deux petit trucs à lire histoire qu'il soit plus simple de t'aider Voir le tuto : Le code, ça pique moins les yeux en couleur et Voir le tuto : Manuel du chocolat DF : « Ça marche pas ! » smile

Edit : Debian Alain, si tu essayes de rajouter de l'essence dans ta voiture électrique, ça ne va pas t'avancer à grand chose, il semble que le problème de sources.list ait été résolu plus haut, le problème n'est donc probablement plus là wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

Pied de page des forums