Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-06-2019 12:07:27

allandore
Membre
Inscription : 27-06-2019

[Résolu] Problème MAJ php 7.3 - unmet dependencies

Bonjour à tous,

Je viens poster ici mon souci car j'avoue être dans le flou total et avoir sûrement fait n'importe quoi.

Je possède un vps chez ovh sur lequel j'ai plusieurs wordpress, ça tourne sur Debian 9. Après une erreur sur l'un de ces wordpress, j'ai cru bon de mettre à jour la version de php pour voir si ça venait de là. J'étais en 7.2.14 je crois, je voulais update en 7.3 et c'est là que les ennuis ont commencé :

Après avoir fait tout un tas de manipulation dont je ne me souviens pas de la moitié, je n'ai plus de version de php actuellement, voici ce que cela donne quand j'essaie d'installer php

sudo apt install php7.3



ce qui me retourne

The following packages have unmet dependencies:
 php7.3 : Depends: libapache2-mod-php7.3 but it is not going to be installed or
                   php7.3-fpm but it is not going to be installed or
                   php7.3-cgi but it is not going to be installed



j'essaie donc d'installer ces packages à la main mais toujours des problèmes de dépendances, exemple :

The following packages have unmet dependencies:
 php7.3-fpm : Depends: php7.3-cli but it is not going to be installed
              Depends: php7.3-opcache but it is not going to be installed
              Depends: libc6 (>= 2.29) but 2.24-11+deb9u4 is to be installed



Dans tous les cas ça ne fonctionne pas et je pense que le problème vient justement de la dépendance libc6, lorsque j'essaie de la mettre à jour vu qu'apparemment il faut une version au moins en 2.29 j'ai ceci :

libc6 is already the newest version (2.24-11+deb9u4).
Calculating upgrade... Done
The following packages have been kept back:
  libssl-dev



Un apt list --upgradable donne ceci :

libgd3/disco 2.2.5-5.1+ubuntu19.04.1+deb.sury.org+1 amd64 [upgradable from: 2.2.5-5+0~20181028223040.1+stretch~1.gbp911a4a]
libssl-dev/disco 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1 amd64 [upgradable from: 1.1.1b-1+0~20190228092419.10+stretch~1.gbp729d89]
libssl1.1/disco 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1 amd64 [upgradable from: 1.1.1b-1+0~20190228092419.10+stretch~1.gbp729d89]



Quand je tente l'upgrade du premier, libgd3/disco :

The following packages have unmet dependencies:
 libgd3 : Depends: libc6 (>= 2.29) but 2.24-11+deb9u4 is to be installed
          Depends: libfontconfig1 (>= 2.12.6) but 2.11.0-6.7+b1 is to be installed
          Depends: libjpeg8 (>= 8c) but it is not installable
E: Broken packages



Le deuxième, libssl-dev/disco :

The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.1 (= 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1) but 1.1.1b-1+0~20190228092419.10+stretch~1.gbp729d89 is to be installed
E: Broken packages



Le dernier libssl1.1/disco :

The following packages have unmet dependencies:
 libssl1.1 : Depends: libc6 (>= 2.25) but 2.24-11+deb9u4 is to be installed
E: Broken packages



Donc on en revient à ce fameux libc6

Peut-être rien à voir avec ce libc6 mais lorsque je tente un simple apt-get update j'ai ceci :

Ign:1 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan InRelease
Hit:2 http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease
Ign:3 http://deb.debian.org/debian stretch InRelease
Hit:4 http://deb.debian.org/debian-security stretch/updates InRelease
Hit:5 http://deb.debian.org/debian stretch-updates InRelease
Hit:6 http://deb.debian.org/debian stretch Release
Ign:7 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan Release
Hit:8 https://packages.sury.org/php stretch InRelease
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Ign:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Ign:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Ign:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Ign:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Ign:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Ign:9 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main all Packages
Err:10 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main amd64 Packages
  404  Not Found
Ign:11 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en_US
Ign:12 http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan/main Translation-en
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/ondrej/apache2/ubuntu/dists/eoan/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.



Enfin voici le contenu de mon /etc/apt/sources.list :

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free



Comme vous l'aurez compris je suis bien paumé, j'ai essayé de vous mettre un max d'infos pour vous orienter au mieux mais n'hésitez pas à me demander quoi que ce soit. Au vu de tout ce que j'ai écrit auriez-vous une piste à me suggérer ?

Merci beaucoup pour vos réponses.

Dernière modification par allandore (27-06-2019 17:46:41)

Hors ligne

#2 27-06-2019 12:59:32

allandore
Membre
Inscription : 27-06-2019

Re : [Résolu] Problème MAJ php 7.3 - unmet dependencies

Petite précision, après un

grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*



J'obtiens ceci :

/etc/apt/sources.list:## Note, this file is written by cloud-init on first boot of an instance
/etc/apt/sources.list:## modifications made here will not survive a re-bundle.
/etc/apt/sources.list:## if you wish to make changes you can:
/etc/apt/sources.list:## a.) add 'apt_preserve_sources_list: true' to /etc/cloud/cloud.cfg
/etc/apt/sources.list:##     or do the same in user-data
/etc/apt/sources.list:## b.) add sources in /etc/apt/sources.list.d
/etc/apt/sources.list:## c.) make changes to template file /etc/cloud/templates/sources.list.debian.tmpl
/etc/apt/sources.list:###
/etc/apt/sources.list:# See http://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.html
/etc/apt/sources.list:# for how to upgrade to newer versions of the distribution.
/etc/apt/sources.list:# deb http://deb.debian.org/debian stretch main contrib non-free
/etc/apt/sources.list:# deb-src http://deb.debian.org/debian stretch main contrib non-free
/etc/apt/sources.list:## Major bug fix updates produced after the final release of the
/etc/apt/sources.list:## distribution.
/etc/apt/sources.list:deb http://deb.debian.org/debian stretch main contrib non-free
/etc/apt/sources.list:deb-src http://deb.debian.org/debian stretch main contrib non-free
/etc/apt/sources.list:deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
/etc/apt/sources.list:deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
/etc/apt/sources.list:
/etc/apt/sources.list:deb http://deb.debian.org/debian stretch-updates main contrib non-free
/etc/apt/sources.list:deb-src http://deb.debian.org/debian stretch-updates main contrib non-free
/etc/apt/sources.list:
/etc/apt/sources.list:## Uncomment the following two lines to add software from the 'backports'
/etc/apt/sources.list:## repository.
/etc/apt/sources.list:##
/etc/apt/sources.list:## N.B. software from this repository may not have been tested as
/etc/apt/sources.list:## extensively as that contained in the main release, although it includes
/etc/apt/sources.list:## newer versions of some applications which may provide useful features.
/etc/apt/sources.list:# deb http://deb.debian.org/debian stretch-backports main contrib non-free
/etc/apt/sources.list:# deb-src http://deb.debian.org/debian stretch-backports main contrib non-free
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:deb http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list.save:deb http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list.save:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list.save:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list.save:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list.save:# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
/etc/apt/sources.list.d/php.list:deb https://packages.sury.org/php/ stretch main
/etc/apt/sources.list.d/php.list.save:deb https://packages.sury.org/php/ stretch main



Je pense avoir installé des choses à partir du mauvais endroit, après un apt-cache policy openssl :


openssl:
  Installed: 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1
  Candidate: 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1
  Version table:
 *** 1.1.1c-1+ubuntu19.04.1+deb.sury.org+1 500
        500 http://ppa.launchpad.net/ondrej/php/ubuntu disco/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1.1b-1+0~20190228092419.10+stretch~1.gbp729d89 500
        500 https://packages.sury.org/php stretch/main amd64 Packages
     1.1.0j-1~deb9u1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        500 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages
 

Dernière modification par allandore (27-06-2019 13:16:46)

Hors ligne

#3 27-06-2019 13:52:00

sebr
Membre
Inscription : 31-01-2019

Re : [Résolu] Problème MAJ php 7.3 - unmet dependencies

Je ne suis pas un pro mais tu as le même genre de problème que moi mais pour apache, des personnes m'ont indiqué plusieurs chose à faire dans mon sujet qui pourrait peut être t'aider: https://debian-facile.org/viewtopic.php?id=24623
Pourquoi ne pas tenter un remove de php7.3 puis un autoremove pour supprimer les paquets non utilisé puis ensuite une installation de php7.2. A moins que tu souhaite absolument garde le 7.3.

Hors ligne

#4 27-06-2019 17:45:23

allandore
Membre
Inscription : 27-06-2019

Re : [Résolu] Problème MAJ php 7.3 - unmet dependencies

Merci pour ta réponse.

J'ai tenté plusieurs choses, j'ai réussi finalement à installer php 7.3 mais mes sites n'apparaissaient plus.

Finalement j'ai utilisé un point de restauration serveur (snapshot) que j'avais fait via l'interface admin d'OVH. Je suis de nouveau en 7.2.14 mais curieusement le problème d'origine sur le wordpress n'est plus là.

Bref sujet à moitié résolu smile

Hors ligne

Pied de page des forums