Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-06-2019 16:29:05

kazem
Membre
Inscription : 29-06-2019

[Résolu] : Internet Oui mais pas https

Bonjour

Me voici de retour sous mon Os favori debian 8.  Apres quelques petits problèmes de réglage wifi, graphique, ouf, je sais pas ce qui c'est passé pour que je ne puisse
plus me connecter aux URL sécurisé https (via chrome, firefox, etc ). Enfin, je suis ici ( https://debian-facile.org/post.php?fid=16) mais j’étais obligé d'emprunter le PC
de voisin pour envoyer le message.

Je vous remercie d'avance si vous avez une idée ou un URL ( non https ) pour m'aider


Voila le message renvoyer par mon navigateur

Ce site est inaccessible
impossible de trouver l'adresse IP de serveur http://www.boursorama.com/
Dns_Probe_Finished_nxdomain

Bizarement j'arrive à lire mes mail sur htpps://mail.google.com

Dernière modification par kazem (30-06-2019 11:39:48)

Hors ligne

#2 29-06-2019 16:40:40

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] : Internet Oui mais pas https

Le message d'erreur suggère une erreur de résolution DNS, mais cela devrait affecter indifféremment HTTP et HTTPS.
Tu as essayé avec autre chose qu'un navigateur, par exemple avec wget ?

Il vaut mieux montrer que raconter.

Hors ligne

#3 29-06-2019 16:46:04

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [Résolu] : Internet Oui mais pas https

Bonjour,
Est-ce que tu peux corriger le lien qui pointe vers ton autre fil du forum car actuellement il n’est pas valide.
Je pensais que ton message était celui d’un spammeurs et si raleur  n’avait pas répondu, je supprimais les lìens actifs.

Hors ligne

#4 29-06-2019 17:10:10

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] : Internet Oui mais pas https

Il n'y a pas d'autre fil. C'est juste l'URL de la page de création d'un nouveau fil dans le forum "Réseau", qui était affiché au moment où kazem a composé son message ("je suis ici").

Il vaut mieux montrer que raconter.

Hors ligne

#5 29-06-2019 17:43:22

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Rebonjour et merci pour rapidité de votre réponse.

J'ai essayé sans succès ssh et sftp et ensuite, je suis tombé sur un #bug suite à la quelle, le système s'est remise à bloqué complètement, à croire une commande
chattr qui s'est passé sur la répertoire /etc.  Mon voisin étant sympa et comme moi, admirateur de chope, on va reprendre tout de 0 mais une installation via réseau

Je vous tiens au courant si on arrive à résoudre le problème

Hors ligne

#6 29-06-2019 17:50:34

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] : Internet Oui mais pas https

kazem a écrit :

J'ai essayé sans succès ssh et sftp et ensuite, je suis tombé sur un #bug suite à la quelle, le système s'est remise à bloqué complètement, à croire une commande chattr qui s'est passé sur la répertoire /etc.


Tout cela est bien vague, aucune info concrète à se mettre sous la dent...


Il vaut mieux montrer que raconter.

Hors ligne

#7 29-06-2019 18:39:17

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Salut

Désolé, me me voici avec debian 9 fraichement installé mais toujours la même probleme à savoir non acces aux URL https et pourtant j'arrive toujours lire mes emails sous
google ( https )

cat /etc/resolv.conf
# Generated by NetworkManager
nameserver fd0f:ee:b0::1

service NetworkManager stop  et je modifie resolv.conf

nameserver 80.67.169.12
nameserver 80.67.169.40

probleme est toujours la et ma la commande wget me donne toujours la même erreur

oot@home:/etc# wget http://www.site.org/rep/01/fichier.txt
--2019-06-29 19:22:13--  http://www.site.org/rep/01/fichier.txt
Résolution de www.site.org (www.site.org)… échec : Nom ou service inconnu.
wget : impossible de résoudre l'adresse de l'hôte « www.site.org »

Hors ligne

#8 29-06-2019 19:30:08

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] : Internet Oui mais pas https

kazem a écrit :

nameserver fd0f:ee:b0::1


Ça sort d'où ? C'est une adresse IPv6 ULA (locale), mais avec un préfixe qui est un peu trop "simple" pour avoir été généré avec la méthode recommandée, et qui n'est joignable que si le réseau local est configuré avec ce préfixe ou bien si cette adresse est gérée par le routeur IPv6 par défaut du réseau.
Par quoi est géré l'accès internet ?
On peut voir la sortie de

ip addr
ip -4 route
ip -6 route
 


kazem a écrit :

Résolution de www.site.org (www.site.org)… échec : Nom ou service inconnu.


Normal, ce nom de domaine n'existe pas. Prends-en un qui existe.


Il vaut mieux montrer que raconter.

Hors ligne

#9 29-06-2019 19:38:44

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Salut

Justement, j'ai pas demandé de domain, au moment d'installation, je n'ai donné que le nom de host "home"

root@home:/var/log# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:24:e8:d0:84:7c brd ff:ff:ff:ff:ff:ff
    inet6 2a01:e35:2fe4:9f20:41f2:265b:c800:b5a8/64 scope global temporary dynamic
       valid_lft 86314sec preferred_lft 85028sec
    inet6 2a01:e35:2fe4:9f20:224:e8ff:fed0:847c/64 scope global mngtmpaddr noprefixroute dynamic
       valid_lft 86314sec preferred_lft 86314sec
    inet6 fe80::224:e8ff:fed0:847c/64 scope link
       valid_lft forever preferred_lft forever

Hors ligne

#10 29-06-2019 19:42:26

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Désolé, mais je suis obligé d'utiliser l'ordi de voisin pour repondre  donc pas très pratique

root@home:/var/log# domainname
(none)
root@home:/var/log# hostname
home

Hors ligne

#11 29-06-2019 19:45:11

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] : Internet Oui mais pas https

pour aller dans le sens de ce qui a déjà été dit :

que donne : ???

wget https://www.debian.org/doc/manuals/debian-faq/debian-faq.fr.txt



(copier - coller)

Hors ligne

#12 29-06-2019 19:52:48

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] : Internet Oui mais pas https

kazem a écrit :

Justement, j'ai pas demandé de domain, au moment d'installation, je n'ai donné que le nom de host "home"


Quel rapport avec le fait d'essayer d'accéder à un site qui n'existe pas (ce qui retourne forcément une erreur) ?

Ton interface ethernet n'a pas d'adresse IPv4, donc la résolution de nom ne risque pas de marcher avec des DNS IPv4 comme ceux de FDN que tu as forcés, et tu ne peux atteindre aucun site qui n'est accessible qu'en IPv4 et pas en IPv6. Pourtant debian-facile.org est accessible en IPv6 donc tu devrais pouvoir y accéder. Vérifie la configuration de ta freebox, et de NetworkManager concernant IPv4.

Tu n'as pas donné le résultat des commmandes ip route.


Il vaut mieux montrer que raconter.

Hors ligne

#13 29-06-2019 20:21:08

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Je ne vois pas de rapport mais tant que je me souviens, à l'installation, tu as le choix de choisir un nom d'hote + dhcp. C'est ce que je fais avec Redhat et Windob
sur la même PC  mais tu as peut-être pas torde puisque pour l'instant, plus je creuse, moins j'avance. Comme on dit, la nuit porte conseil et surtout évite d'avoir
des problèmes avec la chef, je vais donc reprendre le tout demain

Meci encore

Hors ligne

#14 29-06-2019 23:24:49

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.8.0-2-amd64
(G)UI : LightDM et Xfce4
Inscription : 29-04-2015

Re : [Résolu] : Internet Oui mais pas https

Et en essayant  de joindre le site https://151.80.145.212/ est-ce que cela fonctionne ?

Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#15 30-06-2019 11:33:46

kazem
Membre
Inscription : 29-06-2019

Re : [Résolu] : Internet Oui mais pas https

Bonjour

Bon, problème résolu et me voici en wifi  avec l’accès URL en https.  Voici les étapes

1: Backup via dd de mon disque ( on sait jamais )
2:  apt remove, purge des paquets réseau
3:  reboot
4: installation de réseau Ethernet ( DHCP )
5 : test  ==> ok ip addr
6:  installation Wifi  :  https://wiki.debian.org/fr/iwlwifi

root@home:/tmp# cat /etc/hosts
127.0.0.1    localhost
127.0.1.1    home

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

oot@home:/tmp# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:24:e8:d0:84:7c brd ff:ff:ff:ff:ff:ff
3: wlp12s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:24:d6:22:e0:66 brd ff:ff:ff:ff:ff:ff
    inet wyz.xyz.1.15/24 brd wyz.xyz.1.255 scope global dynamic wlp12s0
       valid_lft 39636sec preferred_lft 39636sec
    inet6 2a01:e53:2f4e:92f0:302f:2e07:6553:9152/64 scope global noprefixroute dynamic
       valid_lft 86355sec preferred_lft 86355sec
    inet6 fe80::71d8:13d:d364:a785/64 scope link
       valid_lft forever preferred_lft forever


Merci beaucoup pour vos aides et un grand merci à mon voisin

Hors ligne

Pied de page des forums