Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 16-08-2019 10:39:10

Pierre16
Membre
Distrib. : debian_version 9 & 10
Noyau : Linux PC-Debian 3.16.0-4-686-pae #1 SMP Debian 3.1
(G)UI : XFCE 4-12
Inscription : 26-01-2017

Re : [Résolu] Installation digikam sur buster impossible

Avec grand plaisir.
Voici ....

HPDE10:~$ cat /etc/apt/sources.list
 



# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

#deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free


deb http://security.debian.org/debian-security buster/updates main contrib non-free

deb-src http://security.debian.org/debian-security buster/updates main  contrib non-free


# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free

deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

deb http://deb.debian.org/debian stretch-backports main

# stable deb-multimedia
deb http://www.deb-multimedia.org stable main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 


pit16@PC-HPDE10:~$ ls /etc/apt/sources.list.d/


google-chrome.list  spotify.list
 



pit16@PC-HPDE10:~$ cat /etc/apt/sources.list.d/*
 


### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
deb http://repository.spotify.com testing non-free

Hors ligne

#27 16-08-2019 10:44:36

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Installation digikam sur buster impossible

tu devrai retirer ceci de ton sources.list :

deb http://deb.debian.org/debian stretch-backports main



tes sources doivent  ressembler à ceci :


# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

#deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free


deb http://security.debian.org/debian-security buster/updates main contrib non-free

deb-src http://security.debian.org/debian-security buster/updates main  contrib non-free


# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free

deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# stable deb-multimedia
deb http://www.deb-multimedia.org stable main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 
 



regarde ici : https://debian-facile.org/doc:system:ap … ist:buster

Dernière modification par Debian Alain (16-08-2019 10:47:57)

En ligne

#28 16-08-2019 10:53:04

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Installation digikam sur buster impossible

Pour ma part, je déconseille les dépôts deb-multimedia, ça m'a mis le bazar plusieurs fois, va pourrait même être la cause du problème.

D'ailleurs, tu n'as pas expliqué ce que tu avais fait pour que ça fonctionne, là, on dirait que c'est tombé en marche par magie de la même façon que c'était tombé en panne wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#29 16-08-2019 11:05:54

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Installation digikam sur buster impossible

si bendia est de mon avis , je t'aurai bien dit de faire ceci , une fois les  sources corrigées :
mise à jour des sources :

apt update


mise à jour succinte des paquets :

apt upgrade


equivalent dist upgrade (mise à jour complète) :

apt full-upgrade


redémarrage

reboot


suivi de


quelle est la version ?

lsb_release -a


donne le résultat (normalement r.a.s.)


et enfin , pour vérifier :
paquets buster : lesquels  ?

dpkg -l | grep deb10


donne le résultat pour vérifier tes paquets . normalement , il doit y avoir une belle petite liste  


paquets deb-multimedia  : lesquels ?

dpkg -l | grep dmo


donnera le listing des paquets multimedia . s'il y en a beaucoup , c'est inquiétant .


bendia  a écrit :

Pour ma part, je déconseille les dépôts deb-multimedia, ça m'a mis le bazar plusieurs fois,


entièrement d'accord ,

bendia  a écrit :

va pourrait même être la cause du problème


oui . mais pour l'instant , on sait pas .

Dernière modification par Debian Alain (16-08-2019 16:47:18)

En ligne

#30 16-08-2019 16:30:27

Pierre16
Membre
Distrib. : debian_version 9 & 10
Noyau : Linux PC-Debian 3.16.0-4-686-pae #1 SMP Debian 3.1
(G)UI : XFCE 4-12
Inscription : 26-01-2017

Re : [Résolu] Installation digikam sur buster impossible

Pour Bendia,voici la commande réalisée pour installer digikam (proposée par Gerinald)

sudo apt-get install --no-install-recommends digikam



Je corrige le tir suivant vos propositions et reviens vers vous.

Dernière modification par Pierre16 (16-08-2019 16:32:44)

Hors ligne

#31 16-08-2019 16:31:43

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Debian Buster
Noyau : 4.19.0-9-amd64
(G)UI : Cinnamon
Inscription : 03-01-2011

Re : [Résolu] Installation digikam sur buster impossible

Bonjour Pierre16,

Content que tu en soit dépanné wink

A tu aussi installé Kipi ???

Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#32 16-08-2019 16:56:22

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Installation digikam sur buster impossible

Donc, en fait, la panne est contournée, mais si un des paquets recommandé par Digikam est à installer pour autre chose, ça reviendra.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#33 16-08-2019 17:03:20

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Debian Buster
Noyau : 4.19.0-9-amd64
(G)UI : Cinnamon
Inscription : 03-01-2011

Re : [Résolu] Installation digikam sur buster impossible

Bonjour Bendia,

Je suis sous Cinnamon, et j'utilise Digikam avec Kipi, l’installation est effectuée suivant le code transmis plus haut.

Depuis trois ans, je n'ai jamais eu de souci, et je peut te dire que je l'utilise avec quasi les 90% de ces possibilités wink

Tu va me dire qu'il reste les 10% .... mais c'est vraiment très minime wink

Par contre oui, si il ne veut pas de souci, il doit impérativement installé kipi smile

Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#34 16-08-2019 17:04:07

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Installation digikam sur buster impossible

bendia , es tu d'accord pour mon post #29 ?

rapport à la question de gerinald , peux tu nous renvoyer le retour de la commande suivante : ???

apt policy kipi-plugins


poste nous le retour

Dernière modification par Debian Alain (16-08-2019 17:06:34)

En ligne

#35 16-08-2019 17:38:51

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Installation digikam sur buster impossible

@Gerinald : As-tu eu le même problème en installant Digikam avec les paquets recommandés ? Si oui, il faut donc remonté au dessus, sinon, c'est que le cas de Pierre16 est différent smile Ta solution à permis l'installation de Digikam en contournant la cause primaire du problème, mais ça ne l'a pas réglé pour autant. Donc, comme je disais au dessus, si un des ces paquets posant problème est nécessaire, le problème se reproduira.

@Debian-Alain : dans une Debian Stable, ce que tu proposes n'est pas problématique. Je en listerait simplement pas les paquets issus de Buster, étant donné que c'est l'état attendu et qu'on ne pourra rien en déduire à mon sens.

Par contre lister les paquet deb-multimedia, là, c'est pertinent smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#36 16-08-2019 17:43:48

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Debian Buster
Noyau : 4.19.0-9-amd64
(G)UI : Cinnamon
Inscription : 03-01-2011

Re : [Résolu] Installation digikam sur buster impossible

@bendia :

Je n'ai aucun souci à l’installation que ce soit en mode graphique ou console.

La seule chose, c'est que via une installation classique, ça te met un paquet de dépendance KDE.

La commande que j'utilise diminue justement le nombre de dépendance dû à l'installation d'un programme dédié à KDE, sous un autre DE.

Et je le redit, je n'ai jamais eu de souci, et vu comment je triture mes distro, quand je les casses ou que j'ai des soucis, ce n'est pas avec Digikam wink

Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#37 16-08-2019 17:47:49

bendia
Chadministrateur
Distrib. : openSUSE Tumbleweed, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : [Résolu] Installation digikam sur buster impossible

@Gerinald : Je n'ai pas dit que Digikam était le problème, ni qu'il avait cassé quoique-ce soit wink Il y a un autre problème sur l'installation de Pierre16, on ne sait pas lequel, il n'est pas résolu et risque de se produire à nouveau avec un autre logiciel, c'est juste ça que j'ai dit smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#38 16-08-2019 17:52:08

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Debian Buster
Noyau : 4.19.0-9-amd64
(G)UI : Cinnamon
Inscription : 03-01-2011

Re : [Résolu] Installation digikam sur buster impossible

@Bendia :

Oups .. désolé, j'ai mal interprété tes écrits, sorry smile

Qu'il enlève déjà la ligne de stretch, ce sera un problème en moins..... mais ça, vous ne lui avait déjà demandé smile

Dernière modification par Gerinald (16-08-2019 17:52:32)


Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

Pied de page des forums