Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 18-08-2019 11:12:41

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

tu peu installer celui la : vdpau-va-driver


The VA-API (Video Acceleration API) enables hardware accelerated video
decode/encode at various entry-points (VLD, IDCT, Motion Compensation
etc.) for the prevailing coding standards today (MPEG-2, MPEG-4
ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3). It provides an interface
to fully expose the video decode capabilities in today's GPUs.

This package contains the VDPAU-based backend driver for use with the VA API
library.
 




apt-get --reinstall install vdpau-va-driver
 



Le paquet n'était pas installé, je vais voir ce que ca donne

Hors ligne

#52 18-08-2019 12:08:13

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

Bonjour
tu peu tester a nouveau "vdpauinfo" pour voir si il fonctionne maintenant.

Hors ligne

#53 18-08-2019 13:18:04

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

Bonjour
tu peu tester a nouveau "vdpauinfo" pour voir si il fonctionne maintenant.



J'ai toujours la même erreur


display: :0   screen: 0
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
 

Hors ligne

#54 18-08-2019 13:29:18

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

Debian Alain a ce message sous Wayland , tu est sur que tu utilises bien X avec gnome ? (et pas wayland ).

au niveau pluging pour firefox (pour lire les vidéos) il n'y a pas grand chose en libre .

Dernière modification par robert2a (18-08-2019 13:34:09)

Hors ligne

#55 18-08-2019 13:42:10

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

Debian Alain a ce message sous Wayland , tu est sur que tu utilises bien X avec gnome ? (et pas wayland ).

au niveau pluging pour firefox (pour lire les vidéos) il n'y a pas grand chose en libre .



Oui j'ai vérifié avec Debian Alain et je suis bien sous X

Hors ligne

#56 18-08-2019 14:00:40

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

X ou Wayland ?

on peut  éventuellement tester  avec les commandes suivantes :

pour wayland :

echo $WAYLAND_DISPLAY


pour X.org / Wayland : 

echo $XDG_SESSION_TYPE


mais , bon , c'est redondant .
là où ce serai comique , ce serai d'avoir les deux : et X et  Wayland ....

mais , bon , m'étonnerai aussi .

Dernière modification par Debian Alain (18-08-2019 14:02:19)

Hors ligne

#57 18-08-2019 14:24:14

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

regarde si tu a ce paquet


apt-cache policy libva2
 



libva2:
  Installé : 2.5.0-1
  Candidat : 2.5.0-1
 Table de version :
 *** 2.5.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



pour ce paquet virtuel  =>  https://packages.debian.org/sid/libva-driver-abi-1.0


apt-cache policy libva2 libgl1 libx11-6
 




libva2:
  Installé : 2.5.0-1
  Candidat : 2.5.0-1
 Table de version :
 *** 2.5.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libgl1:
  Installé : 1.1.0-1
  Candidat : 1.1.0-1
 Table de version :
 *** 1.1.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libx11-6:
  Installé : 2:1.6.7-1
  Candidat : 2:1.6.7-1
 Table de version :
 *** 2:1.6.7-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



ps: ma machine est un peu spéciale , j'ai tout d' installé au niveau graphique en libre (paquets non installés par défaut sur debian )
pour les utilitaires:
mesa-utils  => commandes => glxinfo et glxgear
mesa-utils-extra => commandes =>  es2gears,  es2_info  et es2tri
clinfo => commande => clinfo (très verbeux  hmm  )

et pour les paquets full Mesa , et OpenCL pour AMD  (tu a un paquet pour intel et opencl mais pas utile pour la lecture vidéo )

tout fonctionne bien chez moi

nota: par contre je garantie pas que ça va résoudre ce problème de cpu trop sollicité  roll

de 2017 =>  https://bugs.debian.org/cgi-bin/bugrepo … bug=869815

un autre paquet  roll


apt-cache policy libvdpau-va-gl1
 


le dossier (différent sur Ubuntu peut être )


cd /usr/lib/x86_64-linux-gnu/vdpau/
 



 ls
 


le contenu


libvdpau_nouveau.so      libvdpau_nouveau.so.1.0.0  libvdpau_r300.so.1.0    libvdpau_r600.so.1      libvdpau_radeonsi.so      libvdpau_radeonsi.so.1.0.0  libvdpau_va_gl.so
libvdpau_nouveau.so.1    libvdpau_r300.so           libvdpau_r300.so.1.0.0  libvdpau_r600.so.1.0    libvdpau_radeonsi.so.1    libvdpau_trace.so.1         libvdpau_va_gl.so.1
libvdpau_nouveau.so.1.0  libvdpau_r300.so.1         libvdpau_r600.so        libvdpau_r600.so.1.0.0  libvdpau_radeonsi.so.1.0  libvdpau_trace.so.1.0.0
 


ps: tu remarque que le paquet pour intel n'est pas présent chez moi (mon gpu est un raven 2200g AMD)

deux autres paquets pour toi (moi en amd il ne sont pas installés )


apt-cache policy i965-va-driver*
 



i965-va-driver:
  Installé : (aucun)
  Candidat : 2.3.0+dfsg1-1
 Table de version :
     2.3.0+dfsg1-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
i965-va-driver-shaders:
  Installé : (aucun)
  Candidat : 2.3.0-1
 Table de version :
     2.3.0-1 500
        500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
 



nota: il y a aussi l'équivalent en i386 (je pense pas que ce soit une obligation de mettre le multiarch) 

tu a vlc installé ?  et tu l'utilise ?

Dernière modification par robert2a (18-08-2019 14:54:03)

Hors ligne

#58 18-08-2019 15:23:44

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

j'ai redémarré la machine , je n'arrive pas a avoir ce "libvdpau_i965.so" dans le dossier
il me faudrait une machine en intel avec un gpu intel pour tester. roll

il te faudrait celui ci => i965-va-driver-shaders (nonfree) , pas possible d'avoir les deux , driver et driver-shaders
la description


The VA-API (Video Acceleration API) enables hardware accelerated video
decode/encode at various entry-points (VLD, IDCT, Motion Compensation
etc.) for the prevailing coding standards today (MPEG-2, MPEG-4
ASP/H.263, MPEG-4 AVC/H.264, and VC-1/WMV3). It provides an interface
to fully expose the video decode capabilities in today's GPUs.

This package contains the video decode and encode driver backend for the
Intel G45 chipsets and Intel HD Graphics for the Intel Core processor family.
The supported platforms include:
 * Cantiga, Intel GMA 4500MHD (GM45)
 * Ironlake, Intel HD Graphics for 2010 Intel Core processor family
 * Sandy Bridge, Intel HD Graphics for 2011 Intel Core processor family
 * Ivy Bridge
 * Haswell
 * Broadwell
 * Skylake
 * Kaby Lake
 * Coffee Lake
 * Cannon Lake

This package contains also contains the non-free encode shaders for VP8, VP9,
HEVC and AVC for generation 7.5 hardware or newer.
 

Hors ligne

#59 18-08-2019 15:53:51

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

Debian Alain a écrit :

X ou Wayland ?

on peut  éventuellement tester  avec les commandes suivantes :

pour wayland :

echo $WAYLAND_DISPLAY


pour X.org / Wayland : 

echo $XDG_SESSION_TYPE


mais , bon , c'est redondant .
là où ce serai comique , ce serai d'avoir les deux : et X et  Wayland ....

mais , bon , m'étonnerai aussi .



On avait deja verifier mais voila le retour des deux commandes qui montre que j'ai bien uniquement X


julien@Huawei-Matebook:~$ echo $WAYLAND_DISPLAY

julien@Huawei-Matebook:~$ echo $XDG_SESSION_TYPE
x11
 

Hors ligne

#60 18-08-2019 16:00:56

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

regarde si tu a ce paquet


apt-cache policy libva2
 



libva2:
  Installé : 2.5.0-1
  Candidat : 2.5.0-1
 Table de version :
 *** 2.5.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



pour ce paquet virtuel  =>  https://packages.debian.org/sid/libva-driver-abi-1.0


apt-cache policy libva2 libgl1 libx11-6
 




libva2:
  Installé : 2.5.0-1
  Candidat : 2.5.0-1
 Table de version :
 *** 2.5.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libgl1:
  Installé : 1.1.0-1
  Candidat : 1.1.0-1
 Table de version :
 *** 1.1.0-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libx11-6:
  Installé : 2:1.6.7-1
  Candidat : 2:1.6.7-1
 Table de version :
 *** 2:1.6.7-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



ps: ma machine est un peu spéciale , j'ai tout d' installé au niveau graphique en libre (paquets non installés par défaut sur debian )
pour les utilitaires:
mesa-utils  => commandes => glxinfo et glxgear
mesa-utils-extra => commandes =>  es2gears,  es2_info  et es2tri
clinfo => commande => clinfo (très verbeux  hmm  )

et pour les paquets full Mesa , et OpenCL pour AMD  (tu a un paquet pour intel et opencl mais pas utile pour la lecture vidéo )

tout fonctionne bien chez moi

nota: par contre je garantie pas que ça va résoudre ce problème de cpu trop sollicité  roll

de 2017 =>  https://bugs.debian.org/cgi-bin/bugrepo … bug=869815

un autre paquet  roll


apt-cache policy libvdpau-va-gl1
 


le dossier (différent sur Ubuntu peut être )


cd /usr/lib/x86_64-linux-gnu/vdpau/
 



 ls
 


le contenu


libvdpau_nouveau.so      libvdpau_nouveau.so.1.0.0  libvdpau_r300.so.1.0    libvdpau_r600.so.1      libvdpau_radeonsi.so      libvdpau_radeonsi.so.1.0.0  libvdpau_va_gl.so
libvdpau_nouveau.so.1    libvdpau_r300.so           libvdpau_r300.so.1.0.0  libvdpau_r600.so.1.0    libvdpau_radeonsi.so.1    libvdpau_trace.so.1         libvdpau_va_gl.so.1
libvdpau_nouveau.so.1.0  libvdpau_r300.so.1         libvdpau_r600.so        libvdpau_r600.so.1.0.0  libvdpau_radeonsi.so.1.0  libvdpau_trace.so.1.0.0
 


ps: tu remarque que le paquet pour intel n'est pas présent chez moi (mon gpu est un raven 2200g AMD)

deux autres paquets pour toi (moi en amd il ne sont pas installés )


apt-cache policy i965-va-driver*
 



i965-va-driver:
  Installé : (aucun)
  Candidat : 2.3.0+dfsg1-1
 Table de version :
     2.3.0+dfsg1-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
i965-va-driver-shaders:
  Installé : (aucun)
  Candidat : 2.3.0-1
 Table de version :
     2.3.0-1 500
        500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
 



nota: il y a aussi l'équivalent en i386 (je pense pas que ce soit une obligation de mettre le multiarch) 

tu a vlc installé ?  et tu l'utilise ?



Avec les deux premières commandes je remarque que je possède les paquets mais avec des versions plus anciennes. Comment je peux les mettre à jour ?


julien@Huawei-Matebook:~$  apt-cache policy libva2
libva2:
  Installé : 2.1.0-3
  Candidat : 2.1.0-3
 Table de version :
 *** 2.1.0-3 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
julien@Huawei-Matebook:~$  apt-cache policy libva2 libgl1 libx11-6
libva2:
  Installé : 2.1.0-3
  Candidat : 2.1.0-3
 Table de version :
 *** 2.1.0-3 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libgl1:
  Installé : 1.0.0-2ubuntu2.3
  Candidat : 1.0.0-2ubuntu2.3
 Table de version :
 *** 1.0.0-2ubuntu2.3 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.0-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
libx11-6:
  Installé : 2:1.6.4-3ubuntu0.2
  Candidat : 2:1.6.4-3ubuntu0.2
 Table de version :
 *** 2:1.6.4-3ubuntu0.2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.6.4-3ubuntu0.1 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     2:1.6.4-3 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
 



Pour le paquet libvdpau-va-gl1, je ne le possède pas , comment l'installer ?


julien@Huawei-Matebook:~$  apt-cache policy libvdpau-va-gl1
libvdpau-va-gl1:
  Installé : (aucun)
  Candidat : 0.4.2-1build1
 Table de version :
     0.4.2-1build1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
 




Pour le dossier j'ai plus de chose


julien@Huawei-Matebook:~$  cd /usr/lib/x86_64-linux-gnu/vdpau/
julien@Huawei-Matebook:/usr/lib/x86_64-linux-gnu/vdpau$ ls
libvdpau_nouveau.so        libvdpau_r600.so.1
libvdpau_nouveau.so.1      libvdpau_r600.so.1.0
libvdpau_nouveau.so.1.0    libvdpau_r600.so.1.0.0
libvdpau_nouveau.so.1.0.0  libvdpau_radeonsi.so
libvdpau_r300.so           libvdpau_radeonsi.so.1
libvdpau_r300.so.1         libvdpau_radeonsi.so.1.0
libvdpau_r300.so.1.0       libvdpau_radeonsi.so.1.0.0
libvdpau_r300.so.1.0.0     libvdpau_trace.so.1
libvdpau_r600.so           libvdpau_trace.so.1.0.0
 



Pour les drivers i965-va-driver* , je les possède mais encore une fois avec des versions plus anciennes que toi


julien@Huawei-Matebook:~$  apt-cache policy i965-va-driver*
i965-va-driver:
  Installé : 2.1.0-0ubuntu1
  Candidat : 2.1.0-0ubuntu1
 Table de version :
 *** 2.1.0-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
i965-va-driver-shaders:
  Installé : (aucun)
  Candidat : 2.1.0-1
 Table de version :
     2.1.0-1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages
 



Pour VLC, je ne l'ai pas utilisé, je vais tester pour voir si ca cause le même problème

Hors ligne

#61 18-08-2019 16:01:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

re,

j'ai trouvé ceci de 2012 , mais j'ai un doute si correct


Intel ne prend pas en charge VDPAU.
Configurez votre logiciel pour utiliser VA-API,
passez à un meilleur logiciel si votre lecteur actuel n’utilise pas VA-API,
ou la lecture avec le rendu du logiciel.
 


par contre il existe bien un paquet nonfree pour le rendu vidéo sur intel "VA API"


VAAPI driver for the Intel GEN8+ Graphics family
 
The VA-API (Video Acceleration API) enables hardware accelerated video
decode/encode at various entry-points (VLD, IDCT, Motion Compensation
etc.) for the prevailing coding standards today (MPEG-2, MPEG-4
ASP/H.263, MPEG-4 AVC/H.264, and VC-1/WMV3). It provides an interface
to fully expose the video decode capabilities in today's GPUs.

This package contains the video decode and encode driver backend for the
Intel HD Graphics of the Intel Core processor family. The supported platforms
include:
 * Broadwell
 * Skylake
 * Broxton
 * Apollo Lake
 * Kaby Lake
 * Coffee Lake
 * Whiskey Lake
 * Cannon Lake
 * Ice Lake
 




apt-get --reinstall install intel-media-va-driver-non-free
 



la question est , firefox va t'il savoir utiliser ce paquet pour un rendu matériel de la vidéo
teste , tous les paquets que j'ai listé sont pour intel , tu peu les installer sans soucis

pour vdpauinfo c'est pas grave , le but est d'utiliser le matériel pour visualiser les vidéos (plutôt que logiciel ).
si j'ai une machine intel sous la main de mon coté je ferai des tests

si tu a vlc , tu peu voir si il le prend en charge aussi (dans la configuration )

Dernière modification par robert2a (18-08-2019 16:03:03)

Hors ligne

#62 18-08-2019 16:03:02

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

j'ai redémarré la machine , je n'arrive pas a avoir ce "libvdpau_i965.so" dans le dossier
il me faudrait une machine en intel avec un gpu intel pour tester. roll

il te faudrait celui ci => i965-va-driver-shaders (nonfree) , pas possible d'avoir les deux , driver et driver-shaders
la description


The VA-API (Video Acceleration API) enables hardware accelerated video
decode/encode at various entry-points (VLD, IDCT, Motion Compensation
etc.) for the prevailing coding standards today (MPEG-2, MPEG-4
ASP/H.263, MPEG-4 AVC/H.264, and VC-1/WMV3). It provides an interface
to fully expose the video decode capabilities in today's GPUs.

This package contains the video decode and encode driver backend for the
Intel G45 chipsets and Intel HD Graphics for the Intel Core processor family.
The supported platforms include:
 * Cantiga, Intel GMA 4500MHD (GM45)
 * Ironlake, Intel HD Graphics for 2010 Intel Core processor family
 * Sandy Bridge, Intel HD Graphics for 2011 Intel Core processor family
 * Ivy Bridge
 * Haswell
 * Broadwell
 * Skylake
 * Kaby Lake
 * Coffee Lake
 * Cannon Lake

This package contains also contains the non-free encode shaders for VP8, VP9,
HEVC and AVC for generation 7.5 hardware or newer.
 



Je viens d'installer le package, je vais voir si ca change des choses. Mais je n'ai pas compris, tu dis qu'il ne faut pas avoir les deux , je dois donc désinstaller le i965-va-driver ?

Hors ligne

#63 18-08-2019 16:06:41

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

non je parle du paquet libre i965-va-driver et du paquet non free  i965-va-driver-shaders
tu a le premier installé (le libre ) reste comme cela et installe celui ci  "intel-media-va-driver-non-free"

pour faire simple "libre i965-va-driver"  => vdpau

                         "intel-media-va-driver-non-free"  => VA API

tu peu avoir les deux installé sans souci

Dernière modification par robert2a (18-08-2019 16:08:58)

Hors ligne

#64 18-08-2019 16:08:19

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

non je parle du paquet libre i965-va-driver et du paquet non free  i965-va-driver-shaders
tu a le premier installé (le libre ) reste comme cela et installe celui ci  "intel-media-va-driver-non-free"



Je l'installe comment ? Avec un apt-get install ca ne fonctionne pas, il ne me le trouve pas (je suis débutant sous ubuntu donc un peu de mal avec les commandes ^^)


julien@Huawei-Matebook:~$ sudo  apt-get --reinstall install intel-media-va-driver-non-free
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet intel-media-va-driver-non-free
 



Je viens de tester VLC , la charge est un peu plus légère qu'avec firefox (environ 60-70%) mais j'ai toujours mon problème avec un trait qui apparait sur la video
Comment voir sous VLC si c'est pris en charge ?

Dernière modification par julaya (18-08-2019 16:15:44)

Hors ligne

#65 18-08-2019 16:17:04

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

tu risque de le trouver dans la section nonfree de Ubuntu , mais je sais pas comment  roll
avec debian on ajoute "contrib nonfree" comme ceci


#bullseye11 https
deb https://deb.debian.org/debian-security bullseye-security/updates main contrib non-free
deb https://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb https://deb.debian.org/debian/ bullseye main contrib non-free
 



pour ubuntu aucune idée comment fonctionnent les dépots de paquets

pour les versions je suis en testing/sid , ce qui explique les versions différentes .

Hors ligne

#66 18-08-2019 16:24:52

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

dans (ouverture de vlc) => outils => préférences =>  vidéo => sortie => automatique
si tu ouvre l'onglet il te propose par exemple "vdpau" au lieu de "automatique"
ps: ça peu provoquer le plantage de vlc , tu revient a "automatique" ou tu choisi une autre option

pour ubuntu il faut autoriser le nonfree quelque part
puis un update


apt update
 



puis il doit apparaître avec ceci


apt-cache policy intel-media-va-driver-non-free
 



intel-media-va-driver-non-free:
  Installé : 19.2.1+ds1-1
  Candidat : 19.2.1+ds1-1
 Table de version :
 *** 19.2.1+ds1-1 500
        500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
        100 /var/lib/dpkg/status
 


si aucun retour , soit il n'existe pas sur ubuntu (ou il a un autre nom) , soit tu n'a pas le bon dépôt pour le récupérer

Dernière modification par robert2a (18-08-2019 16:35:49)

Hors ligne

#67 18-08-2019 16:47:53

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

dans (ouverture de vlc) => outils => préférences =>  vidéo => sortie => automatique
si tu ouvre l'onglet il te propose par exemple "vdpau" au lieu de "automatique"
ps: ça peu provoquer le plantage de vlc , tu revient a "automatique" ou tu choisi une autre option

pour ubuntu il faut autoriser le nonfree quelque part
puis un update


apt update
 



puis il doit apparaître avec ceci


apt-cache policy intel-media-va-driver-non-free
 



intel-media-va-driver-non-free:
  Installé : 19.2.1+ds1-1
  Candidat : 19.2.1+ds1-1
 Table de version :
 *** 19.2.1+ds1-1 500
        500 https://deb.debian.org/debian bullseye/non-free amd64 Packages
        100 /var/lib/dpkg/status
 


si aucun retour , soit il n'existe pas sur ubuntu (ou il a un autre nom) , soit tu n'a pas le bon dépôt pour le récupérer



C'est bon j'ai réussi à l'installer big_smile
Voila le retour


 apt-cache policy intel-media-va-driver-non-free
intel-media-va-driver-non-free:
  Installé : 18.4.1+ds1-1
  Candidat : 18.4.1+ds1-1
 Table de version :
 *** 18.4.1+ds1-1 100
        100 /var/lib/dpkg/status
 



Pour VLC, j'ai bien la proposition vdpau mais ca fait planter donc je suis retourner sur automatique.

Sinon le paquet n'améliore rien

Dernière modification par julaya (18-08-2019 17:04:49)

Hors ligne

#68 18-08-2019 17:17:09

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

je pense de plus en plus aux posts #28 et #39 de melissa

Hors ligne

#69 18-08-2019 18:20:10

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

voila j'ai trouvé une machine intel , juste activé le gpu intel , la carte nvidia est en place.


lspci
 


retour


00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
02:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
 




glxinfo -B
 



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)  (0x1912)
    Version: 18.3.6
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 


ps: intel est définit comme premier dans le bios et un seul écran sur ce gpu


vdpauinfo
 



display: :0   screen: 0
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
 


on a la même chose  wink

Dernière modification par robert2a (18-08-2019 18:25:04)

Hors ligne

#70 18-08-2019 18:44:18

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

OpenCL fonctionne (j'ai cuda aussi pour nvidia )
je met que le début , celui aussi très bavard


clinfo
 



Number of platforms                               2
  Platform Name                                   Intel Gen OCL Driver
  Platform Vendor                                 Intel
  Platform Version                                OpenCL 2.0 beignet 1.3
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_3d_image_writes cl_khr_image2d_from_buffer cl_khr_depth_images cl_khr_spir cl_khr_icd cl_intel_accelerator cl_intel_subgroups cl_intel_subgroups_short cl_khr_gl_sharing
  Platform Extensions function suffix             Intel

  Platform Name                                   NVIDIA CUDA
  Platform Vendor                                 NVIDIA Corporation
  Platform Version                                OpenCL 1.2 CUDA 10.1.173
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer
  Platform Extensions function suffix             NV

  Platform Name                                   Intel Gen OCL Driver
Number of devices                                 1
  Device Name                                     Intel(R) HD Graphics Skylake Desktop GT2
  Device Vendor                                   Intel
  Device Vendor ID                                0x8086
  Device Version                                  OpenCL 2.0 beignet 1.3
  Driver Version                                  1.3
  Device OpenCL C Version                         OpenCL C 2.0 beignet 1.3
  Device Type                                     GPU
  Device Profile                                  FULL_PROFILE
  Device Available                                Yes
  Compiler Available                              Yes
  Linker Available                                Yes
  Max compute units                               23
  Max clock frequency                             1000MHz
  Device Partition                                (core)
    Max number of sub-devices                     1
    Supported partition types                     None, None, None
    Supported affinity domains                    (n/a)
  Max work item dimensions                        3
  Max work item sizes                             512x512x512
  Max work group size                             512
  Preferred work group size multiple              16
  Preferred / native vector sizes                
 


je vais installer VLC pour voir ce qu'il me propose comme driver vidéo

si tu veu tester Vulkan , la commande :


vulkaninfo --html

Xlib:  extension "NV-GLX" missing on display ":0".
INTEL-MESA: warning: ../src/intel/vulkan/anv_device.c:1200: FINISHME: Implement pop-free point clipping
 


ps: tu trouvera le fichier dans ton /home/ton-user/   si tu la lance a partir d une console "user"

Dernière modification par robert2a (18-08-2019 18:55:34)

Hors ligne

#71 18-08-2019 19:29:13

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

le cpu est plus petit que le tien un I3 dual core avec HT
je tourne a 20% environ avec Firefox
VLC si tu a une URL pour tester (ou pour tester avec Firefox)
mon cpu


cpu-info
 



Packages:
  0: Intel Core i3-6100
Cores:
  0: 2 processors (0-1), Intel Sky Lake
  1: 2 processors (2-3), Intel Sky Lake
Logical processors:
  0: APIC ID 0x00000000
  1: APIC ID 0x00000001
  2: APIC ID 0x00000002
  3: APIC ID 0x00000003
 



pour la prise en charge matérielle rien trouvé , les paquets sont installés , mais je sais pas si utilisé .
VLC ne me propose pas "VA API" , juste "vdpau" , sinon la même liste que toi opengl , opengl portable etc ..........
au niveau des erreurs la machine est propre


journalctl -r -p err
-- Logs begin at Sun 2019-08-18 19:33:23 CEST, end at Sun 2019-08-18 20:33:34 CEST. --
-- No entries --
 

Dernière modification par robert2a (18-08-2019 19:41:35)

Hors ligne

#72 18-08-2019 19:45:24

julaya
Membre
Inscription : 05-08-2019

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

robert2a a écrit :

le cpu est plus petit que le tien un I3 dual core avec HT
je tourne a 20% environ avec Firefox
VLC si tu a une URL pour tester (ou pour tester avec Firefox)
mon cpu


cpu-info
 



Packages:
  0: Intel Core i3-6100
Cores:
  0: 2 processors (0-1), Intel Sky Lake
  1: 2 processors (2-3), Intel Sky Lake
Logical processors:
  0: APIC ID 0x00000000
  1: APIC ID 0x00000001
  2: APIC ID 0x00000002
  3: APIC ID 0x00000003
 



pour la prise en charge matérielle rien trouvé , les paquets sont installés , mais je sais pas si utilisé .
VLC ne me propose pas "VA API" , juste "vdpau" , sinon la même liste que toi opengl , opengl portable etc ..........
au niveau des erreurs la machine est propre


journalctl -r -p err
-- Logs begin at Sun 2019-08-18 19:33:23 CEST, end at Sun 2019-08-18 20:33:34 CEST. --
-- No entries --
 



Déjà un grand merci pour ton investissement pour m'aider a resoudre mon problème
Les 20% ca correspond a la consommation indiquée sur la ligne Firefox lors d'un top ? Ou la consommation totale du processeur ? Si ca correspond a la ligne Firefox c'est que j'ai bien un problème de mon coté

Hors ligne

#73 19-08-2019 09:24:32

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

je m'efforce à dire que c'est pas un problème que tu as (je parle du pourcentage élevé du cpu)
ton pc n'est pas un pc de guerre, ça reste un petit laptop de 14" et c'est pas parce que ça coute 1600€ que ça signifie que c'est une bête de course.
rien que le cpu intel badgé de la lettre U est assez parlant wink

en revanche le trait noir lors de la lecture de vidéo, là oui c'est mieux un problème d'ordre graphique, mais si ça touche que la lecture de vidéos, c'est soit qu'il te manque des pilotes adéquats, soit un manque de décodeur, soit par exemple le kernel de ubuntu qui est merdique (chose réelle).

plutot que de t'acharner sur ubuntu, teste une autre distribution en live usb, et fais les mêmes tests, et tu verra bien ce qu'il se passe.
si toutes les autres distributions il y a le même phénomène (le trait noir je parle), alors ca peut venir de ton pc qui est mal pris en charge par linux (chose qui arrive fréquemment hélas et qui demande quelques manipulations pour s'en sortir, ou pas).

à un moment faut un peu écouter ce qu'on te dit, si en te prouvant par A + B pour le pourcentage de cpu que c'est tout à fait normal, ça te convient toujours pas, ce post va faire 600 pages et vous tournerez toujours autour d'un faux problème.!!! (le pseudo problème imaginaire du cpu élevé)

il existe des live usb sous linux, c'est sa force, alors pourquoi ne pas tester.??
au moins le résultat sera bien + parlant que de faire des manip qui vous font juste tourner en rond et ne font absolument rien avancer..

Dernière modification par melissa6969 (19-08-2019 09:27:11)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#74 19-08-2019 10:01:25

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

ça donne ceci


Tasks: 151 total,   2 running, 149 sleeping,   0 stopped,   0 zombie
%Cpu(s):  4,6 us,  9,8 sy, 16,6 ni, 66,3 id,  0,2 wa,  0,0 hi,  2,6 si,  0,0 st
MiB Mem :  15929,2 total,  13535,6 free,   1030,7 used,   1362,9 buff/cache
MiB Swap:  16310,0 total,  16310,0 free,      0,0 used.  14479,9 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                  
 3124 fahclie+  39  19   29,2g 344076 108352 R 100,3   2,1 813:04.30 FahCore_21                                                              
 3875 robert    20   0 1681784 226372 119120 S  11,0   1,4   0:12.43 Web Content                                                              
 3829 robert    20   0 2442628 280300 138008 S   7,3   1,7   0:14.87 firefox-esr                                                              
  632 root      20   0  415656  84920  57212 S   4,3   0,5   6:25.48 Xorg                                                                    
 3817 robert    20   0  486428  42172  31492 S   1,7   0,3   0:00.91 mate-terminal                                                            
 1080 robert     9 -11 1972124  30504  22628 S   1,3   0,2   0:16.25 pulseaudio                                                              
 1069 robert    20   0  679844  36808  27880 S   1,0   0,2   1:14.64 marco                                                                    
  929 fahclie+  20   0   57,3g  29380  16600 S   0,3   0,2   0:48.91 FAHClient                                                                
 1053 robert    20   0  174152   6812   6144 S   0,3   0,0   0:01.14 at-spi2-registr                                                          
 3113 robert    20   0  337248  53992  26900 S   0,3   0,3   4:32.91 FAHControl                                                              
    1 root      20   0  169532  10188   7804 S   0,0   0,1   0:01.36 systemd  
 



donc je pense pour la vidéo cela correspond a ça


3875 robert    20   0 1681784 226372 119120 S  11,0   1,4   0:12.43 Web Content                                                              
 3829 robert    20   0 2442628 280300 138008 S   7,3   1,7   0:14.87 firefox-esr    
 



11% et 7.3% pour "web content" et "firefox-esr" (a mon avis une vidéo en HD )
j'ai une application qui utilise un core a 100% (fahcore)

le cpu est a environ 50degrés


coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +50.0°C  (high = +80.0°C, crit = +100.0°C)
Core 0:        +41.0°C  (high = +80.0°C, crit = +100.0°C)
Core 1:        +50.0°C  (high = +80.0°C, crit = +100.0°C)
 



le cpu fonctionne a 3.7Ghz , peut être le tien moins ? (voir le mode repos vs turbo )

ps: la commande "top" en console user.

nota:pour faire une bonne comparaison , il faudrait la même vidéo
la vidéo et le son sont correct.

comme dit avant tout cumulé (4 threads ) , je peu monter a 400%
uniquement la vidéo je suis a moins de 20%

teste les idées de melissa6969 si tu peu.
par contre il y a des cpu de portable très puissant , le "U" indique une gestion plus fine de l'énergie et un package adapté (type mobile) .
au niveau caractéristiques entre cpu de bureau et portable ils sont similaire techniquement aux fréquences et consommation près.
la nuance est au niveau du bruit émit a forte charge  roll
nota: ceci pour une machine récente (les choses ont bien évolué depuis les premiers portables).

j'ai appris quelque chose , vdpau ne fonctionne pas avec intel , et je sais pas sous debian la prise en charge de la vidéo est optimum . (pour des vidéos de haute qualitées )
je n'utilise jamais le gpu intel , a la différence de AMD ou Nvidia

Hors ligne

#75 19-08-2019 10:15:21

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [Résolu] Vidéo Youtube = CPU à plus de 100%

c'est pour ça que je m'acharne à dire que le processus firefox au delà de 100% n'est pas un problème.
c'est un calcul différent fait par top et htop.
que le pc chauffe, bah c'est un laptop donc ça chauffe et c'est bruyant, et encore + maintenant avec leur fantasme de faire des pc aussi fin qu'une feuille de papier, ça a des répercussions sur le bruit, donc c'est un problème imaginaire que vous traitez depuis 3 pages...

pourtant en un message je vous ai prouvé que le comportement était normal et reproductible en +, mais quand on écoute pas, forcément hein.

et pour finir, la lettre U castre les performances des cpu mobile, pour la même vidéo sur youtube, mon cpu vieux de 6 ans (et moins puissant sur le papier) était moins sollicité que le i5 8250u de son huawei, ça aussi je l'ai démontré + haut roll

maintenant pour le trait noir, avec des tests en live usb de fedora, manjaro, debian, opensuse par exemple, on aura déjà une bonne réponse.
il refait les mêmes tests, et si le trait noir apparait alors oui y a problème, si pas de trait noir, bah ubuntu est coupable.
et si le trait noir apparait sur toutes les distros, on peut pas ignorer non plus un problème matériel.

c'est des tests simples, rapides, efficaces, et vraiment indicatifs

Dernière modification par melissa6969 (19-08-2019 10:17:40)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

Pied de page des forums