Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-10-2019 17:59:35

j57jp
Membre
Inscription : 24-11-2016

une erreur dans ma source.list

Bjr
voici ma sources list   

y aurait il un spécialiste qui puisse trouver l'erreur dans celle-ci
----- ''''' 

# deb cdrom:[Debian GNU/Linux 10.1.0 _Buster_ - Official amd64 xfce-CD Binary-1$

# debian buster , depot principal
deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

# debien buster, mises a jour de décurité
deb http://deb.debian.org/debian-security/ buster/updates main
deb-src http://deb.debian.org/debian-security/ buster/updates main

# debian buster , mises a jour volatiles
deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

#  debian buster , depot principal + paquets non libres
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free

# debian buster , mises a jour de securité + paquets non libres
deb http://deb.debian.org/debian-security/ buster updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster updates main contrib non-$

# debian buster , mises a jour volatiles  + paquets non libres
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free


-----'''''

Merci
car sinon , je ne peux pas faire apt-get upgrade

Hors ligne

#2 24-10-2019 18:03:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

tu peux t'inspirer de ce lien : https://debian-facile.org/doc:system:ap … ist:buster

en clair , ceci (sources idéales) :

# Debian Buster, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ buster main contrib non-free
# Debian Buster, mises à jour de sécurité + paquets non libres
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
# Debian Buster, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
# Debian Buster, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ buster-backports main contrib non-free



tu peux éditer tes sources avec nano .

si tu préfère plus simple (en deux - trois commandes) , fais moi signe , je te les donnerai .

Dernière modification par Debian Alain (24-10-2019 18:06:03)

En ligne

#3 24-10-2019 18:14:14

j57jp
Membre
Inscription : 24-11-2016

Re : une erreur dans ma source.list

oui , j'avais mis tous les exemples , libre, non libres en m'inspirant de ces exemples
mais ca ne marche pas
(je me demande à quoi ils servent tous)

j'ai donc fait ce que tu viens d'inscrire mais
-----'''''

root@debian:~# apt-get upgrade
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Il est possible qu'un autre processus l'utilise.

-----'''''

pas facile le linux !!!

Hors ligne

#4 24-10-2019 18:17:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

tu as essayé de commencer d'abord avec :

apt update


???

En ligne

#5 24-10-2019 18:30:18

j57jp
Membre
Inscription : 24-11-2016

Re : une erreur dans ma source.list

désolé, je suis très genant , mais ...   bon, merci

-----"""""

root@debian:~# apt update
Atteint :1 http://deb.debian.org/debian buster InRelease
Atteint :2 http://deb.debian.org/debian-security buster/updates InRelease
Atteint :3 http://deb.debian.org/debian buster-updates InRelease
Atteint :4 http://deb.debian.org/debian buster-backports InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
2 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

Hors ligne

#6 24-10-2019 18:36:49

j57jp
Membre
Inscription : 24-11-2016

Re : une erreur dans ma source.list

root@debian:~# apt list --upgradable
En train de lister... Fait
openjdk-11-jre-headless/stable 11.0.5+10-1~deb10u1 amd64 [pouvant être mis à jour depuis : 11.0.4+11-1~deb10u1]
openjdk-11-jre/stable 11.0.5+10-1~deb10u1 amd64 [pouvant être mis à jour depuis : 11.0.4+11-1~deb10u1]

Hors ligne

#7 24-10-2019 18:37:57

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

désolé, je suis très genant , mais ...   bon, merci



non , t'inquiète . on a tous été débutant .
celui qui ne l'a jamais été est un menteur .

en général , la commande de mise à jour est la suivante :

mise à jour des sources : apt-get update (pour être parfait)
et mise à jour des paquets ensuite : apt-get upgrade

s'il y a des paquets à effacer ou à reconfigurer : apt-get full-upgrade (ou apt-get dist-upgrade)

En ligne

#8 24-10-2019 18:39:01

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

Maintenant que tu as fait

apt update

tu peut faire

apt upgrade

et

exit



J'espère que pour devenir root tu as fait

su -

en oubliant pas l'espace entre su et le tiré ?


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#9 24-10-2019 18:45:31

j57jp
Membre
Inscription : 24-11-2016

Re : une erreur dans ma source.list

root@debian:~# apt-get upgrade
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Il est possible qu'un autre processus l'utilise.
root@debian:~# apt-get full-upgrade
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Il est possible qu'un autre processus l'utilise.
root@debian:~# apt-get dist-upgrade
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Il est possible qu'un autre processus l'utilise.

Hors ligne

#10 24-10-2019 18:52:33

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

"s'il y a des paquets à effacer ou à reconfigurer : apt-get full-upgrade (ou apt-get dist-upgrade)"

Où est-ce que tu as vu ça Debian Alain ? pfffff

apt-get dist-upgrade c'est pour faire une mise à niveau

Dernière modification par Jean-Pierre Pinson (24-10-2019 18:55:26)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#11 24-10-2019 18:59:02

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

j57jp  "Il est possible qu'un autre processus l'utilise." Si tu as synaptic de lancé ferme le ou quite le et recommence

apt-get upgrade

Dernière modification par Jean-Pierre Pinson (24-10-2019 19:00:52)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#12 24-10-2019 19:01:00

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

oui , c'est vrai , mais tu sais aussi bien que moi que des fois apt répond :

xx non mis à jour ...

dans ce cas , un full upgrade règle souvent le problème .

pour dist upgrade , je suis moins sur , mais je pense que c'est kif kif , non ?

En ligne

#13 24-10-2019 19:12:46

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

Debian Alain En espérant que ça t'évite De raconter n'importe quoi: https://www.lecoindunet.com/difference- … ll-upgrade

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#14 24-10-2019 19:18:41

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

apt dist-upgrade et apt full-upgrade
# apt full-upgrade
Les options dist-upgrade ou full-upgrade sont identiques, utiliser l’une ou l’autre revient donc au même.

Ces deux options agissent plus « intelligemment » que la fonction upgrade. En plus de mettre à jour les paquets existants, elles vont également être en mesure de gérer les dépendances. Si de nouveaux paquets doivent être installés pour satisfaire des dépendances, ils le seront. Ceux qui ne sont plus utiles, sont supprimés et les paquets essentiels ou requis, sont installés. Les paquets les plus importants sont traités en priorité.



je reprends ton post et ta référence :

Si de nouveaux paquets doivent être installés pour satisfaire des dépendances, ils le seront. Ceux qui ne sont plus utiles, sont supprimés



c'est bien ce que je dis .

je me suis sans doute mal exprimé . pardon .

En ligne

#15 24-10-2019 20:00:46

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

je reprends mon post et ma référence

Cette commande est moins conservatrice et peux causer des résultats inattendus en raison des possibilités de nouvelles installations ou de suppressions. Ne pas faire l’amalgame de « dist » avec distribution, la terminologie n’a rien n’a voir. La terminologie « full-upgrade » est maintenant plus adaptée et ne porte pas à confusion.

Dois-je utiliser apt upgrade ou apt full-upgrade?
Maintenant que vous connaissez la différence entre un apt upgrade ou un apt full-upgrade, vous vous posez peut-être la question suivante : quelle instruction dois-je utiliser pour mettre à jour mon système Linux basé sur Debian ?

Dans un environnement hautement critique et qui doit rester stable, la commande upgrade est plus sûr. Si vous désirez faire une opération de mise à jour courante et minorer le risque, il en est de même. Seuls les paquets actuellement installés sont traités. Les risques de dysfonctionnement suite à la suppression ou l’installation d’un nouveau paquet sont réduits.

Dernière modification par Jean-Pierre Pinson (24-10-2019 20:03:51)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#16 24-10-2019 20:30:53

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

Cette commande est moins conservatrice et peux causer des résultats inattendus



j'ai jamais dit le contraire .

j'ai parlé du fonctionnement d'apt full-upgrade , jamais de ses dangers .

c'est très bien que tu en parles . ce n'est pas à négliger en effet .

quoique , pour l'utiliser parfois , j'ai très rarement eu des problèmes avec .

Dernière modification par Debian Alain (24-10-2019 20:32:05)

En ligne

#17 24-10-2019 20:37:52

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

Donc il faut savoir ce que l'on fait, avant de taper cette commande, et donc conseiller ça à un débutant, non je ne vois pas !

Dernière modification par Jean-Pierre Pinson (24-10-2019 20:38:32)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#18 24-10-2019 20:45:21

j57jp
Membre
Inscription : 24-11-2016

Re : une erreur dans ma source.list

trop tard c'est fait

Hors ligne

#19 24-10-2019 20:45:46

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : une erreur dans ma source.list

mon but n'était pas de conseiller mais d'expliquer .

en étant le plus exhaustif possible .

mais c'est vrai , j'ai un peu gaffé :

vu comme c'était dit , çà ressemblait à un conseil .

cela ne retire rien à tes connaissances et à tes explications qui sont ,

sans doute pour lui , très intéressantes .

En ligne

#20 25-10-2019 15:56:31

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

vv222 a dit :dans le tuto que j'ai donné

« L’option upgrade installe les mises à jour identifiée avec apt update sans supprimer les paquets installés et sans en installer de nouveaux. » Cela est faux ?
Cʼest le comportement de `apt-get upgrade`
apt upgrade` peut installer de nouveaux paquets (mais pas en supprimer).
Lʼéquivalent serait `apt-get upgrade –with-new-pkgs`
Le reste semble bon à vv222

Dernière modification par Jean-Pierre Pinson (25-10-2019 16:02:19)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#21 25-10-2019 17:47:00

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.15.0-55-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : une erreur dans ma source.list

apt-get upgrade



Utilisation
upgrade ne supprime pas les paquets qui entravent les mises à jour mais il marque quand même les dépendances inutiles comme à supprimer et qui seront supprimées définitivement par la commande autoremove et du coup, les mises à jour peuvent être partielles mais au moins, on est sûr qu'il ne vire aucun paquet qu'on utilise.

upgrade va essayer de mettre à jour ce qu'il peut sans rien casser, il est plus sûr pour les débutants qui n'ont pas le réflexe de lire la liste des paquets supprimés.
dixit le captnfab sur le forum df :

https://debian-facile.org/viewtopic.php … 25#p159625


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

Pied de page des forums