Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-11-2019 17:22:35

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

debian 10 nvidia-detect pas de wayland [non résolu]

bonjour
je viens d'installer mon nouveau pc avec une carte graphique nvidia
j'ai donc installé nividia-detect .
en me connectant a ma session ,je m'aperçois que je ne suis pas sous wayland. je n'ai pas le moyen de cocher quelquechose pour activer wayland..
est ce que le fait d'avoir installé nvidia-detect provoque le fait de devoir tourner uniquement sur xorg???ou est ce autre chose?
quelles solutions?
merci

Dernière modification par Herbert west (25-11-2019 00:27:02)


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#2 19-11-2019 17:34:26

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

faudrai que je cherche les docs mais , de mémoire , les pilotes proprio nvidia ne fonctionnent pas avec wayland .

seul nouveau fonctionne .

https://linuxfr.org/forums/linux-debian … us-wayland

En ligne

#3 19-11-2019 17:51:08

raleur
Membre
Inscription : 03-10-2014

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Herbert west a écrit :

est ce que le fait d'avoir installé nvidia-detect provoque le fait de devoir tourner uniquement sur xorg?


Je ne vois pas comment ce serait possible. nvidia-detect n'est qu'un simple programme.
Quel gestionnaire de connexion et quel environnement de bureau ?


Il vaut mieux montrer que raconter.

Hors ligne

#4 19-11-2019 18:06:43

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

raleur a écrit :

Herbert west a écrit :

est ce que le fait d'avoir installé nvidia-detect provoque le fait de devoir tourner uniquement sur xorg?


Je ne vois pas comment ce serait possible. nvidia-detect n'est qu'un simple programme.
Quel gestionnaire de connexion et quel environnement de bureau ?


gnome3.30.2

https://debian-facile.org/viewtopic.php?id=23716
robert dis que wayland ne fonctionne pas avec le driver nvidia ..or chez moi, nvidia-detect est le driver libre non?

autre hypothese
le partitionnement:
j'éprouve des difficultés a chaque fois que j'installe un nouveau debian afin de partionner de façon optimum; aujourd'hui en allant trop vite , je n'ai pas placé home dans une étendue..
serais ce le probleme

nb: dans l'installateur graphique j'ai pourtant bien coché environnement de bureau et gnome
aussi c'est le premier ordi ou j'ai installé en uefi ;je ne sais pas si c'est bien ou pas mais je l'ai fait


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#5 19-11-2019 18:15:05

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Herbert West  a écrit :

nvidia-detect est le driver libre non?



nvidia-detect n'est que un utilitaire qui sert à indiquer la bonne version des pilotes propriétaires par rapport au matériel installé dans ton pc .

"nouveau" est le pilote libre pour carte nvidia compatible wayland

"nvidia-legacy-XXXxx-driver" est le pilote proprio , non compatible avec wayland , seulement avec X

Dernière modification par Debian Alain (19-11-2019 18:16:27)

En ligne

#6 19-11-2019 18:26:41

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

echo $WAYLAND_DISPLAY


me renvoit rien du tout



pourquoi je ne suis pas sous wayland??
j'essaierai de reinstaller debian avec partition étendue


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#7 19-11-2019 18:42:07

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

-- cela -- peut il t'aider ?

que donne : ?

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log

En ligne

#8 19-11-2019 20:01:51

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Debian Alain a écrit :

-- cela -- peut il t'aider ?

que donne : ?

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log



J'ai déjà fait l'installe du wiki


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#9 19-11-2019 22:55:36

raleur
Membre
Inscription : 03-10-2014

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Herbert west a écrit :

j'éprouve des difficultés a chaque fois que j'installe un nouveau debian afin de partionner de façon optimum


LVM est ton ami.

Herbert west a écrit :

je n'ai pas placé home dans une étendue..
serais ce le probleme


Non, aucun rapport. Pourquoi home devrait être dans une partition étendue ?

Herbert west a écrit :

aussi c'est le premier ordi ou j'ai installé en uefi ;je ne sais pas si c'est bien ou pas


Ce n'est ni bien ni mal. C'est juste prendre le risque de rencontrer un des innombrables bugs spécifiques aux firmwares UEFI.


Il vaut mieux montrer que raconter.

Hors ligne

#10 19-11-2019 23:11:54

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : debian 10 nvidia-detect pas de wayland [non résolu]

un retour vide de
echo $WAYLAND_DISPLAY
indique que t'es sous xorg.

les pilotes proprios ne fonctionnement pas sous wayland, tout comme certains logiciels.

la question serait plutôt
pourquoi vouloir à tout prix utiliser wayland.??
qu'est ce qu'il t'apporte de + que xorg.??
en sachant que wayland te posera + de soucis que xorg (avec obstudio c'est mort, vokoscreen idem, synaptic tu peux oublier, certains ralentissements si ta machine est vieillissante)

et le choix se fait sur l'écran de gdm via la petite roue crantée, xorg ou wayland, ou un 3e choix (gnome-machin-truc je sais pas quoi) j'utilise pas gnome wink

Dernière modification par melissa6969 (19-11-2019 23:13:03)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#11 20-11-2019 07:49:52

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

melissa6969 a écrit :

un retour vide de
echo $WAYLAND_DISPLAY
indique que t'es sous xorg.

les pilotes proprios ne fonctionnement pas sous wayland, tout comme certains logiciels.

la question serait plutôt
pourquoi vouloir à tout prix utiliser wayland.??
qu'est ce qu'il t'apporte de + que xorg.??
en sachant que wayland te posera + de soucis que xorg (avec obstudio c'est mort, vokoscreen idem, synaptic tu peux oublier, certains ralentissements si ta machine est vieillissante)

et le choix se fait sur l'écran de gdm via la petite roue crantée, xorg ou wayland, ou un 3e choix (gnome-machin-truc je sais pas quoi) j'utilise pas gnome wink



salut ,si tu lis plus haut, j'ai deja fait tout ça.
ne pas utiliser gnome , ni wayland: seuls tes choix t'appartiennent; perso je comprends pas comment certaines personnes n'utilisent pas gnome, si ce n'est a cause d'une config vieillissante; c'est peut etre aussi pour ça qu'il est l’environnement par défaut de debian..
bref, je vais retenter l'instal


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#12 20-11-2019 08:51:30

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Peut être parce que gnome est pensé façon tablette et que ça plaît pas aux gens d'avoir un bureau qui ressemble à tout sauf à vrai bureau avec un vrai menu et qu'on puisse en faire ce qu'on veut.

Gnome est castré, faut lui mettre des extensions qui tôt ou tard finissent par poser soucis car incompatible.

On a pas tous des pc flambants neufs ni la folie d'acheter le dernier joujou à 1400€ a la mode et on a surtout pas tous des écrans tactiles (bah oui gnome a été pensé comme du tactile, sans écran de la sorte il a plus aucun intérêt) hormis devenir chiant moche et lourd comme pas possible.

Les autres d.e sont des vrais bureaux traditionnels bien pensés et simple à comprendre et accessible même aux + novice des novices smile

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#13 20-11-2019 09:41:42

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

melissa6969 a écrit :

Peut être parce que gnome est pensé façon tablette et que ça plaît pas aux gens d'avoir un bureau qui ressemble à tout sauf à vrai bureau avec un vrai menu et qu'on puisse en faire ce qu'on veut.

Gnome est castré, faut lui mettre des extensions qui tôt ou tard finissent par poser soucis car incompatible.

On a pas tous des pc flambants neufs ni la folie d'acheter le dernier joujou à 1400€ a la mode et on a surtout pas tous des écrans tactiles (bah oui gnome a été pensé comme du tactile, sans écran de la sorte il a plus aucun intérêt) hormis devenir chiant moche et lourd comme pas possible.

Les autres d.e sont des vrais bureaux traditionnels bien pensés et simple à comprendre et accessible même aux + novice des novices smile



on va pas faire un débat su gnome ; perso il me convient;j'aime son ihm (coup de souris en haut a gauche dévoile toutes mes fenres; tu as raison pour les extensions.

je garde mes pc entre 8 et 12ans, je bosse suffisemment pour acheter le pc que je veux ;les 3/4 sont d'occaz.
bref tes remarques me gonflent et ne sont pas constructives pour mon problème


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#14 20-11-2019 09:54:26

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

si gnome te plaît pas , dans la même veine (à peu près) , y a aussi mate(gnome 2, pas mal) et cinnamon (j'aime beaucoup moins).  big_smile

Xfce est bien aussi mais un peu rustique . roll

Synaptic a été réactualisé , maintenant il est compatible wayland . big_smile

sinon

echo $XDG_SESSION_TYPE

tongue
te dira clairement si tu es  sous wayland ou sous X11 .
(gnome , les  autres , sais pas) smile
chez moi :

wayland



-- quelques bureaux (wiki d-f) --

-- quelques bureaux (debian wiki) --

p.s.: la commande "env" te donnera une liste de variables d'environnement .
tu peux y piocher celle(s) qui t'intéresse(nt) .

Dernière modification par Debian Alain (20-11-2019 10:21:01)

En ligne

#15 20-11-2019 12:05:21

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Debian Alain a écrit :

si gnome te plaît pas , dans la même veine (à peu près) , y a aussi mate(gnome 2, pas mal) et cinnamon (j'aime beaucoup moins).  big_smile

Xfce est bien aussi mais un peu rustique . roll

Synaptic a été réactualisé , maintenant il est compatible wayland . big_smile

sinon

echo $XDG_SESSION_TYPE

tongue
te dira clairement si tu es  sous wayland ou sous X11 .
(gnome , les  autres , sais pas) smile
chez moi :

wayland



-- quelques bureaux (wiki d-f) --

-- quelques bureaux (debian wiki) --

p.s.: la commande "env" te donnera une liste de variables d'environnement .
tu peux y piocher celle(s) qui t'intéresse(nt) .



salut alain; je connais la commande; elle me renvoie x11.


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#16 20-11-2019 12:11:48

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

si tu cherches à tout prix à utiliser  wayland ,

peux tu te permettre une réinstall ?

(liens torrent)

-- lien des images non-free --

-- lien debian live stable gnome non-free --

je sais que tu as déjà testé le tuto , mais , peux tu poster le retour de cette commande :

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log

chez moi :

[   141.164] (II) Module amdgpu: vendor="X.Org Foundation"
[   141.164]  compiled for 1.20.4, module version = 19.0.1
[   141.164]  Module class: X.Org Video Driver
--
[   141.164] (II) Module ati: vendor="X.Org Foundation"
[   141.164]  compiled for 1.20.4, module version = 19.0.1
[   141.164]  Module class: X.Org Video Driver
--
[   141.182] (II) Module modesetting: vendor="X.Org Foundation"
[   141.182]  compiled for 1.20.4, module version = 1.20.4
[   141.182]  Module class: X.Org Video Driver
--
[   141.183] (II) Module fbdev: vendor="X.Org Foundation"
[   141.183]  compiled for 1.20.0, module version = 0.5.0
[   141.183]  Module class: X.Org Video Driver
--
[   141.184] (II) Module vesa: vendor="X.Org Foundation"
[   141.184]  compiled for 1.20.4, module version = 2.4.0
[   141.184]  Module class: X.Org Video Driver



par ailleurs , que donne : ?

apt-get update && apt-get install --reinstall xserver-xorg-video-nouveau libgl1-mesa-glx libgl1-mesa-dri



éventuellement , en plus , ceci peut il t'arranger ?

tuto  a écrit :


Configuration
Normalement, il n'y a rien à faire.

Si le pilote n'a pas été choisi par défaut, créez et éditez un fichier /etc/X11/xorg.conf avec nano ainsi :

nano /etc/X11/xorg.conf
Et si elle n'y sont pas déjà, y écrire les lignes suivantes :

Extrait de /etc/X11/xorg.conf
Section "Device"
Identifier  "Video Card"
Driver    "nouveau"
EndSection

Dernière modification par Debian Alain (20-11-2019 12:21:54)

En ligne

#17 20-11-2019 14:22:04

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian
Noyau : Dur
(G)UI : gui gui, je zuis un doiseau
Inscription : 07-07-2008
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Plop,
Il me semble que pour utiliser Wayland, il ne faut pas utiliser les pilotes propriétaires nvidia mais bien rester sur nouveau.
Ensuite, tous les environnements de bureau ne supportent pas Wayland. Gnome et KDE Plasma fonctionnent avec Wayland. Pour les autres, je ne suis pas sûr…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.
Je suis parrain linux !

Hors ligne

#18 20-11-2019 14:45:40

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Kde
Inscription : 21-09-2016

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Debian Alain a écrit :



Synaptic a été réactualisé , maintenant il est compatible wayland . big_smile



Bonjour à tous,
je ne savais pas que Synaptic était maintenant compatible Wayland. On en apprend tous les jours yes.gif


Acer Aspire 5733 - Debian 10 Kde

Hors ligne

#19 20-11-2019 15:09:39

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

salut captn, ça faisait un bail.

j'utilise le pilote nouveau ;d'apres ce que j'ai compris ce n'est que le pilote proprio qui n'est pas utilisable sous wayland.
pour ce qui est de la demande d'alain:

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
[     4.224] (II) Module nvidia: vendor="NVIDIA Corporation"
[     4.224]  compiled for 4.0.2, module version = 1.0.0
[     4.224]  Module class: X.Org Video Driver
--
[     4.226] (II) Module nouveau: vendor="X.Org Foundation"
[     4.226]  compiled for 1.20.3, module version = 1.0.16
[     4.227]  Module class: X.Org Video Driver
--
[     4.228] (II) Module modesetting: vendor="X.Org Foundation"
[     4.228]  compiled for 1.20.4, module version = 1.20.4
[     4.228]  Module class: X.Org Video Driver
--
[     4.229] (II) Module fbdev: vendor="X.Org Foundation"
[     4.229]  compiled for 1.20.0, module version = 0.5.0
[     4.229]  Module class: X.Org Video Driver
--
[     4.230] (II) Module vesa: vendor="X.Org Foundation"
[     4.230]  compiled for 1.20.1, module version = 2.4.0
[     4.230]  Module class: X.Org Video Driver



attention ,je sais que xorg bosse sur wayland ;est ce pour cela que le driver est un xorg video.

je vais essayer la reinstallation de nouveau et de ses copines

------>non toujours pas;toujours x11
j'ai du faire une boulette quelquepart
me semble avoir installé les linux non-free apres le nvidia-detect
ou alors c'est uefi....

Dernière modification par Herbert west (20-11-2019 15:25:13)


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#20 20-11-2019 15:17:22

raleur
Membre
Inscription : 03-10-2014

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Visiblement, tu as installé le pilote propriétaire Nvidia, pas seulement nvidia-detect. Petit cachottier.
Réinstaller nouveau ne t'apportera rien ; il faut désinstaller le pilote Nvidia.

Dernière modification par raleur (20-11-2019 15:18:01)


Il vaut mieux montrer que raconter.

Hors ligne

#21 20-11-2019 15:35:26

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

tu t'es trompé Herbert West ,

d'après ton rapport , tu utilises le pilote propriétaire Nvidia et non le pilote libre Nouveau .

donc , dans cette configuration , tu n'aura jamais wayland .

je pense  que ceci va me confirmer .
si tu peux poster le retour de :

lspci -nnk | grep -iE "vga|3d|display" -A 3



il faut :
1) désinstaller le pilote Nvidia
2) installer "nouveau" en lieu et place .

si tu préfères , tu peux tenter une réinstall de ton système , "nouveau" devrai s'installer part défaut .

aussi , à la mano , tu peux faire :

désinstaller les pilotes Nvidia :

apt-get remove nvidia-driver nvidia-glx nvidia-kernel-dkms xserver-xorg-video-nvidia



en recovery mode :
- supprimer les pilotes Nvidia

aptitude purge '~i nvidia'


- supprimer les fichiers de conf du pilote

rm /etc/X11/xorg.conf


rm -r /etc/X11/xorg.conf.d


- installer "nouveau" :
pour les pilotes proprement dits :

apt-get update && apt-get install --reinstall xserver-xorg-video-nouveau


pour l'accélération graphique :

apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri



puis , une fois fait , reboot .

reboot



avec de la chance ...
source :  https://debian-facile.org/doc:materiel: … ia:accueil

Dernière modification par Debian Alain (20-11-2019 15:40:31)

En ligne

#22 20-11-2019 17:38:03

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

raleur a écrit :

Visiblement, tu as installé le pilote propriétaire Nvidia, pas seulement nvidia-detect. Petit cachottier.
Réinstaller nouveau ne t'apportera rien ; il faut désinstaller le pilote Nvidia.



Re
Lisez bien le post.
Si je vous dis que j'ai juste installé nvidia-detect...
Donc pour preuve, j'ai réinstallé debian en uefi toujours, mais cette fois ci en lvm assisté. Au passage je n' utilise jamais l'assistant de l'installateur, il a toujours fait n'importe quoi. Bref, je redémarre sans rien installer. Ni nvidia-detect, même pas ajouté les contrib non-free. Pas de Wayland. Et pourtant cette fois ci, j'ai le choix dans les sessions entre gnome classic, gnome, x11, etc.
Donc soit ce satané driver libre n'est dispo que pour x11, soit c'est ce mozeurf.. De uefi.

Du coup reinstall sans uefi.
Je vous dirai.
Ps râleur, si tu cherches a étoffer tes connaissances avec un mec qui tombe sur les problèmes rare des installs et drivers, je suis dispo wink

Dernière modification par Herbert west (20-11-2019 17:58:12)


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#23 21-11-2019 16:53:17

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

bon!
j'avais donc bien raison :
je n'ai jamais installé de pilote proprietaire
en fait c'est l'uefi qui transforme nouveau et m'oblige de passer en x11
j'ai donc réinstallé debian10 sans uefi: sans rien toucher je suis sous wayland
j'installe nvidia detect, je detecte --->gtx 1050 ti par contre dans parametres-détail ma cg est une llvmpipe(llvm7.0,256bits)
je te dis pas la lenteur de la souris et la galere pour ouvrir firefox!!!!

j'ai ensuite installé libgl1-mesa-glx et pas mesa-dri car deja installé avec nouveau pendant l'installation de debian
tjrs pareil
installation linux-firware-nonfree
tjrs pareil
bref ça rame
soit il y a une solution que je ne trouve pas
soit il est impossible d'utiliser cette carte sans prendre le pilote proprio nvidia-driver des dépots(c'est bien celui la le proprio??) et donc basculer sur x11
quoiqu'il en soit en uefi nouveau ne permet pas d'utiliser cette carte sous wayland

debian et gnome choisissent wayland ,je suis. mais pour l'instant : fuck nvidia

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#24 21-11-2019 17:16:41

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

ben , Herbert West , je comprends pas trop .

tu installes debian par défaut , donc en legacy et avec nouveau .

et , par dessus , tu installes le pilote proprio  ...  scratchhead.gif

surtout que , à première vue , çà avait l'air de bien fonctionner avec nouveau , non ? 56kPowaa.gif

non , vraiment , comprends pas ... roll

tongue

p.s. : si tu installes le pilote proprio , tu as pensé à installer les headers , avant ?
que donne :

dpkg -l | grep -iE "linux-image|linux-headers"

Dernière modification par Debian Alain (21-11-2019 17:47:27)

En ligne

#25 21-11-2019 18:08:37

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

re Alain
t'as pas bien lu ou je m'exprime mal ;seconde option est souvent la plus probable

mon souhait est d'etre a tout prix sous wayland

je n'ai jamais installé de pilote proprio
en fait ,je sais pas comment ,c'est le bios uefi qui me l'installe (nb: raleur avait raison ;et je rajoute que n'installerai pas uefi avant longtemps!!trop de risque de conflit avec le firmware)

le pilote libre nouveau fonctionne extremement mal : j'ai le curseur de la souris qui rame grave

conclusion temporaire sauf si on trouve une solution : si tu as une nvidia gtx 1050 ti , tu veux utiliser le pilote libre nouveau --->laisses tomber
en fait il faut obligatoirement installer le proprio pour que ça rame pas
le piolote proprio ne marche que sous x11, pas sous wayland

je vais essayer de me faire echanger cette merde de nvidia et prendre une amd rx5xx qui elles sont bcp mieux supportées

bref , je deteste nvidia

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

Pied de page des forums