Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-11-2019 02:45:26

Romu
Membre
Inscription : 25-11-2019

Debian c'est cool mais ce sont des reac. installer libpng12 impossible

Je suis un peux colère, c'est la 3 éme fois que je bosse sous Debian et à chaque foi la même chose. Dés que je veux modifier  quoi que ce soit, il me faut des jours et des jours de recherches acharnés pour ne pas trouver la solution. Sous Ubuntu (pour ma compagne, Ubuntu 18.04) en quelques minutes j'ai toutes infos qu'il me faut !Je veux installer java 8 jdk et libpng12 sous Debian Buster et ne trouve aucune solution.
Merci de votre attention et aide.
Romu.

Hors ligne

#2 25-11-2019 05:57:12

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

Bonjour,

je ne suis pas sous Debian mais si tu es sous Buster


apt install libpng16-16



openjdk-8-jdk n'est pas "encore" dans les dépôts Buster, je crois.

Dernière modification par golgot200 (25-11-2019 05:59:07)

Hors ligne

#3 25-11-2019 05:59:44

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

Sous Buster, voici je pense le paquet que tu recherches, pour le java, je sais pas, peut-être qu'il a lui aussi changer de version ?

apt-cache show libpng16-16


Package: libpng16-16
Source: libpng1.6
Version: 1.6.36-6
Installed-Size: 439
Maintainer: Maintainers of libpng1.6 packages <libpng1.6@packages.debian.org>
Architecture: amd64
Depends: libc6 (>= 2.14), zlib1g (>= 1:1.2.11.dfsg)
Description-fr: bibliothèque PNG –⋅exécutable (version⋅1.6)
 Libpng est une bibliothèque qui implémente une interface pour lire et
 écrire des fichiers au format PNG (« Portable Network Graphics »).
 .
 Ce paquet contient les fichiers de bibliothèque exécutables nécessaires
 pour exécuter des logiciels qui utilisent libpng.
Description-md5: d5a985e94f8651ba49089e3bee0eb18f
Multi-Arch: same
Homepage: http://libpng.org/pub/png/libpng.html
Tag: role::shared-lib
Section: libs
Priority: optional
Filename: pool/main/libp/libpng1.6/libpng16-16_1.6.36-6_amd64.deb
Size: 292020
MD5sum: e7d08fac51aac08c36f3c733a39469c4
SHA256: 82a252478465521cde9d5af473df01ed79f16e912effc5971892a574e9113500


C'est marrant de venir se plaindre d'une distro et en même temps demander de l'aide, non ? big_smile

Edit : Argh marqué par golgot200 !

Dernière modification par smolski (25-11-2019 06:01:50)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 25-11-2019 06:02:25

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.9.4-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

wink

et regarder aussi du coté de :

openjdk-11-jdk




smolski a écrit :

...
C'est marrant de venir se plaindre d'une distro et en même temps demander de l'aide, non ? big_smile
....




C'était 2H45 du mat big_smile

Dernière modification par golgot200 (25-11-2019 06:04:19)

Hors ligne

#5 25-11-2019 13:04:53

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

Romu a écrit :

]Sous Ubuntu (pour ma compagne, Ubuntu 18.04) en quelques minutes j'ai toutes infos qu'il me faut !Je veux installer java 8 jdk et libpng12 sous Debian Buster et ne trouve aucune solution


Si tu n'utilise pas le bon outil pour une tâche donnée, n'accuse pas l'outil.

Ubuntu est mieux adapté aux débutants, et Debian mieux adapté à ceux qui prévilégient la stabilité. Dans tous les cas ce que tu veux faire est possible mais demande plus de compétence sous Debian. La solution la plus simple dans ton cas c'est certainement d'utiliser Ubuntu - ou de monter en compétence. Mais rien ne sert de rager envers l'outil >.>

Au pif, la première réponse de n'import quel site semble suggérer qu'on peut installer des PPAs sous debian : https://www.digitalocean.com/community/ … n-debian-8

Dernière modification par otyugh (25-11-2019 13:15:51)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#6 25-11-2019 13:38:02

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 10
(G)UI : Kde
Inscription : 21-09-2016

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

Bonjour,
sinon un bon deal, entre Debian et ubuntu, prends MX linux wink
https://tutorialforlinux.com/2018/04/15 … asy-guide/

Acer Aspire 5733 - Debian 10 Kde

Hors ligne

#7 25-11-2019 13:54:09

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian
Noyau : Dur
(G)UI : gui gui, je zuis un doiseau
Inscription : 07-07-2008
Site Web

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

@golgot200: en fait, on en est à openjdk-11 dans buster (et 13, 14 dans sid/experimental), et pour la libpng, comme tu dis, on en est à la 16.

Romu galère parce qu'il veut installer des versions très vieilles et non-supportées sous Debian (ni ailleurs d'ailleurs).
Il se trouve que sur Ubuntu, quelqu'un a mis en place des PPA (qui sont sans garantie de ne pas casser le système, comme tous les ppa…)

Le vrai problème, c'est que l'appli de Romu ne tourne pas avec openjdk-11 et libpng 1.6, probablement parce qu'elle n'a pas été mise à jour. Les options seraient, soit d'installer une Debian 8.0 (Jessie), dernière à supporter la libpng12 (quitte à le faire dans un chroot), soit porter l'application vers ces nouvelles versions des librairies.

C'est vrai que ce n'est pas facile à faire, mais vu que ça peut compromettre le système, c'est peut-être bien ?

En tout cas, de mon point de vue, Debian n'est pas "coupable" de ne pas supporter les vieilles versions de openjdk et libpng, alors que leurs auteurs ne les supportent pas eux non-plus.
À la limite, l'auteur du ppa Ubuntu est "coupable" de mettre en danger les utilisateurs en leur permettant d'installer des lib pouvant casser leur système ou rajouter des failles de sécurité…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.
Je suis parrain linux !

Hors ligne

#8 25-11-2019 14:01:38

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Debian c'est cool mais ce sont des reac. installer libpng12 impossible

trouvé çà , si çà peut aider :

https://wiki.debian.org/Java

En ligne

Pied de page des forums