Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-12-2019 20:52:46

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

[RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonjour,
Sur l'ordinateur suivant : Compaq Presario CQ60 / Pentium Dual / 3Go RAM DDR2 avec Debian 10 Buster LXQT 32 bits, mis à jour.
équipé d'une carte graphique NVIDIA Corporation G98M [GeForce 9200M GS]
je souhaiterais installer le pilote non libre, mais il ne trouve pas nvidia-detect malgré que j'ai rajouté non-free dans les dépôts. (je suis ce tuto)

helene@debian-LN:~$ sudo apt-get install nvidia-detect
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet nvidia-detect


Que puis-je faire ? merci d'avance, belle soirée à tous.

Dernière modification par le_lutin (05-12-2019 16:04:49)

Hors ligne

#2 03-12-2019 22:40:24

Grompf
Membre
Distrib. : Debian Buster Gnome
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.30.2
Inscription : 08-06-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Hello !

Première question : tu utilises sudo, c'est normal ?

Ensuite, qu'est-ce que ça donne si tu fais une mise à jour ? Tu as un message d'erreur  ou est-ce que ça passe ?

CONFIGURATION :
1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Gnome (stable)
2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Debian Gnome (stable)
3. Lenovo Thinkpad X230 i5 - carte graphique Intel Corporation - Debian Gnome (stable)

Hors ligne

#3 04-12-2019 06:33:32

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonjour,
Pas de message d’erreur concernant l’utilisation de sudo.
Après avoir ajouté contrib et non-free aux lignes du sources.list as-tu bien rechargé les paquets avec

sudo apt-get update


Que donne

apt-cache policy nvidia-detect



Merci de compléter ton profil pour avoir des réponses pertinentes comme expliqué ici :
Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Hors ligne

#4 04-12-2019 10:41:46

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Grompf : oui c'est volontaire de ma part d'utiliser sudo. La mise à jour apt fonctionne bien et ne délivre aucun message d'erreur.

Chalu : oui, j'ai bien fait un update après avoir rajouté non-free au sources.list. Et :

helene@debian-LN:~$ apt-cache policy nvidia-detect
N: Impossible de trouver le paquet nvidia-detect


Peut-être ai-je fait une erreur dans le sources.list. Voici son contenu à tout hasard :

helene@debian-LN:~$ more /etc/apt/sources.list
#

# deb cdrom:[Official Debian GNU/Linux Live 10.2.0 lxqt 2019-11-16T13:23]/ buster main

#deb cdrom:[Official Debian GNU/Linux Live 10.2.0 lxqt 2019-11-16T13:23]/ buster main

deb http://ftp.fr.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.


Pour mon profil, ben en fait, je travaille sur l'ordi d'une amie … je sais pas quel est l'usage mais là je vois pas trop l'intérêt de renseigner l'install dans mon profil. Sur mon ordi perso j'ai aussi Debian mais pour l'instant tout tourne bien avec !

Hors ligne

#5 04-12-2019 10:56:04

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Tu es sur un système 32 bits tu dis.
Or nvidia-detect est dispo que pour le 64 bits d'où l'impossibilité d'y installer.

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#6 04-12-2019 11:26:59

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

melissa6969 a écrit :

Tu es sur un système 32 bits tu dis.
Or nvidia-detect est dispo que pour le 64 bits d'où l'impossibilité d'y installer.


ah d'accord oh là là ! mais alors comment puis-je savoir quelle version du pilote non-libre pourrait convenir ?
Sinon je reformaterai vers un 64bits, je pense que l'ordi supporterait …
La carte graphique : NVIDIA Corporation G98M [GeForce 9200M GS]
merci.

Dernière modification par le_lutin (04-12-2019 11:27:39)

Hors ligne

#7 04-12-2019 11:32:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonjour le_lutin,

le_lutin a écrit :

Peut-être ai-je fait une erreur dans le sources.list ?


Le sources.list est bon... c'est le paquet nvidia-legacy-340xx-driver qu'il faut choisir (GPU de 2008).

Hors ligne

#8 04-12-2019 11:33:48

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

èfpé a écrit :

Le sources.list est bon... c'est le paquet nvidia-legacy-340xx-driver qu'il faut choisir (GPU de 2008).


ok, j'essaie, je vous tiens au courant.

Hors ligne

#9 04-12-2019 12:46:44

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

En faite pourquoi installer le pilote non libre sur une vieille GPU.??
Il me semble que le pilote 340 n'est plus maintenu depuis 2018 ce qui laisse certaines failles de sécurité potentielles.

Si tu fais pas de jeux, vaut mieux garder le pilote nouveau pour une meilleure sécurité.
Mais c'est qu'un avis perso.

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#10 04-12-2019 12:55:18

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

melissa6969 a écrit :

En faite pourquoi installer le pilote non libre sur une vieille GPU.??


C'est moi qui ai suggéré de tester le driver privateur vu que le plantage de falkon qu'il experiançait semblait venir du driver graphique. Après c'était juste pour essayer en cinq minute >.>


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#11 04-12-2019 13:37:30

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

alors j'ai installé le pilote 340, mais au redémarrage, écran noir et invite de commande … sad
Comment savoir où ça cloche ? merci d'avance.

Hors ligne

#12 04-12-2019 18:37:39

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

As-tu bien le paquet linux-headers-qui va avec le noyau installé ?

dpkg -l |grep linux-image

Hors ligne

#13 04-12-2019 18:57:10

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

je viens apporter ma (toute petite) pierre :

sudo apt -s install  nvidia-detect:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet nvidia-detect:i386



sudo apt -s install  nvidia-legacy-340xx-driver:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-legacy-340xx-driver:i386 : Dépend: xserver-xorg-video-nvidia-legacy-340xx:i386 (= 340.107-7) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



sudo apt -s install xserver-xorg-video-nvidia-legacy-340xx:i386


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 xserver-xorg-video-nvidia-legacy-340xx:i386 : Dépend: xorg-video-abi-24:i386 ou
                                                        xorg-video-abi-23:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-20:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-19:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-18:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-15:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-14:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-13:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-12:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-11:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-10:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-8:i386 mais il n'est pas installable ou
                                                        xorg-video-abi-6.0:i386 mais il n'est pas installable
                                               Dépend: xserver-xorg-core:i386 (< 2:1.20.99) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



apt show nvidia-legacy-340xx-driver:i386


Package: nvidia-legacy-340xx-driver:i386
Version: 340.107-7
Priority: optional
Section: non-free/x11
Source: nvidia-graphics-drivers-legacy-340xx
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 1029 kB
Provides: nvidia-glx-any
Pre-Depends: nvidia-installer-cleanup
Depends: nvidia-legacy-340xx-driver-libs (= 340.107-7), nvidia-legacy-340xx-driver-bin (= 340.107-7), xserver-xorg-video-nvidia-legacy-340xx (= 340.107-7), nvidia-legacy-340xx-vdpau-driver (= 340.107-7), nvidia-legacy-340xx-alternative (= 340.107-7), nvidia-legacy-340xx-kernel-dkms (= 340.107-7) | nvidia-legacy-340xx-kernel-340.107, nvidia-support
Recommends: nvidia-settings-legacy-340xx, nvidia-persistenced
Suggests: nvidia-legacy-340xx-kernel-dkms (>= 340.107) | nvidia-legacy-340xx-kernel-source (>= 340.107)
Homepage: https://www.nvidia.com
Download-Size: 365 kB
APT-Sources: https://deb.debian.org/debian testing/non-free i386 Packages
Description: NVIDIA metapackage (340xx legacy version)
 This metapackage depends on the NVIDIA binary driver and libraries
 that provide optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server.
 .
 Please see the nvidia-legacy-340xx-kernel-dkms or
 nvidia-legacy-340xx-kernel-source packages
 for building the kernel module required by this package.
 This will provide nvidia-legacy-340xx-kernel-340.107.
 .
 This legacy version is the last release that supports the following GPUs:
 GeForce 205 [GT218], GeForce 210 [GT216], GeForce 210 [GT218],
 GeForce 305M [GT218M], GeForce 310 [GT218], GeForce 310M [GT218M],
 GeForce 315 [GT216], GeForce 315 [GT218], GeForce 315M [GT218M],
 GeForce 320M [MCP89], GeForce 405 [GT216], GeForce 405 [GT218],
 GeForce 8100 [C77], GeForce 8200 [C77], GeForce 8200M [C77],
 GeForce 8200M G [C77], GeForce 8200M G [MCP79], GeForce 8300 [C77],
 GeForce 8300 GS [G84], GeForce 8300 GS [G86], GeForce 8300 GS [G98],
 GeForce 8400 [G98], GeForce 8400 GS [G84], GeForce 8400 GS [G86],
 GeForce 8400 GS Rev. 2 [G98], GeForce 8400 GS Rev. 3 [GT218],
 GeForce 8400 SE [G86], GeForce 8400M G [G86M], GeForce 8400M GS [G86M],
 GeForce 8400M GT [G86M], GeForce 8500 GT [G86], GeForce 8600 GS [G84],
 GeForce 8600 GT [G84], GeForce 8600 GTS [G84], GeForce 8600M GS [G86M],
 GeForce 8600M GT [G84M], GeForce 8700M GT [G84M], GeForce 8800 GS [G92],
 GeForce 8800 GT [G92], GeForce 8800 GTS [G80], GeForce 8800 GTS 512 [G92],
 GeForce 8800 GTX [G80], GeForce 8800 Ultra [G80], GeForce 8800M GTS [G92M],
 GeForce 8800M GTX [G92M], GeForce 9100 [C78], GeForce 9100M G [C77],
 GeForce 9100M G [C79], GeForce 9200 [C77], GeForce 9200 [C79],
 GeForce 9200M GS [G98M], GeForce 9300 [C79], GeForce 9300/ION [C79],
 GeForce 9300 GE [G98], GeForce 9300 GS [G98], GeForce 9300 GS Rev. 2 [GT218],
 GeForce 9300 SE [G98], GeForce 9300M G [G86M], GeForce 9300M GS [G98M],
 GeForce 9400 [C79], GeForce 9400 [MCP7A], GeForce 9400 GT [G86],
 GeForce 9400 GT [G96], GeForce 9400M [C79], GeForce 9400M [ION VGA],
 GeForce 9400M G [C79], GeForce 9500 GS [G96], GeForce 9500 GT [G96],
 GeForce 9500M G [G96M], GeForce 9500M GS [G84M], GeForce 9600 GS [G94],
 GeForce 9600 GSO 512 [G94], GeForce 9600 GSO [G92], GeForce 9600 GSO [G94],
 GeForce 9600 GT [G94], GeForce 9600M GS [G96M], GeForce 9600M GT [G96M],
 GeForce 9650 S [G96], GeForce 9650M GS [G84M], GeForce 9650M GT [G96M],
 GeForce 9700M GT [G96M], GeForce 9700M GTS [G94M], GeForce 9800 GT [G92],
 GeForce 9800 GTX [G92], GeForce 9800 GTX+ [G92], GeForce 9800 GX2 [G92],
 GeForce 9800M GS [G94M], GeForce 9800M GT [G92M], GeForce 9800M GTS [G94M],
 GeForce 9800M GTX [G92M], GeForce G 100 [G98], GeForce G 102M [C79],
 GeForce G 103M [G98M], GeForce G 105M [G98M], GeForce G 105M [GT218M],
 GeForce G 110M [G96M], GeForce G 210 [GT218], GeForce G 210M [GT218M],
 GeForce GT 120 [G96], GeForce GT 120M [G96M], GeForce GT 130 [G94],
 GeForce GT 130M [G96M], GeForce GT 140 [G94], GeForce GT 220 [GT215],
 GeForce GT 220 [GT216], GeForce GT 220/315 [GT215], GeForce GT 220M [G96M],
 GeForce GT 230 OEM [G92], GeForce GT 230 [G94], GeForce GT 230M [GT216M],
 GeForce GT 240 [GT215], GeForce GT 240M [GT216M], GeForce GT 320 [GT215],
 GeForce GT 320M [GT216M], GeForce GT 325M [GT216M], GeForce GT 330 [G92],
 GeForce GT 330 [GT215], GeForce GT 330M [GT216M], GeForce GT 335M [GT215M],
 GeForce GT 340 [GT215], GeForce GT 415 [GT216], GeForce GTS 150M [G94M],
 GeForce GTS 160M [G94M], GeForce GTS 240 [G92], GeForce GTS 250 [G92],
 GeForce GTS 250M [GT215M], GeForce GTS 260M [GT215M],
 GeForce GTS 350M [GT215M], GeForce GTS 360M [GT215M],
 GeForce GTX 260 [GT200], GeForce GTX 260M [G92M], GeForce GTX 275 [GT200b],
 GeForce GTX 280 [GT200], GeForce GTX 280M [G92M], GeForce GTX 285 [GT200b],
 GeForce GTX 285M [G92M], GeForce GTX 295 [GT200], GeForce GTX 295 [GT200b],
 HICx16 + Graphics [G98], ION VGA, ION LE VGA, ION [C79], ION [GT218],
 ION 2 [GT218], NVS 300 [GT218], NVS 2100M [GT218M], NVS 3100M [GT218M],
 NVS 5100M [GT216M], Quadro 400 [GT216GL], Quadro CX [GT200GL],
 Quadro FX 360M [G86GLM], Quadro FX 370 [G84GL], Quadro FX 370 LP [G98GL],
 Quadro FX 370M [G98GLM], Quadro FX 380 [G96GL], Quadro FX 380 LP [GT218GL],
 Quadro FX 380M [GT218GLM], Quadro FX 570 [G84GL], Quadro FX 570M [G84GLM],
 Quadro FX 580 [G96GL], Quadro FX 770M [G96GLM], Quadro FX 880M [GT216GLM],
 Quadro FX 1600M [G84GLM], Quadro FX 1700 [G84GL], Quadro FX 1700M [G96GLM],
 Quadro FX 1800 [G94GL], Quadro FX 1800M [GT215GLM], Quadro FX 2700M [G94GLM],
 Quadro FX 2800M [G92GLM], Quadro FX 3600M [G92GLM], Quadro FX 3700 [G92GL],
 Quadro FX 3700M [G92GLM], Quadro FX 3800 [GT200GL], Quadro FX 3800M [G92GLM],
 Quadro FX 4600 [G80GL], Quadro FX 4700 X2 [G92GL], Quadro FX 4800 [GT200GL],
 Quadro FX 5600 [G80GL], Quadro FX 5800 [GT200GL], Quadro NVS 130M [G86M],
 Quadro NVS 135M [G86M], Quadro NVS 140M [G86M], Quadro NVS 150M [G98M],
 Quadro NVS 160M [G98M], Quadro NVS 290 [G86], Quadro NVS 295 [G98],
 Quadro NVS 320M [G84GLM], Quadro NVS 420 [G98], Quadro NVS 450 [G98],
 Quadro Plex 2200 D2 [GT200GL], Quadro Plex 2200 S4 [GT200GL],
 Quadro VX 200 [G92GL], Tesla C870 [G80GL], Tesla C1060 [GT200GL],
 Tesla M1060 [GT200GL], nForce 720a [C77], nForce 730a [C77],
 nForce 730i [C79], nForce 750a SLI [C77], nForce 760i SLI [C79],
 nForce 780a SLI [C77], nForce 980a SLI [C77], GRID K1 [GK107GL],
 GRID K2 [GK104GL], GRID K340 [GK107GL].
 .
 There are several "more modern" GPUs supported by this package, too, but the
 updated drivers in the newer legacy packages or the current nvidia-driver
 package usually provide more features and better support.
 Look at the other legacy packages for older cards.
 .
 See /usr/share/doc/nvidia-legacy-340xx-driver/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.
 .
 Building the kernel module has been tested up to Linux 5.3.

N: Il y a 1 enregistrement supplémentaire. Veuillez utiliser l'opérande « -a » pour le voir



pour faire court :

 Please see the nvidia-legacy-340xx-kernel-dkms or
 nvidia-legacy-340xx-kernel-source packages
 for building the kernel module required by this package.
 This will provide nvidia-legacy-340xx-kernel-340.107.
 


Building the kernel module has been tested up to Linux 5.3.




si çà peut aider (testing bullseye)

Dernière modification par Debian Alain (04-12-2019 19:08:25)

En ligne

#14 04-12-2019 19:45:28

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Les headers s'installent automatiquement avec le pilote vu que c'est une dépendance Obligatoire.

L'écran noir provient d'un mauvais build de dkms.
Il aurait fallu relever tous les messages que dkms retournait lors du build.

Et éventuellement regarder les logs lorsque X démarre pas, voir un peu ça que ça raconte.

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#15 04-12-2019 20:02:27

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

regarde si lynx peut pas t'aider ?
(un navigateur en cli)

apt install lynx


tu pourra peut être nous poster le retour de

cat /var/log/Xorg.0.log

En ligne

#16 04-12-2019 20:26:14

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

èfpé  a écrit :

Le sources.list est bon... c'est le paquet nvidia-legacy-340xx-driver qu'il faut choisir (GPU de 2008).



chalu  a écrit :

dpkg -l |grep linux-image



peux tu nous renvoyer le retour de

dpkg -l | grep -iE "linux-image|linux-headers"


si l'image et les headers sont identiques ,
alors désinstalle ton pilote "proprio" afin de revenir sur le pilote "nouveau"
et donc , p ê , de récupérer ton bureau .

Dernière modification par Debian Alain (04-12-2019 20:29:50)

En ligne

#17 04-12-2019 20:38:18

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.2
Noyau : Linux 5.3.18
(G)UI : KDE 5.18.5
Inscription : 11-03-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Ah oui bien vu, j’ai oublié la moitié de la commande smile

Hors ligne

#18 04-12-2019 20:50:01

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bon, j'ai réussi à désinstaller le pilote Nvidia, j'ai retrouvé mon environnement de bureau tongue
du coup :

helene@debian-LN:~$ dpkg -l | grep -iE "linux-image|linux-headers"
ii  linux-headers-4.19.0-6-686-pae        4.19.67-2+deb10u2                   i386         Header files for Linux 4.19.0-6-686-pae
ii  linux-headers-4.19.0-6-common         4.19.67-2+deb10u2                   all          Common header files for Linux 4.19.0-6
ii  linux-headers-686-pae                 4.19+105+deb10u1                    i386         Header files for Linux 686-pae configuration (meta-package)
ii  linux-image-4.19.0-6-686              4.19.67-2+deb10u2                   i386         Linux 4.19 for older PCs (signed)
ii  linux-image-686                       4.19+105+deb10u1                    i386         Linux for older PCs (meta-package)
 


Une question quand même : le wifi fonctionne de manière aléatoire, cela peut-il être lié à la carte graphique aussi ? car le wifi c'est important pour la propriétaire de cet ordi …
merci, belle soirée.
PS : lorsque je fais cat /var/log/Xorg.0.log, j'ai un texte très long voici la fin, mais je peux poster tout si nécessaire :

[    44.031] (**) Option "xkb_model" "pc105"
[    44.031] (**) Option "xkb_layout" "fr"
[    44.032] (**) Option "xkb_variant" "latin9"
[    44.034] (II) event7  - HP WMI hotkeys: is tagged by udev as: Keyboard Switch
[    44.034] (II) event7  - HP WMI hotkeys: device is a keyboard
[    44.034] (II) event7  - HP WMI hotkeys: device is a switch device
[    44.104] (EE) Failed to open authorization file "/var/run/sddm/{4e0f7662-9d8a-4c77-b787-37c76932cf04}": No such file or directory
[    70.396] (II) modeset(0): Disabling kernel dirty updates, not required.
[    77.749] (II) modeset(0): EDID vendor "AUO", prod id 4332
[    77.749] (II) modeset(0): Printing DDC gathered Modelines:
[    77.749] (II) modeset(0): Modeline "1366x768"x0.0   72.00  1366 1414 1446 1486  768 771 775 806 -hsync -vsync (48.5 kHz eP)
[    78.695] (II) modeset(0): EDID vendor "AUO", prod id 4332
[    78.696] (II) modeset(0): Printing DDC gathered Modelines:
[    78.696] (II) modeset(0): Modeline "1366x768"x0.0   72.00  1366 1414 1446 1486  768 771 775 806 -hsync -vsync (48.5 kHz eP)
[    78.753] (II) modeset(0): EDID vendor "AUO", prod id 4332
[    78.753] (II) modeset(0): Printing DDC gathered Modelines:
[    78.753] (II) modeset(0): Modeline "1366x768"x0.0   72.00  1366 1414 1446 1486  768 771 775 806 -hsync -vsync (48.5 kHz eP)
[   164.016] (II) Axis 0x1 value 5098 is outside expected range [1232, 5091]
See https://wayland.freedesktop.org/libinput/doc/1.12.6/absolute_coordinate_ranges.html for details
[   225.797] (EE) event5  - SynPS/2 Synaptics TouchPad: kernel bug: Touch jump detected and discarded.
See https://wayland.freedesktop.org/libinput/doc/1.12.6/touchpad-jumping-cursors.html for details
 

Dernière modification par le_lutin (04-12-2019 20:52:19)

Hors ligne

#19 04-12-2019 20:58:38

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

tu as quoi comme wifi le_lutin ?

lspci -nnk | grep -i net -A2

(identifiants pci)

poste le retour


et

lsusb

(identifiants usb)

poste le retour


éventuellement , pour savoir ce que tu as comme machine :

apt install inxi

(petit utilitaire :  -- inxi -- )

inxi -F

et poste le retour


pour détailler ton réseau :

inxi -nxx


pour vérifier tes firmwares :

dmesg | grep firmware


voilà ...

Dernière modification par Debian Alain (04-12-2019 21:16:25)

En ligne

#20 04-12-2019 21:06:28

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Le retour de log de Xorg aurait été intéressant lors du crash avec  le pilote nvidia, pour identifier le problème, là en l'état il sert a rien vu que tout fonctionne.

Et pour la wifi pas de lézard, ça a aucun rapport avec le GPU.
Peut être (sûrement.??) Un firmware manquant donc une certaine instabilité du réseau.

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#21 04-12-2019 21:22:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonsoir le_lutin,

le_lutin a écrit :

dpkg -l | grep -iE "linux-image|linux-headers"

ii  linux-headers-4.19.0-6-686-pae  4.19.67-2+deb10u2  i386  Header files for Linux 4.19.0-6-686-pae
ii  linux-headers-4.19.0-6-common   4.19.67-2+deb10u2  all   Common header files for Linux 4.19.0-6
ii  linux-headers-686-pae           4.19+105+deb10u1   i386  Header files for Linux 686-pae configuration (meta-package)
ii  linux-image-4.19.0-6-686        4.19.67-2+deb10u2  i386  Linux 4.19 for older PCs (signed)
ii  linux-image-686                 4.19+105+deb10u1   i386  Linux for older PCs (meta-package)


Ah tiens, il y a effectivement un souci : linux-headers-686-pae ne match pas avec linux-image-686.
Le paquet linux-headers-686-pae est une recommandation pour dkms (dépendance pour le pilote).

Le problème est facilement reproductible... les modules pour le noyau ne sont juste pas construits :

apt install nvidia-legacy-340xx-driver

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
...
Paramétrage de nvidia-legacy-340xx-kernel-dkms (340.107-4) ...
Loading new nvidia-legacy-340xx-340.107 DKMS files...
Building for 4.19.0-6-686
Module build for kernel 4.19.0-6-686 was skipped since the
kernel headers for this kernel does not seem to be installed.
Paramétrage de nvidia-legacy-340xx-driver (340.107-4) ...


dkms status

nvidia-legacy-340xx, 340.107: added


Par contre, une fois le métapaquet linux-headers-686 installé, l'installation se déroule normalement :

apt install nvidia-legacy-340xx-driver

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
...
Paramétrage de nvidia-legacy-340xx-kernel-dkms (340.107-4) ...
Loading new nvidia-legacy-340xx-340.107 DKMS files...
Building for 4.19.0-6-686
Building initial module for 4.19.0-6-686
Done.

nvidia-legacy-340xx.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-6-686/updates/dkms/

nvidia-legacy-340xx-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-6-686/updates/dkms/

depmod...

DKMS: install completed.
Paramétrage de nvidia-legacy-340xx-driver (340.107-4) ...
 


dkms status

nvidia-legacy-340xx, 340.107, 4.19.0-6-686, i686: installed


Deux possibilités, donc. Soit (1) tu installes les en-têtes 686. Soit (2) tu installes le noyau 686-pae.

Dernière modification par èfpé (05-12-2019 15:22:42)

Hors ligne

#22 04-12-2019 21:40:38

Grompf
Membre
Distrib. : Debian Buster Gnome
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.30.2
Inscription : 08-06-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Remarque en passant : le matériel supporterait une version 64 bits, non ?

CONFIGURATION :
1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Gnome (stable)
2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Debian Gnome (stable)
3. Lenovo Thinkpad X230 i5 - carte graphique Intel Corporation - Debian Gnome (stable)

Hors ligne

#23 04-12-2019 21:53:43

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

sur un pentium ?  tu es sûr grompf ? (même dual core ...)

En ligne

#24 04-12-2019 22:02:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonsoir @all,

Grompf a écrit :

Remarque en passant : le matériel supporterait une version 64 bits, non ?


Cela paraît probable... Ceci dit, les premiers Pentium Dual-Core (2007 H1, "Yonah") étaient 32 bits...

Hors ligne

#25 05-12-2019 08:56:51

le_lutin
Membre
Lieu : Alsace
Distrib. : Debian 10 Buster
Noyau : 4.19.0-10-amd64
(G)UI : Gnome
Inscription : 01-11-2019

Re : [RESOLU] Pilote non libre pour Carte graphique NVIDIA / Wifi instable

Bonjour à tous, Merci pour tous vos derniers messages.
Le processeur est 64 bits. Mais là j'ai envie de mettre de côté cette histoire de pilote Nvidia, et de m'occuper du wifi :

ebian-LN:~$ lspci -nnk | grep -i net -A2
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 02)
        Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller [103c:360b]
        Kernel driver in use: r8169
        Kernel modules: r8169
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)
        Subsystem: Hewlett-Packard Company AR242x / AR542x Wireless Network Adapter (PCI-Express) [103c:137b]
        Kernel driver in use: ath5k
        Kernel modules: ath5k
 


ian-LN:~$ lsusb
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04f2:b091 Chicony Electronics Co., Ltd Webcam
Bus 002 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 


@debian-LN:~$ inxi -F
System:    Host: debian-LN Kernel: 4.19.0-6-686 i686 bits: 32 Desktop: LXQt 0.14.1 Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Laptop System: Hewlett-Packard product: Compaq Presario CQ60 Notebook PC v: F.32 serial: <root required>
           Mobo: Wistron model: 3617 v: 09.48 serial: <root required> BIOS: Hewlett-Packard v: F.32 date: 11/20/2008
CPU:       Topology: Dual Core model: Intel Pentium Dual T3200 bits: 64 type: MCP L2 cache: 1024 KiB
           Speed: 1922 MHz min/max: 1000/2000 MHz Core speeds (MHz): 1: 1944 2: 1962
Graphics:  Device-1: NVIDIA G98M [GeForce 9200M GS] driver: nouveau v: kernel
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
           OpenGL: renderer: NV98 v: 3.3 Mesa 18.3.6
Audio:     Device-1: Intel 82801I HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k4.19.0-6-686
Network:   Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
           Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter driver: ath5k
           IF: wlp3s0 state: down mac:
Drives:    Local Storage: total: 232.89 GiB used: 9.64 GiB (4.1%)
           ID-1: /dev/sda vendor: Hitachi model: HTS543225L9A300 size: 232.89 GiB
Partition: ID-1: / size: 28.71 GiB used: 9.41 GiB (32.8%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 195.54 GiB used: 238.8 MiB (0.1%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 34.0 C mobo: 34.0 C gpu: nouveau temp: 39 C
           Fan Speeds (RPM): N/A
Info:      Processes: 148 Uptime: 7m Memory: 2.96 GiB used: 682.8 MiB (22.5%) Shell: bash inxi: 3.0.32
 


e@debian-LN:~$ inxi -nxx
Network:   Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet vendor: Hewlett-Packard RTL810xE driver: r8169
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8136
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
           Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter vendor: Hewlett-Packard driver: ath5k v: kernel
           port: 3000 bus ID: 03:00.0 chip ID: 168c:001c
           IF: wlp3s0 state: down mac:
 


sudo dmesg | grep firmware (retour vide)


Je remarque qu'il y a deux interfaces wifi, est-ce normal selon vous ? voir :

e@debian-LN:~$ sudo rfkill list
0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
 

merci.

Dernière modification par le_lutin (05-12-2019 09:32:15)

Hors ligne

Pied de page des forums