Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-12-2019 18:46:42

bruno-legrand
Adhérent(e)
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 14-06-2016

problème pour la configuration du pare-feu

Salut tout le monde   smile

Je fais partie d'Infothema et j'ai appris auprès de mon copain d'asso l'importance d'avoir un pare-feu et de le configurer un minimum.

J'ai suivi un sujet du forum infothema pour le configurer : Installer ufw & gufw – Un firewall simplifié

Je suis sous Debian 10 Gnome avec un compte user et un compte admin, pour info.   wink


J’ai procédé à l’installation via apt install gufw

Ensuite j’ai suivi cela :

Animateur forum infothema a écrit :

Ensuite ajoutons quelques règles pour le trafic web entrant. Coller les lignes suivantes une à la fois et taper Entrée pour chacune:

sudo ufw deny 5353/udp
sudo ufw deny 5900/tcp
sudo ufw deny 22
sudo ufw deny 25/tcp
sudo ufw deny 135,139,445/tcp
sudo ufw deny 137,138/udp
sudo ufw deny 110
sudo ufw deny 2049
sudo ufw deny 143
sudo ufw deny 21/tcp
sudo ufw deny ssh


(j’ai modifié ces lignes en enlevant sudo puisque je me suis mit en admin avant via su)

Ensuite j’ai activé les changements, puis je les ai vérifié via les 2 commandes indiqués dans le sujet.

Jusque là ça va, sauf que quand je veux voir ensuite ça en graphique cela ne fonctionne pas.
Et c’est embêtant je voulais essayer de rajouter en graphique le torrent en activé dans le pare-feu mais accepté.

Si j’essaye d’ouvrir gufw en terminal pour voir, voilà les retours du terminal :

bruno@bru-pc:~$ gufw
No protocol specified
Unable to init server: Could not connect: Connection refused
No protocol specified
Unable to init server: Impossible de se connecter : Connection refused

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gdk-CRITICAL **: 17:23:45.512: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.512: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.514: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.514: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(gufw.py:4509): Gtk-CRITICAL **: 17:23:45.514: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed
/usr/bin/gufw-pkexec : ligne 13 :  4509 Erreur de segmentation  python3 ${LOCATIONS[${i}]} $1


bloc à supprimer si la commande n’affiche rien



Merci de m’aider, là je ne vois pas trop ce que je peux faire.   wink

Hors ligne

#2 10-12-2019 19:31:25

paul-riluma
Membre
Distrib. : debian...
Noyau : euh...
(G)UI : ah tiens !
Inscription : 22-09-2019

Re : problème pour la configuration du pare-feu

ello...
bon, alors
ton parefeu se configure avec des droits en root puisque tu entres les paramètres avec sudo

ensuite
quand tu veux lancer en console ton parefeu, ben il faut le faire en root.
donc le mieux c'est de passer par su
puis là tu lances ufw

la réponse de gtk vient de ce que tu n'est pas en root mais en utilisateur ordinaire. et de toute façon, quand on lance un truc genre mousepad ou autre éditeur de texte gtk, ben ça renvoie toujours des messages d'erreur, parce que normalement, ben faut pas lancer de l'édition de texte en root avec un éditeur graphique... il te répond qu'on met son système en danger grâve et tout que ça va s'effondrer...
bref... euh...

lances ton ufw dans une console root : si ça fait des cacas nerveux encore, ben là... c'est qu'il y a un autre problème...

Hors ligne

#3 11-12-2019 18:13:28

bruno-legrand
Adhérent(e)
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 14-06-2016

Re : problème pour la configuration du pare-feu

Salut, merci pour ta réponse.   wink

Oui je sais qu'il faut être en root, je disais justement dans mon message précédent   "(j’ai modifié ces lignes en enlevant sudo puisque je me suis mit en admin avant via su)"

Et le retour de commande que j'ai mis ensuite je l'ai fait en root via su, et je viens de réessayer pour être sûr, en passant bien en root avant via su, et j'ai le même retour, il ne veut pas m'ouvrir l'interface graphique du pare-feu gufw    sad

Hors ligne

#4 11-12-2019 18:44:24

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème pour la configuration du pare-feu

fais attention bruno-legrand ,
on utilise plus "su" mais "su -"
pour passer root

su -


et mdp root

ou

sudo -i


et mdp user

En ligne

#5 11-12-2019 18:59:38

bruno-legrand
Adhérent(e)
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 14-06-2016

Re : problème pour la configuration du pare-feu

Merci Debian Alain pour les infos.   ;)

Néanmoins je ne comprends pas, je viens de vérifier en faisant su dans le terminal et il me demande mon mdp, je renseigne le mdp root, et ensuite il me passe en root, voir :

bruno@bru-pc:~$ su
Mot de passe :
 


root@bru-pc:/home/bruno#



Et j'en profite pour reconfirmer que je passe bien root quand j'essaye d'ouvrir gufw.

Hors ligne

#6 11-12-2019 19:11:07

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème pour la configuration du pare-feu

bruno-legrand , su est une vieille commande .
actuellement dépréciée .
actuellement , si tu tiens à faire les choses bien , utilises "su -" .
si tu veux aller au fond des choses , c'est une histoire de "path" .
les deux terminologies n'utilisent pas tout à fait le même path .
ou plutôt l'un (su) est incomplet et source de problèmes par opposition à l'autre (su -) , conseillé , donc .

par ailleurs , je confirme (en tout cas  sous testing) :
gufw , lancé en graphique , demande bien le mdp user .

Dernière modification par Debian Alain (12-12-2019 17:32:00)

En ligne

#7 11-12-2019 23:02:04

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : problème pour la configuration du pare-feu

su est une vieille commande toujours appréciée. smile

Extraits du manuel :

DESCRIPTION
       La commande su permet de devenir un autre utilisateur pour la durée
       d'une session. Invoqué sans nom d'utilisateur, le comportement par
       défaut de suest de devenir superutilisateur. Le paramètre optionnel -
       permet d'obtenir un environnement similaire à celui que l'utilisateur
       aurait obtenu lors d'une connexion directe…
…      -, -l, --login
           Fournir à l'utilisateur un environnement similaire à celui qu'il
           aurait obtenu s'il s'était connecté directement.

           When - is used, it must be specified before any username. For
           portability it is recommended to use it as last option, before any
           username. The other forms (-l and --login) do not have this
           restriction.

Dernière modification par Philou92 (11-12-2019 23:03:33)


Tousse antique Ovide !

Hors ligne

#8 12-12-2019 11:37:12

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème pour la configuration du pare-feu

oui , je me suis peut être avancé un peu vite .
c'est pas su qui est déprécié mais son usage .

man  a écrit :

su allows to run commands with a substitute user and group ID.

       When  called  without  arguments, su defaults to running an interactive
       shell as root.

       For backward compatibility, su defaults to not change the  current  directory  and to only set the environment variables HOME and SHELL (plus
       USER and LOGNAME if the target user is not root).  It is recommended to
       always use the --login option (instead of its shortcut -) to avoid sid effects caused by mixing environments.



man traduit  a écrit :

su permet d'exécuter des commandes avec un nom d'utilisateur et un ID de groupe de substitution.

       Lorsqu'il est appelé sans arguments, su exécute par défaut un programme interactif
       shell en tant que root.

       Pour des raisons de rétrocompatibilité, su propose par défaut de ne pas modifier le répertoire courant et de ne définir que les variables d'environnement HOME et SHELL (plus
       USER et LOGNAME si l'utilisateur cible n'est pas root).  Il est recommandé de
       utilisez toujours l'option --login (au lieu de son raccourci -) pour éviter les effets secondaires causés par les environnements de mixage.

Traduit avec www.DeepL.com/Translator (version gratuite)



-- wiki DF (su /su -) --

En ligne

#9 12-12-2019 17:18:50

bruno-legrand
Adhérent(e)
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 14-06-2016

Re : problème pour la configuration du pare-feu

Merci pour vos informations c'est intéressant.   wink

En tout cas c'est embêtant que je n'arrive pas à ouvrir gufw en graphique.

Hors ligne

#10 12-12-2019 18:03:45

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : problème pour la configuration du pare-feu

1) mon path par défaut :

echo $PATH


/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/alain/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin


je suis où ?

pwd


/home/alain

dans mon /home . ouf ! tout va bien .
je lance et j'éteinds gufw :

gufw


localuser:root being added to access control list
localuser:root being removed from access control list


il me demande mon mot de passe user et se lance , tout va bien . je l'éteinds .

2) je passe root avec su :

su


Mot de passe :
root@Alain-PC:/home/alain#


je suis où : ?

pwd


/home/alain


fonctionnement anormal , je devrai être root et non user avec des privilèges root .
par ailleurs , le path n'est pas bon . pas modifié donc pas bon .
mon path :

echo $PATH


/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/alain/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin


lancer gufw :

gufw


/usr/bin/gufw: 2: [: =: unexpected operator
/usr/bin/gufw: 7: [: =: unexpected operator


il se lance et  fonctionne (curieux ...) scratchhead.gif
fonctionnement anormal . si su était fidèle aux normes posix , il devrait réagir comme su - (ci dessous)
qui plus est , le path est anormal , il devrait être comme ci- dessous (su -)

3) je passe root avec su - :

su -


Mot de passe :
root@Alain-PC:~#


je suis où ?

pwd


là , c'est bon , je suis devenu root .complètement . pas à demi comme précédemment .

/root


mon path :

echo $PATH


et le path est dûment modifié :

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin


lancer gufw :

gufw


/usr/bin/gufw: 2: [: =: unexpected operator
Unable to init server: Could not connect: Connection refused
Unable to init server: Impossible de se connecter : Connection refused

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.111: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.111: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.112: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.112: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_modifier_mask: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gdk-CRITICAL **: 16:53:35.112: gdk_keymap_get_for_display: assertion 'GDK_IS_DISPLAY (display)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.112: _gtk_replace_virtual_modifiers: assertion 'GDK_IS_KEYMAP (keymap)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.113: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.113: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(gufw.py:68725): Gtk-CRITICAL **: 16:53:35.113: _gtk_style_provider_private_get_settings: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed
/usr/bin/gufw-pkexec : ligne 13 : 68725 Erreur de segmentation  python3 ${LOCATIONS[${i}]} $1
/usr/bin/gufw: 7: [: =: unexpected operator



echo $XDG_SESSION_DESKTOP


gnome


echo $XDG_SESSION_TYPE


wayland

Dernière modification par Debian Alain (12-12-2019 18:16:57)

En ligne

#11 12-12-2019 20:10:43

infothema
CA Debian-Facile
Lieu : Bégard (Côtes d'Armor)
Distrib. : CentOS 8 - Fedora 32
(G)UI : MATE
Inscription : 28-01-2012
Site Web

Re : problème pour la configuration du pare-feu

Hello bruno-legrand smile

Pour configurer un pare-feu, la règle est de tout bloquer par définition puis d'ouvrir port par port pour l'usage des applications web utilisées.

Tu ne devrais pas mélanger des commandes en ligne avec une configuration graphique ! Parfois cela génère des conflits et franchement c'est plus clair en ligne de commande.

Pour t'aider, tu peux parcourir cette documentation : https://www.leshirondellesdunet.com/pare-feu-ufw

Le support contient plusieurs infos sur les ports courants.

@+

Association libriste infothema  située dans les Côtes d'Armor (Bretagne)
Blog : https://www.infothema.fr / Forum : https://www.infothema.fr/forum
Twitter : https://twitter.com/asso_infothema / Compte Mastodon : https://framapiaf.org/@infothema
Diaspora : https://framasphere.org/u/association_infothema

En ligne

#12 26-12-2019 13:15:29

bruno-legrand
Adhérent(e)
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome
Inscription : 14-06-2016

Re : problème pour la configuration du pare-feu

Salut tout le monde    smile
Merci à vous pour vos réponses.

Personnellement ce n'est pas si simple et limpide pour moi de gérer le pare-feu en ligne de commande, autant l'installation de programmes il n'y a aucun soucis mais là pour le pare-feu actuellement je trouve que je ne comprends moins bien les lignes de commandes ce qu'elles font.

Je pense que la prochaine fois je passerai directement par l'interface graphique.   wink

Le problème c'est que je veux autoriser l'usage du torrent dans mon pare-feu, et dans ton lien donné il dit ceci :

16/ Autoriser Amule, Transmission (et autres Torrent)
Passez par l'interface graphique et utilisez l'onglet "pré-configuré", c'est le plus simple.


Le problème c'est que je ne peux pas passer par l'interface graphique maintenant comme j'expliquais + haut.

Hors ligne

#13 27-12-2019 18:06:34

LaFouine
Membre
Distrib. : Debian testing
Noyau : 4.19.0-4-amd64
(G)UI : Xfce
Inscription : 10-04-2017

Re : problème pour la configuration du pare-feu

Bon

Utiliser une interface graphique pour gérer le système est a mon humble avis, une mauvaise habitude. Certe la documentation est grande et donc prend du temps. et quand elle veux bien marcher...

Déjà il s'agis de netfilter, qui est gérer par iptables, en cour de révision  pour devenir nftables. et donc tu veux ajouter une couche graphique roll

Ceci est un lien qui si tu veux approfondir et arreter de te prendre la tête avec ce qui est une surcouche de l'essentiel (enfin presque).
https://www.inetdoc.net/guides/iptables-tutorial/  il est plutot complet tu en trouvera aussi sur la FAQ de DF  mai bon je m'éloigne de ton souci.

pour ton souci il lui manque un paramettre dans ta commande.

/usr/bin/gufw: 2: [: =: unexpected operator



Cela est surement du shell et montre un paramètre manquant qui est pas tester correctement par son développeur.
je ne connait pas gufw mai tu devrai trouver ce paramètre dans sa documentation

Essaye un classique /usr/bin/gufw start ou gufw start
Amuse toi bien


Debian testing, nvidia 980 gtx sli, cm asurock 16 gb ram cpu i7 4,2 ghz

Hors ligne

#14 29-09-2020 21:38:51

pili36
Membre
Lieu : Lille
Distrib. : Debian Bullseye / Raspbian Buster
Noyau : 5.10_amd64 / 4.19_armhf
(G)UI : Xfce
Inscription : 03-11-2009

Re : problème pour la configuration du pare-feu

Bonjour,

@Bruno-Legrand ma réponse arrive sûrement trop tard mais ça pourra peut-être aider d'autres personnes. J'ai rencontré le même problème récemment avec gufw sous Gnome. Ce message n'apparaît que sous une session Gnome Wayland. Si tu lances la session Gnome sous Xorg, Gufw va se lancer. Je pense qu'il s'agit d'un incompatibilité de la version Gufw dans Debian Buster avec Wayland.

Dernière modification par pili36 (29-09-2020 21:40:07)


Debian Bullseye amd64, Xfce, Lenovo G50, Amd Q4000 4*1,3Ghz, 8Go RAM, Amd Radeon R3
Debian Buslleye amd64, (pour Steam), Xfce, Amd Ryzen 5 2600 6*3.4Ghz, 16Go RAM, Amd Radeon RX560 4Go
Raspbian Buster, armhf, Xfce, Raspberry Pi 4 4Go model B

Hors ligne

Pied de page des forums