Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-12-2019 18:29:55

Tuxuedo
Membre
Inscription : 13-01-2018

Problème Port USB fonctionnement aléatoire

Bonjour,

J'ai un problème avec mes ports USB.
Je possède deux USB 2 et un port USB 3 sur un portable (Lenovo G50-30), depuis quelques jours leurs fonctionnements semble aléatoire. 

Un des port USB 2 semble totalement mort, le deuxième détecte une clé USB sans problème mais ne semble pas reconnaître la souris , pourtant elle semble être alimenter par intermittence. Mais la souris ne réagit jamais.
Le port USB 3 reconnaît lui aussi la clé USB mais souris ne réagit pas non plus.
J'ai testé la souris sur un autre ordinateur sous Linux , elle fonctionne parfaitement. Il s'agit d'une souris Logitech bas de gamme.
J'ai aussi booté sur un LiveDVD sur le portable et j'observe le même comportement des ports USB. C'est donc matériel à priori.

Voici un exemple des logs lorsque j'insère la souris dans les ports USB.

iza6.png

Pouvez-vous m'aidez à résoudre le problème ou à comprendre ce qu'il se passe.
J'ai l'impression qu'il y a peut-être une problème d'alimentation des ports USB, je vais me renseigner de mon côté mais j'ai peu d'espoir.
Je me demande si le contrôleur USB n'est pas entrain de rendre l'âme.

Merci

Dernière modification par Tuxuedo (11-12-2019 18:37:02)

Hors ligne

#2 11-12-2019 21:45:16

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : Problème Port USB fonctionnement aléatoire

tu peux éviter de mettre des photos pour montrer des logs [modéré]
Voir là : Vous aimez les ours blanc : utilisez la ligne de commande au lieu des captures d'écran wink
ça serait un problème de reconnaissance matériel à cause de Debian ok, mais là on peut pas faire grand chose à vrai dire.
[Modéré]

Dernière modification par melissa6969 (11-12-2019 21:47:35)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#3 11-12-2019 21:47:46

raleur
Membre
Inscription : 03-10-2014

Re : Problème Port USB fonctionnement aléatoire

Qu'est-ce que ça donne avec un périphérique auto-alimenté (=alimenté autrement que par le bus USB) ?
Si c'était un ordinateur de bureau, j'aurais suggéré de vérifier les tensions d'alimentation +5V et +5VSB.

Dernière modification par raleur (11-12-2019 21:48:47)


Il vaut mieux montrer que raconter.

Hors ligne

#4 12-12-2019 11:25:35

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

melissa6969 a écrit :

tu peux éviter de mettre des photos pour montrer des logs,
étant donné que c'est matériel en quoi on peut concrètement t'aider ?? [post modéré]
Vous aimez les ours blanc : utilisez la ligne de commande au lieu des captures d'écran



Je suis étonné de ton comportement agressif et de ton commentaire , jamais je n'avais vu un tel comportement dans la communauté open source ..
Pour te répondre :
- J'ai fais un screenshot car ce n'est pas mon pc, c'était plus facile pour moi.
- J'ai fais pas mal de recherche de mon côté et il semblerait que ce soit une erreur assez fréquente, il se pourrait que ce soit software -> Linux.

Franchement je suis déçu par ce type de réponse non constructive

Dernière modification par Tuxuedo (12-12-2019 11:34:01)

Hors ligne

#5 12-12-2019 11:31:50

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

raleur a écrit :

Qu'est-ce que ça donne avec un périphérique auto-alimenté (=alimenté autrement que par le bus USB) ?
Si c'était un ordinateur de bureau, j'aurais suggéré de vérifier les tensions d'alimentation +5V et +5VSB.



Hello, Merci pour ta réponse.
Dans mes recherches , utiliser un hub alimenté / périphérique auto-alimenté était un piste à suive.

J'ai aussi essayé plusieurs choses sans succès jusqu'à présent.

https://paulphilippov.com/articles/how- … ress-error
https://urukrama.wordpress.com/2009/01/ … -error-71/
https://www.linuxquestions.org/question … 175640937/

Je vais essayer un disque dur alimenté voir comment réagissent les ports USB
Je vais aussi brancher un hub usb historie de voir, malheureusement le mien n'est pas alimenté.
Merci

Edit : Je viens de tester la souris USB via un hub non alimenté et elle fonctionne.
Le hub est donc reconnu et l'adressage de la souris est accepté.

Que faut-il en conclure ?

Dernière modification par Tuxuedo (12-12-2019 12:22:40)

Hors ligne

#6 12-12-2019 14:39:28

raleur
Membre
Inscription : 03-10-2014

Re : Problème Port USB fonctionnement aléatoire

Difficile de dire si c'est l'alimentation ou la communication qui est améliorée par le hub bus-alimenté.

PS : Je n'ai pas trouvé le commentaire de Melissa agressif. C'est une remarque qui est souvent faite quand on estime qu'une capture d'écran graphique n'était pas justifiée. D'ailleurs initialement j'avais écrit un commentaire de la même teneur dans ma réponse, puis l'ai supprimé quand j'ai vu le message posté par Melissa entretemps pour ne pas faire doublon. D'autre part, je ne vois pas en quoi une copie du texte brut était plus difficile qu'une copie d'écran graphique.

Il vaut mieux montrer que raconter.

Hors ligne

#7 12-12-2019 14:53:56

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème Port USB fonctionnement aléatoire

pure curiosité Tuxuedo , tu as pensé à upgrader ton kernel ? scratchhead.gif

tu utilises quelle distribution ?

lsb_release -a


quel noyau : ?

uname -a

Dernière modification par Debian Alain (12-12-2019 14:55:19)

Hors ligne

#8 12-12-2019 16:02:47

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

raleur a écrit :

Difficile de dire si c'est l'alimentation ou la communication qui est améliorée par le hub bus-alimenté.

PS : Je n'ai pas trouvé le commentaire de Melissa agressif. C'est une remarque qui est souvent faite quand on estime qu'une capture d'écran graphique n'était pas justifiée. D'ailleurs initialement j'avais écrit un commentaire de la même teneur dans ma réponse, puis l'ai supprimé quand j'ai vu le message posté par Melissa entretemps pour ne pas faire doublon. D'autre part, je ne vois pas en quoi une copie du texte brut était plus difficile qu'une copie d'écran graphique.



Hello
Je ne sais pas non plus. Mais le Hub USB n'est PAS alimenté. 
Je vais chercher, bien que pour l'aspect pratique c'est plus ou moins résolu.
J'espère que la situation ne vas pas se dégrader et que c'est bien un problème software.

A propos du commentaire de Mélissa.
Je ne savais tout simplement pas que je ne pouvais pas ou que ce n'est pas conseillé de poster une capture d'écran.
Oui d'un point de vue technique c'est aussi facile de poster un log, c'était un choix , une préférence de ma part.
Elle aurait pu me le dire d'une façon plus aimable. Moi je l'ai trouvé que l'attitude était exagérée.

Nous somme ici pour nous aider, trouver des solutions.

Hors ligne

#9 12-12-2019 16:05:09

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

Debian Alain a écrit :

pure curiosité Tuxuedo , tu as pensé à upgrader ton kernel ? https://debian-facile.org/img/smilies/x … chhead.gif

tu utilises quelle distribution ?

lsb_release -a


quel noyau : ?

uname -a



Hello

Merci pour ta réponse.

Tout est à jour.
Il s'agit d'Ubuntu 18.04.  Il doit s'agir du noyay 4.15.0-72-generic (Je précise que c'est une verrsion LTS)
Mais la distrib ne semble pas avoir d'importance.
J'ai retesté ce matin avec Arch-Linux , le même problème se produit. (J'ai testé sur Debian Buster Hier)
Je pensais booter sur un ancien noyau pour voir si il y avait un changement mais j'ai oublié de le faire.
A priori , je pense que le résultat serait le même.

Dernière modification par Tuxuedo (12-12-2019 16:13:39)

Hors ligne

#10 12-12-2019 16:10:27

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème Port USB fonctionnement aléatoire

arf  ! tu dois avoir raison : panne matérielle .

je n'ai jamais vu debian , et à priori ubuntu , faire dysfonctionner des ports usb .

par contre , j'ai facilement observé des ports défectueux .

en général , c'est un mauvais présage pour la carte mère .

si tu veux rester en LTS , tu sais qu'on est passé à la 18.04.3 ?

et à la 19.10 , en version classique "desktop"

Dernière modification par Debian Alain (12-12-2019 16:17:41)

Hors ligne

#11 12-12-2019 16:14:47

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

Oui j'en ai peur ! sad
Je vais encore faire quelques tests dès que possible

Merci

Hors ligne

#12 12-12-2019 16:21:00

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Hors ligne

#13 12-12-2019 17:35:23

raleur
Membre
Inscription : 03-10-2014

Re : Problème Port USB fonctionnement aléatoire

Tuxuedo a écrit :

Mais le Hub USB n'est PAS alimenté


Il est alimenté par l'ordinateur via le bus USB. Et il relaie cette alimentation vers ses ports USB (après avoir prélevé sa part pour sa propre consommation).
Il peut avoir un effet de stabilisation (lissage) de l'alimentation fournie par l'ordinateur si celle-ci est instable. Par contre je doute qu'il soit capable de remonter une alimentation faiblarde.


Il vaut mieux montrer que raconter.

Hors ligne

#14 12-12-2019 17:58:19

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire



Merci , ça peut-être utile.

raleur a écrit :

Tuxuedo a écrit :

Mais le Hub USB n'est PAS alimenté


Il est alimenté par l'ordinateur via le bus USB. Et il relaie cette alimentation vers ses ports USB (après avoir prélevé sa part pour sa propre consommation).
Il peut avoir un effet de stabilisation (lissage) de l'alimentation fournie par l'ordinateur si celle-ci est instable. Par contre je doute qu'il soit capable de remonter une alimentation faiblarde.



Oui, tu as raison. Je voulais dire que le Hub n'est pas auto-alimenté.
Le Hub est en USB 1.1 , il est super vieux, ça a peut-être une incidence ?
Merci

Hors ligne

#15 12-12-2019 18:11:02

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : Problème Port USB fonctionnement aléatoire

sur certaines machines, dans le bios y a des options pour la rétro-compatibilité des ports usb, mais je sais plus le nom exact de l'option, à aller checker dans le bios.

mais une chose est sure, si ça fonctionnait avant, et plus subitement, la panne matérielle est souvent l'origine du soucis.
surtout si l'os a pas changé, et que le problème est reproductible sur plusieurs os différents..
ça met vite les choses au clair (en général)

@raleur, c'est rare quand on est en accord tous les deux wink

Dernière modification par melissa6969 (12-12-2019 18:15:36)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#16 12-12-2019 18:13:56

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.8.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème Port USB fonctionnement aléatoire

Le Hub est en USB 1.1 , il est super vieux, ça a peut-être une incidence ?


je sais pas , possible .
je crois que la norme usb 2.0 définit un courant maxi de 500mA. par prise (ou par port , sais plus)
sauf erreur , je crois que l'usb 3.0 "bride" ses ports à 1 A. toujours en 5 Volts .

https://fr.wikipedia.org/wiki/Universal_Serial_Bus (je sais pas s 'il est exact . ses valeurs me semblent un peu trop hautes .)

Dernière modification par Debian Alain (12-12-2019 18:14:28)

Hors ligne

#17 12-12-2019 18:48:33

Tuxuedo
Membre
Inscription : 13-01-2018

Re : Problème Port USB fonctionnement aléatoire

melissa6969 a écrit :

sur certaines machines, dans le bios y a des options pour la rétro-compatibilité des ports usb, mais je sais plus le nom exact de l'option, à aller checker dans le bios.

mais une chose est sure, si ça fonctionnait avant, et plus subitement, la panne matérielle est souvent l'origine du soucis.
surtout si l'os a pas changé, et que le problème est reproductible sur plusieurs os différents..
ça met vite les choses au clair (en général)

@raleur, c'est rare quand on est en accord tous les deux wink



Hello,
J'ai regardé dans le Bios hier soir mais il est minimaliste au possible.
Je n'ai rien vu de tel malheureusement.
Merci

Debian Alain a écrit :

Le Hub est en USB 1.1 , il est super vieux, ça a peut-être une incidence ?


je sais pas , possible .
je crois que la norme usb 2.0 définit un courant maxi de 500mA. par prise (ou par port , sais plus)
sauf erreur , je crois que l'usb 3.0 "bride" ses ports à 1 A. toujours en 5 Volts .

https://fr.wikipedia.org/wiki/Universal_Serial_Bus (je sais pas s 'il est exact . ses valeurs me semblent un peu trop hautes .)



Tu en sais déjà plus que moi.

Hors ligne

Pied de page des forums