Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-12-2019 16:06:22

Feanor
Membre
Inscription : 18-12-2019

Impossible d'installer php7.2

Salut a tous-tes,

voila j'aimerai installer php7.2 mais j'ai beau essayer de bien des maniere, il ne veux rien entendre. hmm


yann@maevys:~$ sudo apt install php7.2
[sudo] Mot de passe de yann : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 php7.2 : Dépend: libapache2-mod-php7.2 mais ne sera pas installé ou
                   php7.2-fpm mais ne sera pas installé ou
                   php7.2-cgi mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



A chaque fois que j'essaye d'installer les dependences demandés, il me dis que ce n'est pas possible. Exemple:


yann@maevys:~$ sudo apt install libapache2-mod-php7.2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'
ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'
information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libapache2-mod-php7.2 : Dépend: php7.2-cli mais ne sera pas installé
                         Dépend: php7.2-opcache mais ne sera pas installé
                         Dépend: libc6 (>= 2.29) mais 2.24-11+deb9u4 devra être installé
                         Dépend: libsodium23 (>= 1.0.14) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Le même probleme reviens pour php7.2-cli, libsodium23,...

Si besoin, voici ma config:


System:    Host: maevys Kernel: 4.9.0-9-amd64 x86_64 (64 bit) Desktop: Cinnamon 3.2.7
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: un-determined System: ASUSTeK product: TP401NAS v: 1.0
           Mobo: ASUSTeK model: TP401NAS v: 1.0
           UEFI: American Megatrends v: TP401NAS.302 date: 10/27/2017
Battery    BAT0: charge: 9.3 Wh 31.1% condition: 29.9/39.0 Wh (77%)
CPU:       Quad core Intel Pentium N4200 (-MCP-) cache: 1024 KB
           clock speeds: max: 2500 MHz 1: 2069 MHz 2: 1758 MHz 3: 2090 MHz 4: 1710 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Integrated Graphics Controller
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@57.31hz
           GLX Renderer: Mesa DRI Intel HD Graphics 505 (Broxton) GLX Version: 3.0 Mesa 13.0.6
Audio:     Card Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-9-amd64
Network:   Card: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlp1s0 state: up mac: 40:9f:38:ab:ae:05
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
Partition: ID-1: / size: 53G used: 31G (62%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 4.15GB used: 2.80GB (68%) fs: swap dev: /dev/mmcblk0p3
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://security.debian.org/debian-security stretch/updates main
           deb-src http://security.debian.org/debian-security stretch/updates main
           Active apt sources in file: /etc/apt/sources.list.d/base.list
           deb http://deb.debian.org/debian/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/dbeaver.list
           deb https://dbeaver.io/debs/dbeaver-ce /
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/leaeasy-ubuntu-dde-eoan.list
           deb http://ppa.launchpad.net/leaeasy/dde/ubuntu eoan main
           Active apt sources in file: /etc/apt/sources.list.d/lutris-team-ubuntu-lutris-eoan.list
           deb http://ppa.launchpad.net/lutris-team/lutris/ubuntu eoan main
           Active apt sources in file: /etc/apt/sources.list.d/lutris.list
           deb http://download.opensuse.org/repositories/home:/strycore/Debian_9.0/ ./
           Active apt sources in file: /etc/apt/sources.list.d/ondrej-ubuntu-apache2-eoan.list
           deb http://ppa.launchpad.net/ondrej/apache2/ubuntu eoan main
           Active apt sources in file: /etc/apt/sources.list.d/ondrej-ubuntu-php-eoan.list
           deb http://ppa.launchpad.net/ondrej/php/ubuntu eoan main
           Active apt sources in file: /etc/apt/sources.list.d/ondrej-ubuntu-php-focal.list
           deb http://ppa.launchpad.net/ondrej/php/ubuntu focal main
           Active apt sources in file: /etc/apt/sources.list.d/php.list
           deb https://packages.sury.org/php/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/stretch-backports.list
           deb http://deb.debian.org/debian stretch-backports main
           Active apt sources in file: /etc/apt/sources.list.d/sublime-text.list
           deb https://download.sublimetext.com/ apt/stable/
           Active apt sources in file: /etc/apt/sources.list.d/teamviewer.list
           deb http://linux.teamviewer.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-ubuntu-java-eoan.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu eoan main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-ubuntu-java-focal.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu focal main
           Active apt sources in file: /etc/apt/sources.list.d/wine.list
           deb https://dl.winehq.org/wine-builds/debian/ stretch main
Info:      Processes: 282 Uptime: 1 day Memory: 3109.6/3819.3MB Client: Shell (bash) inxi: 2.3.5

 



Si quelqu'un sais comment résoudre ça... je vous remercie d'avance

Hors ligne

#2 18-12-2019 16:42:20

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2

si çà peut t'aider :  https://tecadmin.net/install-php-debian-9-stretch/

mais je crois qu'il faut , avant tout , désinstaller complètement l'ancienne version avant de mettre la nouvelle . (de mémoire , pas sûr) .

ci dessous , l'auteur installe la dernière version de php avant de faire une M.A.J. (entre autres  les  vhosts (c'est quoi ?)) et de désinstaller l'ancienne version .

https://it.izero.fr/web-mise-a-jour-de-php-7-0-en-7-3/

Dernière modification par Debian Alain (18-12-2019 16:43:08)


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#3 18-12-2019 17:11:09

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2

Bonjour,

merci pour le lien. Malheureusement j'ai deja testé tout ce qu'il propose. Le problème reste présent kernal_panic.gif

(j'en ai profité pour desinstaller php avec un apt remove php*)

Dernière modification par Feanor (18-12-2019 17:12:24)

Hors ligne

#4 18-12-2019 17:15:00

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2

je suis très loin d'être connaisseur en php , mais que donnent : ?

ls  /etc/php/


php --version


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#5 18-12-2019 17:57:59

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2


yann@maevys:~$ ls /etc/php/
5.6  7.0  7.1  7.2  7.3  7.4
 



pour la version de php comme j'ai supprimé la version 7.1 de php, il ne reconnais plus la commande php. mais quand j'essaye d'installer le 7.2 ca ne veux vraiment rien savoir. c'est un vrai bordel de dependances que je n'arrive a installer

Hors ligne

#6 18-12-2019 18:20:19

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2

as tu un site web de créé ?
te sers tu de php , comment ?
peux tu te permettre de remettre à zero ta configuration de php ?

j'ai installé sur ma stretch64 en V.M. (virtualbox) , php 7.3 .

lsb_release -a


No LSB modules are available.
Distributor ID: Debian
Description:  Debian GNU/Linux 9.11 (stretch)
Release:  9.11
Codename: stretch


uname -a


Linux stretch 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64 GNU/Linux


ls /etc/php


7.3


php --version


PHP 7.3.12-1+0~20191128.49+debian9~1.gbp24559b (cli) (built: Nov 28 2019 07:38:18) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.12, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.12-1+0~20191128.49+debian9~1.gbp24559b, Copyright (c) 1999-2018, by Zend Technologies


dpkg --get-selections | grep php


libapache2-mod-php7.3       install
php-common          install
php7.3            install
php7.3-cli          install
php7.3-common         install
php7.3-curl         install
php7.3-json         install
php7.3-mbstring         install
php7.3-mysql          install
php7.3-opcache          install
php7.3-readline         install
php7.3-xml          install



suivant ces fils : https://tecadmin.net/install-php-debian-9-stretch/
https://it.izero.fr/web-mise-a-jour-de-php-7-0-en-7-3/

je suis parti  de zero , soit un "/etc/php/" vierge .
donc en utilisant le dépôt de  "sury"  proposé dans ces fils (et les posts)  ci-dessus .

je m'arrête là .

tu as tellement de dépôts ubuntu dans ta stretch (qui en plus n'est pas à jour) que j'ai trop peur de casser la baraque  ...

pourquoi as tu installé tous ces ppa ? que voulais tu faire ? tu n'as pas trouvé d'équivalent debian pour tes projets ?

https://wiki.debian.org/fr/DontBreakDebian

tu gagnerai pas à passer à "stable" ou à "testing" ?

-- live iso non-free buster  --

-- live iso non-free testing --

Dernière modification par Debian Alain (19-12-2019 10:51:16)


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#7 19-12-2019 00:26:54

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2

Effectivement c'est un joyeux bordel. les installations se sont faites progressivement sur ce que je trouvais sur internet en fonction des besoins. quand je faisais

sudo apt update


je tombais sur des erreurs de signature ou de repertoires usagés. je n'y pretait pas attention pensant que les packets corrects étaient quand meme mis a jour. Il semblerait que non. De plus, ne trouvant pas mes repository sur /etc/apt/sources.list, je ne savais pas bien comment les supprimer... (ils etaient dans /etc/apt/sources.list.d/[...])

Voici le resultat après le menage:


Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://security.debian.org/debian-security stretch/updates main
           deb-src http://security.debian.org/debian-security stretch/updates main
           Active apt sources in file: /etc/apt/sources.list.d/base.list
           deb http://deb.debian.org/debian/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/dbeaver.list
           deb https://dbeaver.io/debs/dbeaver-ce /
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/php.list
           deb https://packages.sury.org/php/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/stretch-backports.list
           deb http://deb.debian.org/debian stretch-backports main
           Active apt sources in file: /etc/apt/sources.list.d/sublime-text.list
           deb https://download.sublimetext.com/ apt/stable/
           Active apt sources in file: /etc/apt/sources.list.d/teamviewer.list
           deb http://linux.teamviewer.com/deb stable main

 




Je ne sais pas si un rangement est encore a faire mais des lors que le apt update s'est réalisé sans encombre, j'ai pu installer mon php7.2 smile

merci beaucoup!!!

Hors ligne

#8 19-12-2019 10:17:08

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2

pour -- dbeaver -- , en fouillant un peu , tu trouve un deb , -- là -- il marche pas ?

pour -- chrome --   , tu aurai pu mettre -- chromium -- - dans les dépôts - (flash va bientôt mourrir , depuis le temps qu'il a du plomb dans l'aile... )

les dépôts sury , bon je dis rien , mais si tu veux des versions plus à jour de php , pense à -- stable -- ou à -- testing -- .

-- skype -- , et -- framatalk -- , c'est pas mieux (ou au moins aussi bien) ?

-- sublime text -- , je m'en suis servi pour arduino : pas mal en effet (https://www.sublimetext.com/)

-- teamviewer -- , il te sert à quoi ?

tu en a profité pour faire ceci : ?

apt update

apt upgrade


que donnent les  retours ? tu n'a plus aucun dépôt défectueux ? (poste s.t.p.)



nb: si je ne me trompe pas , php , dans stretch (oldstable) est limité à la version 7.0 :
https://packages.debian.org/search?suit … ywords=php .
il n'existe pas de version backportée de php sous stretch et pour la  curiosité , buster (stable) tourne avec php 7.3 :
https://packages.debian.org/search?suit … ywords=php .
testing , quand à elle , de mme que sid , tourne avec php 7.3 . seul expérimental tourne avec php 7.4  .

Feanor  a écrit :

je tombais sur des erreurs de signature ou de repertoires usagés.
je n'y pretait pas attention pensant que les packets corrects étaient quand meme mis a jour.
Il semblerait que non.


ben oui , si la clé de déchiffrage / authentification n'est pas  bonne ou que l'adresse du dépôt est incorrecte ,
comment tu veux  que çà se passe ?
mal forcément .

https://wiki.debian.org/fr/DontBreakDebian

si tu cherche des programmes particuliers , pose la question sur le forum ou sur l' irc .
tu devrai trouver chaussure à ton pied .
enfin presque ... (souvent qd mme) .

Dernière modification par Debian Alain (19-12-2019 10:58:48)


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#9 19-12-2019 11:01:00

melissa6969
Membre
Distrib. : Sid Xfce Minimal
Inscription : 30-11-2016

Re : Impossible d'installer php7.2

Debian Alain a écrit :


-- skype -- , et -- framatalk -- , c'est pas mieux (ou au moins aussi bien) ?


framatalk mieux (ou aussi bien) que skype.??
désolé mais ça se voit que t'as pas utilisé/comparé les deux wink
framatalk est juste à des années-lumières de skype en terme de fonctionnalités, performances, stabilité, quand framatalk est censé servir pour la vidéoconférence mais que la vidéo lague complètement, le son est juste inaudible avec de la friture, à ce jour framatalk est bien en dessous de skype.

skype for linux fonctionne super bien, et tout est fonctionnel comme il se doit et comme on y attend d'un logiciel de vidéoconférence (pour être dans de bonnes conditions pour parler à ses proches, entretien d'embauche par exemple)

framatalk aurait pu être bien mais comme toujours chez la famille frama* trop de trucs pas aboutis ou qui plantent alors que les alternatives font (bien) mieux, du coup avoir un logiciel libre mais non fonctionnel, l'intérêt se résume à rien...
et y proposer aux novices en connaissant les défauts majeurs de framatalk fera que dire que le libre c'est de la merde.. roll

@feanor
un conseil continues à utiliser skype, sinon tu vas vite te retrouver avec des soucis divers et variés dans des vidéoconférences, et tu passera + de temps à résoudre les problèmes qu'à réellement parler lol

Dernière modification par melissa6969 (19-12-2019 11:02:21)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#10 19-12-2019 11:26:30

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Buster 10.3
Noyau : 4.19.0-8-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Impossible d'installer php7.2

voila j'aimerai installer php7.2 mais j'ai beau essayer de bien des maniere, il ne veux rien entendre

@ Feanor : un tuto pour Debian 9.x + PHP 7.2.x

Dernière modification par jce76350 (19-12-2019 11:27:55)


--
Jc E

Hors ligne

#11 19-12-2019 11:48:01

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2

melissa  a écrit :

framatalk mieux (ou aussi bien) que skype.??
désolé mais ça se voit que t'as pas utilisé/comparé les deux


ben si , justement . et j'ai eu des bonnes surprises avec framatalk .
logiciel un peu spécial mais très intéressant .


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#12 19-12-2019 12:44:21

melissa6969
Membre
Distrib. : Sid Xfce Minimal
Inscription : 30-11-2016

Re : Impossible d'installer php7.2

très spécial et peu adapté aux novices du genre je trouve personnellement.
perso au vu de mon utilisation (qui est donc similaire à celles de 90% des gens qui utilisent des logiciels comme skype)
je trouve framatalk peu ergonomique, et surtout son instabilité et bugs récurrents qui le rendent inutilisable.
parler à sa famille loin de nous via webcam mais avoir une vidéo figée, et un son qui saccade, on peut pas dire que c'est très pratique pour tenir une conversation, et c'est bien framatalk qui bug, puisque sur skype, zéro soucis du genre.

Dernière modification par melissa6969 (19-12-2019 12:44:44)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#13 19-12-2019 22:26:51

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2

merci pour les conseils smile

Hors ligne

#14 20-12-2019 13:11:49

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2

je suis désolé de revenir comme ca mais sur l'installation du 7.2 il semblerai qu'il y ai un probleme. je ne sais pas si c'est en relation avec la repo ondrej qui le contenais mais il semblerait que l'extension Phar ne soit pas installé par défaut. Comment installe le t-on?

 php -i | grep 'phar'



ne renvoi rien

Pour info et pour repondre a ta question @Alain, je dois installer un projet Web Laravel.

Dernière modification par Feanor (20-12-2019 13:12:57)

Hors ligne

#15 20-12-2019 13:24:46

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-4 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Impossible d'installer php7.2


Classqiue a la gratte electrique

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#16 20-12-2019 15:05:22

Feanor
Membre
Inscription : 18-12-2019

Re : Impossible d'installer php7.2

ça explique que c'est natif depuis php 5.3 mais pourquoi je ne l'ai pas alors?? scratchhead.gif

(je n'ai mis aucun dislable)

EDIT: j'ai mis json et phar dans php.ini pour le prenne en compte ça a l'air de fonctionner

Dernière modification par Feanor (21-12-2019 12:14:20)

Hors ligne

Pied de page des forums