Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-12-2019 17:01:43

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

pb-install-grub-installation dvd[Résolu]

Bonjour à tous, j'essaie actuellement  de réinstaller Debian en simple boot sur une machine qui étais précédemment en dualboot win/débian, je n'avais pas eu de soucis quand j'avais fait le dual boot il y à 2 ans.
Je repart de zéro, tout formaté, l'installation à l'air de bien se passer, mais quand j'arrive à l'installation de GRUB j'ai un message d'erreur : L'exécution de "grub-install dummy" a échoué. Cette erreur est fatale.

-la carte mère est en UEFI.
-secure boot est désactivé.
-J'installe à partir d'une clé usb sur dvd complet car pas de connexion filaire chez moi.

Partitionnement manuel:
-racine 100go sur ssd
-swap 16go sur ssd
-EFI 4 GO sur ssd
-home 1to sur dd classique

Je n'arrive pas à voir se que j'ai fait différemment de la dernière fois.

Quelqu'un voit-il le problème qui bloque l'installation de Grub dans mon installation?
Eventuellement, est se que quelqu'un a déjà eu ce problème?

Dernière modification par Debianico (01-01-2020 17:17:07)

Hors ligne

#2 21-12-2019 17:20:59

Caribou22
CA Debian-Facile
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stable
Noyau : Sans pépins
(G)UI : Xfce, Gnome
Inscription : 10-11-2014
Site Web

Re : pb-install-grub-installation dvd[Résolu]

Bonjour smile

Il y a un bug de GRUB avec les installations en UEFI qui impose d'être connecté à Internet pour l'installation il me semble. Est-ce que tu étais bien connecté à Internet lors de l'installation ?

Hors ligne

#3 21-12-2019 17:40:40

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Bonsoir caribou,
non je fais l'installation depuis une image complète car pas de connexion filaire, uniquement le téléphone en modem.
Donc effectivement, lors de ma première install, j'avais fait une netinstall et pas de soucis.

On pourrait donc considérer le problème comme résolu?

Dernière modification par Debianico (21-12-2019 17:41:39)

Hors ligne

#4 21-12-2019 20:56:16

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Debianico a écrit :

à l'installation de GRUB j'ai un message d'erreur : L'exécution de "grub-install dummy" a échoué. Cette erreur est fatale.


Il aurait fallu regarder l'erreur détaillée dans les logs d'installation.

Debianico a écrit :

-EFI 4 GO sur ssd


Allouer 4 Go de précieux espace du SSD pour la partition EFI en single boot, c'est du gaspillage. Debian n'a besoin que de quelques Mo sur cette partition.

Debianico a écrit :

home 1to sur dd classique


Pas optimal pour les performances.

Debianico a écrit :

Je n'arrive pas à voir se que j'ai fait différemment de la dernière fois.


Les conditions initiales sont différentes. Tu avais conservé la partition EFI existante et installé Debian/GRUB pour la première fois. Cette fois tu as effacé la partition EFI existante, recréé une nouvelle et Debian était déjà enregistré dans les variables de boot EFI. Des conditions suffisantes pour faire planter un firmware UEFI buggé (ils le sont tous à des degrés divers).

Si j'ai un conseil à donner : si le firmware UEFI supporte l'amorçage "traditionnel" (BIOS/legacy), il y a beaucoup moins de risque de bug dans ce mode.

Caribou22 a écrit :

Il y a un bug de GRUB avec les installations en UEFI qui impose d'être connecté à Internet pour l'installation il me semble


D'où vient cette information ? Elle me semble absurde, et j'ai la prétention de connaître un peu GRUB.


Il vaut mieux montrer que raconter.

Hors ligne

#5 22-12-2019 12:02:54

Caribou22
CA Debian-Facile
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stable
Noyau : Sans pépins
(G)UI : Xfce, Gnome
Inscription : 10-11-2014
Site Web

Re : pb-install-grub-installation dvd[Résolu]

raleur a écrit :

Caribou22 a écrit :

Il y a un bug de GRUB avec les installations en UEFI qui impose d'être connecté à Internet pour l'installation il me semble


D'où vient cette information ? Elle me semble absurde, et j'ai la prétention de connaître un peu GRUB.



Ça vient de live-build, pardon. Il y avait (et il y a toujours) ce soucis avec les ISOs DF personnalisées : https://debian-facile.org/viewtopic.php … 95#p226295

Le programme d'installation télécharge le paquet grub-efi à la fin, donc sans connexion, ça échoue.

Hors ligne

#6 22-12-2019 13:30:58

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Si je comprends bien ça ne concerne pas Debian mais l'installateur live de DF, et ce n'est pas "un bug de GRUB" mais un bug de l'installateur live de DF.
Mais ça me semble tout aussi absurde. Pourquoi ce paquet pourtant essentiel n'est-il pas inclus dans l'installateur ?

En tout cas ce n'est pas la cause du problème de ce fil, puisque l'exécution de grub-install montre que grub-efi a été installé.

Dernière modification par raleur (24-12-2019 09:35:27)


Il vaut mieux montrer que raconter.

Hors ligne

#7 22-12-2019 13:38:41

Caribou22
CA Debian-Facile
Lieu : 22, Côtes d'Armor, Bretagne
Distrib. : Debian Stable
Noyau : Sans pépins
(G)UI : Xfce, Gnome
Inscription : 10-11-2014
Site Web

Re : pb-install-grub-installation dvd[Résolu]

Comme j'en sais peu sur ce problème, j'ai juste pensé que le problème pouvait exister sur toutes les ISOs live.

Hors ligne

#8 23-12-2019 23:53:09

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Bonsoir, dsl pour l'attente et merci pour vos réponses et conseils, je vais essayer le legacy dés que je peux, pour le net install, pas sur que je puisse essayer dans le mois qui vient, y à t'il un raccourci pour accéder aux logs d'erreur ?

En attendant de vous tenir au courant, joyeux noël à tous!

Hors ligne

#9 24-12-2019 09:39:14

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Dans l'installateur Debian, la console 4 (Ctrl+Alt+F4) affiche les derniers logs. S'il faut remonter plus loin, on peut accéder au log complet enregistré dans le fichier /var/log/syslog depuis le shell de la console 2 (Ctrl+Alt+F2) ou 3 (Ctrl+Alt+F3).

Il vaut mieux montrer que raconter.

Hors ligne

#10 24-12-2019 23:16:52

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Merci râleur.

Hors ligne

#11 25-12-2019 01:37:49

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : pb-install-grub-installation dvd[Résolu]

raleur a écrit :

Caribou22 a écrit :

Il y a un bug de GRUB avec les installations en UEFI qui impose d'être connecté à Internet pour l'installation il me semble


D'où vient cette information ? Elle me semble absurde, et j'ai la prétention de connaître un peu GRUB.


Je vais pouvoir donner un peu de grain à moudre, j'avais heurté le souci à l'époque.
Le paquet grub-efi-ARCH et grub-legacy-ARCH sont en conflits, donc les deux ne peuvent être installés ; j'ai bien pensé essayer de mettre un grub-efi-ARCH.deb dans le cache de APT (pour pouvoir me passer de connexion internet), mais je suis jamais parvenu a contourner le souci au final (ce n'était pas pris en compte)...

À ma connaissance ce problème existe chez tous les projets live-build : voyager, mxlinux, emmabuntu, parrotos, librazik... Aucun n'a de workaround - du moins mes recherches et mes tentatives n'avaient rien donné. Vu que je n'utilise quasiment jamais l'installation EFI, j'ai lâché la lutte.:x

Si ce que je dis n'est plus vrai pour une des ces "debian custom", ça serait super facile à copier alors je suis toute ouïe yikes

Dernière modification par otyugh (25-12-2019 02:51:53)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

En ligne

#12 25-12-2019 10:17:24

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

otyugh a écrit :

Le paquet grub-efi-ARCH et grub-legacy-ARCH sont en conflits, donc les deux ne peuvent être installés


1) Il n'existe pas de paquet grub-legacy-ARCH, seulement un paquet grub-legacy. Sauf besoin très particulier, personne n'installe ce paquet qui contient l'ancienne version obsolète de GRUB (GRUB 1), et non la version actuelle GRUB 2 pour PC BIOS. C'est le paquet grub-pc qui contient cette dernière.

2) En quoi le fait que deux paquets grub* sont en conflit est-il un problème ? Il n'est pas question de les installer tous les deux, il faut installer seulement celui qui correspond au firmware/mode d'amorçage effectif, soit dans le cas d'un PC : grub-pc (BIOS), grub-efi-ia32 (EFI 32 bits) ou grub-efi-amd64 (EFI 64 bits).

3) Enfin, qu'est-ce que la connexion internet et le cache APT viennent faire là-dedans ?


Il vaut mieux montrer que raconter.

Hors ligne

#13 30-12-2019 20:40:08

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Bonsoir à tous,
Suite à vos réponses, j'ai retenté l'installation, le boot est bien en mode legacy.
Voici l'image du partitionnement manuel, si tant est qu'il y aie une erreur ici:
lo4m.jpg

Ainsi que l'image des derniers logs d'installation(je ne suis pas en mesure de les interpréter):
nkzg.jpg

Je n'ai toujours pas accès à une connexion filaire pour tenter une NetInstall comme mentionné plus haut, mais vu les derniers messages postés, il semble que ça réglerait le problème.
Je vais chercher quelqu'un chez qui emmener ma tour la semaine prochaine.

Dernière modification par Debianico (30-12-2019 20:45:51)

Hors ligne

#14 30-12-2019 21:10:02

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Debianico a écrit :

le boot est bien en mode legacy


Non, on peut voir que le boot est en mode EFI puisque l'installateur essaie d'installer GRUB pour la plate-forme x86_64-efi. Le partitionnement est correct pour un amorçage EFI.
Sans surprise, on voit que c'est l'enregistrement de l'entrée d'amorçage dans les variables EFI qui échoue. Par contre le message d'erreur "Block device required" ne me parle pas. Il faudrait pouvoir exécuter grub-install avec l'option -v pour savoir si les paramètres qu'il applique à efibootmgr sont corrects, mais je ne pense pas que l'installateur le permette.

Contournements possibles :
- faire l'installation en mode BIOS/legacy et non EFI
- faire l'installation en mode expert et installer une copie de GRUB dans le "chemin de support amovible".

Dernière modification par raleur (31-12-2019 13:15:13)


Il vaut mieux montrer que raconter.

Hors ligne

#15 31-12-2019 12:30:41

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

raleur à écrit:
Non, on peut voir que le boot est en mode EFI puisque l'installateur essaie d'installer GRUB pour la plate-forme x86_64_efi.


3y2m.jpg
J'ai le choix entre UEFI et Legacy+UEFI,j'ai choisi la deuxième option, je suis donc à priori en legacy?
Pourtant l'installateur choisi:

GRUB pour la plate-forme x86_64_efi


Est-ce que j'aurais choisi une mauvaise image d'installation?

raleur à écrit
- faire l'installation en mode expert et installer une copie de GRUB dans le "chemin de support amovible".



Je t'avoues ne pas être sur de comprendre se que tu veux dire(installer Grub sur une clé USB?), et hélas je ne pense pas non plus avoir le niveau pour le faire.

Quoi qu'il en soit, je n'ai toujours pas tenté de netinstall.

Dernière modification par Debianico (31-12-2019 12:38:48)

Hors ligne

#16 31-12-2019 13:14:32

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Debianico a écrit :

J'ai le choix entre UEFI et Legacy+UEFI,j'ai choisi la deuxième option, je suis donc à priori en legacy?


Non, cette option permet l'amorçage en mode legacy mais le mode EFI reste prioritaire s'il est disponible. Il faudrait une option "legacy only", mais elle semble ne plus être disponible avec les machines récentes.

Pour forcer l'amorçage de l'installateur en mode legacy, il faut passer par le menu de boot du firmware qu'on fait apparaître au démarrage de la machine en appuyant sur une touche particulière (indiquée dans le manuel ou sur l'écran si on a de la chance) qui varie selon le fabricant. Si un support est amorçable dans les deux modes, il apparaîtra deux fois, une fois pour chaque mode. Il faut sélectionner la ligne qui contient "legacy" ou ne contient pas "EFI".

Si l'installateur est amorcé en mode EFI, on tombe sur le menu de GRUB qui l'indique clairement. En mode legacy, on tombe sur le menu d'ISOLinux qui n'indique rien sur le mode d'amorçage.

Debianico a écrit :

st-ce que j'aurais choisi une mauvaise image d'installation?


Les images ISO hybrides d'installation de Debian pour amd64 sont amorçables à la fois en mode EFI 64 bits et legacy, donc dans ton cas c'est l'EFI qui a la priorité et est sélectionné par défaut. Tu pourrais utiliser une image i386 qui est amorçable en mode EFI 32 bits et legacy mais pas en EFI 64 bits, ce qui forcerait le firmware UEFI 64 bits à l'amorcer en mode legacy. Mais ce serait dommage d'installer un système 32 bits sur une machine 64 bits récente.

S'il n'est pas possible de démarrer en mode legacy via le menu de boot du firmware, il reste en dernier recours la possibilité de supprimer la partition EFI sur la clé USB afin d'empêcher son amorçage en mode EFI.

Debianico a écrit :

faire l'installation en mode expert et installer une copie de GRUB dans le "chemin de support amovible"


Je t'avoues ne pas être sur de comprendre se que tu veux dire(installer Grub sur une clé USB?)


Non, rien à voir avec une clé USB.
L'installation en mode expert se sélectionne à partir du sous-menu "advanced" du menu de démarrage de l'installateur. Cela fait poser plus de question qu'une installation normale. Quand on ne sait pas répondre, pas de panique, il suffit de valider la réponse par défaut.
Lors de l'installation de GRUB, il y aura une question concernant le "chemin de support amovible" ou quelque chose du genre. C'est juste une expression pour désigner l'emplacement du chargeur par défaut dans une partition EFI. Cet emplacement ne nécessite pas d'enregistrer une entrée d'amorçage dans les variables de boot EFI et est utilisé notamment pour démarrer à partir d'un support amovible (installateur, système live) d'où le nom.


Il vaut mieux montrer que raconter.

Hors ligne

#17 31-12-2019 16:07:41

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Merci râleur,
J'ai pu forcer le boot en Legacy en passant par le menu de boot du firmware, mais je suis perdu au moment de la partition manuel car l'installateur ne propose plus la possibilité de créer une partition EFI, du coup il faut créer une partition boot ?Pour l'instant je n'ai pas trouvé de réponse sur google.

Dernière modification par Debianico (31-12-2019 16:08:01)

Hors ligne

#18 31-12-2019 16:16:44

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Une partition EFI ne sert à rien pour l'amorçage legacy donc il est logique que l'installateur ne propose pas ce type. Si tu veux pouvoir retester l'amorçage EFI ultérieurement tu peux conserver la partition EFI existante si tu ne l'as pas supprimée ni recréé une nouvelle table de partition. Sinon, tu peux créer une partition FAT que tu pourras transformer en EFI.

Par contre si la table de partition est au format GPT il est recommandé, voire obligatoire dans certains cas, de créer une partition d'amorçage BIOS ("BIOS boot") de 1 Mo au plus pour GRUB.

Il vaut mieux montrer que raconter.

Hors ligne

#19 01-01-2020 17:15:30

Debianico
Membre
Lieu : GAP
Distrib. : Debian GNU/Linux 10 (buster) 64 bits
(G)UI : Gnome 3.30.2
Inscription : 09-12-2017

Re : pb-install-grub-installation dvd[Résolu]

Merci raleur,
ça a fonctionné en suivant les conseils de tes précédents posts:
-forçage du bbot en legacy
-création d'une partion /BIOS/boot
-création d'une partition /boot/efi en fat16 si besoin
-grub s'est bien installé
-il boot dessus au démarrage

Merci à tous pour vos conseils!RAS pour l'instant ça tourne.:)

Hors ligne

#20 01-01-2020 20:29:14

raleur
Membre
Inscription : 03-10-2014

Re : pb-install-grub-installation dvd[Résolu]

Amorçage traditionnel : 1
Amorçage EFI : 0

C'était vraiment bien la peine de se fatiguer à pondre cette usine à gaz d'UEFI si c'est pour en arriver là...

Note que pour transformer la partition FAT en partition EFI, il faudra modifier son type en "EFI System Partition" (ESP) avec un éditeur de table de partition comme fdisk, gdisk, parted ou gparted.

Dernière modification par raleur (01-01-2020 20:30:33)


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums