Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-12-2019 10:13:09

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

Bonjour.

Je pense que c'est après avoir copié mon /home sur une nouvelle machine que j'ai ce problème. Selon moi c'est une histoire de permissions sur un fichier mais je ne suis pas sûr.
Bref, je suis obligé de rentrer ma passphrase enigmail à chaque redémarrage de ma machine pour consulter des mails en brouillon dans thunderbird par exemple. J'ai beau demander que la passphrase soit mémorisée dans le gestionnaire rien n'y fait.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 23-12-2019 10:33:10

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

laguespa a écrit :

J'ai beau demander que la passphrase soit mémorisée dans le gestionnaire rien n'y fait.


C'est exactement ce qu'il fait. Il retient le passphrase pour la session. S'il le retenait en permanence, il n'y aurait plus aucune sécurité protégeant l'accès à ta clé privé... 

Sécurité et "pratique" c'est deux monde. En théorie tu peux parfaitement utiliser une clé GPG sans mot de passe. Juste elle sera facile à piquer par n'importe qui (un simple copier-coller). Donc on perd un peu l'intêret du truc.


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 23-12-2019 11:26:30

raleur
Membre
Inscription : 03-10-2014

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

J'aurais tendance à être d'accord avec otyugh, mais la première phrase de laguespa me laisse penser que ça se passait différemment sur l'ancienne machine.

Il vaut mieux montrer que raconter.

Hors ligne

#4 23-12-2019 12:31:58

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

raleur a écrit :

J'aurais tendance à être d'accord avec otyugh, mais la première phrase de laguespa me laisse penser que ça se passait différemment sur l'ancienne machine.



C'est juste.


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#5 23-12-2019 12:41:37

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

Je vois pas trop comment c'est possible. Après je n'ai jamais utilisé enigmail au quotidien (j'utilise claws-mail + plugin GPG) ; mais se pourrait-il que tu ai juste recréer une clé GPG verrouillé par un mot de passe dans ta nouvelle installation ? Il ne te le demandait pas avant parce qu'avant, tu n'avais mis aucun mot de passe pour verrouiller ta clé privé dans ta précédente installation ?

... Je sais pas hein, je fais une supposition, ça me semble l'explication la plus simple.

Dernière modification par otyugh (23-12-2019 12:43:24)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#6 23-12-2019 12:59:15

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

otyugh a écrit :

Je vois pas trop comment c'est possible. Après je n'ai jamais utilisé enigmail au quotidien (j'utilise claws-mail + plugin GPG) ; mais se pourrait-il que tu ai juste recréer une clé GPG verrouillé par un mot de passe dans ta nouvelle installation ? Il ne te le demandait pas avant parce qu'avant, tu n'avais mis aucun mot de passe pour verrouiller ta clé privé dans ta précédente installation ?

... Je sais pas hein, je fais une supposition, ça me semble l'explication la plus simple.




Non, j'ai repris le /home tel qu'il était sans conservation des droits parce que périphérique de stockage pas en ext4

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#7 23-12-2019 13:56:27

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.9.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

Juste comme ça, ne serait-ce un bête truc qui coince avec le daemon gpg-agent ?

Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#8 23-12-2019 14:45:48

raleur
Membre
Inscription : 03-10-2014

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

laguespa a écrit :

j'ai repris le /home tel qu'il était sans conservation des droits parce que périphérique de stockage pas en ext4


C'est risqué de transférer le contenu d'un /home via un système de fichiers non POSIX qui ne supporte pas les types de fichiers spéciaux et les permissions Unix. Non seulement les permissions ne sont pas préservées (certains fichiers doivent avoir des permissions spéciales, par exemple certains programmes refusent par sécurité de prendre en compte un fichier de clé privée si ses permissions sont trop laxistes et autorisent sa lecture par d'autres utilisateurs que le propriétaire), mais aussi les fichiers spéciaux (tubes, liens symboliques et physiques, sockets...) ne peuvent pas être transférés.

Une solution de contournement aurait consisté à créer une archive tar contenant les fichiers à transférer afin de préserver les propriétaires, permissions et fichiers spéciaux.


Il vaut mieux montrer que raconter.

Hors ligne

#9 23-12-2019 14:52:39

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

raleur a écrit :

Une solution de contournement aurait consisté à créer une archive tar contenant les fichiers à transférer afin de préserver les propriétaires, permissions et fichiers spéciaux.



Intéressant. Je ne savais pas. Tu veux dire que sur du fat32 une archive en tar conserve les droits et qu'on les retrouve une fois qu'elle est décompressée ?

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#10 23-12-2019 15:04:38

raleur
Membre
Inscription : 03-10-2014

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

Les droits des fichiers qu'elle contient, pas ses droits à elle (mais on s'en fiche). Seules les méta-données de l'archive dépendent du système de fichiers, son contenu est indépendant du système de fichier.

Dernière modification par raleur (23-12-2019 15:08:39)


Il vaut mieux montrer que raconter.

Hors ligne

#11 23-12-2019 23:12:10

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

ah beh moi c'est l'inverse qui se passe... avant il me demandait toujours la passphrase, plus maintenant..
apres, si tu vas dans le menu de thunderbird -> enigmail ->préférences -> Envoi
au lieu qui soit coché utiliser les parametres par défaut tu coches sur le configurer manuellement
apres quand tu reouvres Menu -> Enigmail -> y'a plus d'options qui s'affichent telles que "vérifier/déchiffrer automatiquement" et/ou "oublier la phrase de passe mémorisée" ...  Regarde a cocher l'un ou l'autre par là,
Aussi dans Menu -> Enigmail -> préférences -> Général   t'as une option "mémoriser la passphrase pendant X minutes "
Ptet ca va t'aider..

Dernière modification par ubub (23-12-2019 23:14:25)

Hors ligne

#12 24-12-2019 08:39:01

laguespa
Membre
Distrib. : Stretch
Noyau : 4.9.0-4-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

ubub a écrit :

Aussi dans Menu -> Enigmail -> préférences -> Général   t'as une option "mémoriser la passphrase pendant X minutes "
Ptet ca va t'aider..



Ok. Merci. Comment je fais si je veux qu'elle soit mémorisée définitivement ?

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#13 24-12-2019 09:39:16

ubub
Membre
Distrib. : debian 10 buster/stable
(G)UI : xfce
Inscription : 14-05-2019

Re : Obligé de rentrer ma passphrase enigmail à chaque redémarrage.

au lieu qui soit coché utiliser les parametres par défaut tu coches sur le configurer manuellement
apres quand tu reouvres Menu -> Enigmail -> y'a plus d'options qui s'affichent telles que "vérifier/déchiffrer automatiquement" et/ou "oublier la phrase de passe mémorisée" ...  Regarde a cocher l'un ou l'autre par là,



j 'imagine que c'est comme ca

Hors ligne

Pied de page des forums