Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-12-2019 18:13:45

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

[résolu] molotov 4.2.2 en panne

bonsoir et bonnes fêtes .

j'ai un souci avec molotov .

j'ai fait la  m.a.j. du fichier  appimage ,

attribué les droits .

et , au lancement , j'obtiens ceci :

./molotov.AppImage


[10527:1224/170247.771233:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found,
but is not configured correctly.
Rather than run without sandboxing I'm aborting now.
You need to make sure that /tmp/.mount_molotom2rgHv/chrome-sandbox is owned by root and has mode 4755.

Trappe pour point d'arrêt et de trace



ls -la /tmp/.mount_molotoh5JyPN/chrome-sandbox


ls: impossible d'accéder à '/tmp/.mount_molotoh5JyPN/chrome-sandbox': Aucun fichier ou dossier de ce type



pour le lancer , désormais , je suis obligé de faire ceci :

./molotov.AppImage --no-sandbox



bien sûr , il ne s'installe plus (les liens ne sont pas créés)

et , si je ferme le terminal , (avec ou sans  "&") je pers molotov .

ls -la molotov.*


-rwxr-xr-x 1 alain lpadmin 69779680 déc.  24 16:21 molotov.AppImage



je ne peux plus l'utiliser .

quand je le lance , j'obtiens ceci : B0hqHbc.png

Dernière modification par Debian Alain (26-12-2019 01:10:57)

En ligne

#2 25-12-2019 00:31:55

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

tu vas dans le dossier /home/user/.local/share/applications
tu modifies le fichier desktop qui s'appelle molotov

et à cette ligne, tu rajoute simplement le --no-sandbox
Exec="/DATA/molotov.AppImage" --no-sandbox %U
tu enregistres.

quelle version de molotov.???
Mis à jour de quelle manière.??

Dernière modification par melissa6969 (25-12-2019 16:57:40)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#3 25-12-2019 10:19:07

dz50
Adhérent(e)
Lieu : REPLONGES 01750
Distrib. : Debian GNU/Linux 10
Noyau : 4.19.0-5-amd64
(G)UI : Xfce 4.12.4
Inscription : 13-07-2016

Re : [résolu] molotov 4.2.2 en panne

Bonjour,
Chez moi, Molotov ne se lance plus depuis hier "sur 2 PC".
J'ai re-télécharger l'application sans obtenir de meilleur résultat.

Hors ligne

#4 25-12-2019 11:19:24

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

A effacer.

Dernière modification par melissa6969 (25-12-2019 16:58:43)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#5 25-12-2019 16:53:23

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

Sur 3 pc je viens de tester la maj de molotov et tout fonctionne bien avec no Sandbox

Donc le problème vient pas de molotov ni de l'Appimage, mais d'un problème de config de la part de l'utilisateur.

Ps :
fonctionne sur le pc de ma cousine, et de mon oncle également.

bon courage, j'ai pas d'autres idées (et pas envie de me casser la tête à chercher, puisque de toute façon, pas de réponse aux questions, et que je suis en train de faire un monologue)
dommage pour les autres qui ont le même soucis, ça pénalise tout le monde une fois encore wink

Dernière modification par melissa6969 (25-12-2019 17:52:36)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#6 25-12-2019 19:02:47

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

suite aux problèmes de chromium sur testing bullseye (crashes  aléatoires) ,

j'ai downgradé chromium en version stable (78 contre 79 , normalement)

chromium --version


Chromium 78.0.3904.108 built on Debian 10.2, running on Debian bullseye/sid


et je l'ai "holdée" en attendant une m.a.j. stable et avec moins de  bugs .

 dpkg -l | grep ^h


hi  chromium                                      78.0.3904.108-1~deb10u1               amd64        web browser
hi  chromium-common                               78.0.3904.108-1~deb10u1               amd64        web browser - common resources used by the chromium packages
hi  chromium-l10n                                 78.0.3904.108-1~deb10u1               all          web browser - language packs
hi  chromium-sandbox                              78.0.3904.108-1~deb10u1               amd64        web browser - setuid security sandbox for chromium



chromium fonctionne beaucoup mieux .
surtout , il est énormément plus stable
(sans comparaison possible, c'est le jour et la nuit)

malheureusement , pour molotov , rien n'a changé .

je serai curieux de télécharger la version 4.2.2 , parce que là , je l'ai pas trouvée sur leur site .
et me dites pas que molotov est prévu pour ubuntu (arrrggghhh .... je m'étrangle !)

En ligne

#7 25-12-2019 19:13:10

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

pour chromium ça a pas de rapport avec molotov, c'est juste que molotov est compilé en electron (et donc se sert du moteur de chromium d'où le soucis récurrent du sandbox sur une majorité d'appimages)

Pourtant c'est bien la dernière en date et fonctionnelle sur Debian, et toutes les distributions puisque .appimage
elle est dispo ici la dernière version (4.2.2 donc)
https://www.molotov.tv/download

chez moi bien la 4.2.2 après l'upgrade proposée par le logiciel lui-même au lancement (enfin méthode habituelle quoi)
7PIbn-R5
Voir l'image en grand

et t'as testé de modifier le lanceur de molotov comme je t'ai expliqué + haut.???
et tu mets à jour de quelle manière molotov.???

Dernière modification par melissa6969 (25-12-2019 19:14:10)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#8 25-12-2019 20:44:09

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

melissa  a écrit :

et t'as testé de modifier le lanceur de molotov comme je t'ai expliqué + haut.???


je le lance en console , avec :

./molotov.AppImage


le lanceur précédemment installé ne fonctionne pas

./molotov.AppImage --no-sandbox


fonctionne mais du coup , c'est google qui coince . question sécurité je crois . mais là , je suis perdu .

et tu mets à jour de quelle manière molotov.???


j'efface le fichier et j'installe le nouveau depuis le site .

trouvé ceci : https://github.com/cypress-io/cypress/issues/5434
mais , rien compris .

si j'ai bien pigé :

Le code pour cela est fait dans cypress-io / cypress # 5458 , mais n'a pas encore été publié.
Nous mettrons à jour ce problème et référencerons le journal des modifications lorsqu'il sera publié.


donc , en théorie , correction faite . reste à publier . donc à attendre .

Dernière modification par Debian Alain (25-12-2019 21:29:54)

En ligne

#9 25-12-2019 21:44:45

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

dans ton lanceur t'as oublié le %U à la fin (mais je sais pas si c'est réellement utile)

pour la mise à jour je fais pareil, parce qu'il y a une erreur quand ça tente de se mettre à jour tout seul (bug connu mais pas résolu)

par contre pour ton soucis de sécurité là je vois pas...
t'as essayé de purger tes fichiers de conf de molotov.??

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#10 25-12-2019 22:08:10

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

connexion non sécurisée, problème connu sur le forum de molotov avec une solution alternative (que j'ai pas lu)
https://aide.molotov.tv/questions/21835 … pte-google

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#11 25-12-2019 22:19:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

après plus de 10 min d'attente et d'essais : site injoignable

En ligne

#12 25-12-2019 22:26:36

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

https://aide.molotov.tv/questions/21835 … pte-google
ici tu devrais signaler que toi aussi t'as le même bug, histoire qu'ils comprennent que c'est pas un cas isolé et qu'ils tentent de l'identifier et y corriger wink

ou essayer de trouver une archive de molotov avec une ancienne version de l'appimage, mais j'ai pas trouvé...
même en utilisant la waybach machine, impossible à trouver une ancienne appimage...
ça aurait permis via une vieille version de l'appimage, de la lancer correctement et de pouvoir établir la connexion sans l'erreur de sécurité.
et ensuite faire l'upgrade la version actuelle, ce qui aurait permis de pouvoir utiliser molotov normalement.

Dernière modification par melissa6969 (25-12-2019 22:33:23)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#13 25-12-2019 22:40:24

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

ça aurait permis via une vieille version de l'appimage, de la lancer correctement et de pouvoir établir la connexion sans l'erreur de sécurité.
et ensuite faire l'upgrade la version actuelle, ce qui aurait permis de pouvoir utiliser molotov normalement.


tu crois ?

en attendant , depuis plus de 20 min , site injoignable , d'une manière ou d'une autre .

je crois que leur site d'aide est "down"

Dernière modification par Debian Alain (25-12-2019 22:43:55)

En ligne

#14 25-12-2019 22:46:57

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

bah je pense que l'erreur vient de leur nouvelle version, du coup si on avait une possibilité d'avoir une ancienne version de molotov, ça aurait pu être intéressant d'y tester.

mais comme c'est un logiciel non-libre, les archives des anciennes versions doivent être sur des serveurs non accessibles au grand public...

t'as le lien en question pour l'aide.???

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#15 25-12-2019 22:50:55

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

y a ça aussi.

https://aide.molotov.tv/pages/contact

pour discuter avec eux par email je suppose, ça peut être pas mal pour qu'ils te disent si le bug est connu, ou en cours de réparation, etc.

Dernière modification par melissa6969 (25-12-2019 22:51:11)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#16 25-12-2019 22:55:30

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

que ce soit ton lien : https://aide.molotov.tv/questions/21835 … pte-google

ou celui - ci : https://www.google.com/search?q=aide+mo … e&ie=UTF-8
(ah tiens ? , çà fonctionne ?) ah ben non .

le peu que j'ai pu voir :
ils conseillent de créer un compte directement sur molotov .
ce qui semble fonctionner .

Dernière modification par Debian Alain (25-12-2019 23:22:42)

En ligne

#17 25-12-2019 23:08:34

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

ça vient de chez toi je pense.
j'ai bien accès aux liens pour ma part scratchhead.gif

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#18 25-12-2019 23:53:21

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

j'ai cherché

ls -la ~/.local/share/applications/molotov*.*


ls: impossible d'accéder à '/home/alain/.local/share/applications/molotov*.*': Aucun fichier ou dossier de ce type


ls -la /usr/share/applications/molotov*.*


-rw-r--r-- 1 root root 415 déc.  25 22:30 /usr/share/applications/molotov.desktop


sudo nano /usr/share/applications/molotov.desktop


[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=molotov
GenericName=molotov
Comment=Télévision par internet
#Icon=/home/alain/Téléchargements/molotov-icône.png
Exec=/home/alain/Téléchargements/molotov.AppImage --no-sandbox
Terminal=false  #ouvrir ou non un terminal lors de l'exécution du programme (false ou true)
StartupNotify=false  #notification de démarrage ou non (false ou true)
Categories=Application



le lanceur ne fonctionne pas :

Exec=./home/alain/Téléchargements/molotov --no-sandbox

avec ou sans point .
cela ne fonctionne pas non plus :

Exec=/home/alain/Téléchargements/molotov.AppImage --no-sandbox


seule fonctionne la commande suivante :

./Téléchargements/molotov.AppImage --no-sandbox


ou :

./Téléchargements/molotov.* --no-sandbox


(electron) 'getName function' is deprecated and will be removed. Please use 'name property' instead.

Dernière modification par Debian Alain (25-12-2019 23:56:46)

En ligne

#19 26-12-2019 00:07:16

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

étrange tout ça
chez moi j'ai pas de molotov.desktop dans /usr/share/applications/

quand ça va dans ce dossier, ça veut dire que l'appimage a été placé et exécutée dans la /racine (par exemple dans le dossier /opt) ou avec sudo

essaie de changer
Exec=/home/alain/Téléchargements/molotov.AppImage --no-sandbox

en

Exec="/home/alain/Téléchargements/molotov.AppImage" --no-sandbox %U

si ça fonctionne chez moi et sur 4 pc de mon entourage, c'est que forcément chez toi ça devrait fonctionner, y a surement un mauvais réglage quelque part, restes à y trouver.

Dernière modification par melissa6969 (26-12-2019 00:10:41)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#20 26-12-2019 00:42:41

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

rien à faire , le lien est cassé .
quoique , je me demande ...
semble fonctionner  qd mme .
si je me trompe pas .

j'ai pu créer 2 liens fonctionnels avec alacarte , mais , je me retrouve avec 3 icônes  dans la page de  gnome dont 1 est h.s. (l'original)

et je ne sais pas où sont rangés les liens , histoire de mettre un peu d'ordre .

j'ai gardé le script suivant :

sudo nano /usr/share/applications/molotov.desktop


[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=molotov
GenericName=molotov
Comment=Télévision par internet
Icon=/home/alain/Téléchargements/molotov.jpeg
Exec="/home/alain/Téléchargements/molotov.AppImage" --no-sandbox %U
Terminal=false  #ouvrir ou non un terminal lors de l'exécution du programme (false ou true)
StartupNotify=false  #notification de démarrage ou non (false ou true)
Categories=Application



avec le bon lien , dans alacarte , tout fonctionne parfaitement .

reste le lien officiel qu'il faut que je retire (celui que molotov a créé , à l'origine) : je sais pas  faire .

mais c'est pas grave . quasiment résolu .

Dernière modification par Debian Alain (26-12-2019 01:26:18)

En ligne

#21 26-12-2019 10:39:14

melissa6969
Banni(e)
Inscription : 30-11-2016

Re : [résolu] molotov 4.2.2 en panne

Regarde dans ton /home
A l'emplacement
.local/share/applications
Tout ce Qu'il y a en rapport avec molotov, t'y supprimes.

Ça te supprimera tes lanceurs qui dysfonctionnent.
Et tu devrais avoir que ton lanceur fonctionnel que t'as créé précédemment qui sera disponible dans le "menu" de gnome, les autres devraient ne plus être présents.

Dernière modification par melissa6969 (26-12-2019 10:40:26)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#22 26-12-2019 10:56:06

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

réglé depuis longtemps , çà .

mais je regarde qd mme .

En ligne

#23 26-12-2019 11:30:58

dz50
Adhérent(e)
Lieu : REPLONGES 01750
Distrib. : Debian GNU/Linux 10
Noyau : 4.19.0-5-amd64
(G)UI : Xfce 4.12.4
Inscription : 13-07-2016

Re : [résolu] molotov 4.2.2 en panne

Chez moi c'est réglé sur les 2 PC, en suivant les recommandations de melissa6969, à savoir :
- suppression du dossier   /home/user/.local/share/applications
- téléchargement de la dernière version de molotov à rendre exécutable
- création du lanceur   Exec="/home/user/Téléchargements/molotov.AppImage" --no-sandbox %U

Hors ligne

#24 26-12-2019 11:44:50

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

la plateforme d'aide de molotov est h.s.

je renonce .
-aide impossible à obtenir
-email ne fonctionne pas
-m.d.p. non plus
-connexion quasi impossible
-compte google ne fonctionne pas
-autres comptes non plus d'ailleurs .

c'est le bordel !

Dernière modification par Debian Alain (26-12-2019 11:47:46)

En ligne

#25 27-12-2019 23:26:27

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [résolu] molotov 4.2.2 en panne

[modéré]

Dernière modification par Debian Alain (28-12-2019 12:22:38)

En ligne

Pied de page des forums