Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-12-2019 16:51:37

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

[Résolu]Kernel super lent à démarrer

Salut,
démarrage sur SSD avec une machine récente, le temps de boot est anormalement lent.

CM : Host: 21161C3 ThinkCentre M72e
Kernel : 5.3.0-0.bpo.2-amd64
OS: Debian GNU/Linux 10 (buster) x86_64

systemd-analyze


Startup finished in 33.474s (kernel) + 2.135s (userspace) = 35.610s



dmesg


[...]
[[    2.534667] input: Dell Dell USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/0003:413C:2003.0004/input/input8
[    2.592187] hid-generic 0003:413C:2003.0004: input,hidraw3: USB HID v1.10 Keyboard [Dell Dell USB Keyboard] on usb-0000:00:1d.0-1.4/input0
[   33.249107] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   33.323043] Not activating Mandatory Access Control as /sbin/tomoyo-init does not exist.
[   33.473414] systemd[1]: Inserted module 'autofs4'
[   33.498206] systemd[1]: systemd 241 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[   33.516110] systemd[1]: Detected architecture x86-64.
[   33.522568] systemd[1]: Set hostname to <debian>.
[   33.523129] systemd[1]: Failed to bump fs.file-max, ignoring: Invalid argument

[...]



Une idée ? À mon avis sans ce problème, l'ordi devrait démarrer en moins de dix secondes. sad

Dernière modification par otyugh (29-12-2019 18:13:26)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#2 28-12-2019 16:59:09

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]Kernel super lent à démarrer

Manque d'entropie ?

Il vaut mieux montrer que raconter.

Hors ligne

#3 28-12-2019 18:00:30

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : [Résolu]Kernel super lent à démarrer

@otyuhg : tu montes des partitions externes au démarrage ?
Dans mon cas :

5.405s (loader) + 2.747s (kernel)

Dernière modification par SuShY (28-12-2019 18:06:09)

Hors ligne

#4 28-12-2019 18:15:29

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

raleur a écrit :

Manque d'entropie ?


Haveged est installé, je vais essayer de la désinstaller pour voir si y a la moindre différence. Cela dit l'unique fois où j'ai vu ce problème il y avait un log qui pointait dans cette direction (et installer haveged avait résolu le problème).

tu montes des partitions externes au démarrage ?


Y a qu'une partition système, tout est en local. Y a même pas de swap (ceymaaal).

Dernière modification par otyugh (28-12-2019 18:15:55)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 28-12-2019 18:16:31

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : [Résolu]Kernel super lent à démarrer

otyugh a écrit :

Y a qu'une partition système, tout est en local.

Une piste d'écartée

Hors ligne

#6 28-12-2019 18:50:45

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

SuShY a écrit :

Une piste d'écartée


Je ne pense pas que c'était une piste valide ; le chargement du kernel se passe avant la prise en charge du réseau en situation normale (vu que je n'ai pas dit démarrer à partir du réseau)..


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#7 28-12-2019 18:56:44

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : [Résolu]Kernel super lent à démarrer

je ne vois pas ce qui peux bloquer le kernel, ça le fait depuis longtemps ?

Hors ligne

#8 28-12-2019 19:09:22

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

Raleur a donné un hyptohèse viable. Certains hardware ne savent pas faire rapidement de l'entropie et ça peut prendre un bail. Je suppose qu'il y a des milliers de possibilités entre firmwares à bug et hardware à problème, je suppose...

L'erreur "Failed to bump fs.file-max, ignoring: Invalid argument" semble être un bug systemd, mais vu que ça survient après les 30sec d'attente où "il fait rien" je ne pense pas que ce soit intéressant.

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#9 28-12-2019 19:13:50

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.9.x-x-amd64
(G)UI : i3WM - 4.18-1
Inscription : 06-01-2018
Site Web

Re : [Résolu]Kernel super lent à démarrer

C'est vrai, tu as des mises à jour récemment qui pourraient jouer la dessus ? Firmware ou Pilotes ?

Hors ligne

#10 28-12-2019 19:17:15

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

Aucune. Mais j'ai testé différents kernel (stretch et buster-backports) : même chose.

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#11 28-12-2019 19:24:50

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]Kernel super lent à démarrer

Si c'était un manque d'entropie, agiter la souris ou actionner le clavier devrait raccourcir le délai.

otyugh a écrit :

Y a qu'une partition système, tout est en local.


Je suppose que la racine est /dev/sda1, montée à 33 s. Donc le délai intervient pendant le déroulement de l'init de l'initramfs, avant le lancement de l'init de la racine (systemd).
Est-ce qu'il s'affiche quelque chose pendant ce temps ? En mode rescue ?
Est-ce que haveged est inclus dans l'initramfs ou n'est lancé qu'après ?
Il y a des trucs lourds inclus dans l'initramfs, comme plymouth ?

Dernière modification par raleur (28-12-2019 19:29:52)


Il vaut mieux montrer que raconter.

Hors ligne

#12 28-12-2019 19:28:10

phlinux
Membre
Distrib. : Jessie
Noyau : 4.9
(G)UI : Openbox (+Rox+Feh)
Inscription : 09-05-2009

Re : [Résolu]Kernel super lent à démarrer

Bsr,

Le problème dont tu parles au #1 c'est la ligne en gras dans dmesg ?

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#13 28-12-2019 19:29:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]Kernel super lent à démarrer

Non, c'est le délai entre cette ligne et la précédente.

Il vaut mieux montrer que raconter.

Hors ligne

#14 28-12-2019 19:38:51

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

raleur a écrit :

Est-ce qu'il s'affiche quelque chose pendant ce temps ? En mode rescue ?
Est-ce que haveged est inclus dans l'initramfs ou n'est lancé qu'après ?
Il y a des trucs lourds inclus dans l'initramfs, comme plymouth ?


Dès que j'ai mis la main dessus (cette semaine) je te retourne ça.

Pour moi la prochaine fois :
- Reconstruire l'initramfs (update-initramfs -ur) et regarder le temps de boot pour avoir ma "mesure étalon"
- Essayer de voir si bouger la souris réduit le délair de démarrage / essayer en supprimant haveged
- Essayer en supprimant plymouth
- Essayer le mode rescue

Si j'ai un impact un moment où l'autre sur le temps de démarrage, j'aurai une piste, j'imagine (et non j'en sais rien de quand haveged est lancé é_è).


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#15 28-12-2019 22:25:11

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.9.0-1-amd64
(G)UI : mutter 3.38.0-2
Inscription : 15-02-2016

Re : [Résolu]Kernel super lent à démarrer

otyugh a écrit :

Salut,
[...]

dmesg


[...]
[[    2.534667] input: Dell Dell USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/0003:413C:2003.0004/input/input8
[    2.592187] hid-generic 0003:413C:2003.0004: input,hidraw3: USB HID v1.10 Keyboard [Dell Dell USB Keyboard] on usb-0000:00:1d.0-1.4/input0
[   33.249107] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   33.323043] Not activating Mandatory Access Control as /sbin/tomoyo-init does not exist.
[   33.473414] systemd[1]: Inserted module 'autofs4'
[   33.498206] systemd[1]: systemd 241 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[   33.516110] systemd[1]: Detected architecture x86-64.
[   33.522568] systemd[1]: Set hostname to <debian>.
[   33.523129] systemd[1]: Failed to bump fs.file-max, ignoring: Invalid argument

[...]



Une idée ? À mon avis sans ce problème, l'ordi devrait démarrer en moins de dix secondes. sad


Avant la ligne : [   33.249107] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
chez moi j'ai le device-mapper et elle n'apparaît pas avec la machine que tu souhaites réparer :

dmesg | grep dm


[    0.209372] DMAR: dmar0: reg_base_addr fed90000 ver 1:0 cap c9008020e30272 ecap 1000
[    0.209469] DMAR: dmar1: reg_base_addr fed91000 ver 1:0 cap c0000020630272 ecap 1000
[    0.209565] DMAR: dmar2: reg_base_addr fed92000 ver 1:0 cap c0000020630272 ecap 1000
[    0.209661] DMAR: dmar3: reg_base_addr fed93000 ver 1:0 cap c9008020630272 ecap 1000
[    1.170412] DMAR: dmar2: Using Register based invalidation
[    1.170455] DMAR: dmar0: Using Register based invalidation
[    1.170496] DMAR: dmar3: Using Register based invalidation
[    4.911922] device-mapper: ioctl: 4.40.0-ioctl (2019-01-18) initialised: dm-devel@redhat.com
[    5.692225] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
[   10.220966] systemd[1]: Starting Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...
[   10.471130] systemd[1]: Started Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling.
[   10.513858] EXT4-fs (dm-0): re-mounted. Opts: errors=remount-ro
[   16.811532] EXT4-fs (dm-3): mounted filesystem with ordered data mode. Opts: (null)
[   16.871463] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
[   17.687125] EXT4-fs (dm-4): mounted filesystem with ordered data mode. Opts: (null)
 


En fait, cela n'a pas de rapport, c'est une fausse piste, c'est parce que j'ai choisi les volumes logiques !

Pour voir les temps de la génération d'aléatoire, la commande est :

dmesg | grep "random\|rng"

Dernière modification par --gilles-- (28-12-2019 22:44:35)


Dans la mégapole d’une superpuissance mondiale, Winston Smith vit, cadenassé dans sa solitude, sous le regard constant du télécran. Employé au ministère de la Vérité, il réécrit quotidiennement les archives de presse pour les rendre conforme avec la ligne officielle du moment.

Hors ligne

#16 29-12-2019 18:09:33

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

dmesg | grep "random\|rng" =>

[    0.000000] random: get_random_u64 called from __kmem_cache_create+0x3e/0x510 with crng_init=0
[    1.580066] random: fast init done
[   11.766810] random: crng init done



Et en effet haveged et bouger sa souris, aucun effet.
Par contre j'ai une nouvelle piste :

update-initramfs -u


update-initramfs: Generating /boot/initrd.img-5.3.0-0.bpo.2-amd64
[...]
W: initramfs-tools configuration sets RESUME=UUID=e71709a9-fbb0-4d8e-9a86-b6dbe7acd940
W: but no matching swap device is available.



EDIT : je confirme, après avoir commenté une ligne dans /etc/initramfs-tools/conf.d/resume,

Startup finished in 2.239s (kernel) + 2.612s (userspace) = 4.852s



Hypothèse : y avait une swap et il la cherchait au démarrage.

Dernière modification par otyugh (29-12-2019 18:13:53)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#17 29-12-2019 19:02:09

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]Kernel super lent à démarrer

Oui, le swap défini pour l'hibernation introuvable. C'est un classique. Partition de swap supprimée ou reformatée, notamment par l'installation d'un autre système (l'installateur Debian est coutumier du fait). Si aucune option RESUME n'est définie, update-initramfs enregistre par défaut le swap actif.

Par contre il me semble que cela aurait dû afficher des messages sur la console lors du démarrage.

Il vaut mieux montrer que raconter.

Hors ligne

#18 29-12-2019 19:11:41

Debeee
Membre
Distrib. : Buster / Testing
Noyau : 4.19.0-8 / 5.4.0-4
(G)UI : mate /mate
Inscription : 11-02-2015

Re : [Résolu]Kernel super lent à démarrer

Salut,
hypothèse bonne, j'ai eu le même truc en faisant des manips d'installation sur un disque que j'ai d'abord installé en externe (donc avec un disque interne avec système + swap) => il y a eu 2 swaps de déclarés pendant l'installation. Quand j'ai remis mon disque en interne, j'ai eu le même pb que toi, avec la latence de 30s. En fait, j'avais pire, j'ai dû nettoyer le fstab avant, ça mettait 1'30 de plus...
Question : pendant le boot, tu n'as pas eu le message "gave up waiting for suspend/resume device" ?
J'ai eu ça, ce qui m'a donné une piste, et la solution sur ce forum : https://www.debian-fr.xyz/viewtopic.php?t=1095

J'ai suivi ce fil en spectateur, j'ai pas le niveau mais ça m'intéresse (j'ai un boot qui traîne aussi), et j'ai appris ce qu'était l'entropie sur un système informatique.
Pour les curieux qui comme moi ne savent pas ce que c'est, il y a un topo intéressant ici:
https://www.deltasight.fr/entropie-linu … leatoires/

Hors ligne

#19 29-12-2019 21:10:26

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]Kernel super lent à démarrer

Par contre il me semble que cela aurait dû afficher des messages sur la console lors du démarrage.


Si c'est le cas ça ne m'a pas sauté aux yeux, j'ai tout lu au moins deux fois à la recherche de ce genre d'info, et avant de poser la question. ^^'

Dernière modification par otyugh (29-12-2019 21:10:43)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

Pied de page des forums