Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-01-2020 13:30:49

ladnad
Membre
Inscription : 08-01-2020

Debian 8 : Support mysql 5.5

Bonjour,

S'il vous plait j'aimerai savoir si mysql 5.5 est supporté par Debian 8 jusqu'au fin de vie de celui-ci qui est en date de : 30-06-2020.

Car comme vous le savez fin de vie de Mysql 5.5 était en : 03-12-2018.

S'il vous plait es-ce qu'il ya des liens qui parle sur ca, j'ai pas trouvé a parte celui-la : https://wiki.debian.org/LTS/TODO/Jessie   mais ils mentionnent pas si Debian 8 supporte mysql 5.5.

Merci pour votre réponse.

Cordialement

Hors ligne

#2 18-01-2020 10:02:29

jibe
Membre
Distrib. : DF-Linux 9
Noyau : Linux 4.9.0-6-amd64
(G)UI : mate
Inscription : 19-06-2018

Re : Debian 8 : Support mysql 5.5

Salut,

Autant je comprends que, tant qu'une version est maintenue, tu ne cherches pas systématiquement à passer à la suivante, autant je me demande pourquoi tu sembles tenir à rester sur une version de mysql qui n'est plus maintenue...

Depuis que mysql a été rachetée par Oracle, nombreux sont ceux qui sont passés à MariaDB, qui en est un fork resté libre. Le passage de l'une à l'autre est en principe assez simple et rapide (rien ou très peu à retoucher, c'est en principe directement compatible aux différences de version près), et tu aurais une version plus à jour. En tous cas, ça m'étonnerait très fortement que Debian maintienne encore une version dont la fin de vie est dépassée !

Pourquoi ne pas tout migrer sous Buster/MariaDB ? Il faudra bien t'y résoudre d'ici 6 mois, à moins de garder des versions plus maintenues, mais autant je trouve inutile la "course à la version" la plus récente, autant je trouve extrêmement dangereux de garder une version au-delà de sa fin de vie - sauf cas exceptionnels et uniquement si le système n'est pas exposé aux éventuelles attaques, donc surtout pas connecté à Internet.

Mon conseil serait donc, plutôt que chercher à savoir si tu peux rester ainsi encore quelque temps, d'organiser et réaliser la migration au plus vite, de manière à pouvoir le faire tranquillement. Sinon, tu t'exposes à devoir le faire en catastrophe, parce que tu as été victime de l'exploitation d'une faille de sécurité, et donc de pas mal galérer et de ne plus pouvoir garder en production ton système pas à jour...

Hors ligne

Pied de page des forums