Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-01-2020 09:45:08

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu] update-grub impossible

Bonjour,
Sur une station avec plusieurs versions de Debian, pour une des version (la plus ancienne)
je n'arrive pas à mettre GRUB à jour.

#update-grub


J'obtiens le retour:
/usr/sbin/grub-probe : erreur :  /boot/grub/device.map:1: No open parenthesis found.
Pour le autres versions, c'est OK pour la mise à jour de GRUB.
Merci pour vos réponses si solution en vue.

Dernière modification par gargamel79 (08-02-2020 11:38:29)

Hors ligne

#2 24-01-2020 11:23:44

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] update-grub impossible

Ça donne quoi le retour de

grub-mkconfig

?


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 24-01-2020 11:33:45

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] update-grub impossible

merci pour ta réponse, mais j'obtiens exactement le même message en retour de cette commande.

Hors ligne

#4 24-01-2020 12:20:21

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] update-grub impossible

Ben la question c'est à quel moment. D'où le pourquoi je veux le retour de la commande avant d'aller plus loin.

J'ai aucune idée de quelle arguments sont donnés à grub-modprobe, il faudrait en savoir plus, c'est ce que je proposais. Faut bien commencer quelque part. Mais je connais pas spécialement le problème en question, donc je propose de tâtonner. Si tu veux pas le faire, ça ne me concerne plus x)

Dernière modification par otyugh (24-01-2020 12:30:18)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 25-01-2020 11:00:44

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] update-grub impossible

Je n'ai, sans doute, pas été clair; lorsque je passe en root la commande:
# grub-mkconfig
j'obtiens la réponse:
/usr/sbin/grub-probe : erreur :  /boot/grub/device.map:1: No open parenthesis found.
voila, voila

Hors ligne

#6 25-01-2020 15:54:52

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu] update-grub impossible

La seule erreur proche que je vois, c'est lié au paquet memtest : https://bugs.launchpad.net/bugs/796776

Du reste je sais vraiment pas, tu pourrai creuse du côté de /etc/grub.d/00_header vu que c'est là qu'est fait l'appel à grub-prober.

Mhm. Autre piste, si j'en crois https://www.gnu.org/software/grub/manua … e-map.html
L'entrée device.map est regénéré automatiquement s'il n'existe pas, tu pourrai essayer de le renommer (ce qui revient à le supprimer sauf que si je me trompais tu peu le re-renommer comme avant) et retenter un update-grub.

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#7 05-02-2020 12:17:35

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian GNU-Linux Version 10 (buster) 64-bit
Noyau : Noyau Linux 4.19.0-x-amd64
(G)UI : KDE Pasma 5.14.5
Inscription : 30-06-2008

Re : [Résolu] update-grub impossible

bonjour, j'ai eu le même problème, je dois taper en root su - update-grub
et là ça fonctionne

Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#8 05-02-2020 15:25:48

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] update-grub impossible

gargamel79 a écrit :

/usr/sbin/grub-probe : erreur :  /boot/grub/device.map:1: No open parenthesis found.


Et bien sûr, tu as eu le réflexe de regarder ce que contient le fichier /boot/grub/device.map ?

otyugh a écrit :

La seule erreur proche que je vois, c'est lié au paquet memtest : https://bugs.launchpad.net/bugs/796776


Aucun rapport avec le paquet memtest qui n'est qu'une victime collatérale dans le bug que tu pointes. L'installation de memtest déclenche l'exécution de update-grub pour mettre à jour le menu de GRUB, ce qui fait apparaître l'erreur.

Dernière modification par raleur (05-02-2020 15:29:30)


Il vaut mieux montrer que raconter.

Hors ligne

#9 07-02-2020 16:52:20

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] update-grub impossible

merci pour ta réponse raleur.
Avec un peu de retard (!) j'ai regardé dans /boot/grub/device.map qui contient :
/dev/sda10
Cette partition contient la racine d'une autre version (debian 9 en 32bits). Aucune parenthèse à l'horizon ...

Dernière modification par gargamel79 (07-02-2020 16:52:46)

Hors ligne

#10 07-02-2020 17:15:33

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] update-grub impossible

gargamel79 a écrit :

Avec un peu de retard (!) j'ai regardé dans /boot/grub/device.map qui contient :/dev/sda10


C'est le contenu intégral du fichier ? Si oui, il est erroné. La commande suivante devrait regénérer un fichier correct :

grub-mkdevicemap


gargamel79 a écrit :

Aucune parenthèse à l'horizon


C'est bien le problème. Chaque ligne de ce fichier est censée contenir une correspondance entre un nom de disque Linux comme /dev/sda et un nom de disque GRUB comme (hd0) qui est inscrit entre parenthèses.

Dernière modification par raleur (07-02-2020 17:18:20)


Il vaut mieux montrer que raconter.

Hors ligne

#11 08-02-2020 11:36:57

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu] update-grub impossible

Effectivement en passant ta commande, maintenant /boot/grub/device.map est correct et update-grub fonctionne à nouveau.
Merci raleur, je passe en résolu. smile

Hors ligne

Pied de page des forums