Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-01-2020 18:25:07

teajrf
Membre
Inscription : 27-01-2020

Problème d'écran noir après installation de Debian 10

Bonjour à tous,
J'ai fait l'acquisition d'un PC portable (HP 14-dk0048nf) et installé Debian 10.2.0 AMD 64 1 + gnome. Au redémarrage le tty1 est en écran noir avec curseur clignotant. Les autres tty ont bien le prompt de login sauf le 7 qui semble inaccessible.
Je suppose que c'est (tty1) un problème de pilote graphique. J'ai suivi quelques proc trouvées sur internet, mais sans succès.
Voilà ce que j'ai fait :

Contenu sources.list
deb http://ftp.fr.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
# buster-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free



apt-get update
apt-get upgrade
apt-get dist-upgrade
dmesg


[    8.136302] r8169 0000:01:00.0: firmware: failed to load rtl_nic/rtl8168h-2.fw (-2)
[    8.136826] r8169 0000:01:00.0: Direct firmware load for rtl_nic/rtl8168h-2.fw failed with error -2
[    8.136832] r8169 0000:01:00.0 eno1: unable to load firmware patch rtl_nic/rtl8168h-2.fw (-2)



apt-get install firmware-linux-nonfree


Fin du retour, plusieurs fois cette ligne :
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169


apt-get install firmware-realtek


Fin du retour :
update-initramfs: Generating /boot/initrd.img-4.19.0-6-amd64


apt-get install dkms



Tout ça n'a rien donné. Toujours écran noir, gnome invisible. Avez vous une idée?
Merci d'avance
Thierry

Hors ligne

#2 28-01-2020 18:38:34

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

curiosité :

peux tu nous renvoyer le retour de la commande suivante :

apt policy gdm3 gnome gnome-shell


si tu peux nous poster le retour ... merci  :)


et aussi celle ci :

lspci -nnkd::0300


s'il te plaît ....

Dernière modification par Debian Alain (28-01-2020 18:40:37)

En ligne

#3 29-01-2020 05:51:16

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

Voilà les résultats :

apt policy gdm3 gnome gnome-shell


gdm3:
  Installé : 3.30.2-3
  Candidat : 3.30.2-3
 Table de version :
 *** 3.30.2-3 500
        500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
gnome:
  Installé : 1:3.30+1
  Candidat : 1:3.30+1
 Table de version :
 *** 1:3.30+1 500
        500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
gnome-shell:
  Installé : 3.30.2-11~deb10u1
  Candidat : 3.30.2-11~deb10u1
 Table de version :
 *** 3.30.2-11~deb10u1 500
        500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status


lspci -nnkd::0300


03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c5)
  Subsystem: Hewlett-Packard Company Picasso [103c:85e0]

Hors ligne

#4 29-01-2020 10:02:59

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

compte tenu de ceci :
https://cateee.net/lkddb/web-lkddb/DRM_AMDGPU.html

et de ceci :

apt show firmware-amd-graphics | grep Picasso


WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

  * "Picasso" ASD firmware (amdgpu/picasso_asd.bin)
  * "Picasso" CE firmware (amdgpu/picasso_ce.bin)
  * "Picasso" GPU info (amdgpu/picasso_gpu_info.bin)
  * "Picasso" ME firmware (amdgpu/picasso_me.bin)
  * "Picasso" MEC firmware (amdgpu/picasso_mec.bin)
  * "Picasso" MEC2 firmware (amdgpu/picasso_mec2.bin)
  * "Picasso" PFP firmware (amdgpu/picasso_pfp.bin)
  * "Picasso" RLC firmware (amdgpu/picasso_rlc.bin)
  * "Picasso" RLC AM4 firmware (amdgpu/picasso_rlc_am4.bin)
  * "Picasso" SDMA firmware (amdgpu/picasso_sdma.bin)
  * "Picasso" VCN firmware (amdgpu/picasso_vcn.bin)
 



peux tu corriger ton sources selon ceci : ? (avec nano par ex.)
https://debian-facile.org/doc:system:ap … -backports

# Debian Buster, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free
 
# Debian Buster, mises à jour de sécurité + paquets non libres
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free
 
# Debian Buster, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free
 
# Debian Buster, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ buster-backports main contrib non-free
deb-src http://deb.debian.org/debian/ buster-backports main contrib non-free
 



puis

cat /etc/apt/sources.list

poste le retour à chaque fois


apt update

poste le retour


apt upgrade

là aussi


apt install xserver-xorg-video-amdgpu  firmware-amd-graphics

et là aussi



donne nous ton retour .

curiosité :
peux tu nous poster aussi le retour de ceci :

lscpu



si la méthode simple ne fonctionne pas , il se peut que tu aies besoin de prendre le kernel backporté ou
de passer à testing .

lu : https://www.phoronix.com/scan.php?page= … ware-Files
d'où il ressort que pour les derniers picasso , un kernel 4.20 est indispensable à minima .

il faudra vraissemblablement upgrader ton kernel .
pour le kernel backporté , le dernier en date est le "5.4.0-0.bpo.2-amd64"

apt search linux-image-5.4.0-0.bpo.2-amd64


En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-5.4.0-0.bpo.2-amd64/buster-backports 5.4.8-1~bpo10+1 amd64
  Header files for Linux 5.4.0-0.bpo.2-amd64

linux-image-5.4.0-0.bpo.2-amd64/buster-backports 5.4.8-1~bpo10+1 amd64
  Linux 5.4 for 64-bit PCs (signed)

linux-image-5.4.0-0.bpo.2-amd64-dbg/buster-backports 5.4.8-1~bpo10+1 amd64
  Debug symbols for linux-image-5.4.0-0.bpo.2-amd64

linux-image-5.4.0-0.bpo.2-amd64-unsigned/buster-backports 5.4.8-1~bpo10+1 amd64
  Linux 5.4 for 64-bit PCs
 

Dernière modification par Debian Alain (29-01-2020 11:24:06)

En ligne

#5 29-01-2020 19:26:08

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

Merci pour toutes ces infos. J'ai fait ce qui suit mais toujours l'écran noir... snif

cat /etc/apt/sources.list


# Debian Buster, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free
 
# Debian Buster, mises à jour de sécurité + paquets non libres
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free
 
# Debian Buster, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free
 
# Debian Buster, dépôt de rétroportages ("backports")
deb http://deb.debian.org/debian/ buster-backports main contrib non-free
deb-src http://deb.debian.org/debian/ buster-backports main contrib non-free



apt update


Réception de :1 http://deb.debian.org/debian buster InRelease [122 kB]
Réception de :2 http://deb.debian.org/debian-security buster/updates InRelease [65,4 kB]
Réception de :3 http://deb.debian.org/debian buster-updates InRelease [49,3 kB]
Réception de :4 http://deb.debian.org/debian buster-backports InRelease [46,7 kB]
Réception de :5 http://deb.debian.org/debian buster/non-free Sources [86,3 kB]
Réception de :6 http://deb.debian.org/debian buster/main Sources [7832 kB]
Réception de :7 http://deb.debian.org/debian buster/contrib Sources [43,1 kB]
Réception de :8 http://deb.debian.org/debian buster/main amd64 Packages [7908 kB]
Réception de :9 http://deb.debian.org/debian buster/main Translation-en [5969 kB]
Réception de :10 http://deb.debian.org/debian buster/main Translation-fr [2478 kB]
Réception de :11 http://deb.debian.org/debian buster/main amd64 DEP-11 Metadata [3807 kB]
Réception de :12 http://deb.debian.org/debian buster/main DEP-11 48x48 Icons [3770 kB]
Réception de :13 http://deb.debian.org/debian buster/main DEP-11 64x64 Icons [7596 kB]
Réception de :14 http://deb.debian.org/debian buster/contrib amd64 Packages [51,0 kB]
Réception de :15 http://deb.debian.org/debian buster/contrib Translation-en [44,7 kB]
Réception de :16 http://deb.debian.org/debian buster/contrib amd64 DEP-11 Metadata [11,5 kB]
Réception de :17 http://deb.debian.org/debian buster/contrib DEP-11 48x48 Icons [56,4 kB]
Réception de :18 http://deb.debian.org/debian buster/contrib DEP-11 64x64 Icons [110 kB]
Réception de :19 http://deb.debian.org/debian buster/non-free amd64 Packages [88,0 kB]
Réception de :20 http://deb.debian.org/debian buster/non-free Translation-en [88,7 kB]
Réception de :21 http://deb.debian.org/debian buster/non-free amd64 DEP-11 Metadata [9096 B]
Réception de :22 http://deb.debian.org/debian buster/non-free DEP-11 48x48 Icons [3491 B]
Réception de :23 http://deb.debian.org/debian buster/non-free DEP-11 64x64 Icons [38,3 kB]
Réception de :24 http://deb.debian.org/debian-security buster/updates/main Sources [99,9 kB]
Réception de :25 http://deb.debian.org/debian-security buster/updates/non-free Sources [688 B]
Réception de :26 http://deb.debian.org/debian-security buster/updates/main amd64 Packages [174 kB]
Réception de :27 http://deb.debian.org/debian-security buster/updates/main Translation-en [90,5 kB]
Réception de :28 http://deb.debian.org/debian-security buster/updates/non-free amd64 Packages [552 B]
Réception de :29 http://deb.debian.org/debian-security buster/updates/non-free Translation-en [344 B]
Réception de :30 http://deb.debian.org/debian buster-updates/main Sources [2544 B]
Réception de :31 http://deb.debian.org/debian buster-updates/main amd64 Packages [5792 B]
Réception de :32 http://deb.debian.org/debian buster-updates/main Translation-en [3655 B]
Réception de :33 http://deb.debian.org/debian buster-backports/contrib Sources [2092 B]
Réception de :34 http://deb.debian.org/debian buster-backports/non-free Sources [4160 B]
Réception de :35 http://deb.debian.org/debian buster-backports/main Sources [171 kB]
Réception de :36 http://deb.debian.org/debian buster-backports/main amd64 Packages [193 kB]
Réception de :37 http://deb.debian.org/debian buster-backports/main Translation-en [160 kB]
Réception de :38 http://deb.debian.org/debian buster-backports/contrib amd64 Packages [4592 B]
Réception de :39 http://deb.debian.org/debian buster-backports/contrib Translation-en [3904 B]
Réception de :40 http://deb.debian.org/debian buster-backports/non-free amd64 Packages [13,7 kB]
Réception de :41 http://deb.debian.org/debian buster-backports/non-free Translation-en [24,1 kB]
41,2 Mo réceptionnés en 9s (4715 ko/s)
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Tous les paquets sont à jour.



apt upgrade


Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Calcul de la mise à jour…
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



apt install xserver-xorg-video-amdgpu  firmware-amd-graphics


Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
xserver-xorg-video-amdgpu est déjà la version la plus récente (18.1.99+git20190207-1).
xserver-xorg-video-amdgpu passé en « installé manuellement ».
firmware-amd-graphics est déjà la version la plus récente (20190114-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



Et enfin

lscpu


Architecture :                          x86_64
Mode(s) opératoire(s) des processeurs : 32-bit, 64-bit
Boutisme :                              Little Endian
Tailles des adresses:                   43 bits physical, 48 bits virtual
Processeur(s) :                         4
Liste de processeur(s) en ligne :       0-3
Thread(s) par cœur :                    2
Cœur(s) par socket :                    2
Socket(s) :                             1
Nœud(s) NUMA :                          1
Identifiant constructeur :              AuthenticAMD
Famille de processeur :                 23
Modèle :                                24
Nom de modèle :                         AMD Athlon 300U with Radeon Vega Mobile Gfx
Révision :                              1
Vitesse du processeur en MHz :          1220.993
Vitesse maximale du processeur en MHz : 2400,0000
Vitesse minimale du processeur en MHz : 1400,0000
BogoMIPS :                              4790.45
Virtualisation :                        AMD-V
Cache L1d :                             32K
Cache L1i :                             64K
Cache L2 :                              512K
Cache L3 :                              4096K
Nœud NUMA 0 de processeur(s) :          0-3
Drapaux :                               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme ssbd sev ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca

Hors ligne

#6 29-01-2020 19:48:58

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

bon , c'est pas grave .

c'est un peu ce que je craignais .

vérifie la présence du kernel suivant :

apt search linux-image-5.4.0-0.bpo.2-amd64


tu dois obtenir ceci :

En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-5.4.0-0.bpo.2-amd64/buster-backports 5.4.8-1~bpo10+1 amd64
  Header files for Linux 5.4.0-0.bpo.2-amd64

linux-image-5.4.0-0.bpo.2-amd64/buster-backports 5.4.8-1~bpo10+1 amd64
  Linux 5.4 for 64-bit PCs (signed)

linux-image-5.4.0-0.bpo.2-amd64-dbg/buster-backports 5.4.8-1~bpo10+1 amd64
  Debug symbols for linux-image-5.4.0-0.bpo.2-amd64

linux-image-5.4.0-0.bpo.2-amd64-unsigned/buster-backports 5.4.8-1~bpo10+1 amd64
  Linux 5.4 for 64-bit PCs
 


si c'est bien le cas , fais ceci :

apt install -t buster-backports linux-image-5.4.0-0.bpo.2-amd64 linux-headers-5.4.0-0.bpo.2-amd64


poste le retour


pour terminer ,

reboot


pour redémarrer et tester ton install


en principe tout doit redevenir normal . tu dois retrouver ton bureau .

si çà marche pas ... ben sais pas quoi faire .

Dernière modification par Debian Alain (29-01-2020 20:13:51)

En ligne

#7 30-01-2020 08:36:55

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

Cela a eu un effet, mais pas celui escompté big_smile
Le boot boucle ainsi :

ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GPP2.B
CM5], AE_NOT_FOUND (20190816/dswload2-160)
ACPI Error:  AE_NOT_FOUND, During name lookup/catalog (20190816/ps
object-221)
pci 0000:00:00.2: AMD-Vi: Unable to write to IOMMU perf counter.
watchdog: BUG: soft lockup - CPU#3 stuck for 22s! [systemd-udevd:141]
NMI watchdog: Watchdog detected hard LOCKUP on cpu 2
NMI watchdog: Watchdog detected hard LOCKUP on cpu 1
rcu: INFO: rcu_sched self-detected stall on CPU
rcu: o3-...!: (83 ticks this GP) idle=eaa/1/0x4000000000000002 softirg=281/281 fqs=10
rcu: rcu_sched kthread starved for 4446 jiffies! g-743 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x0 ->cpu=3
rcu: RCU grace-period kthread stack dump:
watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [migration/0:12]
watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [migration/1:15]
watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [migration/2:20]
watchdog: BUG: soft lockup - CPU#3 stuck for 23s! [systemd-udevd:141]
watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [migration/1:15]
watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [migration/0:12]
watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [migration/2:20]
watchdog: BUG: soft lockup - CPU#3 stuck for 23s! [systemd-udevd:141]
rcu: INFO: rcu_sched self-detected stall on CPU
rcu: o3-...!: (336 ticks this GP) idle=eaa/1/0x4000000000000002 softirg=281/281 fqs=10
rcu: rcu_sched kthread starved for 20225 jiffies! g-743 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x0 ->cpu=3
rcu: RCU grace-period kthread stack dump:
watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [migration/0:12]
watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [migration/1:15]
watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [migration/2:20]
watchdog: BUG: soft lockup - CPU#3 stuck for 23s! [systemd-udevd:141]
watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [migration/1:15]
watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [migration/0:12]
watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [migration/2:20]
watchdog: BUG: soft lockup - CPU#3 stuck for 23s! [systemd-udevd:141]
rcu: INFO: rcu_sched self-detected stall on CPU
rcu: o3-...!: (588 ticks this GP) idle=eaa/1/0x4000000000000002 softirg=281/281 fqs=10
rcu: rcu_sched kthread starved for 36005 jiffies! g-743 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x0 ->cpu=3

...

Hors ligne

#8 30-01-2020 08:38:15

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

voilà le résultat de la commande menant à ce boot en boucle

apt install -t buster-backports linux-image-5.4.0-0.bpo.2-amd64 linux-headers-5.4.0-0.bpo.2-amd64


Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets supplémentaires suivants seront installés :
  linux-headers-5.4.0-0.bpo.2-common linux-kbuild-5.4
Paquets suggérés :
  linux-doc-5.4 debian-kernel-handbook
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-5.4.0-0.bpo.2-amd64 linux-headers-5.4.0-0.bpo.2-common
  linux-image-5.4.0-0.bpo.2-amd64 linux-kbuild-5.4
0 mis à jour, 4 nouvellement installés, 0 à enlever et 105 non mis à jour.
Il est nécessaire de prendre 58,3 Mo dans les archives.
Après cette opération, 334 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] Réception de :1 http://deb.debian.org/debian buster-backports/main amd64 linux-headers-5.4.0-0.bpo.2-common all 5.4.8-1~bpo10+1 [8238 kB]
Réception de :2 http://deb.debian.org/debian buster-backports/main amd64 linux-kbuild-5.4 amd64 5.4.8-1~bpo10+1 [319 kB]
Réception de :3 http://deb.debian.org/debian buster-backports/main amd64 linux-headers-5.4.0-0.bpo.2-amd64 amd64 5.4.8-1~bpo10+1 [584 kB]
Réception de :4 http://deb.debian.org/debian buster-backports/main amd64 linux-image-5.4.0-0.bpo.2-amd64 amd64 5.4.8-1~bpo10+1 [49,2 MB]
58,3 Mo réceptionnés en 7s (8396 ko/s)
Sélection du paquet linux-headers-5.4.0-0.bpo.2-common précédemment désélectionné.
(Lecture de la base de données...
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 159868 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-headers-5.4.0-0.bpo.2-common_5.4.8-1~bpo10+1_all.deb ...
Dépaquetage de linux-headers-5.4.0-0.bpo.2-common (5.4.8-1~bpo10+1) ...
Sélection du paquet linux-kbuild-5.4 précédemment désélectionné.
Préparation du dépaquetage de .../linux-kbuild-5.4_5.4.8-1~bpo10+1_amd64.deb ...
Dépaquetage de linux-kbuild-5.4 (5.4.8-1~bpo10+1) ...
Sélection du paquet linux-headers-5.4.0-0.bpo.2-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-5.4.0-0.bpo.2-amd64_5.4.8-1~bpo10+1_amd64.deb ...
Dépaquetage de linux-headers-5.4.0-0.bpo.2-amd64 (5.4.8-1~bpo10+1) ...
Sélection du paquet linux-image-5.4.0-0.bpo.2-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../linux-image-5.4.0-0.bpo.2-amd64_5.4.8-1~bpo10+1_amd64.deb ...
Dépaquetage de linux-image-5.4.0-0.bpo.2-amd64 (5.4.8-1~bpo10+1) ...
Paramétrage de linux-headers-5.4.0-0.bpo.2-common (5.4.8-1~bpo10+1) ...
Paramétrage de linux-image-5.4.0-0.bpo.2-amd64 (5.4.8-1~bpo10+1) ...
I: /vmlinuz is now a symlink to boot/vmlinuz-5.4.0-0.bpo.2-amd64
I: /initrd.img is now a symlink to boot/initrd.img-5.4.0-0.bpo.2-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.4.0-0.bpo.2-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125a-3.fw for module r8169
/etc/kernel/postinst.d/zz-update-grub:
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-5.4.0-0.bpo.2-amd64
Image mémoire initiale trouvée : /boot/initrd.img-5.4.0-0.bpo.2-amd64
Image Linux trouvée : /boot/vmlinuz-4.19.0-6-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.19.0-6-amd64
Adding boot menu entry for EFI firmware configuration
fait
Paramétrage de linux-kbuild-5.4 (5.4.8-1~bpo10+1) ...
Paramétrage de linux-headers-5.4.0-0.bpo.2-amd64 (5.4.8-1~bpo10+1) ...

Hors ligne

#9 30-01-2020 09:27:24

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

si tu peux booter sur ton nouveau kernel ,
tu as essayé : ?

apt update && apt upgrade



que donne : ?

dpkg -l | grep -iE "linux-image-|linux-headers-"



sinon , il te reste plus qu'à faire une testing :

regarde là :
https://cdimage.debian.org/cdimage/unof … so-hybrid/

c'est la seule solution que je vois avec ces µp récents .

Dernière modification par Debian Alain (30-01-2020 09:56:11)

En ligne

#10 30-01-2020 10:59:58

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

Malheureusement je ne peux pas booter (à moins que quelque chose m'échappe sur la procédure).
J'ai le message sur le CPU#3 stuck (voir ci-dessus) qui revient sans arrêter. Pas d'accès à un autre terminal et ctrl+C sans effet.

Hors ligne

#11 30-01-2020 11:05:44

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

normalement , dans le grub , "options avancées" , tu dois pouvoir choisir le kernel sur lequel tu bootes .

fais le , et désinstalle le kernel 5.4 puisqu'il ne passe pas .

apt remove --purge linux-image-5.4.0-0.bpo.2-amd64 linux-headers-5.4.0-0.bpo.2-amd64


reboot



puis fais toi une image de testing et installe la .

Dernière modification par Debian Alain (30-01-2020 11:11:16)

En ligne

#12 31-01-2020 07:20:01

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

L'installation de la testing m'amène directement à un boot en boucle similaire à celui montré plus haut.
Je crois que pour le moment je vais, la mort dans l'âme, remettre win10 sur ce PC. J'avais fait un Clonezilla avant...
Mais merci beaucoup pour l'aide !

Thierry

Hors ligne

#13 01-02-2020 12:46:40

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème d'écran noir après installation de Debian 10

Bonjour
tu a essayé une installation minimale ? (sans bureau)
ensuite il y a plein de manière de booter en debian
en mode maintenance par exemple
le but est d'identifier la ou sa coince
ps: j'ai pas suivi le fil mais
1 - l'installation se passe bien ? (si non ou ça bloque )
2 - après l'installation le reboot ne va pas jusque a l'invite de connexion ?
3 - en mode maintenance ça fonctionne ?
etc .....
nota: il y a peut être des options a passer dans le grub au démarrage (pour que la machine démarre correctement ) , si par exemple le noyau plante au chargement

Il te faudrait l'aide d'un barbu et le message exact quand ça plante (je sais pas toujours facile roll  )

ps: je sais pas de quel matériel il s'agit , peut être très récent ?
une recherche sur le net ?

Hors ligne

#14 01-02-2020 16:01:03

teajrf
Membre
Inscription : 27-01-2020

Re : Problème d'écran noir après installation de Debian 10

Bonjour,
Il s'agit d'une machine récente. En fait l'installation se passait bien et le boot aussi avec un prompt et fonctionnement normal en ligne de commande. C'est le graphique qui coinçait. D'où les différents essais qui ont mené au boot qui boucle, y compris la testing.

Hors ligne

#15 01-02-2020 16:46:17

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème d'écran noir après installation de Debian 10

que donne : ?

dpkg -l | grep -iE "linux-image-|linux-headers-"


qu'as tu comme carte mère ?

dmidecode --type baseboard


dmidecode --type 0

Dernière modification par Debian Alain (01-02-2020 16:59:53)

En ligne

#16 01-02-2020 19:08:12

naguam
Membre
Lieu : Quelque part
Distrib. : Plusieurs
Noyau : Ça dépend
(G)UI : La CLI il n'y a que ça de vrai!
Inscription : 13-06-2016

Re : Problème d'écran noir après installation de Debian 10

D'après ce que j'ai recherché, il y a un soucis avec le mmu amd.
juste pour essayer, sur une debian stable, avec le dernier kernel des backports (celui que t'as fait installer Debian Alain)
et l'option dans le grub iommu=soft (celui que j'essayerais en premier), ou amd_iommu=off ou iommu=off, est-ce que cela corrigerais le problème ?
(Pour éditer le grub, utiliser nano, et ajouter l'option soulignée sur la ligne commençant par GRUB_CMDLINE_LINUX=)
Ensuite

update-grub

Picasso est une architecture (ryzen zen + -->ryzen 3XXX) toute récente et debian stable est un peu ancienne.
ça peut poser des problèmes.

Beaucoup de personnes ayant ces derniers ryzen ont ce genre de problème sur le net (suffit de tapper "AMD-Vi: Unable to write to IOMMU perf counter." sur google ou autres).

Liste non exhaustive de zen+
amd-ryzen-athlon-mobile-650x508.jpg

Aussi si il y a possibilité de mettre à jour le bios, et qu'il y a une update disponible, cela ferais pas de mal:
Si le contructeur n'a pas mis a jour le bios avant de vendre la machine si elle a été en stock depuis un moment.
https://www.phoronix.com/scan.php?page= … pdate-Good

Sur le lien que j'ai marqué il est spécifié qu'il y a eu une update qui corrige des problèmes.
Mais comme tu arrives a aller sur un prompt, en stable, peut-être que le bios est correct.

Un kernel encore plus récent que les backport résoudraient peut-être le problème https://www.phoronix.com/scan.php?page= … -Linux-5.5

Dernière modification par naguam (01-02-2020 19:51:31)

Hors ligne

Pied de page des forums